Disclaimer

Harmonic reserves the right to alter the equipment specifications and descriptions in this publication without prior notice. No part of this publication shall be deemed to be part of any contract or warranty unless specifically incorporated by reference into such contract or warranty. The information contained herein is merely descriptive in nature, and does not constitute a binding offer for sale of the product described herein. Harmonic assumes no responsibility or liability arising from the use of the products described herein, except as expressly agreed to in writing by Harmonic. The use and purchase of this product do not convey a license under any patent rights, copyrights, trademark rights, or any intellectual property rights of Harmonic. Nothing hereunder constitutes a representation or warranty that using any products in the manner described herein will not infringe any patents of third parties.

Trademark Acknowledgments

Harmonic and all Harmonic product names are trademarks of Harmonic Inc. All other trademarks are the property of their respective owners.

Conventions

**NOTE:** The Note symbol calls your attention to additional information that you will benefit from heeding. It may be used to call attention to an especially important piece of information you need, or it may provide additional information that applies in only some carefully delineated circumstances.

**TIP:** The Tip symbol calls your attention to parenthetical information that is not necessary for performing a given procedure, but which, if followed, might make the procedure or its subsequent steps easier, smoother, or more efficient.

In addition to these symbols, this manual uses the following text conventions:

- **Data Entry:** indicates text you enter at the keyboard.
- **User Interface:** indicates a button to click, a menu item to select, or a key or key sequence to press.
- **Screen Output:** shows console output or other text that is displayed to you on a computer screen.
- **Bold:** indicates the definition of a new term.
- **Italics:** used for emphasis, cross-references, and hyperlinked cross-references in online documents.

Revision History

<table>
<thead>
<tr>
<th>Revision</th>
<th>Date</th>
<th>Description</th>
<th>By</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>January 2010</td>
<td>Updating according to 1.6</td>
<td>Tova</td>
</tr>
<tr>
<td>B</td>
<td>March 2010</td>
<td>Updating EdgeCluster</td>
<td>Tova</td>
</tr>
</tbody>
</table>
# Table of Contents

## Chapter 1  Features and Specifications

1.1 Introduction .................................................. 6  
1.2 Main Firmware Related Features .............................. 7  
1.3 Management Interfaces ........................................ 9  

## Chapter 2  Getting Started

2.1 Initial Configuration of NSG 9000 .......................... 11  
2.1.1 Configuring Ethernet Ports ............................... 11  
2.2 Full Device Configuration .................................... 12  
2.2.1 Web Client Specifications ................................. 12  
2.2.2 Logging Into the Device via IE ......................... 13  
2.2.3 Understanding the Web Client Page ..................... 14  
2.2.4 Stages of NSG 9000 Configuration ....................... 17  

## Chapter 3  Configuring Platform Parameters

3.1 Platform Tab Overview ........................................ 18  
3.1.1 Global Chassis Buttons .................................. 19  
3.1.2 Firmware Upgrade ........................................ 20  
3.2 Configuring Ethernet Ports .................................. 22  
3.3 Configuring General Device Parameters .................... 22  
3.3.1 Configuring/Viewing Chassis Properties ............... 22  
3.3.2 Setting a Password ....................................... 23  
3.3.3 Configuring SNMP Parameters ........................... 24  
3.3.4 Setting Device Time and Date Parameters ............. 25  
3.4 Configuring Advanced Networking Options ................ 26  
3.4.1 Configuring Routing Table Parameters ................. 26  
3.4.2 Generating Access Control List ........................ 26  
3.5 Configuring GbE Ports ...................................... 27  
3.5.1 Configuring GbE Port Redundancy ....................... 29  
3.6 Configuring QAM-RF Modules ............................... 31  
3.7 Configuring/Viewing DTI Parameters ....................... 32  
3.7.1 Configuring DTI Client Parameters .................... 33  
3.7.2 Viewing DTI Client and DTI Port Information ....... 33  
3.8 Configuring Global RF & QAMs Parameters ............... 35  
3.9 Configuring a QAM-RF Module ............................ 37  
3.9.1 Configuring Module RF Ports ........................... 38  
3.9.2 Configuring/Viewing QAM-RF Parameters .............. 41  
3.9.3 Viewing QAM-RF Module Information .................. 43  
3.10 Managing Your Licenses .................................... 44  
3.10.1 Working with Licenses .................................. 44  
3.11 Configuring NGOD .......................................... 49  
3.11.1 Configuring NGOD General Parameters ............. 49  
3.11.2 Configuring ERM Parameters ........................... 49  

© 2010 Harmonic Inc.
### Table of Contents

3.12 Configuring ISA ................................................................. 50
3.13 Configuring EdgeCluster .................................................. 51
  3.13.1 Enabling EdgeCluster .................................................. 52
  3.13.2 EdgeCluster Related Procedures .................................. 55

### Chapter 4 Defining Applications

4.1 Applications Overview .................................................... 57
4.2 VOD Application ............................................................. 57
  4.2.1 Defining Session Inactivity Time .................................. 57
  4.2.2 Defining MPEG Parameters ......................................... 58
  4.2.3 Defining Emulation/QAM Mapping Mode ....................... 60
  4.2.4 Viewing VOD QAMs ..................................................... 61
4.3 Broadcast Application ...................................................... 63
  4.3.1 Defining a Passthrough Session .................................. 63
  4.3.2 Defining Service Remux Sessions .................................. 65
  4.3.3 Defining PID Remux Sessions ....................................... 66
4.4 SDV Application .............................................................. 69
  4.4.1 SDV Settings ............................................................. 69
  4.4.2 Viewing SDV QAM Parameters ..................................... 70
  4.4.3 Viewing NGOD Active Sessions .................................... 71
  4.4.4 Viewing ISA Active Sessions ....................................... 72
4.5 M-CMTS Application ......................................................... 74
4.6 D2E Application ............................................................... 76
  4.6.1 Viewing ISA Active Sessions ....................................... 77

### Chapter 5 Conditional Access System (CAS)

5.1 CAS Overview ............................................................... 79
  5.1.1 DVB SCR Scrambling Overview .................................... 79
  5.1.2 Privacy Mode Scrambling Overview ............................... 80
5.2 Defining Global CAS Parameters ....................................... 80
5.3 Defining DVB Scrambling Parameters .................................. 81
  5.3.1 Defining DVB Session Based Parameters ....................... 82
  5.3.2 Defining DVB Tier Based Parameters ............................. 82
  5.3.3 Viewing EIS Information ............................................. 83
  5.3.4 Defining ECMGs and NSG 9000 Communication Parameters 83
  5.3.5 Viewing CAS Status ................................................... 84
5.4 Defining Privacy Mode Scrambling Parameters ..................... 85

### Chapter 6 Monitoring and Troubleshooting

6.1 Monitoring the NSG 9000 Overview .................................. 86
6.2 Device Utilization ........................................................... 86
  6.2.1 Viewing Traffic ........................................................ 89
  6.2.2 Viewing RF Parameters .............................................. 90
  6.2.3 Viewing Input Information .......................................... 90
  6.2.4 Viewing Output Information ....................................... 91
6.3 Monitoring NSG 9000 Status and Alarms ............................ 93
  6.3.1 Viewing Alarms Via the Web Client ............................... 93
<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.3.2</td>
<td>Alarm List</td>
<td>94</td>
</tr>
<tr>
<td>6.3.3</td>
<td>Warning List</td>
<td>98</td>
</tr>
<tr>
<td>6.3.4</td>
<td>Notification List</td>
<td>99</td>
</tr>
<tr>
<td>6.3.5</td>
<td>Setting Alarm Parameters</td>
<td>100</td>
</tr>
<tr>
<td>6.4</td>
<td>Diagnosing and Analyzing Traffic</td>
<td>101</td>
</tr>
<tr>
<td>6.4.1</td>
<td>Saving Configuration</td>
<td>101</td>
</tr>
<tr>
<td>6.4.2</td>
<td>ASI and GbE Forwarding</td>
<td>101</td>
</tr>
<tr>
<td>6.5</td>
<td>Generating and Viewing Logs</td>
<td>102</td>
</tr>
<tr>
<td>6.5.1</td>
<td>Alarms Log</td>
<td>102</td>
</tr>
<tr>
<td>6.5.2</td>
<td>Monitoring the GbE Ports</td>
<td>104</td>
</tr>
<tr>
<td>6.5.3</td>
<td>Monitoring the ISA Communication</td>
<td>105</td>
</tr>
<tr>
<td>6.6</td>
<td>Viewing Available Reports</td>
<td>106</td>
</tr>
<tr>
<td>6.7</td>
<td>Clearing Configuration During Power Up</td>
<td>107</td>
</tr>
<tr>
<td>Appendix A</td>
<td>QAM Mapping Mode</td>
<td></td>
</tr>
<tr>
<td>A.1</td>
<td>NSG 9000 Emulation</td>
<td>108</td>
</tr>
<tr>
<td>Appendix B</td>
<td>Control Panel</td>
<td></td>
</tr>
<tr>
<td>B.1</td>
<td>Using the Control Panel</td>
<td>109</td>
</tr>
<tr>
<td>Appendix C</td>
<td>Standard ES Types and Descriptors</td>
<td></td>
</tr>
<tr>
<td>C.1</td>
<td>Standard Elementary Stream (ES) Types</td>
<td>114</td>
</tr>
<tr>
<td>C.2</td>
<td>Standard ES and Program Descriptors (MPEG)</td>
<td>114</td>
</tr>
<tr>
<td>C.3</td>
<td>Standard ES and Program Descriptors (DVB)</td>
<td>115</td>
</tr>
<tr>
<td>Appendix D</td>
<td>EIA SDT and HRC Standards</td>
<td></td>
</tr>
<tr>
<td>Index</td>
<td></td>
<td>122</td>
</tr>
</tbody>
</table>
1.1 Introduction

This guide describes the configuration and monitoring instructions for NSG™ (Network Services Gateway) 9000.

This universal high density EdgeQAM system supports multiple applications and delivers up to 72 QAM-RF output streams. The number of the delivered transport streams is defined according to the device configuration and number of QAM-RF modules mounted in the slots of the device. Each QAM may serve a different application allowing a single device to concurrently support multiple applications. The supported applications are:

- VOD (Video On Demand)
- Broadcast
  - MPTS passthrough
  - Service remux
  - PID remux
- SDV (Switched Digital Video)
  - NGOD (Next Generation On Demand)
  - ISA
- High Speed Data
  - M-CMTS (Modular CMTS)
  - D2E (Direct to Edge)
## 1.2 Main Firmware Related Features

The following table describes the main features supported by the narrowcast firmware:

### Table 1-1: Main Firmware Related Features

<table>
<thead>
<tr>
<th>Category</th>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input</td>
<td>Max input sockets</td>
<td>1000</td>
</tr>
</tbody>
</table>
|                           | Max. Input bit rate                          | ■ Up to 3,000 Mbps (3 Gbps) per device  
■ Up to 52 Mbps per socket                                                                 |                                                                                                                                                          |
|                           | Dynamic Extraction of input                  | Video only - Dynamic detection of changes in services and PSI tables at the input.                                                                                                                                 |
|                           | Input Format                                 | Video - MPEG2 transport over UDP/IP                                                                                                                                                                           |
|                           | VOD - In-band provisioning of IP/UDP unicast sockets | Programs are automatically routed to the required output QAM channel based on their UDP port number. User may select between several different UDP mapping templates. See 4.2.3 Defining Emulation/QAM Mapping Mode on page 60. |
|                           | IP unicast or multicast                      | Supports IGMP ver 1/2/3                                                                                                                                                                                     |
|                           | Multiplexing/ provisioning options           | ■ Full multiplexing (any input to any output)  
■ Multicast of any input stream to multiple transport streams.  
■ MPTS socket passthrough - NSG 9000 may be configured to pass input sockets in their entirety to a given output QAM channel. However, passthrough sockets may not be multicast to multiple output QAM channels.  
■ Service remux - up to 500 services  
■ Spooling of PSI/SI tables                                                                                                                                 |
|                           | Switched Digital Video                       | Supports SDV:  
■ NGOD R6 and D6 protocols  
■ ISA                                                                                                                                                                                                     |
|                           | Scrambling                                   | ■ DVB-CSA scrambling, in two sub-modes:  
■ Session-based - distinct access criteria per program  
■ Tier-based SimulCrypt - same access criteria for all VOD programs, with up to 3 ECMs per program  
■ Motorola Privacy Mode scrambling                                                                                                                                                                        |
|                           | M-CMTS                                       | Serves as an EdgeQAM in WB & NB applications, supports the following DOCSIS 3.0 protocols:  
■ DEPI (MPT)  
■ DRFI  
■ DTI                                                                                                                                                                                                 |
### Table 1-1: Main Firmware Related Features

<table>
<thead>
<tr>
<th>Category</th>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output</td>
<td>Max output bit rate</td>
<td>See <em>NSG 9000 Hardware and Installation User’s Guide</em></td>
</tr>
<tr>
<td></td>
<td>QAM-RF</td>
<td>See <em>NSG 9000 Hardware and Installation User’s Guide</em></td>
</tr>
<tr>
<td></td>
<td>ASI/GbE Monitoring</td>
<td>The unit duplicates any requested QAM channel to the ASI output port/GbE port for monitoring purposes.</td>
</tr>
<tr>
<td>Management</td>
<td>Management and monitoring</td>
<td>Web client&lt;br&gt;MCT (Mass Configuration Tool)&lt;br&gt;Control Panel&lt;br&gt;SNMP&lt;br&gt;NMX - Harmonic’s Digital Service Manager</td>
</tr>
<tr>
<td></td>
<td>QAM utilization statistics</td>
<td>When NMX is used for alarms and status monitoring, it may also provide statistical reports of QAM utilization.</td>
</tr>
</tbody>
</table>
1.3 Management Interfaces

Harmonic offers several methods for configuring the NSG 9000 devices and monitoring their status. All management interfaces listed below connect to the NSG 9000 over LAN, via its ETH1 Ethernet port.

✨ Caution: ✨ Harmonic strongly recommends using an Ethernet network that is isolated from any other networks or subnets at your site for management of the NSG 9000 gateways. It ensures adequate security, and prevents possible disturbances to the normal operation of NSG 9000 devices due to uncontrolled network activity.

The table below lists the available management interfaces according to the management purpose for which they are designed:

Table 1-2: Management Interfaces

<table>
<thead>
<tr>
<th>Tool</th>
<th>Purpose</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control Panel</td>
<td>Preliminary configuration and monitoring of a single NSG 9000 device</td>
<td>The NSG 9000 control panel is located on the front panel of the NSG 9000. The control panel is active once the NSG 9000 boots up and provides means for preliminary configuration of a single NSG 9000 device. It also allows you to monitor the NSG 9000's status, view its alarms (if present), and troubleshoot them.</td>
</tr>
<tr>
<td>Web Client</td>
<td>Configuration and monitoring of a single NSG 9000 device</td>
<td>The NSG 9000 web client is an on-board web-based user interface, that is an integral part of the NSG 9000 firmware. The web client is accessible through Microsoft Internet Explorer, and provides means for configuring a single NSG 9000 device. It also allows the user to monitor the NSG 9000's status, view its alarms (if present), and troubleshoot them. For details on accessing the web client, see &quot;Logging into NSG 9000&quot; on page 11.</td>
</tr>
<tr>
<td>MCT (Mass Configuration Tool)</td>
<td>Configuration of multiple NSG 9000 devices</td>
<td>The MCT is a spreadsheet-oriented system designed to configure multiple NSGs simultaneously. MCT is recommended for large-scale NSG deployments. Besides simultaneous configuration of large number of NSG devices, it also allows users to perform firmware upgrade for multiple devices. MCT is sold separately - contact Harmonic Customer Support for more details. Note: MCT is not automatically updated when an NSG is configured through the web client. Using the web client for configuring individual NSG in an MCT-based site, is not recommended. If the web client is used, care should be taken to update MCT with the changed configuration. For details on synchronizing MCT with NSG devices, refer to the MCT online help.</td>
</tr>
</tbody>
</table>
### Table 1-2: Management Interfaces

<table>
<thead>
<tr>
<th>Tool</th>
<th>Purpose</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>3rd party SNMP monitoring</td>
<td>Status and Alarm Monitoring of multiple NSG 9000 devices</td>
<td>The integrated SNMP supports an extended set of SNMP MIBs. In addition, NSG 9000 may generate SNMP traps in the following SNMP versions: v1, v2c, v3.</td>
</tr>
<tr>
<td>Harmonic NMX - Harmonic’s Digital Service Manager</td>
<td>Status and Alarm Monitoring of multiple NSG 9000 devices</td>
<td>NMX may be used for monitoring general status and alarms of multiple NSG 9000 devices. A single NMX manager may be used to monitor several hundreds NSG 9000 devices, located in several different sites</td>
</tr>
</tbody>
</table>
2.1 Initial Configuration of NSG 9000

The NSG 9000 device is configured and controlled by a remote management system. Once you have finished cabling the device (see, NSG 9000 Hardware and Installation User’s Guide), set NSG IP address, that is, the IP addresses of the Ethernet ports located on the back panel of the NSG 9000. To set the NSG IP address, use the control panel located on the front panel of the NSG 9000.

NOTE: The NSG 9000 requires a user name and password to log in to all management interfaces including the serial communications console, web client and FTP. Both user name and password are configured.

2.1.1 Configuring Ethernet Ports

NSG 9000 is monitored and configured by a remote management system, via the Ethernet ports located on the back panel of the NSG 9000.

The Ethernet ports labeled ETH1 and ETH2 provide access to two independent networks. The NSG 9000 uses the Ethernet port labeled ETH1 to communicate with the management network. You may set the ETH1 IP address, subnet mask and default gateway.

NSG 9000 uses the Ethernet port labeled ETH2 to communicate with the CAS network. For ETH 2 you may configure only its IP address and subnet mask.

To configure the Ethernet ports of an individual device, use the Control Panel of the device.

The following sections describe how to configure individual NSG 9000 devices using the control panel of the unit.

When you configure the network parameters of ETH ports via the control panel, the application checks the validity of the IP address and network group parameters.

To configure ETH1 port:
1. Navigate to the Network Config screen (see page 109) and click <Enter>.
   The Ethernet Port 1 screen appears.
2. Click <Enter>. The ETH1 IP Address screen appears.
3. Click <Enter>. The Edit IP Address screen appears.
4. Edit the IP address and click <Enter>.
   The program checks whether you entered a valid IP address and only then applies changes. The Edit Ethernet Subnet Mask screen appears.
5. Edit the subnet mask and click <Enter>. The Edit Default GW screen appears.
6. Edit the ETH gateway and click <Enter>.
   The program checks whether you entered valid network parameters and only then applies changes. The ETH1 IP Address screen appears.
   If invalid network parameters are entered an error message appears.

To configure ETH2 port
NOTE: If you are using the ETH2 port, you must configure its IP address on a different subnet than that of the Ethernet 1 port.

Once you are in Config mode, do the following:
1. Navigate to the Network Configuration screen and click <Enter>.
2. Click <Down or Up> to open the Ethernet Port 2 screen.
3. Click <Enter>. The ETH2 IP Address screen appears.
4. Click <Enter>. The Edit IP Address screen appears.
5. Enter the required IP address and click <Enter>.
   The program checks whether you entered a valid IP address and only then applies changes. The Edit Subnet Mask screen appears.
6. Enter the required subnet mask and click <Enter>.
   The program checks whether the network group parameters are valid and only then applies the changes. The ETH2 IP Address screen appears.
   If invalid network parameters are entered an error message appears.

NOTE: You can re-configure the Ethernet ports using the MCT or Web client. The MCT allows the configuration of a number of NSG devices and the Web client allows a remote individual configuration.

For further information about the Control Panel, see B.1 Using the Control Panel on page 109.

2.2 Full Device Configuration

The NSG 9000 web client allows a full configuration of the NSG 9000 device. It also allows the user to monitor the NSG 9000's status, view its alarms (if present), and troubleshoot them. This manual describes and instructs you on how to configure and monitor the device via the web client.

2.2.1 Web Client Specifications

The NSG 9000 Web Client may run only on PCs that meet the following minimal hardware/software specifications:

Table 2-1: Web Client Specifications

<table>
<thead>
<tr>
<th>Item</th>
<th>Specification</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPU</td>
<td>Pentium 4</td>
</tr>
<tr>
<td>Operating Systems</td>
<td>Windows 2000 or Windows XP</td>
</tr>
<tr>
<td>Screen resolution</td>
<td>1024x768 or higher</td>
</tr>
</tbody>
</table>

The web client is accessible through Microsoft Internet Explorer (IE). The following versions of IE are supported:

- 5.5
- 6.0
- 7.0
- 8.0 only in compatibility view
Using IE 8.0

To access the web client using IE8, you should use Compatibility View. This view allows to observe browser pages in a mode that is compatible with IE8.

To set compatibility view

1. Open IE8.
2. Select Tools > Compatibility View Settings.

3. Check Display all Websites in Compatibility View, or specify the IP address for specific sites.

2.2.2 Logging Into the Device via IE

The NSG 9000 device offers two access levels. Each access level offers a different mode of work with the device. The following table lists the various access levels and the available working modes:

Table 2-2: Access Levels

<table>
<thead>
<tr>
<th>Access Level</th>
<th>Working Mode</th>
</tr>
</thead>
<tbody>
<tr>
<td>Monitor</td>
<td>Allows only to monitor the operation of the device.</td>
</tr>
<tr>
<td>Configure</td>
<td>Allows to configure the device and to define the Config and Guest access level password.</td>
</tr>
</tbody>
</table>

Each access level requires a correct username and password combination. The current access level appears in the title bar.

<table>
<thead>
<tr>
<th>Username</th>
<th>Password</th>
</tr>
</thead>
<tbody>
<tr>
<td>monitor</td>
<td>monitor</td>
</tr>
<tr>
<td>configure</td>
<td>configure</td>
</tr>
</tbody>
</table>
The current access level appears in the upper right hand corner of the web client.

Once the NSG 9000 is properly cabled and setup in your network, you may access it via the web client in order to configure and monitor it.

To log into the device
1. Open an Internet browser.
2. In the Address box, type the address of the required device.
3. Click Login.
4. Type in the required username and password.
5. To save the password for the future, select the Save this Password in your password list box.
6. Click Ok.

The web client page appears and you may start working with the device according to the restrictions of your access level.

**NOTE:** To change the password, see 3.3.2 Setting a Password on page 23.

### 2.2.3 Understanding the Web Client Page

Once you have logged into the device, the web client page appears. The web client reads data from the NSG 9000 and presents it in an easy to use User Interface (UI). It includes the following sections:
Title bar - displays the following:

- Device model, for example: NSG 9000
- Device name - by default it is the IP address of the device. You can select it and type any name for easy identification and click Apply. For example: Rack 5-NSG 3.
- Logged-in user
- Alarm indicator - the alarm indicator is actually a link to the Alarm page and the indicator provides the following information:

Table 2-3: Alarm Indication

<table>
<thead>
<tr>
<th>Alarm Indication</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Green Alarm button</td>
<td>No active alarms.</td>
</tr>
</tbody>
</table>
Table 2-3: Alarm Indication

<table>
<thead>
<tr>
<th>Alarm Indication</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Red Alarm button</td>
<td>There is at least one active alarm. Once the mouse pointer hovers on it, a hint appears displaying the alarm description. Once you click it, the Alarm page opens.</td>
</tr>
<tr>
<td>Orange Alarm button</td>
<td>There is at least one active warning. Once the mouse pointer hovers on it, a hint appears displaying the alarm description. Once you click it, the Alarm page opens.</td>
</tr>
</tbody>
</table>

| N Active Alarms       | ‘N’ stands for the amount of registered alarms/warnings. Click the link to open the Alarm page. |
| N Active Warnings     |                                                                                             |

- Help button - allows you to access information about the various options provided by the web client. The provided help is a context sensitive help. Upon clicking the help button, the help page relevant to the open web client page appears.

- Tabs bar - Links you to parameters required for NSG 9000 configuration. The Tabs bar is comprised of two sections:
  - Main tabs - includes the tabs listed in the following table and the Apply button
  - Sub tabs - includes tabs related to the Main tab as the following table describes.

Table 2-4: Available Tabs

<table>
<thead>
<tr>
<th>Main Tab</th>
<th>Sub Tab</th>
</tr>
</thead>
<tbody>
<tr>
<td>Platform</td>
<td>General - allows to configure chassis parameters, input and output ports and QAM-RF module parameters.</td>
</tr>
<tr>
<td></td>
<td>Licensing - allows to manage the licenses</td>
</tr>
<tr>
<td></td>
<td>NGOD - Currently disabled.</td>
</tr>
<tr>
<td></td>
<td>ISA - allows to set general ISA parameters to enable communication with the NSG 9000 device</td>
</tr>
<tr>
<td>Application</td>
<td>VOD - allows to define the VOD parameters. See page 57.</td>
</tr>
<tr>
<td></td>
<td>Broadcast - allows to define service remux. See page 63.</td>
</tr>
<tr>
<td></td>
<td>SDV - allows to define SDV sessions. See page 69.</td>
</tr>
<tr>
<td></td>
<td>M-CMTS - allows to define M-CMTS sessions. See page 71.</td>
</tr>
<tr>
<td></td>
<td>D2E - for future use only</td>
</tr>
<tr>
<td></td>
<td>CAS - allows to define the CAS parameters. See page 74.</td>
</tr>
<tr>
<td>Monitoring</td>
<td>Traffic - shows the traffic that flows out of the device. See page 89.</td>
</tr>
<tr>
<td></td>
<td>Alarms - shows the currently raised alarms. See page 93.</td>
</tr>
<tr>
<td></td>
<td>Diagnostics - allows ASI and IP forwarding for monitoring and analysis purposes.</td>
</tr>
<tr>
<td></td>
<td>Logs - allows to view the GbE counters, alarm logs, NGOD RTSP messages and RPC communication messages. See page 104 - page 105.</td>
</tr>
<tr>
<td>Reports</td>
<td>Allows to view the RF configuration. See page 106.</td>
</tr>
</tbody>
</table>

- Apply button - to the right of the Tabs bar. A click on this button sends the updated configuration to the device.
2.2.4 Stages of NSG 9000 Configuration

Configuring the NSG 9000 model includes the following stages:

- Defining/viewing Platform Parameters, a one time configuration. During this stage, define Ethernet 1&2 ports, GbE input ports and view platform parameters such as status of slots, software version, chassis serial number, and more. You can also set general device parameters such as:
  - Device security parameters (device password)
  - SNMP traps
  - NTP
  - Advanced network options - routing table and Access Control list

- Defining QAM-RF module parameters - during this stage define the following:
  - Global RF and QAMs parameters
  - RF port parameters
  - QAMs parameters
  - View a summary of general attributes

- Licensing - during this stage, view the licenses installed on the NSG device, install new licenses if needed, and assign licenses to QAM channels.

- Applications - during this stage, define the parameters of the required application. The available applications are as follows:
  - VOD
  - Broadcast
  - M-CMTS
  - D2E
  - CAS - in case CAS is required, define whether DVB scrambling or Privacy Mode scrambling is required and set the attributes as required

2.2.4.1 Before you Begin

Before you start configuring and provisioning the device, pay attention to the following:

- Fields that are for viewing only, are greyed out.
- To change parameter values, click in the field and type the required values. Once you click away from the field, the web client interface is updated and displays the new parameters. However, the parameters are not sent to the device.
- To apply changes to fields marked with this icon ☐, you should reset the device.
- To send to the device the newly configured parameters, click Apply. Only when you click Apply, you actually submit the new parameters to the device.
- To delete rows in a table, check the Select box and then click Delete Selected.
- A web page dialog includes a Done button. When clicking this button, you save the new configuration without applying it to the device and you close the web page dialog.

To close a web page dialog without saving the configuration, click the ✗ button at the upper right corner of each page. For example, see Add License web page dialog on page 47.
Chapter 3
Configuring Platform Parameters

3.1 Platform Tab Overview

The Platform tab is the default tab. As soon as you link to the device it opens with the General tab selected. The Platform tab enables you to configure device parameters which are usually a one time configuration and it is recommended to configure as soon as you start working with the device. The Platform parameters are organized in the following tabs:

- **Platform > General Tab** - The Platform > General tab includes a graphical view of the device back panel. Focusing on each component, allows to view or configure the parameters of the component in focus. By default, Chassis is selected and the General tab is in focus. The following table lists the available components and the tabs related to each component.

### Table 3–1: Platform Page – Components and Available Tabs

<table>
<thead>
<tr>
<th>Selected Component</th>
<th>Available Tabs</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chassis</td>
<td>- General - view general chassis parameters and define device name. See page 22.</td>
</tr>
<tr>
<td></td>
<td>- Global RF &amp; QAMs - set global QAM-RF module parameters. See page 35.</td>
</tr>
<tr>
<td></td>
<td>- SNMP - set SNMP parameters. See page 24.</td>
</tr>
<tr>
<td></td>
<td>- NTP - set NTP parameters. See page 25.</td>
</tr>
<tr>
<td></td>
<td>- Passwords - set access passwords. See page 23.</td>
</tr>
<tr>
<td></td>
<td>- Routing Table - set ETH and GbE ports routing table. See page 26.</td>
</tr>
<tr>
<td></td>
<td>- Port Redundancy - set GbE port redundancy. See page 29.</td>
</tr>
<tr>
<td>Eth1, 2</td>
<td>General. See page 22.</td>
</tr>
<tr>
<td>GbE</td>
<td>General. See page 27.</td>
</tr>
<tr>
<td>DTI</td>
<td>General (Currently not applicable). It provides status and details for both DTI ports, which are used in M-CMTS application.</td>
</tr>
<tr>
<td>Slot</td>
<td>- General - view a general summary of the QAM configuration. See page 43.</td>
</tr>
<tr>
<td></td>
<td>- Ports - (default view) enable a QAM-RF port, set the number of channels and the power level of the port. See page 38.</td>
</tr>
<tr>
<td></td>
<td>- QAMs - view and set QAM parameters such as QAM manager. See page 41.</td>
</tr>
</tbody>
</table>

- **Platform > Licensing Tab** - The Platform > Licensing tab allows to manage your licenses as explained in 3.10.1 Working with Licenses on page 44.
- **Platform > NGOD Tab** - The Platform > NGOD tab allows to set the parameters required for the NSG NGOD ERM communication. See 3.11 Configuring NGOD on page 49.
- **Platform > ISA Tab** - The Platform > ISA tab allows to set the parameters required for the NSG ISA communication. See 3.12 Configuring ISA on page 50.
3.1.1 Global Chassis Buttons

Table 3-2: Global Chassis Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Button Name</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="button" alt="Identify unit" /></td>
<td>Identify unit</td>
<td>See page 19.</td>
</tr>
<tr>
<td><img src="button" alt="Export Configuration to File" /></td>
<td>Export Configuration to File</td>
<td>See page 19.</td>
</tr>
<tr>
<td><img src="button" alt="Import Configuration to Device" /></td>
<td>Import Configuration to Device</td>
<td>See page 19.</td>
</tr>
<tr>
<td><img src="button" alt="Firmware upgrade" /></td>
<td>Firmware upgrade</td>
<td>See page 20.</td>
</tr>
<tr>
<td><img src="button" alt="Factory default" /></td>
<td>Factory default</td>
<td>See page 20.</td>
</tr>
<tr>
<td><img src="button" alt="If Chassis is selected Reset Device" /></td>
<td>If Chassis is selected, Reset Module</td>
<td>See page 20.</td>
</tr>
<tr>
<td><img src="button" alt="Validate" /></td>
<td>Validate</td>
<td>Validates the QAM-RF module configuration only. See page 38.</td>
</tr>
</tbody>
</table>

NOTE: Some of the buttons open a pop-up window which in many cases is blocked by the pop-up blocker. Watch for the Information bar message and allow Internet Explorer to display pop-ups from the device. Alternatively, disable pop-up blocking by selecting Tools > Internet Options > Security tab > Custom Level....

To identify unit

1. Select the Platform tab.
   - By default Chassis is selected.
2. Click Identify Unit.
   - The LEDs of Output ports 4, 5 and 6 are blinking and the button toggles to Stop Blinking.

To Export the configuration to File

1. Select the Platform tab.
   - By default chassis is selected.
2. Click Export Configuration to File.
   - The Export File From Device dialog appears.
3. Click either of the following:
   - Open - to open the XML file and to view the configuration of the device.
   - Save - to save the XML file with the device configuration at the required location.

To import configuration
1. Select the Platform tab.
   By default chassis is selected.

2. Click Import Configuration to Device.
   The Import File To Device dialog appears.
3. To locate the required XML file previously exported, click Browse.
4. To import, click Import.
   Wait until a message notifying you of a successful import appears.
5. For the device to run with the newly imported configuration, reset the device.

To upgrade firmware

See, 3.1.2 Firmware Upgrade on page 20.

To clear configuration and Revert to Factory Defaults

1. Select the Platform tab.
   By default chassis is selected.
2. Click Factory Default.
   The following message appears:
   This action will clear configuration and reset the device. Are you sure?
3. To confirm the action, click OK.
   The device configuration is removed and device boots up with factory defaults.

To reset the device

1. Select the Platform tab.
   By default chassis is selected.
2. Click Reset Unit.
3. Click Ok to confirm the action.
   The reset process takes place.

To reset a QAM-RF module

1. Select the Platform tab.
2. Select the required slot/QAM-RF module.
3. Click Reset Module.
4. Click Ok to confirm the action.
   The reset process takes place.

### 3.1.2 Firmware Upgrade

The NSG 9000 ships with firmware and the web client installed. However, Harmonic periodically releases firmware updates. To find out if the provided firmware meets your needs or must be updated, contact Harmonic Technical Support.

**NOTE:** In case the device is working in a EdgeCluster mode, refer before you start upgrading, to 3.13.2.1 EdgeCluster and Firmware Upgrade on page 55.

To upgrade the firmware
1. Copy the new firmware file residing in the provided CD, or on Harmonic's FTP site to your computer.
2. Click Firmware Upgrade.

The following dialog appears:

3. Click Install Firmware Package.
4. Click Browse to locate the software package file.
5. Click Install, to transfer and install the firmware on the device.

The following message appears:

Software installation takes a couple of minutes. Do you want to proceed?
6. To proceed, click Ok.
7. Once installation is complete, the following message appears:

Software was installed successfully. Do you want to reset the unit?
8. To reset the unit and to restart with the new firmware click OK.

The device reboots with the upgraded firmware.
9. Select Platform > Chassis > General tab and verify that the device reports the same version number as the required firmware.

NOTE: The following sections are organized according to the recommended sequence of steps for device configuration.
3.2 Configuring Ethernet Ports

The IP address of the ETH ports or NSG 9000 primary IP address is configured as part of the NSG 9000 installation (see 2.1.1 Configuring Ethernet Ports on page 11). However, when required, you may change the IP address settings via the Platform screen, Ethernet table:

**NOTE:** Configure the IP address of ETH1 on a different subnet than that of ETH2. Configuring both ports to be on the same subnet may result in serious network communication problems. NSG 9000 uses the ETH1 port to communicate with the network for management purposes and ETH2 for Conditional Access Systems (CAS) purposes.

To change configuration of ETH1 and ETH2

1. Select the Platform tab.
2. Select the required Ethernet port.
   
   The ETH1 or the ETH2 Properties General tab appears.

3. To enable the port, check Enable Port.
4. To define the physical layers of the Ethernet communication, open the Ethernet list and select one of the following:
   - Auto Neg - The Auto Negotiation is a handshake protocol used in GbE links. Select this check box to activate the Auto Negotiation protocol only if the other end of the GbE link also uses auto negotiation.
   - 100 BT full - sets the speed to 100 BT and communication mode to full duplex.
   - 10 BT full - sets the speed to 10 BT and communication mode to full duplex.
   - 100 BT half - sets the speed to 100 BT and communication mode to half duplex.
   - 10 BT half - sets the speed to 10 BT and communication mode to half duplex.
5. In MAC Address, view the MAC Address.
6. Type the required IP address, subnet mask and default gateway of ETH1 and/or ETH2.
7. Click **Apply** to apply changes.

**NOTE:** The MAC address is the physical address of the unit. The address is retrieved and presented in the Platform page for viewing purposes only.

3.3 Configuring General Device Parameters

3.3.1 Configuring/Viewing Chassis Properties

This procedure allows you to do the following:

- View general device parameters like software version
Chapter 3 Configuring Platform Parameters

Configuring General Device Parameters

- Define device name
- Working in IGMP V2 protocol only
- Setting EdgeCluster parameters

To view/set chassis properties
1. Select the Platform tab.
2. In Back Panel View, select Chassis > General tab.

The Chassis Properties & Main Board Properties section appears.

3. View the following Chassis information:
   - SW Version - The device’s firmware version and revision.
   - BOOT Version - The BOOT flash version of the device.
   - Main Board FPGA Version - The version of the FPGA firmware loaded onto the main board.
   - Main Board Serial Number - The serial number of the main board.
   - Chassis Serial Number - The serial number of the chassis.
   - Force IGMP V2 - To set the GbE management to support the IGMPv2 protocol only, select Force IGMP V2. NSG 9000 ignores any IGMPv3 messages and does not generate any IGMPv3 messages.

4. To define EdgeCluster (device redundancy) settings, see 3.13 Configuring EdgeCluster on page 51.

5. To define device name, focus on the System Information section and in DeviceName (SysName), enter a name. The device name should allow easy identification of the device. Once you click Apply, the newly entered device name appears in the title bar. If you type in the title bar another name, once you click Apply it overrides the device name entered in DeviceName box.

NOTE: The System Information parameters are also required for the SNMP manager when defining the attributes of the SYSTEM MIB.

3.3.2 Setting a Password

1. Select the Platform tab.
2. Select Chassis > Passwords tab.
3. In User Name, verify that the required user name appears.

   If you logged as Configure you are authorized to change your password or the password
   of Monitor.

4. In Current Password, enter the current password.

5. In New Password, enter the new password.

6. In Verify Password, re-enter the new password.

7. To apply the password change, click Change Password.

   When logging in, use the newly set password.

---

**NOTE:** After three unsuccessful login attempts, or if you forgot the password/user name, reset your
password. To reset the password, call Harmonic Customer Support.

### 3.3.3 Configuring SNMP Parameters

The Simple Network Management Protocol allows network management systems to
communicate with network elements. By default the SNMP is enabled and you may disable it
when required.

The SNMP Trap Destinations table allows you to create a list of SNMP managers to receive
messages from network elements. Once you have accomplished that, configure the SNMP
Community String.

The SNMP Community String section allows you to set password like strings for the various
network elements. The default string value for the Get community is public. If you wish to
block unauthorized SNMP access to your system, change this string to any string of your
choice.

To set SNMP trap parameters

1. Select the Platform tab.

2. Select Chassis > SNMP tab.

3. By default SNMP is enabled. Verify that it is enabled.

   To disable SNMP, de-select Enable SNMP.

4. In the SNMP Trap Destinations table, enable the required table-row by selecting the Enable
   box.

5. Enter the IP Address of the computer to which you wish to forward all SNMP traps from
   the NSG.

6. Open the Version list and select the required SNMP version.

7. In the SNMP Community String table, enter the required string value for each community:
   - Get Community - The name of the community having Read access to the network
     elements. The elements will respond to this community Get commands. The default
string is `public`.

8. In System MIB, enter the following information:
   - Contact (SysContact) - enter contact information
   - Location (SysLocation) - enter the location of the device. In other words, the location of the host on which the SNMP agent, or server runs.

### 3.3.4 Setting Device Time and Date Parameters

Set the device time according to either of the following options:

- **Automatically** - Synchronize the NSG 9000 time with the Universal Time Coordination (UTC) by connecting to an NTP (Network Time Protocol) server. If you enable this option, you cannot set the time of the unit manually.

- **Manually** - Use this option when NTP server is not available.

.helper

To set the time of the device according to the NTP server

1. Select the Platform tab.
2. Select Chassis > NTP tab.

   ![NTP Configuration Table](image)

3. To allow to establish communication with the NTP server, select Enable NTP.
4. Enter the IP address of the NTP server in NTP Server IP Address.
5. Open the Time Zone list and select the required local time offset to match between the time of the device, that is UTC time, and the Greenwich Mean Time (GMT).

.helper

To set the time of the device manually

1. Verify that Enable NTP is not selected.
2. In Date, enter, in the required format, the current date.
3. In Time, enter, in the required format, the current time.
4. Open the Time Zone list and select the required local time offset to match between the time of the device and the Greenwich Mean Time (GMT).

.helper

**NOTE:** When you manually set the date and time of the device, this event is logged in the unit alarm log.

.helper

To set the daylight saving time of the device

1. Select Chassis > NTP tab.
2. Click in DST Start Date to open a calendar.
3. Select the required day and month.
4. Click in DST End Date to open a calendar.
5. Select the required day and month.
3.4 Configuring Advanced Networking Options

3.4.1 Configuring Routing Table Parameters

The routing table allows you to define Ethernet routes to specific networks. This option is required in special network topologies that require more than the capabilities of a default gateway.

To set the Routing table parameters, do the following:

1. Select Platform > General tab.
2. In Back Panel View, select Chassis.
3. In Chassis and Main Board Properties, select Routing Table.
4. Click Add Route to add a blank row to the table.
5. Enter the required values as explained below:
   - Destination - Enter the IP address of the destination device or network.
   - Mask - Specify the subnet mask. The combination of mask and destination IP will determine the exact range of IP destinations that may be accessed through this route.
   - Gateway - Enter the IP address of the gateway through which the NSG will attempt to make a connection to a destination. For ETH1 or ETH2, the gateway must be in the same NSG subnet for either ETH1 or ETH2 ports. For GbE 1, 2 and 3 ports, the gateway must be in the same NSG subnet for each GbE port.
   - Delete - Check this box to remove this route. The route is removed once you click Delete Route.

3.4.2 Generating Access Control List

To control the access of other network devices to the NSG 9000 device, you can create either of the following lists of network devices:

- Network devices with permission to communicate with the EdgeQAM
- Network devices that are prohibited from communicating with the EdgeQAM.

To generate access control list

1. Select the Platform tab.
2. Select Chassis > Access Control List tab.

3. To create the list, click Add Entry.

**NOTE:** You can create a list of up to 10 devices that are prohibited/allowed to communicate with the NSG device.

4. To activate the Access Control feature, click Enable.

5. Open the Mode list and select either of the following:
   - Exclude - To create a list of network devices that are prohibited from communicating with the device.
   - Include - To create a list of network devices that are allowed to communicate with the device.

6. Define the following parameters:
   - **Src IP/Network** - enter the IP address of the source device, that is the device to communicate or to be banned from communicating with the device.
   - **Mask** - enter the required IP mask. You can allow/block a group of network devices to communicate with the device.

**3.4.2.1 Changing Access Control**

In case you wish to change the access control to the NSG 9000 device, do the following:

1. Select the Platform tab.
2. Select Chassis > Access Control List tab.
3. Open the Mode list and change it to the required mode.
   - A message appears notifying you that the list of devices will be removed.
4. Click Ok.

**3.5 Configuring GbE Ports**

The GbE ports are working as eight independent ports receiving eight different feeds.

⇒ To define GbE port properties

1. Select the Platform tab.
2. In Back Panel View, select the GbE ports.
The GbE # Properties General tab appears.

3. To define the GbE port parameters, do the following:

   Enable Port - select to enable the port.
   Port In Use - select either of the following:
   - SFP - when fiber SFP is mounted
   - RJ45 - when copper SFP is mounted
   SFP Vendor - (Read only) view the vendor of the SFP module mounted in the GbE port.
   SFP Mode - (Read only) view the mode of the SFP module mounted in the GbE. It can be multi mode, single mode or copper.
   SFP Type - (Read only) view the type of SFP mounted.
   - Copper - when copper SFP is mounted
   - when fiber SFP is mounted either of the following is indicated:
     - SX - usually used for short distances (up to 200 m)
     - LX - usually used for long distances (10km and up).

   **NOTE:** If the SFP is not mounted, Not Mounted appears in the SFP Vendor, SFP Mode and SFP Type parameters.

   Auto Negotiation - The Auto Negotiation is a handshake protocol used in GbE links. Select this check box to activate the Auto Negotiation protocol only if the other end of the GbE link also uses auto negotiation.

   MAC Address - view the physical address of the GbE as retrieved from the device. This is a read only parameter.

   Status - reflects the current status of the relevant GbE channel. Displays OK, Link Down, SFP Not Mounted, or Disable Mode.

   FPGA Version - view the FPGA version as retrieved from the device. This is a read only parameter.

   NGOD Input Group Name - Enter the name of the input group according to the D6 standard.

   Route Refresh - When enabled, the NSG routinely sends ARP messages to the gateway of the GbE port. Requests are sent approximately once per 5 seconds, thus preventing expiration of the route.

   Refresh Interval (Msec) - Define, in Msec, how often to send a Ping request.

4. In the IP Addresses table, enter the following parameters.

   IP Address1 - type in the required IP address
Subnet - type in the required subnet mask.

Gateway - Enter the IP address of the gateway through which the NSG will attempt to make a connection to a destination. The gateway must be in the same NSG subnet for GbE1, GbE2 and Gb3 ports.

**NOTE:** When working in emulation mode, you can define additional IP addresses.

### 3.5.1 Configuring GbE Port Redundancy

#### 3.5.1.1 Overview

NSG 9000 supports 1:1 port redundancy. For each input GbE port with fiber/copper SFP, you can define a backup port with copper RJ-45 connector. The backup port backs up one primary port only.

- Redundancy is always between fiber/copper SFP and RJ-45 SFP, where:
  - Primary port is always fiber/copper SFP
  - Backup port is always copper RJ-45
  - Redundancy combinations are only as follows:

<table>
<thead>
<tr>
<th>Primary</th>
<th>Backup</th>
</tr>
</thead>
<tbody>
<tr>
<td>GbE port 1 copper/fiber SFP</td>
<td>GbE port 1 copper RJ-45</td>
</tr>
<tr>
<td>GbE port 2 copper/fiber SFP</td>
<td>GbE port 2 copper RJ-45</td>
</tr>
<tr>
<td>GbE port 3 copper/fiber SFP</td>
<td>GbE port 3 copper RJ-45</td>
</tr>
</tbody>
</table>

- Both Primary and backup ports have the same IP address.
- Only one of the ports can be active at any given time.
- As soon as you enable the port redundancy, you cannot configure or change the configuration of the GbE port.
- Port redundancy is automatic only. If both primary and backup port failed, by default the device defines the primary port as the active port and redundancy is halted until the fault is fixed. In case only the faulty backup port is fixed, a manual revert is required.
- To manually change the active port, use the *Switch* button.

#### 3.5.1.2 Port Redundancy Related Alarms

- Triggering redundancy:
  - Link Down
  - No Traffic on Input Port
- After redundancy switch, the following warning is raised: Backup Port Activated

#### 3.5.1.3 Configuring GbE Port Redundancy

- To enable GbE port redundancy
  1. Open the web client of the device.
2. Select Platform > Chassis > Port Redundancy.

3. To view the current status of the ports, click Refresh Ports State.
   The Active Port column is updated to display the currently active port.

4. To enable port redundancy for a specific port, select Enable for the required GbE port.
   The Switch button is enabled and the configuration of the GbE port is disabled.

   **NOTE:** If you click Switch before sending to the device, that is clicking Apply, a message appears asking you to click Apply and only then Switch.

5. Click Apply.
   Port redundancy is activated and if the primary port is faulty, an automatic redundancy switch will take place.

   **To disable port redundancy**
   1. Open the web client of the device.
   2. Select Platform > Chassis > Port Redundancy.
   3. To disable port redundancy for a specific port, de-select Enable for the required GbE port.
   
   The Switch button is disabled and the configuration of the port is enabled.

   **NOTE:** If you click Switch before sending to the device, that is clicking Apply, a message appears asking you to click Apply and only then Switch.

4. Click Apply.
   Redundancy for the port is de-activated and N/A appears as the active port status:

   **To switch active port**
   1. Verify that port redundancy is enabled for the required port.
NOTE: The Switch button is enabled once you enable redundancy.

2. To switch to the backup/primary port, click Switch.
3. In the message that appears, click OK.

The primary/backup port immediately changes and the active port status changes to reflect the switch.

3.6 Configuring QAM-RF Modules

The NSG 9000 device has nine slots. Each slot accommodates a single QAM-RF module.

<table>
<thead>
<tr>
<th>Module Type</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>NSG-2R QUAD</td>
<td>up to four QAM-RF channels per RF port</td>
</tr>
<tr>
<td>NSG-2R1G OCTAL</td>
<td>up to eight QAM-RF channels per RF port. Channels frequency is between 53-999MHz.</td>
</tr>
<tr>
<td>NSG-8R1G OCTAL</td>
<td>up to eight QAM-RF channels per RF port. Currently only four QAM-RF channels are supported</td>
</tr>
</tbody>
</table>

NOTE: To view the actual mounted module, select the Module tab.
Chapter 3 Configuring Platform Parameters

Configuring/Viewing DTI Parameters

- Slot Status - either of the following appears:
  - Module OK - indicates that the slot is occupied with the configured module and the latter is working.
  - Module Out - indicates that the slot is vacant.
  - Module Fail - indicates that the mounted module is faulty or that the applied configuration does not match the currently mounted module.

**NOTE:** To view licensing granted for this module, select Platform > Licensing > Assign Licenses.

In addition, when selecting a slot, you may access the properties of the mounted module. The Module Properties are arranged in the following tabs:

- Module - the default tab. See 3.9 Configuring a QAM-RF Module on page 37.
- Port - see 3.9.1 Configuring Module RF Ports on page 38.
- QAMs - see 3.9.2 Configuring/Viewing QAM-RF Parameters on page 41.
- General - see 3.9.3 Viewing QAM-RF Module Information on page 43.

You can also reset each module by clicking the Reset Module button. See page 20.

The following sections guide you on how to configure the QAM-RF modules. The QAM-RF module configuration includes the following stages:

- Configuring global parameters - the same definitions are sent to all of the QAM-RF modules/QAM channels. The Global configuration is available via the Platform > General > Chassis > Global RF & QAMs tab.
- Configuring parameters for each QAM-RF module - To allow the NSG 9000 device to support multiple applications, during this configuration you may override the configuration of global parameters such as module encoding mode and QAM manager. The configuration of each QAM-RF module is available via the Platform > General > Slot Module > Module/Ports/QAMs tabs.

### 3.7 Configuring/Viewing DTI Parameters

**TIP:** This section is applicable only if a DTI card is installed on the NSG 9000 device. If a DTI card is installed on the NSG 9000 device, select the DTI component and do the following:

- Configure DTI parameters:
  - Enslave NSG 9000-6G clock to the DTI clock by selecting Use DTI Clock
  - Define the DTI port redundancy mode, and select the preferred DTI port (if applicable, depending on the redundancy mode)
  - Configure the SNMP traps

- View the following:
  - DTI client properties and status - via the Client Information section
3.7.1 Configuring DTI Client Parameters

1. Select the Platform > General tab.
2. In the In Back Panel View, select the DTI component.

**NOTE:** The DTI section is enabled only when a DTI card is installed in the device.

The General tab appears.
3. When working in M-CMTS mode, enslave the NSG clock to the DTI clock. To enslave, select Use DTI Clock.
4. To set the DTI port redundancy mode, open the Redundancy Mode list and select one of the following:
   - Manual - you need to select the DTI port. No automatic switching/activation of ports is done, regardless of the status of the DTI ports.
   - Automatic (no Auto Revert) - selecting the active port is completely automatic, without any intervention and without any preference of a specific port. If the active port fails, the standby port is activated and assumes the role of "active" as long as it is in normal state. If the latter fails, ports will be switched again. This switching can continue any number of times, without any preference of a specific port.
   - Automatic (Auto Revert) - in this mode, the selected port (as defined in Selected Port) is always preferred over the other port. In case that the selected port fails, the standby port is automatically activated. Once the selected port is fixed, the NSG automatically switches back to the selected port.
5. To select the active DTI port, open the Selected Port list and select either port 1 or 2.

**NOTE:** The Selected Port list is disabled if Automatic (no Auto Revert) is selected.
6. In Notification, define which notification to send once the status of the DTI client changes:
   - Log Status Change Events - send a notification to the alarm log upon a change in the status of the DTI client
   - Send Trap on Status Change - send an SNMP trap upon a change in the status of the DTI client

3.7.2 Viewing DTI Client and DTI Port Information

1. Select the Platform > General tab.
2. In the In Back Panel View, select the DTI component.

**NOTE:** The DTI section is enabled only when a DTI client is installed in the device.

The General tab appears.
3. To view DTI client information, focus on Client Information section.
   - In Status, verify that the DTI status is NORMAL. The following table lists the available Status options:

<table>
<thead>
<tr>
<th>Status</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Warmup</td>
<td>Local oscillator has not yet stabilized</td>
</tr>
</tbody>
</table>
Table 3-4: DTI Client State Options

<table>
<thead>
<tr>
<th>Status</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Freerun</td>
<td>DTI client is not locked to the signal of the DTI server, and is running freely using its own internal real-time clock. Freerun indicates that since its last initialization, the client was not locked to the server.</td>
</tr>
<tr>
<td>Normal</td>
<td>DTI client is locked to the DTI server, working normally</td>
</tr>
<tr>
<td>Bridging</td>
<td>This is a transient state, which may last up to 2 seconds. It indicates that the DTI client has experienced a momentary interruption in its timing signal, but is still able to maintain acceptable timing. NSG 9000 is still locked to the DTI server clock.</td>
</tr>
<tr>
<td>Holdover</td>
<td>DTI client lost its sync to the DTI server clock. Working in &quot;best effort mode&quot;, with the last known valid time correction</td>
</tr>
<tr>
<td>Fast</td>
<td>The DTI client has just acquired a valid signal, and is in the process of locking to it. If this status is displayed for a prolonged time, this indicates a problem with the received DTI signal or with the DTI client.</td>
</tr>
</tbody>
</table>

- In 10Mhz Ref., indicates whether the 10Mhz Reference signal is present.
- In Timestamp, view the last DTI timestamp
- In Active Port, view the currently active DTI port.
- In FPGA Version, view the installed FPGA version of the DTI client.
- In Serial Number, view the serial number of the DTI client.

4. To view DTI client port information, focus on the Per Port Information section. For each port view the following information:
   - DTI Signal Detected - indicates whether a valid DTI signal is detected.
   - Server Status - indicates the status of the server as it is communicated to the client. Available status indications are as follows: Warmup, Freerun, Fast, Normal, or Holdover.
   - CRC Error Count - indicates the number of CRC error occurrences on the DTI link.
   - Cable Advanced Valid - indicates whether cable advance is valid. A valid, i.e. Stable, Cable Advance value is essential in order for the client to lock to the server.
   - Frame Error Rate - indicates the Frame Error Rate as follows: Below 2%, 2% to 5%, or Over 5%. 

- In 10Mhz Ref., indicates whether the 10Mhz Reference signal is present.
3.7.2.1 DTI Flow

- Reboot
  - Status = Warmup, changes to Freerun once oscillator stabilizes.
  - Alarm: DTI Link Down

- Link Detected
  - Status = Fast
  - Alarm: DTI Not Locked

- Successful sync
  - Status = Normal

- Sync lost

- Link lost
  - Status = Bridging, changes to Holdover after a few seconds.
  - Alarm: DTI Not Locked

3.8 Configuring Global RF & QAMs Parameters

**TIP:** Defining the global parameters of the RF ports & QAM channels is the first stage of the QAM-RF module configuration.

When configuring the QAM-RF module parameters, you may send definition to all of the QAM-RF modules/QAM channels as the following table shows:

### Table 3–5: Setting Global RF&QAM Parameters

<table>
<thead>
<tr>
<th>Required Action</th>
<th>Required Buttons</th>
</tr>
</thead>
<tbody>
<tr>
<td>To send definitions to all of the QAM-RF modules, click Set All Modules and then Apply.</td>
<td>1. [Set All Modules] 2. [Apply]</td>
</tr>
<tr>
<td>To send definitions to all of the QAMs, click Set All QAMs and then Apply.</td>
<td>1. [Set All QAMs] 2. [Apply]</td>
</tr>
</tbody>
</table>

To define global RF and QAMs settings
1. Select Platform > General tab.
2. In Back Panel View, select Chassis.
3. Select the Global RF & QAMs tab.

4. To define the encoding mode, open the ITU-T Annex list and select one of the following:

   Table 3-6: Encoding Mode

<table>
<thead>
<tr>
<th>Encoding Mode</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Annex-A (DVB)</td>
<td>This mode is used mainly in European and Asian countries. Utilizes bandwidth of 8 MHz per QAM-RF channel.</td>
</tr>
<tr>
<td>Annex-B</td>
<td>This is the mode used in North-American countries. Utilizes bandwidth of 6 MHz per QAM-RF channel.</td>
</tr>
<tr>
<td>Annex-C (Japan)</td>
<td>As implied by its name, used mainly in Japan. It is similar to Annex A in the most part, but utilizes bandwidth of 6 MHz per QAM-RF channel.</td>
</tr>
</tbody>
</table>

5. To define the required constellation, open the Constellation list. The Constellation is the type of Quadrature Amplitude Modulation (QAM) used. QAM constellation affects Data Rate and Symbol Rate, and must be set according to HFC network properties. Valid values are:

<table>
<thead>
<tr>
<th>Encoding Mode</th>
<th>Valid Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Annex-A or Annex-C</td>
<td>16, 32, 6, 128, 256</td>
</tr>
<tr>
<td>Annex-B</td>
<td>64 and 256</td>
</tr>
</tbody>
</table>

6. In Symbol Rate (Msps), (Read-only), view the rate of QAM symbols that are encoded and transmitted per second.

7. In Data Rate, (Read-only), view the bit rate of the transport stream in Bps.

8. To apply the configuration to all of the QAM-RF modules, click Set All Modules.

   **NOTE:** The configuration will take effect once you click Apply.

9. To select a QAM manager for all of the QAM-RF modules, open the QAM Manager list and select the required QAM Manager. See, Table 3-9: QAM Manager on page 42.

10. To send configuration to all of the QAMs, click Set All QAMs.

   **NOTE:** The configuration will take effect once you click Apply.

11. To set the QAM-RFs frequency, open the RF Template list and select one of the following:
Chapter 3 Configuring Platform Parameters

Configuring a QAM-RF Module

1. Select the Platform tab.
2. In Back Panel View, select the required slot.
3. Select the Module tab.

4. Define/View the following module information:
   - Expected Module Type - view the module that is supposed to be mounted in the slot. See Table 3-3 on page 31.
   - Actual Module Type - view the currently mounted module type.
   - ITU-T ANNEX - open the list to select the required encoding mode. Changes to the encoding mode override the encoding mode configured during global module configuration. See 3.8 Configuring Global RF & QAMs Parameters on page 35.
   - Constellation - select the required constellation. The Constellation is the type of Quadrature Amplitude Modulation (QAM) used. QAM constellation affects Data Rate and Symbol Rate, and must be set according to HFC network properties. Valid values are: Annex-A or Annex-C: 16, 32, 64, 128, 256. Annex-B are: 64 and 256. Changes override the constellation configured during global module configuration.
   - Symbol Rate - define/view the rate of QAM symbols that are encoded and transmitted per second. You can define the symbol rate in Annex A and C. In Annex B, you can only view its value. Changes override the symbol rate configured during global module configuration.
   - Data Rate - view the defined data rate.
   - Interleaver 1 - view the interleaver values as defined in the QAM tab. NSG 9000 has two optional Interleaver values, set the required value for this interleaver.
   - Interleaver 2 - See Interleaver 1.
   - QAM Placement - See 3.9.0.1 Setting QAM Placement on page 38.
   - RF Template - define/view the RF Template. Define the RF template for Annex B only. View for Annex A and C. The RF template is defined during the global RFs & QAMs
configuration. See 3.8 Configuring Global RF & QAMs Parameters on page 35. Changes override the RF template configured during global module configuration.

### 3.9.0.1 Setting QAM Placement

**NOTE:** Relevant to QAM-RF module NSG-8R1G only.

The QAM Placement feature allows you to configure the QAM-RF channels as follows:
- **Block** - standard placement of adjacent QAM-RFs, depending on the selected ITU-T Annex.
- **Per QAM** - you can place each individual QAM anywhere within the 48Mhz block as long as the following conditions are met:

  - QAM placement prevents out-of-block configurations. QAM placement should not surpass the 48Mhz block.
  - The order of the frequencies is from lowest to highest.
  - No overlapping frequencies (according to the symbol rate). The bandwidth range of each signal does not overlap the bandwidth range of its adjacent signal.
  - The QAMs frequency steps of RF port 1 and RF port 2 are identical. If QAM frequencies of RF port 1 are as follows: 500, 506, 515Mhz, offset of +6 and +15 from the lowest, then the frequencies of RF port 2 should be, for example, as follows: 600, 606, 615.

**NOTE:** You can validate your configuration using the **Validate** button.

**Switching from Block to Per QAM**
- Verify that the number of QAM-RF channels is identical in both ports. See, 3.9.1 Configuring Module RF Ports on page 38.
- When changing from Block to Per QAM, the previously defined frequencies appear and you can change them as required.
- When changing from Per QAM to Block, the default frequencies appear according to the defined ITU-T Annex.

### 3.9.1 Configuring Module RF Ports

1. Select the Platform tab.
2. In Back Panel View, select the required slot.
3. Select the Port tab.

4. For each RF port, define the following:
   - RF Enable - select to enable the RF port. Enable the port only after completing the output configuration.
   - #QAMs per Port - select the number of active QAM channels. The number of active channels is license dependent and by default two channels are active. Following is a list of the optional number of active channels:
     1 - only one active QAM channel
     2 - (Default) two active QAM channels
     3 - applies to Annex A only, and activates three QAM channels. The frequency of the QAM channels is consecutive and each channel utilizes six MHz.
     4 - applies to Annex B and C only, and activates four QAM channels. Applies also to Annex A when an NSG-8R1G module is mounted and activates four QAM channels.
   - Power Level (dBmV) - The power level of the RF port. Once you define the RF power level, the power level of all QAM channels in the port change accordingly. All QAM channels have the same power level in relation to the defined RF port level.
   - Power Level Per QAM - define the QAM power level for all QAM channels within the port. This value appears in the QAM tab as a read-only value.

**NOTE:** In dual, triple and quad, the frequency of the QAM channels is consecutive and each channel utilizes six or eight MHz: In ANNEX B and C - 6MHz and in ANNEX A 8MHz.

   - Power Level (dBmV) - The power level of the RF port. Once you define the RF power level, the power level of all QAM channels in the port change accordingly. All QAM channels have the same power level in relation to the defined RF port level.
   - Power Level Per QAM - define the QAM power level for all QAM channels within the port. This value appears in the QAM tab as a read-only value.

**NOTE:** Any changes to the RF power level affect the QAMs power level and vice versa.

5. Review the port and its QAM channels configuration via the provided bar graphs as explained in the following section.

### 3.9.1.1 Understanding the RF Port Graph

A bar graph, for each RF port displays the current configuration of the RF port as the following table explains:
### Table 3-7: RF Port Legend

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Explanation</th>
</tr>
</thead>
</table>
| RF Enable                     | Blue grid - RF port is enabled  
                              Red grid - RF port is disabled |
| # QAMs per Port               | Number of bars in graph. Each QAM-RF channel is represented by a bar. |
| Power Level (dBmV)            | Height of bar. Each bar represents a QAM, however the power level of each QAM depends on the RF port power level. |
| Bar color                     | Blue - license is granted and QAM is active  
                              Light shade of blue - license is granted and QAM is mute.  
                              Gray - no license is granted  
                              Light shade of gray - no license and QAM is mute. |
| Bar shape                     | Rectangle like - normal  
                              Pointy bar - CW is activated  
                              Truncated bar - channel is mute. |
| ![Arrows](image)              | Indicates that spectral inversion is applied on this QAM. The arrows appear at the top of the bar. |
Once you hover the mouse pointer over a bars you can read QAM channel related information as the following table explains:

<table>
<thead>
<tr>
<th>Hint Parameter</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Frequency</td>
<td>Indicates the center frequency of the QAM-RF channel</td>
</tr>
<tr>
<td>Power level</td>
<td>Indicates the power level of the QAM-RF channel</td>
</tr>
<tr>
<td>Mute</td>
<td>Indicates whether mute or not</td>
</tr>
<tr>
<td>Spectral Inversion</td>
<td>Indicates whether spectral inversion is applied</td>
</tr>
<tr>
<td>CW Signal</td>
<td>Indicates whether CW is applied or not</td>
</tr>
<tr>
<td>QAM License</td>
<td>Indicates whether QAM license is granted</td>
</tr>
</tbody>
</table>

### 3.9.2 Configuring/Viewing QAM-RF Parameters

1. Select the Platform tab.
2. In Back Panel View, select the required slot.
3. Select the QAMs tab.
4. Define RF attributes according to the following explanation:
   - RF Enable - Read only parameter. To enable the port, see 3.9.1 Configuring Module RF Ports on page 38. Select to enable the port.
- RF Output - Read only. It indicates the QAM-RF output channel in the following pattern x.y.z where
  x - Module number
  y - RF port number
  z - RF channel number
For example, 1.2.2 refers to output traffic of module 1, output via RF 2 port, channel 2.
- QAM Index - Read Only. An index number to identify each QAM channel within the 144 available QAM-RF channels of the device.
- TS ID - sets the ID of the transport stream carried over this QAM-RF channel.
- QAM Manager - The QAM manager determines the functionality of the QAM. The default QAM manager is VOD SRM. You can select one of the following QAM managers:

<table>
<thead>
<tr>
<th>QAM-RF Manager</th>
<th>Application</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>VOD SRM</td>
<td>VOD Service Remux</td>
<td>VOD - the NSG 9000 automatically detects the incoming streams and automatically routes them, according to the indicated UDP, to the required QAM-RF channel. The traffic routed via the QAM-RFs is controlled by the SRM (Session Resource Manager). The SRM may also route to the QAM-RFs service remux.</td>
</tr>
<tr>
<td>NGOD ERM (default)</td>
<td>VOD SDV Service &amp; PID Remux</td>
<td>The NGOD ERM controls the QAM-RFs for binding SDV sessions and for routing VOD sessions. The ERM may also route to the QAM-RFs service remux or PID remux. All QAM-RFs send D6 messages to the NGOD ERM if NGOD ERM server is configured and enabled by selecting Applications &gt; NGOD.</td>
</tr>
<tr>
<td>ISA SRM</td>
<td>SDV VOD Service &amp; PID Remux</td>
<td>All QAM-RFs are controlled by ISA (Interactive Service Architecture) using the RPC protocol. VOD sessions are provisioned via ISA or by autodetection. The ISA may also route to the QAM-RFs service remux.</td>
</tr>
<tr>
<td>Passthrough</td>
<td>Passthrough</td>
<td>The incoming stream is streamed out without any changes, that is without generating new tables, services or PIDs. The traffic is locally routed (device Passthrough manager) to the QAM-RFs as indicated by the UDP port.</td>
</tr>
<tr>
<td>M-CMTS</td>
<td>M-CMTS</td>
<td>The QAM-RFs deliver M-CMTS data and are controlled by the CMTS.</td>
</tr>
<tr>
<td>D2E</td>
<td>D2E</td>
<td>The D2E server controls the QAMs. Future use only.</td>
</tr>
</tbody>
</table>

**NOTE:** To change a QAM Manager, verify that no session or service are provisioned/remuxed to this QAM-RF.

- Serving Area - Enter the ID of the area that this QAM channel serves.
- NGOD Group Name - enter the QAM group name according to the D6 standard.
- EIA Channel - Appears when in RF Template you select EIS-STD. It indicates the channel number based on the EIA-STD channel table.
- Frequency - The RF frequency (Hz) of this transport stream. The allowed ranges are as follows:

<table>
<thead>
<tr>
<th>Module Type</th>
<th>ANNEX B (ITU-T) &amp; ANNEX C</th>
<th>ANNEX A (DVB)</th>
</tr>
</thead>
<tbody>
<tr>
<td>NSG-2R</td>
<td>53000000-86700000</td>
<td>54000000-86600000</td>
</tr>
<tr>
<td>NSG-2R1G</td>
<td>53000000-99900000</td>
<td>54000000-99800000</td>
</tr>
</tbody>
</table>

- Power Level (dBmV) - Indicates the power level as defined in the RF Port tab. See, 3.9.1 Configuring Module RF Ports on page 38.
- InterLeaver - An advanced QAM configuration parameter. For Annex-B, Interleaver value depends on the constellation in use.
- Spectral Inversion - The spectral inversion is an advanced QAM configuration parameter. If checked, spectral inversion is enabled.
- Mute - Allows you to control the IF signal within the QAM-RF module before it is up-converted. This option should be set to ON at all times.
- CW - Select for testing purposes only.

### 3.9.3 Viewing QAM-RF Module Information

1. Select the Platform tab.
2. In Back Panel View, select the required slot.
3. Select the General tab.

4. View the following information:
   - Serial Number - The serial number of the mounted module.
   - FPGA Version - The version of the interface FPGA card.
   - HUC SW Version - The version of the Harmonic Up Converter firmware. A version of 06.00 and higher indicates an up converter of 1G.
   - Status - Indicates the status of the module:
     - Module OK - the module is mounted and works properly
     - Module is Out - the module is not mounted in the slot
     - Module Failed - the mounted module is faulty or there is a mismatch between the
module and the configuration.

- License Status - shows the QAM channel number, its frequency, and granted QAM/PM licenses. See, 3.10 Managing Your Licenses on page 44.

3.10 Managing Your Licenses

The output QAM-RF channels of the NSG 9000 device are license dependent. All licenses are per QAM port and the available licenses are as follows:

- Temporary All License - all of the QAM-RF channels are operating. This license is time limited. It can be limited as follows:
  - 14 days - default license. Once you purchase the device and as soon as the device starts working it works for 14 days with all of its capabilities. This grace period of 14 days allows you to activate your licenses to guarantee device operation according to its licensed functions.
  - 90 day - usually for trial or demo purposes
  - 30 day - usually for trial or demo purposes

- Narrowcast QAM License -(Default Module License for 4 QAM). When you purchase a QAM-RF module, you also receive a license for two QAM channels per QAM-RF port. To operate additional QAM channels of the module, you need to purchase additional QAM licenses.

- PM Scrambling License - Not applicable. Allows you to output TSs scrambled in the Privacy Mode encryption technology of Motorola.

3.10.1 Working with Licenses

To work with licenses, you need to install the purchased licenses on the device. It is recommended to install and to remove licenses using the License Manager tool. Obtain this tool free of charge from Harmonic customer support.

For instructions on how to install, remove, or move licenses across the NSG devices, see License Manager documentation.

For the device to operate according to the purchased license you need to do the following:

Table 3-11: Claiming a License

<table>
<thead>
<tr>
<th>Action</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Install a license on the device</td>
<td>Licenses are received from Harmonic as numbered License Packs, and need to be installed onto the NSG device. To instal, use the License Manager. In rare cases, install the license via the web client. See page 47.</td>
</tr>
<tr>
<td>Assign a license</td>
<td>Activate a license per each QAM-RF channel. If the requested licenses are installed on the NSG device, after the configuration is applied, the relevant license is enabled on this QAM-RF channel.</td>
</tr>
<tr>
<td>Viewing license status</td>
<td>View license status:</td>
</tr>
<tr>
<td></td>
<td>- At the top section of the Assign Licenses tab</td>
</tr>
<tr>
<td></td>
<td>- Licenses Summary tab</td>
</tr>
</tbody>
</table>
Licenses are limited by time and an alarm is issued 24 and 72 hours before the license expires. Once a license is expired, NSG 9000 disables the channels from the first channel in the first port of the first slot regardless of the channel that has expired.

### 3.10.1.1 Assigning a License

When assigning a license, you activate a license per each QAM-RF channel. If the requested licenses are installed on the NSG device, after the configuration is applied, the relevant license is assigned/enabled on this QAM-RF channel.

1. Select **Platform > Licensing > Assign Licenses.**

   The Assign License to QAMs page opens:

<table>
<thead>
<tr>
<th>Action</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remove a license from the device</td>
<td>To remove installed licenses, see License Manager. To view deleted licenses, see page 47.</td>
</tr>
</tbody>
</table>

   Once the page opens, you can view the current status of each license:

   - Requested and granted - all checked licenses
2. Scroll down to the required module.
3. To request a license, check the required QAM channel(s).
4. To claim the license(s), click Apply.

   The licenses are granted and the QAM channels operate according to the granted license.

   If you try to claim more licenses than you purchased, a message appears notifying you of the QAM channel its license is deferred. The channel appears in the table with a red background.

5. To view the total number of the licenses according to their current status, scroll to the top of the page:

<table>
<thead>
<tr>
<th></th>
<th>QAM License</th>
<th>PM License</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total Available Licenses</td>
<td>20</td>
<td>0</td>
</tr>
<tr>
<td>Total Requested Licenses</td>
<td>36</td>
<td>0</td>
</tr>
<tr>
<td>Total Claimed Licenses</td>
<td>20</td>
<td>0</td>
</tr>
<tr>
<td>Total Granted Licenses</td>
<td>20</td>
<td>0</td>
</tr>
</tbody>
</table>

   Total Available Licenses - the total number of purchased licenses that were added by entering the license key.

   Total Requested Licenses - the total number of licenses you checked to allow granting them.

   Total Claimed Licenses - the total number of licenses you requested (checked them) and send to the device (click Apply) to claim them. A license is claimed but not granted in the following cases:
   - The module is not mounted in the slot
   - The module’s state is Failed
   - QAM channel is not active due to the selected RF mode

   Total Granted Licenses - the total number of licenses that you requested and are granted, that is that the QAM is operating according to the license.

### 3.10.1.2 License Summary

1. Select Platform > Licensing.
The Licenses Summary page appears:

<table>
<thead>
<tr>
<th>License Type</th>
<th>Qty</th>
<th>In Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Temporary All Features</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Narrowcast QAM</td>
<td>4</td>
<td>0</td>
</tr>
<tr>
<td>PM Scrambling</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

2. View the following information:

License Type - lists all the available types of licenses:
- Temporary All License - allows the NSG 9000 device to operate with all of its capabilities. Usually this license type is time limited.
- Narrowcast QAM License - allows to operate the QAM port channels. Usually a module is purchased with a license for two QAM channels per RF port.
- PM Scrambling License - allows to output TSs via the PM license QAM using Motorola Privacy Mode scrambling technology.
- DOCSIS QAM - allows to operate the QAM port channels as part of an M-CMTS system.
- DOCSIS QAM + DTI Sync - allows to operate the QAM port channels as part of an M-CMTS system with DTI sync messages.

Qty - indicates the total number of purchased licenses of that type.
In Use - indicates the number of licenses that were successfully granted.

3.10.1.3 Adding/Deleting a License

NOTE: Manage the licenses via the License Manager. Only in rare cases, manage the licenses via the web client as described below.

⇒ To add a license

1. Select Platform > Licensing > Manage Licenses. The following page appears.
2. To add a license, click Add License. The Add License dialog appears.

3. Enter the license key you received from Harmonic Customer Support.
4. Click Done.

The license is added to the list, the serial and part numbers are generated according to the license key and the license is available. The following details appear in the table:

- License Description - provides details about the license.
- License Part Number - indicates the part number as generated according to the license key.
- License Serial Number - indicates the serial number as generated according to the license key.
- Qty - indicates the number of QAM channels included in this license.
- Expiration Date - indicates when the license expires.
- Delete- allows you to delete a license.

### 3.10.1.4 Viewing Deleted Licenses

**NOTE:** You can delete licenses via the License Manager only.

- To view the deleted licenses, select the Deleted Licenses tab. The table that appears lists the deleted licenses and their details:

<table>
<thead>
<tr>
<th>License Description</th>
<th>Part Number</th>
<th>License SN</th>
<th>Key SN</th>
<th>Qty</th>
<th>Expiration Date</th>
<th>Deletion Receipt</th>
</tr>
</thead>
<tbody>
<tr>
<td>Internal 14 day Temporary License</td>
<td>M16123456</td>
<td>M16123456</td>
<td>1</td>
<td>2008-08-10</td>
<td>M00123456</td>
<td>Deletion receipt</td>
</tr>
</tbody>
</table>

- License Description - provides details about the license
- Part Number - indicates the part number as generated according to the license key.
- License SN - indicates the Serial Number of the license
- Key SN - indicates the Serial Number of the key
- Qty - indicates the number of QAM channels included in this license
Expiration Date - indicates when the license expired
Deletion Receipt - a string you need to record and use when approaching Harmonic Customer Support.

To organize the Available/Deleted Licenses table
- By default, the first row of the table lists the license entered the latest. To arrange the records in a sequential order, click on any of the column names. An arrow appears to indicate the list order.

3.11 Configuring NGOD

When the EdgeQAM is part of an NGOD system architecture, you need to configure the following to allow the QAM-RFs of the EdgeQAM to outflow SDV/VOD sessions:
- Configure and enable an NGOD ERM server as explained below.
- Define the NGOD ERM as the QAM-RF manager of the required QAM-RFs. See 3.9.2 Configuring/Viewing QAM-RF Parameters on page 41.

Setting NGOD ERM parameters requires to set general and the ERM parameters.

3.11.1 Configuring NGOD General Parameters

To allow communication with the ERM, the NSG 9000-6G device supports the D6 and R6 NGOD protocols. When communicating using the R6 protocol, NSG is always listening on port 554(RTSP).

1. Select Platform > NGOD tab.

2. Focus on the General section.

3. In NGOD Component Name, enter the component name as defined in the D6 protocol.

4. In Bandwidth Update Threshold (kbps), define the allowed deviation from the current output bit rate of the device. Whenever the bit rate deviation reaches the value defined in this field, the NSG sends the ERM the updated output bit rate.

5. In Routing Cost, enter a value as defined in the D6 protocol.

6. In R6 RTSP Port, enter 554 as the port number. When communicating using the R6 protocol NSG is always listening on port 554(RTSP).

3.11.2 Configuring ERM Parameters

1. Select Platform > NGOD tab.
2. Click Add, to add an ERM.
3. In IP Address, enter the ERM IP address.
4. In Port, enter the ERM TCP port number.
5. In Version, select the supported version of the protocol. Version 2 is the default version.
6. In Streaming Zone, enter the streaming zone as defined in the D6 protocol.
7. To enable the NSG-ERM communication, select the Enable ERM box.
8. In Status, view the connection status.

   Connect indicates that the connection is ok.
   Idle indicates that there is no connection with the ERM.
9. Check Delete to remove the line when clicking Delete.
10. In ERM Keep Alive, enter a period of time in seconds to indicate the duration between the keepalive messages transmitted by the NSG to the ERM. The default is 30 seconds.
11. In Connection Retry Threshold (sec), enter a period of time in seconds to indicate the duration between retrials to connect to the ERM to send D6 messages.
12. In Hold Time (sec), enter a period of time in seconds to indicate the duration between responses to successive Keep Alive and or UPDATE messages received by the NSG. If the duration time elapses and a response is not received, NSG tries to re-establish the connection with the ERM.

3.12 Configuring ISA

When the EdgeQAM is part of an ISA SRM system architecture, you need to configure the following parameters to allow the QAM-RFs of the EdgeQAM to outflow SDV/VOD sessions:

1. Select Platform > ISA tab.

<table>
<thead>
<tr>
<th>General</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Reset Indication</td>
</tr>
<tr>
<td>SRM IP Address</td>
</tr>
<tr>
<td>SRM Port</td>
</tr>
<tr>
<td>Connection Type</td>
</tr>
<tr>
<td>Timeout Period (Sec)</td>
</tr>
</tbody>
</table>

2. Define the following parameters:

   - Enable Reset Indication - if selected, an indication is sent to the ISA server (either ERM or SRM).
   - SRM IP Address - enter the IP address of the SRM server
   - SRM Port - enter the port number over which the device communicates with the SRM
   - Connection Type - select either TCP or UDP
   - Timeout Period - enter a period of time in seconds to indicate the duration between the NSG trials to connect to the ISA server.

NOTE: EdgeCluster, device redundancy, is not applicable to this version.
3.13 Configuring EdgeCluster

NSG 9000 supports EdgeCluster technology. This technology offers high availability obtained by 1:1 device redundancy. The active and standby devices are configured the same and are provisioned with the same sessions. However, the output ports of the standby device are disabled. Both the active and standby devices communicate with each other via their Eth1 and Eth2 ports:

- Eth1 - management port connection. See *NSG 9000 Hardware and Installation User’s Guide*.
- Eth2 - connected with an Ethernet crossover cable.

The input ports of both NSG devices must be configured the same including their IP addresses.

The active device sends heartbeat messages in pre-defined intervals. Once a triggering alarm is issued on the active device, the following takes place:

- The active NSG 9000 device stops sending heartbeat messages to the standby device.
- The active NSG 9000 device closes its QAM-RF ports.
- The active NSG 9000 shuts up its GbE ports (Link Down) for a pre-defined period of time to signal the source device that the device is faulty.
- If no heartbeat messages are received by the standby NSG 9000 device, it enables its QAM-RF ports and starts sending heartbeat messages to its peer device. The source device starts transferring data to the standby device.

The following picture is an example of an application of the EdgeCluster technology. In this example, the technology is applied to an M-CMTS system:

For various EdgeCluster applications with and without switch, see *EdgeCluster Application Note*.

To view the list of the default triggering alarms and to define triggering alarms, see 3.13.1 Defining Triggering Alarms on page 54.
3.13.1 Enabling EdgeCluster

Enabling and monitoring the EdgeCluster feature is done via the Platform > Chassis > General tab.

The EdgeCluster tab includes the following options:

**Device Mode** - Allows to select either of the following modes:
- **StandAlone** - when selected, EdgeCluster options are disabled.
- **EdgeCluster** - when selected, EdgeCluster options are enabled.

**ETH1 Peer IP** - Allows to configure the IP address of Eth1 of the peer device.

**ETH2 Peer IP** - Allows to configure the IP address of Eth2 of the peer device.

**GbE Signaling** - Allows to configure the GbE link during fail-over. By default, GbE Signaling is set to Const Link Down. It is recommended not to change the default configuration.
- **Const Link Down** - Default option. GbE port is constantly in link down.
- **Temp Link Down** - GbE port is in link down for a pre-defined time to signal the source device that the device is faulty.

**NOTE:**
GbE Signaling is available only if your edge device is running with either of the following versions:
NSG 9000 version 1.5.3 and up, NSG 9000-6G version 2.2 and up.
Constant link down is required for uBRK10 running with IOS version 12.2SCB and up.

**Mute All RF** - Select to close all RF ports.

To enable EdgeCluster, perform the following instructions in their sequential order. Failing to perform the instructions according to their order may adversely affect the EdgeCluster capability.

**NOTE:** The provided instructions assume that a single NSG 9000 device is working (referred to as Active device) and you would like to add a standby device.

**NOTE:** If your uBR10K is running with IOS version 12.2 SCB and up, use NSG 9000 1.5.3.and up or NSG 9000-6G version 2.2 and up only.
1. Configure the designated standby device exactly as its peer device.

2. Check that the designated standby device is working properly by connecting it to an external analyzer.

3. Verify that you can connect the devices according to the scheme described in 3.13 Configuring EdgeCluster on page 51.
   Note: At this stage don’t connect the designated standby device to the HFC network.

4. In the web client of the designated standby device, select Platform > Chassis > General tab.

5. Focus on the EdgeCluster Settings section.

6. Select Mute All RF and click Apply.

7. Connect the device to the HFC network.
   Connect the input ports according to the scheme described in 3.13 Configuring EdgeCluster on page 51 and connect the QAM-RF ports cables.

8. In the web client of the Active device only, select Platform > Chassis > General tab and focus on the EdgeCluster Settings section.

9. Select EdgeCluster.
   The Mute All RF option is disabled.

10. In Eth1 Peer IP and in Eth2 Peer IP enter the Eth1 and Eth2 address of the peer device, in this case the standby device, respectively.

11. Verify that GbE Signaling is set to Const Link Down.

12. Click Apply.

13. Verify that Active Peer appears in the title bar of the web client.

14. In the web client of the standby device only, select EdgeCluster.

15. Verify that Eth1 Peer IP and Eth2 Peer IP are configured as required.

16. Verify that GbE Signaling is set to Const Link Down.
3.13.1.1 EdgeCluster Indications

Once you set the EdgeCluster configuration, various indications appear at the title bar of the web client and on the front panel LCD display. The indications reflect the status of the device in the EdgeCluster topology as the following table shows:

<table>
<thead>
<tr>
<th>Device Status</th>
<th>Title bar</th>
<th>Front Panel LCD</th>
<th>LCD Legend</th>
</tr>
</thead>
<tbody>
<tr>
<td>Active</td>
<td>Active Peer</td>
<td>A</td>
<td>Active</td>
</tr>
<tr>
<td></td>
<td>Failed Peer (upon redundancy switch)</td>
<td>F</td>
<td>Failed</td>
</tr>
<tr>
<td>Standby</td>
<td>Standby Peer</td>
<td>S</td>
<td>Standby</td>
</tr>
<tr>
<td>RF ports disabled</td>
<td>RF Disabled</td>
<td>D</td>
<td>Disabled</td>
</tr>
</tbody>
</table>

17. Click **Apply**.

18. Verify that Standby Peer appears in the title bar of the web client.

3.13.1.2 Defining Triggering Alarms

By default, critical hardware alarms are defined as triggering device fail-over. Advanced users may re-define the triggering alarms as explained in 6.3.5 Setting Alarm Parameters on page 98. To view whether an alarm triggers a redundancy switch, see 6.3.2 Alarm List on page 91 and 6.3.3 Warning List on page 95.
### 3.13.2 EdgeCluster Related Procedures

#### 3.13.2.1 EdgeCluster and Firmware Upgrade

When you wish to upgrade the firmware of NSG 9000 devices working in EdgeCluster mode, perform the following steps in their provided order.

⇒ **To upgrade the firmware of the NSG 9000 device in EdgeCluster Mode**

**NOTE:** During this procedure you are instructed to upgrade the firmware of the standby device first.

<table>
<thead>
<tr>
<th>Standby Device</th>
<th>Active Device</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. In the web client of the Standby device only, select <strong>Platform &gt; Chassis &gt; General</strong> tab and focus on the <strong>EdgeCluster Settings</strong> section.</td>
<td></td>
</tr>
<tr>
<td>2. In Device mode, select <strong>StandAlone</strong>.</td>
<td></td>
</tr>
<tr>
<td>3. Select <strong>Mute All RF</strong>.</td>
<td></td>
</tr>
<tr>
<td>4. Click <strong>Apply</strong>.</td>
<td></td>
</tr>
<tr>
<td>5. Save the current configuration of the standby device using the MCT software.</td>
<td></td>
</tr>
<tr>
<td>6. Upgrade the firmware as instructed on page 20.</td>
<td></td>
</tr>
<tr>
<td>7. Verify that the device is running with the newly installed firmware and apply the required configuration to the device. Note: The standby device is currently working with the new firmware and the required configuration which implies that its QAM-RF ports are disabled.</td>
<td>8. In the web client of the Active device only, select <strong>Platform &gt; Chassis &gt; General</strong> tab and focus on the <strong>EdgeCluster Settings</strong> section.</td>
</tr>
<tr>
<td>9. In Device mode, select <strong>StandAlone</strong>.</td>
<td>9. In Device mode, select <strong>StandAlone</strong>.</td>
</tr>
<tr>
<td>10. Select <strong>Mute All RF</strong>.</td>
<td>10. Select <strong>Mute All RF</strong>.</td>
</tr>
<tr>
<td>11. Click <strong>Apply</strong>.</td>
<td>11. Click <strong>Apply</strong>.</td>
</tr>
<tr>
<td>12. In the web client of the Standby device only, de-select <strong>Mute All RF</strong> and click <strong>Apply</strong>. The device is streaming traffic and is working in standalone mode.</td>
<td>13. Save the current configuration using the MCT software.</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### 3.13.2.2 EdgeCluster Manual Revert

The following section instructs you on how to revert from the Standby device to the Active device after fixing a faulty Active device.

The following procedure assumes the following:
- The fixed Active device is working in a Standby mode
- EdgeCluster is enabled in both devices
- The designated Standby device is currently the Active device

To manually revert to the designated Active device

In the web client of the designated Standby device, do the following:
1. Select **Platform > Chassis > General** and focus on the **EdgeCluster Settings** section.
2. In **Device Mode**, select **StandAlone**.
3. Select **Mute All RF**.
4. Click **Apply**.
5. In **Device Mode**, select **EdgeCluster**.
6. Click **Apply**.
7. Verify that **Standby Peer** appears in the title bar.

<table>
<thead>
<tr>
<th>Standby Device</th>
<th>Active Device</th>
</tr>
</thead>
<tbody>
<tr>
<td>14. Upgrade the firmware as instructed on page 20.</td>
<td>15. Verify that the Active device is running with the newly installed firmware and apply the required configuration to the device.</td>
</tr>
<tr>
<td>16. In the web client of the Active device only, select <strong>Platform &gt; Chassis &gt; General</strong> tab and focus on the <strong>EdgeCluster Settings</strong> section.</td>
<td>17. In <strong>Device Mode</strong>, select <strong>EdgeCluster</strong>.</td>
</tr>
<tr>
<td>18. Verify that the peer parameters are correct.</td>
<td>19. Click <strong>Apply</strong>. Both Active and Standby device are streaming out traffic.</td>
</tr>
<tr>
<td>20. In <strong>Device Mode</strong>, select <strong>EdgeCluster</strong>.</td>
<td>21. Verify that peer parameters are as required.</td>
</tr>
<tr>
<td>22. Click <strong>Apply</strong>.</td>
<td>23. Verify that Standby Peer appears in the title bar.</td>
</tr>
</tbody>
</table>
Chapter 4
Defining Applications

4.1 Applications Overview

NSG 9000 operates in the following applications:

VOD Application - The system serves as a highly integrated digital video gateway, capable of multiplexing on-demand content streamed over an IP network.

Broadcast Applications - The system broadcasts remuxed services.

SDV Application - The device streams out SDV sessions provisioned by ISA.

M-CMTS Application - NSG 9000 supports wideband M-CMTS data PIDs. As part of the MCMTS system, NSG 9000 processes down streams and improves downstream data rates by significantly reducing costs.

D2E Application - NSG 9000 supports Multicast IP down streams encapsulated as DOCSIS 3.0 with DBC requests (when required) on dedicated frequencies (D2E server frequencies).

CAS - NSG 9000 supports both DVB-CSA and Privacy Mode scrambling.

NOTE: When provisioning static sessions through the web client or MCT, NSG 9000 may carry up to 500 sessions only. When dynamic sessions are provisioned through ISA SRM or VOD SRM, NSG 9000 may carry up to 2,000 dynamic SDV sessions.

4.2 VOD Application

The VOD application includes two tabs:

- Settings - allows you to set the following:
  - General parameters - session inactivity time
  - MPEG related parameters
  - Emulation mode (currently disabled)

- QAMs - a read only page to view QAMs settings

4.2.1 Defining Session Inactivity Time

Define the allowed duration for session inactivity before the session is removed from the output.
1. Select Applications > VOD > Settings tab.

2. In Session Inactivity Teardown Threshold (Sec.), enter the allowed period of time in seconds for session inactivity. In case the interval is longer than the indicated time, the session is removed from the output port.

3. By default, Allow Auto Detection is selected. Verify that this option is selected to allow auto detection, in the input, of the output QAM according to the indicated UDP port.

4.2.2 Defining MPEG Parameters

4.2.2.1 PID Remapping

The PID Remapping option allows you to remap according to a specific paradigm or randomly. In either case, the NSG prevents the assignment of conflicting PIDs.

- **Paradigm** - The elementary stream PIDs are chosen from a predefined hex-decimal formula for PMT, Video, Audio 1 & 2, ECM, PIDs. The range is:

<table>
<thead>
<tr>
<th>Formula</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Service ID = 0xN</td>
<td>Service ID = 0x34</td>
</tr>
<tr>
<td>PMT PID = LeftShift (N) = 0xN0</td>
<td>PMT PID = 0x340</td>
</tr>
<tr>
<td>PCR=Video=PMT+1= 0xN1</td>
<td>Video = 0x341</td>
</tr>
<tr>
<td>Audio 1&amp;2 = PMT+ 4/5 = 0xN 4,0xN5</td>
<td>Audio 1&amp;2 = 0x344, 0x345</td>
</tr>
<tr>
<td>ECM=PMT+9= 0xN9</td>
<td>ECM PID= 0x349</td>
</tr>
</tbody>
</table>

**NOTE:** The Paradigm mode is not suitable for processing services with service IDs greater than 510. If you are using service ID that are greater than 510 you must use the Random mode.
Random - The NSG remaps incoming PIDs to PID numbers that are randomly selected from a predefined range. Define the range in the PID Range field. The PID range is written in hex-decimal format. Range of acceptable values is 0x21 to 0x1FF0.

Changing the PID remapping mode may interrupt the streams currently flowing through the device. It is recommended to change the remapping mode only when no active streams are flowing through the device.

In addition, changing the PID remapping may affect the operation of some STB (Set-up Boxes.) Various STBs operate better with a specific mode. If you suspect such a case, call the STB vendor before changing the PID remapping.

**NOTE:** Do not change the default settings unless it is necessary. Changing the parameters may cause serious problems with elementary stream transmission.

**NOTE:** Changing the PID Remapping mode is global. It applies to the platform and to both VOD and SDV sessions.

To change PID remapping

1. Select Applications > VOD > Settings:

2. By default the remapping method is Paradigm. To change the remapping method, select Random.

   The PID Range (Per TS) option is enabled.

3. In PID Range (Per TS), define the PID range (in hex-decimal format) that the NSG will use for random PID assignment. The range of acceptable values is 0x21 to 0x1FF0.

   **NOTE:** Changes take affect after device reset only.

4.2.2.2 Setting PAT/PMT Intervals

1. In PMT Interval, define the interval in milliseconds at which PMT packets are sent over the NSG's output transport streams.

2. In PAT Interval, define the interval in milliseconds at which PAT packets are sent over the NSG's output transport streams.

   **NOTE:** Changes take affect after device reset only.

3. Select Update PMT Version to update the PMT version. This version is incremented every time the PMT’s data is changed (e.g. the Video PID changes).
4.2.2.3 Creating and Setting SAT

1. Select Create SAT (Service Area Table), to create SAT at the output. Once Create SAT is selected, the following parameters are enabled:
   - Original Network ID
   - Serving Area Location in SAT

2. If Create SAT is selected, define the original network ID.

3. If Create SAT is selected, open the Serving Area Location in SAT list and select one of the following:
   - TS ID - the serving area is written to the TS ID.
   - First Service Name - the serving area is written to the first service name
   - Both - the serving area is written to both the TS ID and the first service name.

4.2.3 Defining Emulation/QAM Mapping Mode

By default the QAM Mapping Mode is set to Normal. However, the NSG 9000 device may emulate the operation of other devices which require a different mapping of the QAMs.

Each Emulation Mode is defined by an XML file. Once you select an emulation mode, NSG 9000 loads the required emulation mode XML file.

You can customize up to four QAM Mapping modes and export them to an XML file and when required you can import them to the device.

To see the emulation mode and its QAM mapping, see A.1 NSG 9000 Emulation on page 108.

To define the QAM mapping mode

1. Select Applications > VOD > Settings tab.

2. Open the Emulation Template list to select the required emulation Template. See 4.2.3 Defining Emulation/QAM Mapping Mode on page 60.

   NOTE: Changing the emulation template, requires an immediate device reset.

3. Once the device boots up the following applies:
   - According to the emulation template, you should configure additional IP addresses to the input GbE port. See 3.5 Configuring GbE Ports on page 27.
   - The RF configuration is set to its default values, if the newly selected emulation
template allows two QAMs per port only and if the previous emulation template allowed a different number of QAMs per port (three or four.) That is, if in the newly loaded emulation mode file, \( RF\ Mode = 2 \), and in the previous emulation mode file \( RF\ Mode = 2 \), the RF configuration is set to its default values. For example, if you work in Normal emulation mode and change to NSG8108 encoded, the device boots up with default RF configuration, which allows two QAMs per port only.

4. To export one of the defined custom QAM Mapping modes, see 4.2.3.1 Exporting Customized QAM Mapping Mode File on page 61.

5. To import a customized QAM Mapping mode, see 4.2.3.2 Importing Customized QAM Mapping Mode File on page 61.

### 4.2.3.1 Exporting Customized QAM Mapping Mode File

1. Select Applications > VOD > Settings.
2. Click Export Custom File.
3. Click either Open or Save the file of the selected QAM Mapping mode.
   
   If you select Open, the file opens and you can view it.
   
   If you select Save, a Save As dialog opens and you may browse to the required location of the file.

### 4.2.3.2 Importing Customized QAM Mapping Mode File

1. Select Applications > VOD > Settings.
2. Click Import Custom File.

   The following dialog appears:

   ![Import Emulation Template File To Device dialog](image)

3. Click Browse to locate the required QAM Mapping mode template.
4. Open the Override Template list and select which template to override.
5. Click Import.

### 4.2.4 Viewing VOD QAMs

The QAMs tab allows you to view the settings of all the QAMs configured to stream out VOD sessions. These QAMs are managed by the following QAM managers:

- VOD SRM
- NGOD ERM
- ISA SRM

\[ \Rightarrow \] To view VOD QAMs
1. Select Applications > VOD > QAMs.

<table>
<thead>
<tr>
<th>QAM Manager</th>
<th>GbE Port</th>
<th>GbE IP Address</th>
<th>UDP Port Range</th>
<th>RF Output</th>
<th>QAM Index</th>
<th>TS ID</th>
<th>NSG Group Name</th>
<th>QAM Frequency</th>
<th>Symbol Rate</th>
<th>Interleaver</th>
<th>Spectral Inversion</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>NGOD ERM</td>
<td>All</td>
<td>All</td>
<td>513 - 767</td>
<td>1.1.2</td>
<td>2</td>
<td>2</td>
<td>Q02</td>
<td>5607000000</td>
<td>5.386937</td>
<td>128-4</td>
<td></td>
<td>Active</td>
</tr>
<tr>
<td>NGOD ERM</td>
<td>All</td>
<td>All</td>
<td>1283 - 1535</td>
<td>1.2.1</td>
<td>5</td>
<td>5</td>
<td>Q05</td>
<td>5610000000</td>
<td>5.386937</td>
<td>128-4</td>
<td></td>
<td>Active</td>
</tr>
<tr>
<td>NGOD ERM</td>
<td>All</td>
<td>All</td>
<td>1537 - 1791</td>
<td>1.2.2</td>
<td>6</td>
<td>6</td>
<td>Q06</td>
<td>5607000000</td>
<td>5.386937</td>
<td>128-4</td>
<td></td>
<td>Active</td>
</tr>
<tr>
<td>NGOD ERM</td>
<td>All</td>
<td>All</td>
<td>2108 - 2559</td>
<td>2.1.1</td>
<td>9</td>
<td>9</td>
<td>Q09</td>
<td>5610000000</td>
<td>5.386937</td>
<td>128-4</td>
<td></td>
<td>Active</td>
</tr>
<tr>
<td>NGOD ERM</td>
<td>All</td>
<td>All</td>
<td>2162 - 2815</td>
<td>2.1.2</td>
<td>10</td>
<td>10</td>
<td>Q010</td>
<td>5607000000</td>
<td>5.386937</td>
<td>128-4</td>
<td></td>
<td>Active</td>
</tr>
<tr>
<td>NGOD ERM</td>
<td>All</td>
<td>All</td>
<td>3329 - 3583</td>
<td>2.2.1</td>
<td>13</td>
<td>13</td>
<td>Q013</td>
<td>5610000000</td>
<td>5.386937</td>
<td>128-4</td>
<td></td>
<td>Active</td>
</tr>
<tr>
<td>NGOD ERM</td>
<td>All</td>
<td>All</td>
<td>3888 - 3889</td>
<td>2.2.2</td>
<td>14</td>
<td>14</td>
<td>Q014</td>
<td>5607000000</td>
<td>5.386937</td>
<td>128-4</td>
<td></td>
<td>Active</td>
</tr>
<tr>
<td>NGOD ERM</td>
<td>All</td>
<td>All</td>
<td>4853 - 4997</td>
<td>3.1.1</td>
<td>17</td>
<td>17</td>
<td>Q017</td>
<td>5520000000</td>
<td>6.95643</td>
<td>12-17</td>
<td></td>
<td>Active</td>
</tr>
<tr>
<td>NGOD ERM</td>
<td>All</td>
<td>All</td>
<td>4609 - 4960</td>
<td>3.1.2</td>
<td>18</td>
<td>18</td>
<td>Q018</td>
<td>5500000000</td>
<td>6.95643</td>
<td>12-17</td>
<td></td>
<td>Active</td>
</tr>
<tr>
<td>NGOD ERM</td>
<td>All</td>
<td>All</td>
<td>4865 - 5119</td>
<td>3.1.3</td>
<td>19</td>
<td>19</td>
<td>Q019</td>
<td>5600000000</td>
<td>6.95643</td>
<td>12-17</td>
<td></td>
<td>Active</td>
</tr>
<tr>
<td>NGOD ERM</td>
<td>All</td>
<td>All</td>
<td>5122 - 5375</td>
<td>3.1.4</td>
<td>20</td>
<td>20</td>
<td>Q020</td>
<td>5700000000</td>
<td>6.95643</td>
<td>12-17</td>
<td></td>
<td>Active</td>
</tr>
<tr>
<td>NGOD ERM</td>
<td>All</td>
<td>All</td>
<td>5377 - 5631</td>
<td>3.2.1</td>
<td>21</td>
<td>21</td>
<td>Q021</td>
<td>5600000000</td>
<td>6.95643</td>
<td>12-17</td>
<td></td>
<td>Active</td>
</tr>
</tbody>
</table>

2. View the following read-only information:

- **QAM Manager** - lists the defined QAM manager for this application. In VOD application, the defined QAM manager can be VOD SRM, NGOD ERM, or ISA SRM. See 3.9.2 Configuring/Viewing QAM-RF Parameters on page 41.

- **GbE Port** - the GbE port routed to this QAM-RF port. The value of this attribute depends on the defined QAM mapping mode. See 4.2.3 Defining Emulation/QAM Mapping Mode on page 60.

- **GbE IP Address** - the GbE IP address port that is routed to the QAM-RF port

- **UDP Port Range** - the UDP port range that is routed to the QAM-RF

- **RF Output** - see 3.9.2 Configuring/Viewing QAM-RF Parameters on page 41

- **QAM Index** - An index number to identify each QAM channel within the 72 available QAM-RF channels of the device. This tab displays the available QAM channels as per the number of QAMs Per Port value.

- **QAM Reference No.** - (Read Only). This parameter indicates the QAM number of the emulated device. This field appears when the device QAM Mapping mode is NSG 8108 bitmap or encoded and NSG 9116 bitmap or encoded.

- **TS ID** - see 3.9.2 Configuring/Viewing QAM-RF Parameters on page 41

- **NGOD Group Name** - see 3.9.2 Configuring/Viewing QAM-RF Parameters on page 41

- **QAM Frequency** see 3.9.2 Configuring/Viewing QAM-RF Parameters on page 41

- **Symbol Rate** - see 3.9.2 Configuring/Viewing QAM-RF Parameters on page 41

- **Interleaver** - see 3.9.2 Configuring/Viewing QAM-RF Parameters on page 41

- **Spectral Inversion** - see 3.9.2 Configuring/Viewing QAM-RF Parameters on page 41

- **Status** - Active or Mute, according to the IF configuration. see 3.9.2 Configuring/Viewing QAM-RF Parameters on page 41
4.3 Broadcast Application

In Broadcast application mode, NSG 9000 allows to route input content to any output, that is to define a session. NSG 9000 allows to create the following types of sessions:

- **Pass through** - to route complete input MPTSs by using the Pass Through tab.
- **Service Remux** - to route specific MPEG services (programs) using the Service Remux tab.
- **PID Remux** - to route individual PIDs using the PID Remux tab.

**NOTE:** VOD application supports barker channels. A VOD session may stream out also a remuxed service or PID.

### 4.3.1 Defining a Passthrough Session

The Pass Through option, allows to output a socket without any changes, that is without remapping and without generating tables. When this option is selected all services in the socket are outputted via the selected output port.

When passing through a TS or a service, you cannot remux a service or a PID included in the pass through TS or service. In addition, you cannot multiplex other input streams to the pass through QAM.

> To configure a pass through a session

**NOTE:** A session is defined as Pass Through during QAM configuration. (See [3.7.4 Configuring/Viewing QAM Channels](#) on page 45). The following procedure guides you on how to define the Pass Through session.

1. Select **Applications** > **Broadcast** > **Pass Through**.

2. Define the following parameters:
   - **Session ID** - Read only. A sequential number starting at 10000, to indicate the number of the session in the current page.
   - **Type** - define whether the session is a Primary or Backup session.
   - **Enable Backup** - see [4.3.1.1 Pass Through Redundancy](#) on page 64.
   - **Active** - by default the primary input socket is the active one. Once you enable a backup socket, check this option to activate the required socket. To view the currently active socket, press <F5>.
   - **Multicast** - select to enable multicast. If selected the IP Address box is cleared.

[Table of definitions]

<table>
<thead>
<tr>
<th>Session ID</th>
<th>Type</th>
<th>Enable Backup</th>
<th>Active</th>
<th>Multicast</th>
<th>Off Part</th>
<th>IP Address</th>
<th>UDP Port</th>
<th>Source IP</th>
<th>RF Output</th>
<th>QAM Frequency</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>10000</td>
<td>Primary</td>
<td>☑</td>
<td>☐</td>
<td>☑</td>
<td>1</td>
<td>192.168.4.22</td>
<td>0.0.0.0</td>
<td>13.1 (12)</td>
<td>54000000Active</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10001</td>
<td>Primary</td>
<td>☑</td>
<td>☐</td>
<td>☑</td>
<td>1</td>
<td>192.168.4.22</td>
<td>0.0.0.0</td>
<td>2.1.4 (12)</td>
<td>54000000Active</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10002</td>
<td>Primary</td>
<td>☑</td>
<td>☐</td>
<td>☑</td>
<td>1</td>
<td>192.168.4.22</td>
<td>0.0.0.0</td>
<td>4.2.2 (15)</td>
<td>54000000Active</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10003</td>
<td>Primary</td>
<td>☑</td>
<td>☐</td>
<td>☑</td>
<td>1</td>
<td>192.168.4.22</td>
<td>0.0.0.0</td>
<td>2.2.4 (16)</td>
<td>54000000Active</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10004</td>
<td>Primary</td>
<td>☑</td>
<td>☐</td>
<td>☑</td>
<td>1</td>
<td>192.168.4.22</td>
<td>0.0.0.0</td>
<td>3.1.3 (19)</td>
<td>54000000Active</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10005</td>
<td>Primary</td>
<td>☑</td>
<td>☐</td>
<td>☑</td>
<td>1</td>
<td>192.168.4.22</td>
<td>0.0.0.0</td>
<td>3.1.4 (20)</td>
<td>54000000Active</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10006</td>
<td>Primary</td>
<td>☑</td>
<td>☐</td>
<td>☑</td>
<td>1</td>
<td>192.168.4.22</td>
<td>0.0.0.0</td>
<td>3.2.3 (21)</td>
<td>54000000Active</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10007</td>
<td>Primary</td>
<td>☑</td>
<td>☐</td>
<td>☑</td>
<td>1</td>
<td>192.168.4.22</td>
<td>0.0.0.0</td>
<td>3.2.4 (24)</td>
<td>54000000Active</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10008</td>
<td>Primary</td>
<td>☑</td>
<td>☐</td>
<td>☑</td>
<td>1</td>
<td>192.168.4.22</td>
<td>0.0.0.0</td>
<td>4.1.3 (27)</td>
<td>54000000Active</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10009</td>
<td>Primary</td>
<td>☑</td>
<td>☐</td>
<td>☑</td>
<td>1</td>
<td>192.168.4.22</td>
<td>0.0.0.0</td>
<td>4.1.4 (28)</td>
<td>54000000Active</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10010</td>
<td>Primary</td>
<td>☑</td>
<td>☐</td>
<td>☑</td>
<td>1</td>
<td>192.168.4.22</td>
<td>0.0.0.0</td>
<td>4.2.2 (31)</td>
<td>54000000Active</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10011</td>
<td>Primary</td>
<td>☑</td>
<td>☐</td>
<td>☑</td>
<td>1</td>
<td>192.168.4.22</td>
<td>0.0.0.0</td>
<td>4.2.4 (32)</td>
<td>54000000Active</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10012</td>
<td>Primary</td>
<td>☑</td>
<td>☐</td>
<td>☑</td>
<td>1</td>
<td>192.168.4.22</td>
<td>0.0.0.0</td>
<td>5.1.3 (35)</td>
<td>57200000Active</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10013</td>
<td>Primary</td>
<td>☑</td>
<td>☐</td>
<td>☑</td>
<td>1</td>
<td>192.168.4.22</td>
<td>0.0.0.0</td>
<td>5.2.3 (39)</td>
<td>57200000Active</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
GbE Port - open the list and select the required input port. Once you define the required GbE port, the IP Address field is updated to display the IP address of the selected port.

In IP Address, enter the IP address of the input GbE port.

In UDP Port, enter the UDP port.

In Source IP, enter the IP address of the upstream device that streams the content to the defined GbE port and socket.

RF Output - Read only. Indicates the output QAM in the following format: X.Y.Z (T) where:
- X – module number (1…9)
- Y – RF port number (1..2)
- Z – channel number (1…4)
- T – QAM index number (1…72)

QAM Frequency - Read only. Indicates the output frequency

Status - Read only. Indicates whether the QAM is active or mute as the following picture shows:

### 4.3.1.1 Pass Through Redundancy

An input socket may have up to two backup input sockets. By default, the first input socket is the primary socket. If it fails, automatically the following configured socket is activated. If the active input socket is the last one in the list and it fails, the redundancy switch is performed manually only. You need to manually switch to another input socket.

<table>
<thead>
<tr>
<th>Session ID</th>
<th>Type</th>
<th>Enable Backup</th>
<th>Active</th>
<th>Multicast</th>
<th>GbE Port</th>
<th>IP Address</th>
<th>UDP Port</th>
<th>Source IP</th>
<th>RF Output</th>
<th>QAM Frequency</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>10002</td>
<td>Primary</td>
<td></td>
<td></td>
<td></td>
<td>1</td>
<td>192.168.4.22</td>
<td></td>
<td>0.0.0.0</td>
<td>2.1.3 (1)</td>
<td>560000000</td>
<td>Active</td>
</tr>
<tr>
<td>10003</td>
<td>Primary</td>
<td></td>
<td></td>
<td></td>
<td>1</td>
<td>192.168.4.22</td>
<td></td>
<td>0.0.0.0</td>
<td>2.1.3 (2)</td>
<td>560000000</td>
<td>Active</td>
</tr>
<tr>
<td>10004</td>
<td>Primary</td>
<td></td>
<td></td>
<td></td>
<td>1</td>
<td>192.168.4.22</td>
<td></td>
<td>0.0.0.0</td>
<td>2.1.3 (3)</td>
<td>560000000</td>
<td>Active</td>
</tr>
</tbody>
</table>

NOTE: Reverting from backup input socket to the primary socket is manual only.

1. Click the Expand all button or link Expand All.
2. Configure the required parameters as explained in To configure a pass through a session on page 63.

To select the active input socket

By default, the first input socket in the list is the active socket. However, you can define any of the configured input sockets to be active.

NOTE: The automatic redundancy switch automatically activates the following configured input socket. If you select the last input socket in the list as the active input socket, the redundancy switch is manual only and you need to select the input socket.
1. To view the currently active input socket, press <F5> to refresh the page.

2. Click Expand.

3. To select another input socket as active, click the required Active button.

---

4.3.2 Defining Service Remux Sessions

You can route a service from any input to any output. You can select whether to output the service with its input ID or to remap it.

When provisioning static sessions through the web client or MCT, session ID starts at 10,000 and you can configure up to 500 sessions only.

**NOTE:** You cannot remux PIDs of remuxed services.

To route a service

1. Select Applications > Broadcast > Service Remux tab:

   - Click Add Session to route a service
   - Click Duplicate, to add a session with definitions exactly as the selected session
   - Click Duplicate Range, to add sessions according to the defined range

2. Click Add Session.

   A row is added to the table with a session ID.

   Session ID- Read only. A sequential number starting at 10000, to indicate the number of the session in the current page.

3. To define the input socket, do the following:
   - Select Multicast, if required. If selected, the IP address is removed from the IP Address box.
   - Select the input GbE Port. Open the GbE Port list to select the required input port. Once you define the required GbE port, the IP Address field is updated to display the IP address of the selected port, unless Multicast is selected.
   - In IP Address, enter the required unicast/multicast IP address of the input port. By default, the IP address of the selected port appears, unless multicast is selected.
   - In UDP Port, indicate the UDP port.
   - In Source IP, view the IP address of the upstream device that streams the content to the defined GbE port and socket.
4. To define the output to stream out the configured service focus on the Output section of the table.

5. To define the output QAM, enter in RF Output the required QAM-RF channel in the following format: X.Y.Z (T) where:
   - X – module number (1…9)
   - Y – RF port number (1..2)
   - Z – channel number (1…4)
   - T – QAM index number (1…72)

6. In Service ID enter the required output service ID. You can output the service with the same input ID number or to remap the service.

   To route a service using the Duplicate button
   
   Once you defined a service and need to route another service with similar configuration, do the following:
   1. In Service Remux page, check the Select box of the required service/session.
   2. Click Duplicate.
      
      The selected row is duplicated and appears as the last row in the table.
   3. Define the required parameters as explained in To route a service on page 65.

   To route a service to a few output ports
   1. In Service Remux page, check the Select box of the required service.
   2. Click Duplicate Range.
      
      The following page appears:

      ![Duplicate Range Dialog](image)

      3. To define the range of the output QAM (logical port number), enter in From QAM and To QAM a number between 1-72 to indicate the beginning and the end of the range, respectively.
   4. Click Done.

   To delete a remuxed service
   1. In Service Remux page, check the Select box of the required service.
   2. Click Delete Selected.

4.3.3 Defining PID Remux Sessions

You can route a PID from any input to any output. You can route up to 8 PIDs to an output, or configure up to 576 PID sessions. You can select whether to add a PMT reference to the PID.

You can route an input PID to a few outputs and remap a PID to output it over different outputs. However, you cannot route a PID to the same output with different remapped PIDs.
The PID 0x10 is reserved for the Network Information Table (NIT). If you remux a PID and remap it to PID 0x10, the PAT points to it as a NIT table PID. NSG 9000 ignores any of the PID 0x10 configuration such as PMT reference and added descriptor.

To route a PID

1. Select Applications > Broadcast > PID Remux.
2. Click Add Session.
   A row is added to the table with a session ID.
   Session ID- Read only. A sequential number to indicate the number of the session in the current page.
3. To define the input socket, do the following:
   - Select Multicast box if required. If selected the IP Address box is cleared.
   - To select the input GbE Port, open the GbE Port list and select the required port. Once you define the required GbE port, the IP Address field is updated to display the IP address of the selected port, unless Multicast is selected.
   - In IP Address, enter the required unicast/multicast IP address of the input port. By default, the IP address of the selected port appears, unless multicast is selected.
   - In UDP Port indicate the UDP port.
   - In Source IP, enter the IP address of the upstream device that streams the content to the defined GbE port and socket.
4. To define the required PID, in Input PID, enter in hexadecimal the required input PID number.
5. To define the output to stream out the configured PID, enter, in RF Output, the required output QAM in the following format: X.Y.Z (T) where:
   X – module number (1…9)
   Y – RF port number (1..2)
   Z – channel number (1…4)
   T – QAM index number (1…72)
6. In Output PID enter the output PID number in hexadecimal. You can output the PID with the same input PID number or to remap the PID.
7. To allow PMT reference, select the PMT Ref box.
   The ES Type field is enabled.
8. If you selected the PMT Reference box, enter the ES Type to stream out the PID. This is the ES type that the PMT table points to. See Standard ES Types and Descriptors on page 118.
9. To add a descriptor, click Descriptor...
   The Descriptor List page opens.
10. Click Add Descriptor.
11. In Descriptor Type and Descriptor Value, enter the required parameters as defined by the MPEG standard.
12. To close the dialog and save configuration, click Done.

To route a PID using the Duplicate button

Once you defined a PID and need to route another PID with similar configuration, do the following:
1. In PID Remux page, check the Select box of the required PID.
2. Click Duplicate.
   The selected row is duplicated and appears as the last row in the table.
3. Define the required parameters as explained in I To route a PID on page 67.

To route a PID to a few output ports

1. In PID Remux, check the Select box of the required PID.
2. Click Duplicate Range.
   The following dialog appears:
   ![Duplicate Range - Web Page Dialog]
3. To define the range of the output QAM (logical port number), enter in From QAM and To QAM a number between 1-72 to indicate the beginning and the end of the range, respectively.
4. To close the dialog and to apply the required range, click Done.
5. Define the required parameters as explained in I To route a PID on page 67.

To delete a remuxed PID

1. In PID Remux page, check the Select box of the required PID. To select all sessions, double click the Select column heading.
2. Click Delete Selected.

4.4 SDV Application

The SDV application includes the following tabs:
- Settings - allows you to set the following:
  - SDV redundancy
  - MPEG related parameters
- QAMs - a read only page to view QAMs settings
- NGOD Active Sessions - lists all the provisioned NGOD sessions. Unavailable for version 2.0
- ISA Active Sessions - lists all the provisioned ISA sessions.

4.4.1 SDV Settings

4.4.1.1 Redundancy

**NOTE:** SDV redundancy is not supported in NSG 9000 version 2.0.

NSG 9000 supports service redundancy that is activated once the device does not detect the service at the input port. Service redundancy is supported in either of the following methods:
- Hot - NSG 9000 JOINs both the primary multicast group and the backup multicast group. Both primary and backup services are streamed to the input ports to allow short fail-over time.
- Warm - NSG 9000 JOINs the primary multicast group only. Once the device does not detect the service at the input, it JOINs the backup multicast group and the fail-over time is longer.

To define SDV redundancy mode
1. Select Applications > SDV > Settings.

<table>
<thead>
<tr>
<th>Redundancy</th>
<th>NGOD Redundancy Mode</th>
<th>Hot / Warm</th>
</tr>
</thead>
<tbody>
<tr>
<td>ISA Redundancy Mode</td>
<td>Hot / Warm</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>MPEG</th>
<th>PID Remapping Method</th>
<th>Paradigm</th>
<th>PID Range (Per TS)</th>
<th>0x1000 - 0x1000</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>PAT Interval (Msec)</td>
<td>200</td>
<td>PMT Interval (Msec)</td>
<td>200</td>
</tr>
<tr>
<td></td>
<td>Update PMT Version</td>
<td>✔</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

2. To set the redundancy mode, do either of the following:
- To set the NGOD redundancy mode, open the NGOD Redundancy Mode list and select one of the modes listed in the Table 4-1: SDV Redundancy Modes table.
- To set the ISA redundancy mode, open the ISA Redundancy Mode list and select one of...
the modes listed in Table 4-1: SDV Redundancy Modes.

Table 4-1: SDV Redundancy Modes

<table>
<thead>
<tr>
<th>Mode</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hot/Warm</td>
<td>The default option. The service has only one redundant service. NSG 9000 JOINs the primary service, and upon failure, JOINs the backup multicast group. As a result, the backup service is streamed from the switch to the input port of the device.</td>
</tr>
<tr>
<td>Hot/Hot</td>
<td>The service has one redundant service. NSG 9000 JOINs both the primary and backup multicast groups and both groups are steamed to the device. Upon failure, the backup service is provisioned to the device resulting in a short fail-over time.</td>
</tr>
<tr>
<td>Hot/Warm/Warm</td>
<td>The service has at least two redundant services. NSG 9000 JOINs the primary multicast group. Upon failure NSG 9000 JOINs the first backup service and as a result the backup service is streamed into the device. If this trial fails, NSG 9000 JOINs the second backup multicast group.</td>
</tr>
<tr>
<td>Hot/Hot/Hot</td>
<td>The service has at least two redundant services. NSG 9000 JOINs all three multicast groups. All three services are streamed to the input ports to allow short fail-over time.</td>
</tr>
</tbody>
</table>

4.4.1.2 Defining MPEG Parameters

See 4.2.2 Defining MPEG Parameters on page 58.

4.4.2 Viewing SDV QAM Parameters

The QAMs parameters allows you to view all of the SDV available QAMs.

1. Select Applications > SDV > QAMs.

2. View the following information.
   - QAM Manager - lists the defined QAM manager. In SDV the QAM manager is ISA.
   - RF Output
   - QAM Index
   - TS ID
   - NGOD Group Name
4.4.3 Viewing NGOD Active Sessions

The NGOD Active Sessions tab lists all the NGOD sessions provisioned to the device.

>To view NGOD active sessions

1. Select Applications > SDV > NGOD Active Sessions.

2. To view the currently provisioned session, click Refresh Sessions.

3. View the following information:
   - On Demand Session ID - a unique session ID generated by the NGOD system.
   - Session ID - a unique session ID generated by the NSG 9000-6G device.
   - RF Output - the output QAM-RF channel through which the service is streamed out of the device.
   - Service ID - the ID of the output service
   - NGOD Group Name - the QAM group name.
   - GbE Port - indicates the GbE input port of the incoming service.
   - Destination IP - the IP address (unicast or multicast) of the input session.
   - UDP Port - the UDP port of the input session.

4. To view further information, click Details.
The following dialog appears:

<table>
<thead>
<tr>
<th>Session Information</th>
<th>Web Page Dialog</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>On Demand Session ID</strong></td>
<td>b4d52f25-02c1-11ea-8b-1</td>
</tr>
<tr>
<td><strong>Session ID</strong></td>
<td>123300</td>
</tr>
<tr>
<td><strong>Session Group</strong></td>
<td>42</td>
</tr>
</tbody>
</table>

**Output**

<table>
<thead>
<tr>
<th>TS ID</th>
<th>Service ID</th>
</tr>
</thead>
<tbody>
<tr>
<td>123</td>
<td>456</td>
</tr>
</tbody>
</table>

**Input Redundancy**

<table>
<thead>
<tr>
<th>GbE Port</th>
<th>Input Service ID</th>
<th>Multicast IP Address</th>
<th>UDP Port</th>
<th>Source IP Address</th>
<th>Active</th>
</tr>
</thead>
<tbody>
<tr>
<td>123</td>
<td>123</td>
<td>123.45.67.89</td>
<td>456</td>
<td>789</td>
<td>False</td>
</tr>
</tbody>
</table>

5. **View the following session information:**
   - On Demand Session ID - a unique session ID generated by the NGOD system.
   - Session ID - a unique session ID generated by the NSG 9000-6G device.
   - Session Group - an optional field. A value given by the ERM for managing the session list length.

6. **View the following Output information:**
   - TS ID- the ID of the output TS that carries the output session.
   - Output Service ID - the ID of the output service.

7. **View the following Input Redundancy information:**
   - # - a sequential number to indicate the number of the listed input redundancy ports.
   - GbE Port - indicates the number of the input GbE port.
   - Input Service ID - indicates the ID of the input service
   - Multicast IP Address - the multicast IP address of the input service
   - UDP Port - the UDP port of the input service
   - Source IP Address - indicates the IP address of the broadcasting device.
   - Active - indicates whether this input port is currently active. The row of the active port is darker.

### 4.4.4 Viewing ISA Active Sessions

The ISA Active Sessions tab lists all the ISA sessions provisioned to the device.

To view ISA active sessions
1. Select Applications > SDV > ISA Active Sessions.

2. To view the currently provisioned sessions, click Refresh Sessions.

3. View the following information:
   - Session ID - a unique session ID generated by the NSG 9000-6G device.
   - RF Output - the output QAM-RF channel through which the service is streamed out of the device.
   - Service ID - the ID of the output service
   - GbE Port - indicates the GbE input port of the incoming service.
   - Destination IP Address - the input IP address (multicast/unicast) of the service
   - UDP Port - the input UDP port

4. To view further information, click Details.

   The following dialog appears:

   5. View the following session information:
      - Session ID - a unique session ID generated by the NSG 9000-6G device.
      - Bitrate - the bitrate of the session.

6. View the following Output information:
TS ID - the ID of the output TS that carries the output session.
Service ID - the ID of the output service.
No PID Remap - indicates whether PID remapping is applied.

7. View the following Input Redundancy information:

# - a sequential number to indicate the number of listed input redundancy ports.
GbE Port - indicates the number of the input GbE port.
Input Service ID - the ID of the input service
IP Address - the IP address of the input service
UDP Port - the UDP port of the input service
Source IP Address - indicates the IP address of the broadcasting device.
Active - indicates whether this input port is currently active. The row of the active port is darker.

4.5 M-CMTS Application

When NSG 9000-6G is integrated in an M-CMTS system, do the following:
- Create an M-CMTS session by defining the QAM Manager as M-CMTS
- Configure the session - When you configure an M-CMTS session, you choose to output a socket without any changes, that is without remapping and without generating tables.

➢ To create an M-CMTS session
1. Select Platform > General tab.
2. select the required slot.
3. Select the QAMs tab.
4. For the required RF Output, open the QAM Manager list and select M-CMTS.

Once you select Applications > M-CMTS tab, the M-CMTS sessions appear and you can define their parameters.

➢ To configure an M-CMTS session

When you configure a session, select the required input port and route it to the required output as instructed below:
1. Select Applications > M-CMTS tab:

Sessions appear in the table according to your QAM configuration in Platform > General > Slot > QAMs. Each session appears with a unique session ID.

Session ID- Read only. A sequential number starting at 10000, to indicate the number of the session in the current page.

NOTE: Steps 2&3 are relevant to primary DS channels only. In case of wideband sessions, move to step 4.

2. Relevant to primary DS channels only - To synchronize with the DTI time, select DTI Sync Restamping. The EdgeQAM re-stamps the DTI sync packets.

3. Relevant to primary DS channels only - In DOCSIS Sync Compensation, enter the sync compensation. The CMTS core router automatically inserts DOCSIS sync packets into the primary DS QAM channels. To ensure the accuracy of the DOCSIS sync packets, the EdgeQAM re-stamps them. Depending on RF network topology, it may be required to fine-tune the sync messages that flow over the various QAM channels of the EdgeQAM. The fine-tuning ensures consistent timing of CMs across all cable interfaces of the system. To fine-tune the sync offset across cable interfaces, use the DOCSIS Sync Compensation option. The sync offset units are ticks of the CMTS 10.24 MHz clock, where 1 tick=97.6 nano-sec. The typical allowed offset difference between modems is +/- 6 ticks. To define the sync compensation value, measure the average Cable Modem (CM) timing offset difference (you can view the timing offset values via the CMTS console) and calculate the desired compensation value for the QAMs of the port. Typically, the compensation value of adjacent QAMs in the port is identical for each QAM in the port.

4. To select the input GbE Port, open the GbE Port list and select the required port. Once you defined the required GbE port, the GbE IP Address box is updated to display the IP address of the selected port.

5. In GbE IP Address, enter the IP address of the GbE input port.

6. In L2TP Session ID, enter the required session ID.

7. View the following Read-only information:
   - In RF Output, view the QAM channel to output the session where:
     X – module number (1…9)
     Y – RF port number (1..2)
     Z – channel number (1…4)
   - QAM Index - see 3.7.4 Configuring/Viewing QAM Channels on page 45.
   - Interleaver - see 3.7.4 Configuring/Viewing QAM Channels on page 45.
4.6 **D2E Application**

The Direct to Edge (D2E) application is for future use only.

When NSG 9000-6G is operating as part of a D2E system, configure it in the same manner as a regular Wideband M-CMTS application:

- Set the QAM manager for the relevant QAMs to M-CMTS
- Configure the sessions as regular Wideband M-CMTS sessions
4.6.1 Viewing ISA Active Sessions

The ISA Active Sessions tab lists all the ISA sessions provisioned to the device.

To view ISA active sessions

1. Select Applications > SDV > ISA Active Sessions.
   The ISA Active Sessions page appears.
2. To view the currently provisioned sessions, click Refresh Sessions.
3. View the following information:
   - Session ID - a unique session ID generated by the NSG 9000 device.
   - RF Output - the output QAM-RF channel through which the service is streamed out of the device.
   - Service ID - the ID of the output service
   - GbE Port - indicates the GbE input port of the incoming service
   - Destination IP Address - the input IP address (multicast/unicast) of the service
   - UDP Port - the input UDP port
   - Active Source IP - indicates the IP address of the upstream broadcasting device.
4. To view further information, click Details.
   The following dialog appears:
5. View the following session information:
   - Session ID - a unique session ID generated by the NSG 9000 device.
   - Bitrate - the bitrate of the session.
   - Time Created - the time the session was generated
6. View the following Output information:
   - TS ID - the ID of the output TS that carries the output session.
   - Service ID - the ID of the output service.
   - No PID Remap - indicates whether PID remapping is applied.
7. View the following Input Redundancy information:
# - a sequential number to indicate the number of listed input redundancy ports.
GbE Port - indicates the number of the input GbE port.
Input Service ID - the ID of the input service
IP Address - the IP address of the input service
UDP Port - the UDP port of the input service
Source IP Address - indicates the IP address of the broadcasting device.
Active - indicates whether this input port is currently active. The row of the active port is darker.
5.1 CAS Overview

The Conditional Access System (CAS) prevents unauthorized viewing of programs by scrambling services that later on can be decrypted using the correct decrypting key.

NSG devices support the following CAS modes:
- DVB SCR scrambling - an encryption mode for the DVB protocol.
- Privacy Mode - an encryption mode developed by Motorola Inc.

**NOTE:** In NSG 9000 you can configure both CAS options at the same time. The configuration is applied to the devices according to the granted license.

5.1.1 DVB SCR Scrambling Overview

A typical CAS is comprised of a few elements. The NSG 9000 includes the SCS, CWS and scrambling modules. Following is a short description of the CAS elements.

- Event Information Scheduler (EIS) - in charge of all of the headend’s schedule information and the CAS configuration to ensure that services are encrypted correctly. It initiates the Scrambler Control Group (SCG) message, the actual request sent by the EIS to the NSG 9000 that encryption is required. The SCG message includes the service ID, time slot and the access criteria.
- SimulCrypt Synchronizer (SCS) - controls and manages the scrambling parameters to allow encryption. It receives requests for encryption and passes them on to the Control Word (CW) generator. Once a CW is initiated the SCS passes it to ECMG.
- Control Word Server (CWG) - generates the encryption key.
- Scrambling Unit - encrypts the services.
- Entitlement Control Message Generator (ECMG) - receives control words and access criteria and generates an Entitlement Control Message (ECM) stream in return.
The EIS sends the NSG 9000 an SCG message, a request to encrypt a service component. In turn, the NSG 9000 sends a message to the ECMG which contains the following:

- Control Word (CW) - the encryption key generated by the NSG 9000.
- Crypto Period (CP) - indicates (in seconds) how often the NSG 9000 generates a new CW.
- Access Criteria (ACC) - a permission to access the service.

The ECMG generates an ECM stream that is sent to the NSG 9000 and is added to the TS.

5.1.2 Privacy Mode Scrambling Overview

Privacy Mode is a real-time encryption method which was developed by Motorola and licensed to Harmonic for VOD applications. Privacy Mode requires an MCT machine which serves as the Privacy Mode ERS proxy as the following illustration shows:

![Privacy Mode Illustration]

When using Privacy Mode scrambling, the only additional configuration that is required within the NSG web client is to enable CAS and to set the behavior upon ECM expiration. However, Privacy Mode also requires an MCT machine which serves as the Privacy Mode ERS proxy. For information on how to configure Privacy Mode parameters in MCT, refer to the MCT User’s Guide.

5.2 Defining Global CAS Parameters

➔ To set global CAS parameters, do the following:

1. Select Applications > CAS. The following tab opens.
2. In CAS Properties, open the Encryption Mode (DVB-PM) list and select either of the following:
   - DVB Scrambling - an encryption mode for the DVB protocol.
   - Privacy Mode Scrambling - an encryption mode developed by Motorola Inc.

3. To enable CAS, select the CAS Enable box.
   The fields of the selected encryption mode are enabled.

5.3 Defining DVB Scrambling Parameters

Once you selected the DVB Scrambling mode, and enabled the CAS, move to the DVB Settings section and do the following:

1. In CP Duration (Sec), enter the required value. By default it is 15 seconds. The Crypto Period defines how often the NSG changes the control word (or "key") for encrypted services. Valid values range between 1-6554.

2. In ECMG Failover Retries, define the number of times the NSG 9000 unit tries to establish communication with the Entitlement Control Message Generator (ECMG) before issuing the alarm ECMG Connection Failure.

3. In CA Descriptor Location, select a location in the PMT for the CA descriptor. The CA descriptor may appear either in a service or elementary level or in both levels.

4. Open the DVB Scrambling Mode box and select either of the following:
   - Session based - the EIS is external and it issues an SCG for each service for which encryption is required. When selected, the DVB Session based features are enabled.
   - Tier based - all services are scrambled with the same control word and ECM and there is no external EIS. Once selected, the DVB Tier Based features are enabled.
5.3.1 Defining DVB Session Based Parameters

Once you selected this option in DVB Scrambling Mode, define the session based parameters as follows:

1. In **TS ID Provisioning**, select how to generate the TS ID to be provisioned:
   - Direct - The default option. The provisioned TS ID is the same as the output TS ID.
   - By QAM Index - The provisioned TS ID is according to the QAM number that is a number between 1-72.

2. In **EIS SCS Port Number**, define the TCP port through which NSG communicates with the EIS. Valid values range between 1-65535.

3. In **Clear to Scramble (Sec)** enter the clear time in seconds before starting to scramble the service, once the SCG is received. Valid values range between 0-9999. The default value is 0 seconds.

5.3.2 Defining DVB Tier Based Parameters

Once you selected this option in DVB Scrambling Mode, define the tier based parameters as follows:

1. Select **Block Upon Failure**, to allow the device to block the stream to protect the content. When a stream is blocked, no picture appears on the end user screen. This action takes place in case the NSG 9000 could not establish communication with the ECMG.

2. In **Failed to Scramble Timeout (Sec)**, define the period of time between outputting the service and recognizing CAS failure. When CAS failure is recognized the following takes place:
   - Scrambling with the last available ECM
   - Block the stream. Applies in case ECM is not available and Block Upon Failure is selected.
   - Outflow a clear stream. Applies in case ECM is not available and Block Upon Failure is not selected.

3. NSG 9000 version 1.6 and up supports SimulCrypt in DVB Tier Based mode. To configure the ECMs, enter the required values in the ECM Group table as explained below. You can add up to three ECM groups:
   - **ECM PID** - enter the ECM PID.
Super CAS ID - enter the Super CAS ID of the ECMG as provided by the vendor.
Access Criteria - enter an access criteria as provided by the vendor.

### 5.3.3 Viewing EIS Information

You can work with multiple EIS devices. The EIS tab lists all EIS connected to the device:

To view EIS log
1. Select Applications > CAS > EIS tab.
2. To update the listed information, click Refresh.
3. View the following information:
   - Date - indicates the date of connection between the NSG and the EIS.
   - Time - indicates the time of connection.
   - Channel ID - indicates the channel of communication between the NSG and the EIS.
   - Description - shortly describes the connection (setup, closed).
   - State - indicates the current status of the NSG and EIS connection.

### 5.3.4 Defining ECMGs and NSG 9000 Communication Parameters

This section instructs you on how to define the ECMG & NSG 9000 communication parameters.

To define ECMGs
1. Select Applications > CAS > ECMG. The ECMG page appears. Each row in the page represents an ECMG. You can define up to 10 ECMGs.

2. Define the communication parameters according to the following explanation:
   - Active - Check the box in the left most column to make the current ECMG active.
   - Name - Enter the name of the ECMG brand.
Priority - to allow redundancy, set priority by indicating the primary and secondary ECMG of the same SuperCasID. In case of ECMGs with the same SuperCasID, NSG 9000 always tries to connect first to the ECMG with the highest priority. Assign priority from 1-10 with 1 as the highest priority.

SuperCasID (Hex) - A 32-bit hexadecimal number that consists of the 16-bit CA vendor ID and an additional 16-bit number that distinguishes one ECM generator from another for the same CAS vendor. The super CAS ID determines which access criteria is coupled with each ECMG. The CAS vendor provides this value.

Protocol Revision - Specifies the CAS mode of operation. Select Revision 1, 2 or 3 for SimulCrypt Ver. 1, 2 or 3 respectively.

IP Address - The IP address of the ECMG. The CAS vendor provides this value.

Port - The number (in decimal format) of the TCP port used to connect the ECMG. The CAS vendor provides this value.

Channel ID - indicates the channel of communication between the NSG and the ECMG.

Status - Indicates the state of the connection:
- Connected - The ECMG and NSG are communicating.
-Disconnected - No communication is taking place at the moment.

5.3.5 Viewing CAS Status

5.3.5.1 Viewing the SCG Parameters

1. Select Applications > CAS > SCGs tab. The SCG page appears.

<table>
<thead>
<tr>
<th>SCG ID</th>
<th>CP Number</th>
<th>TS ID/QAM Index</th>
<th>Service ID</th>
<th>State</th>
<th>Access Criteria</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>135</td>
<td>32767</td>
<td>1</td>
<td>Scrambling</td>
<td>00:01:00:02</td>
</tr>
</tbody>
</table>

The following information is listed:

Number of SCGs - indicates the number of listed SCGs.

SCG ID - The ID number of the SCG.

CP Number - A running counter of the number of Crypto Periods. It indicates the number of times the ECM has been changed for this stream.

TS ID/QAM Index - The stream that carries the service to be encrypted as sent by the EIS.

Service ID - The ID of the program/service being scrambled using the specific SCG.

State - Indicates the status of the service as follows:
- Scrambling - Indicates that the service is encrypted.
- Clear - Indicates that scrambling failed.

Access Criteria - shows all access criteria as provided by the vendor.

2. Click Refresh to update the information in the SCG table.

5.3.5.2 Viewing ECM Parameters

The Entitlement Control Message (ECM) page provides information about the ECM stream that is sent to the NSG and is added to the TS.
1. Select Applications > CAS > ECMs tab. The ECM page appears and you can view the following information:

   Number of ECMs - indicates the number of listed ECMs.
   Stream ID - The ID number of the stream.
   ECM ID - The ID of the ECM as sent by the EIS.
   SuperCasID - Identifies the ECMG that encrypts this program. This number is provided by the CAS vendor.
   SCG ID - The ID of the SCG that requested the ECM stream.

2. Click Refresh to update the information.

### 5.4 Defining Privacy Mode Scrambling Parameters

1. Select Applications > CAS > Privacy Mode Settings section.

   ![Privacy Mode Settings](image)

2. Open the Stream Processing on ECM Expiration list and select either of the following:
   - Scramble with Last ECM - All NSGs of the VODS should be updated with the new ECM.
   - Don’t Scramble - do not scramble the stream.

   **TIP:** Once provisioning/multiplexing is complete, enable the RF ports. See 3.9.1 Configuring Module RF Ports on page 38.
6.1 Monitoring the NSG 9000 Overview

Monitoring the NSG 9000 comprises the following two aspects:

- Monitoring the device utilization
- Monitoring the device status

6.2 Device Utilization

The Traffic tab displays a read-only information about the output streams of the device. This information is displayed in the following views:

- **Service View** - default view. It displays the output services running over each QAM-RF channel.
- **Bitrate View** - displays the actual bit rate of each active QAM-RF channel.
- **Output view** - displays information on the selected output content. See 6.2.4 Viewing Output Information on page 91.
- **Input view** - displays the number of incoming services and the current frequency. See 6.2.3 Viewing Input Information on page 90.

The Service and Bit rate view pages are divided into nine sections. Each section represents a QAM-RF module with both output ports and QAM-RF channels. Each section includes the following:

- **Module Number** - displayed as a link. Once you click it, the Module Traffic page opens. When the module is assigned but no module is mounted in the slot, the module number appears with (Card Missing) indication.
- **RF Port Number** - displayed as a link. Once you click it, you can view the selected module global configuration and the configuration of the RF parameters. See 6.2.2 Viewing RF Parameters on page 90.
Bar graph - represents the output TSs of each RF port. Each RF port is represented by a unique color. The available colors are as follows:

**Table 6-1: Bar Graph Colors**

<table>
<thead>
<tr>
<th>Color</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Orange</td>
<td>Service based traffic - VOD, SDV, NGOD and ISA</td>
</tr>
<tr>
<td>Dark red</td>
<td>Pass Through sessions</td>
</tr>
<tr>
<td>Dark grey</td>
<td>M-CMTS sessions</td>
</tr>
<tr>
<td>Light grey</td>
<td>D2E sessions (for future use only)</td>
</tr>
</tbody>
</table>

The number at the top of each bar, indicates the following:

- **Service view** - the amount of services output in that TS.
- **Bitrate view** - the actual bit rate in Mbps.

Each bar is labeled in the following pattern x.y.z where:

- x - module number
- y - RF port number
- z - RF channel number

For example: bar 1.2.2 presents output traffic of module 1, output via RF 2 port, channel 2.

**NOTE:** Hover the mouse pointer over the bar to view the QAM-RF manager. Hover the mouse pointer over the bar label to view the service ID and its frequency.

The following figure shows a section of the Service view:
The following figure shows the same section in Bitrate view:

Module number. Click the link to view module traffic information
QAM-RF port
Actual bit rate
Output module, port, channel and QAM index
Hovering pointer over a bar, a tool tip with the bit rate appears
Hovering pointer over the module, a tool tip with further information appears
6.2.1 Viewing Traffic

The Module Traffic page displays all the services outputted via each QAM-RF channel together with detailed information on each service.

To view the traffic streamed out of the device in a bar graph display:
1. Select Monitoring > Service View/Bitrate View.
2. Click Module #.

The following page opens. It shows the traffic flowing via RF port 1 of module 1:

3. To view detailed information about a service, select the required service in the bar graph.

The following page opens. It shows the traffic flowing via RF port 1 of module 1 with detailed information regarding service 5 of QAM-RF 1.1.1:

---

**NOTE:** Currently, the Module Traffic page shows only eighteen services per channel.

You can view traffic also via the Input view and Output View pages.
2. To view updated information, click Refresh Output/Input Information.
3. View the following service related information:

**NOTE:** PID appears in Hex. and in decimal in the following pattern: Hex. (Decimal.)

- Service ID - Read Only. The ID number of the service.
- Port:IP - The number of the input port and its IP address.
- UDP Port - The UDP according to the source configuration.
- PMT Ver - The version of the PMT PID
- PMT PID - The PID over which the service’s Program Map Table (PMT) is transmitted.
- PCR PID - The PID of the service’s Program Clock Reference (PCR).
- ECM PID - The PID of the Entitlement Control Message (ECM). In case of simulcrypt, indicates all ECM PIDs.

The following picture shows the Output view tab:

See also 6.2.4 Viewing Output Information on page 91.

### 6.2.2 Viewing RF Parameters

1. Select Monitoring > Service View/Bitrate View.
2. Click RF #.

The following page opens.

3. In Module # Properties, view module parameters.
4. In RF Parameters, view RF parameters.

### 6.2.3 Viewing Input Information

To view the number of incoming services and the input bitrate, do the following:
1. Select Monitoring > Input View tab.
2. View the required information.

6.2.4 Viewing Output Information

1. Select Monitoring > Output View tab.

2. Open the Output Module list and select the required QAM-RF module.
3. In the tree view, do one of the following:
   - To view TS related information, select the required TS.
   - Drill down to the required service and select it.
4. View the required information. The following information appears:

**TS Information**
- QAM Manager
- Serving Area
- NGOD QAM Group Name
- Input Source
- UDP Port Range
- ASI Forwarding

**Service Information**
- Service ID
- Port:IP
- UDP Port
- PMT PID
- PMT Ver
- Source IP
- Service Descriptors
- PID Descriptors

**PI Information**
- Orig PID
- Remap PID
- PID Type
- Language
- PMT Reference
- PCR PID
- ES Descriptors

<table>
<thead>
<tr>
<th>TS</th>
<th>Service/service Remux</th>
<th>PID</th>
<th>PID Remux</th>
</tr>
</thead>
<tbody>
<tr>
<td>QAM Manager</td>
<td>Service ID</td>
<td>Orig PID</td>
<td>Orig PID</td>
</tr>
<tr>
<td>Serving Area</td>
<td>Port:IP</td>
<td>Remap PID</td>
<td>Remap PID</td>
</tr>
<tr>
<td>NGOD QAM Group Name</td>
<td>UDP Port</td>
<td>PID Type</td>
<td>PID Type</td>
</tr>
<tr>
<td>Input Source</td>
<td>PMT PID</td>
<td>Language</td>
<td>PMT Reference</td>
</tr>
<tr>
<td>UDP Port Range</td>
<td>PCR PID</td>
<td>ES Descriptors</td>
<td>ES Descriptors</td>
</tr>
<tr>
<td>ASI Forwarding</td>
<td>ECM PID</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>PMT Ver</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Source IP</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Service Descriptors</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

5. View the required information.
6.3 Monitoring NSG 9000 Status and Alarms

When ever the NSG 9000 detects an internal failure or problems related to the input/output streams, it asserts an alarm to indicate the specific failure. The alarms are exhibited as follows:

Table 6-2: Alarm Exhibition

<table>
<thead>
<tr>
<th>Component</th>
<th>Reaction Upon Malfunction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Front Panel</td>
<td>The Alarm LED is illuminated in red when an alarm is issued and in orange when a warning is issued.</td>
</tr>
</tbody>
</table>
| Web client | - The alarm indicator turns red  
- The number of active alarms is updated  
- A message appears notifying you of the nature of the problem |
| NMX | Alarm is issued in the NMX alarm manager |

6.3.1 Viewing Alarms Via the Web Client

The Active Alarms tab allows you the following:

- View the alarms/warnings
- Save active alarm log as an XML file
- Configuring the alarms

To view alarms in the web client

1. Select Monitoring > Alarms > Active Alarms.

2. View the alarms. You can also save the alarm log as an XML file. The alarms are listed with the following parameters:

   - # - index number of the alarm.
   - Module - the faulty component.
   - Description - describes the fault that invoked the alarm. Red color entry - indicates an alarm, orange color entry - indicates a warning.

**NOTE:** You may view the alarms also by moving the mouse pointer to the Alarm indicator located in Title bar. A window opens displaying the current alarms.
To save active alarms log to file
1. Select Monitoring > Alarms > Active Alarms.
2. Click Export.
3. Browse to the required location and click Save.

### 6.3.2 Alarm List

The following table lists the alarms of NSG 9000 according to the module that issues the alarm. The alarms are arranged in alphabetical order with a short description and a solution to remit the alarm. Alarms with a star are NOT reflected in NMX.

<table>
<thead>
<tr>
<th>Alarm Message</th>
<th>Trigger Device Redundancy</th>
<th>Description</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Platform</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>DTI Card Missing</td>
<td>Yes</td>
<td>DTI card is not installed in the device</td>
<td>Install DTI card</td>
</tr>
<tr>
<td>Fan X Failure</td>
<td>No</td>
<td>Fan X (x= 1-4) is malfunctioning.</td>
<td>Replace the fan as instructed in the HW User’s Guide.</td>
</tr>
<tr>
<td>Front Panel Communication Failure</td>
<td>No</td>
<td>Cannot establish communication with the control panel module.</td>
<td>1. Replace the front panel. 2. Replace the Processing module. 3. Call Customer Support.</td>
</tr>
<tr>
<td>Front Panel Missing</td>
<td>No</td>
<td>Front panel is missing.</td>
<td>Verify that the front panel is fastened securely to its place.</td>
</tr>
<tr>
<td>High Temperature Failure</td>
<td>Yes</td>
<td>The unit is overheating Raised when board FPGA processor temperature &gt;= 80°C, or board CPU temperature &gt;= 75°C.</td>
<td>Check front panel connection and the speed of the fans.</td>
</tr>
<tr>
<td>LCD Communication Failure</td>
<td>No</td>
<td>Cannot establish communication with the LCD panel.</td>
<td>1. Replace the front panel. 2. Replace the Processing module. 3. Call Customer Support.</td>
</tr>
<tr>
<td>NGOD D6 Connection Loss</td>
<td>No</td>
<td>NGOD VREP0-R6 client has lost connection and there are live SDV sessions within the NSG.</td>
<td>Check the Ethernet connection to the R6 client.</td>
</tr>
<tr>
<td>No Input Traffic</td>
<td>Yes</td>
<td>All configured and enabled GbE ports receive no input data.</td>
<td>Check source.</td>
</tr>
<tr>
<td>Power Supply X Failure</td>
<td>Yes</td>
<td>Power supply (x= 1-2) is malfunctioning.</td>
<td>Replace power supply unit.</td>
</tr>
<tr>
<td>System Voltage Error</td>
<td>Yes</td>
<td>Invalid voltage is detected in the device</td>
<td>1. Reboot the device. 2. If persists, call Customer Support.</td>
</tr>
<tr>
<td>Temp/Voltage Communication Error</td>
<td>No</td>
<td>Cannot read the temperature or voltage.</td>
<td>Call Customer Support.</td>
</tr>
<tr>
<td>Slot</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Card Missing*</td>
<td>Yes</td>
<td>No module is mounted in the slot and the corresponding RF port is enabled.</td>
<td>1. Disable the RF port. 2. Mount a module in the slot. 3. Enable the corresponding RF port.</td>
</tr>
<tr>
<td>Alarm Message</td>
<td>Trigger Device Redundancy</td>
<td>Description</td>
<td>Solution</td>
</tr>
<tr>
<td>-----------------------</td>
<td>---------------------------</td>
<td>----------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Card Mismatch*</td>
<td>No</td>
<td>Mismatch between the mounted module and the sent configuration.</td>
<td>Check configuration or mounted module.</td>
</tr>
<tr>
<td>GbE Port</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>CRC Error</td>
<td>No</td>
<td>At least one packet has CRC error</td>
<td>Check the switch, fiber, and copper connections. Check source (input or output).</td>
</tr>
<tr>
<td>ETH Buffer Overflow</td>
<td>No</td>
<td>Management traffic on the GbE port exceeds the port’s capacity.</td>
<td>Check sources for excessive management traffic.</td>
</tr>
<tr>
<td>Invalid Input Packet</td>
<td>No</td>
<td>The payload length of an input UDP packet is not divisible by 188 bytes a standard length of an MPEG packet</td>
<td>Check source.</td>
</tr>
<tr>
<td>L2TPv3 Sequence Error</td>
<td>No</td>
<td>The sequence number of L2TP frames is not sequential, which means that some L2TP frames were dropped in the input.</td>
<td>Check input source.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>▪ Check switch.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>▪ Check fiber and copper connections.</td>
</tr>
<tr>
<td>No Input Traffic on Port</td>
<td>Yes</td>
<td>No input data on a configured and enabled GbE port</td>
<td>Check source</td>
</tr>
<tr>
<td>SFP Link Down</td>
<td>Yes</td>
<td>Problematic link to the SFP.</td>
<td>Verify that the fiber is connected properly to the SFP.</td>
</tr>
<tr>
<td>SFP Missing</td>
<td>Yes</td>
<td>The SFP connector is missing from the GbE port.</td>
<td>Check that the SFP connector is fully inserted.</td>
</tr>
<tr>
<td>GbE Card</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>GbE Controller Failure</td>
<td>Yes</td>
<td>PHY ID Error; instable communication with GbE module.</td>
<td>1. Reset unit. 2. If problem persists, call Customer Support.</td>
</tr>
<tr>
<td>MPEG Buffer Overflow</td>
<td>No</td>
<td>Buffer is overloaded with too high bit rate</td>
<td>Reduce bit rate.</td>
</tr>
<tr>
<td>General HW Failure</td>
<td>No</td>
<td>GbE module fatal error.</td>
<td>Call Customer Support</td>
</tr>
<tr>
<td>TS Out</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>TS Out Overflow</td>
<td>No</td>
<td>The actual output bit rate exceeds the configured QAM output bit rate.</td>
<td>Deprovision several services of the specific output until the alarm clears.</td>
</tr>
<tr>
<td>TS In GbE Socket</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>PAT Corrupted*</td>
<td>No</td>
<td>Invalid PAT</td>
<td>Check source.</td>
</tr>
<tr>
<td>PAT Missing*</td>
<td>No</td>
<td>PAT is missing in input signal.</td>
<td>Check source.</td>
</tr>
<tr>
<td>PMT Corrupted*</td>
<td>No</td>
<td>Invalid PMT</td>
<td>Check source.</td>
</tr>
<tr>
<td>PMT Missing*</td>
<td>No</td>
<td>PMT is missing in input signal.</td>
<td>Check source.</td>
</tr>
<tr>
<td>Socket Passthrough Source Failure</td>
<td>No</td>
<td>Socket passthrough is missing in input signal</td>
<td>Check source.</td>
</tr>
<tr>
<td>PID Remux Source Failure</td>
<td>No</td>
<td>The PID is missing in input signal</td>
<td>Check source.</td>
</tr>
<tr>
<td>Alarm Message</td>
<td>Trigger Device Redundancy</td>
<td>Description</td>
<td>Solution</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------------------</td>
<td>------------------------------------------------------------------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>CVOD</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Invalid UDP Detected*</td>
<td>No</td>
<td>The UDP is destined to an invalid output port</td>
<td>Check source.</td>
</tr>
<tr>
<td>Session</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Service Missing*</td>
<td>No</td>
<td>Service is missing in input signal</td>
<td>Check source.</td>
</tr>
<tr>
<td>QAM-RF Module</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Initialization Failure</td>
<td>Yes</td>
<td>Card initialization failed because the actual card is different than the assigned card.</td>
<td>Replace module, or assign proper configuration</td>
</tr>
<tr>
<td>Communication Failure</td>
<td>Yes</td>
<td>The device cannot communicate with the QAM-RF module</td>
<td>1. Check that the module is properly inserted</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>2. Assign the module</td>
</tr>
<tr>
<td>Critical Error</td>
<td>Yes</td>
<td>Internal fatal error in the QAM-RF modules</td>
<td>1. Re-install the module</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>2. If problem persists, call Customer Support.</td>
</tr>
<tr>
<td>Processing Error</td>
<td>Yes</td>
<td>QAM-RF global error</td>
<td>Replace module</td>
</tr>
<tr>
<td>Temperature Out of Range</td>
<td>Yes</td>
<td>The temperature is out of the defined range</td>
<td>Call Customer Support</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Module temperature $\geq$ 85°C.</td>
<td></td>
</tr>
<tr>
<td>QAM Channel</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>QAM License Missing</td>
<td>Yes</td>
<td>The QAM License is either expired or is not granted.</td>
<td>Request a QAM license</td>
</tr>
<tr>
<td>PM License Missing</td>
<td>Yes</td>
<td>The Privacy Mode license is either expired or is not granted.</td>
<td>Request a PM license</td>
</tr>
<tr>
<td>SCR License Missing</td>
<td>Yes</td>
<td>The DVB scrambling license is either expired or is not granted.</td>
<td>Request a DVB scrambling license</td>
</tr>
<tr>
<td>DOCSIS QAM + DTI Sync License Missing</td>
<td>Yes</td>
<td>This license is either expired or is not granted.</td>
<td>Request this license</td>
</tr>
<tr>
<td>DOCSIS QAM License Missing</td>
<td>Yes</td>
<td>The DOCSIS QAM license is either expired or is not granted.</td>
<td>Request a DOCSIS QAM license</td>
</tr>
<tr>
<td>RF port</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Communication Failure</td>
<td>Yes</td>
<td>The device can not communicate with the upconverter.</td>
<td>1. Reset unit</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>2. Replace the module</td>
</tr>
<tr>
<td>RF Level Out of Range</td>
<td>No</td>
<td>The power level of the RF signal going into the upconverter is out of the allowed range.</td>
<td>Call Customer Support</td>
</tr>
<tr>
<td>PLL1 Failure</td>
<td>Yes</td>
<td>Indicates a HW failure</td>
<td>Replace the module</td>
</tr>
</tbody>
</table>
### Monitoring NSG 9000 Status and Alarms

#### Alarm Message

<table>
<thead>
<tr>
<th>Alarm Message</th>
<th>Trigger Device Redundancy</th>
<th>Description</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>PLL2 Failure</td>
<td>Yes</td>
<td>Indicates a HW failure</td>
<td>Replace the module</td>
</tr>
<tr>
<td>Power Supply Failure</td>
<td>Yes</td>
<td>Power level to the upconverter momentarily exceeded limits.</td>
<td>Call Customer Support</td>
</tr>
<tr>
<td>Software Failure</td>
<td>Yes</td>
<td>Indicates a failure of the RF software.</td>
<td>Replace the module</td>
</tr>
</tbody>
</table>

#### CAS Privacy Mode

<table>
<thead>
<tr>
<th>Alarm Message</th>
<th>Trigger Device Redundancy</th>
<th>Description</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>ECM Expired</td>
<td>No</td>
<td>ECM Expired</td>
<td>Update PM ECM via MCT.</td>
</tr>
<tr>
<td>ECM Missing</td>
<td>No</td>
<td>ECM is missing</td>
<td>Updated Privacy Mode ECM via MCT.</td>
</tr>
</tbody>
</table>

#### DTI Card

<table>
<thead>
<tr>
<th>Alarm Message</th>
<th>Trigger Device Redundancy</th>
<th>Description</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>DTI Client Not Locked</td>
<td>Yes</td>
<td>The status of the DTI client is not NORMAL</td>
<td>Check that DTI server status is NORMAL.</td>
</tr>
</tbody>
</table>

#### Service Remux Session

<table>
<thead>
<tr>
<th>Alarm Message</th>
<th>Trigger Device Redundancy</th>
<th>Description</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>PAT Corrupted*</td>
<td>No</td>
<td>Invalid PAT</td>
<td>Check source.</td>
</tr>
<tr>
<td>PAT Missing*</td>
<td>No</td>
<td>PAT is missing in input signal.</td>
<td>Check source.</td>
</tr>
<tr>
<td>PMT Corrupted*</td>
<td>No</td>
<td>Invalid PMT</td>
<td>Check source.</td>
</tr>
<tr>
<td>PMT Missing*</td>
<td>No</td>
<td>PMT is missing in input signal.</td>
<td>Check source.</td>
</tr>
<tr>
<td>Service Remux Source Failure*</td>
<td>No</td>
<td>When Service Remux is configured and the input socket is not active.</td>
<td>Check source.</td>
</tr>
</tbody>
</table>

#### CMTS Session

<table>
<thead>
<tr>
<th>Alarm Message</th>
<th>Trigger Device Redundancy</th>
<th>Description</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Socket CMTS Failure*</td>
<td>No</td>
<td>When CMTS socket is configured and the input socket is not active.</td>
<td>Check source.</td>
</tr>
</tbody>
</table>

#### PID Remux Session

<table>
<thead>
<tr>
<th>Alarm Message</th>
<th>Trigger Device Redundancy</th>
<th>Description</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>PID Remux Source Failure*</td>
<td>No</td>
<td>When PID Remux is configured and the input socket is not active.</td>
<td>Check source.</td>
</tr>
</tbody>
</table>

#### License

<table>
<thead>
<tr>
<th>Alarm Message</th>
<th>Trigger Device Redundancy</th>
<th>Description</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>License Expired</td>
<td>No</td>
<td>License expired</td>
<td>Add and request a new license.</td>
</tr>
</tbody>
</table>
### 6.3.3 Warning List

The following table lists the warnings of NSG 9000 according to the module that issues the warning. The warnings are arranged in alphabetical order with a short description and a solution to remit the warning. Warnings with a star are NOT reflected in NMX.

<table>
<thead>
<tr>
<th>Alarm Message</th>
<th>Triggers Device Redundancy</th>
<th>Description</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Platform</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Nearing High Temperature</td>
<td></td>
<td>The unit is close to overheating.</td>
<td>Check front panel connection and the speed of the fans.</td>
</tr>
<tr>
<td>NGOD R6 Connection Loss</td>
<td></td>
<td>NGOD VREP0-D6 server has lost connection and there are live SDV sessions within the NSG.</td>
<td>Check the Ethernet connection to the D6 server.</td>
</tr>
<tr>
<td>Running on Temporary License*</td>
<td></td>
<td>The system is running with an active temporary license while using the non-default features granted by the license.</td>
<td>Claim the required license.</td>
</tr>
<tr>
<td><strong>GbE Port</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Backup Port Activated</td>
<td></td>
<td>Redundancy switch has taken place</td>
<td>Check primary port</td>
</tr>
<tr>
<td>SFP Communication Error</td>
<td></td>
<td>Instable communication with the SFP module</td>
<td>1. Verify that the SFP module is mounted properly</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>2. Replace SFP</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>3. Reset unit</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>4. If problem persists, call Customer Support</td>
</tr>
<tr>
<td><strong>GbE Card</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Exceeding Max Sockets</td>
<td></td>
<td>The number of incoming streams exceeds the allowed limit.</td>
<td>Check the source.</td>
</tr>
<tr>
<td>Extraction Buffer Overflow</td>
<td></td>
<td>Extraction descriptor FIFO overrun.</td>
<td>Check PSI bit rate.</td>
</tr>
<tr>
<td>GbE Management Rx Failure</td>
<td></td>
<td>Management traffic buffer overload resulting in management packets loss.</td>
<td>Check the bit rate of the management packets.</td>
</tr>
<tr>
<td>GbE Management Tx Failure</td>
<td></td>
<td>Detecting problems when trying to transmit management data</td>
<td>1. Reset unit.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>2. If problem persists, call Customer Support</td>
</tr>
<tr>
<td>MPEG Sync Loss</td>
<td></td>
<td>GbE traffic contains No valid MPEG data</td>
<td>1. Check source.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>2. Check the input cable and replace if defective.</td>
</tr>
<tr>
<td><strong>TS Out</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Traffic on Invalid TS*</td>
<td></td>
<td>The input traffic points to an invalid output.</td>
<td>Check source and QAM mapping.</td>
</tr>
<tr>
<td><strong>RF port</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### Notification List

The following table lists notifications of NSG 9000. A notification is a message sent from the device to the alarm log to denote a status change without raising any alarm. However, depending on the configuration, a notification issue may trigger an SNMP trap. The notifications are arranged in alphabetical order with a short description.

<table>
<thead>
<tr>
<th>Notification Message</th>
<th>Trigger Device Redundancy</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switched to Alternate Source</td>
<td>No</td>
<td>The NSG has switched to the alternative IP/UDP source that is configured for this session</td>
</tr>
<tr>
<td>DTI Client Status Changed</td>
<td>No</td>
<td>The status of DTI Client has changed to the value reflected in Platform &gt; General DTI.</td>
</tr>
<tr>
<td>DTI Active Port Changed</td>
<td>No</td>
<td>The active port of the NSG’s DTI client has changed (from 1 to 2 or vice-versa)</td>
</tr>
</tbody>
</table>
### 6.3.5 Setting Alarm Parameters

The Alarms > Settings page lists the alarms according to their class, that is the object that issues the alarm.

The Alarms > Settings page includes the following information for each alarm:
- **Class** - the module that issues the alarm
- **Alarm Description** - the alarm text
- **Alarm ID** - the ID of the alarm
- **Severity** - defines whether the alert is an alarm or a warning

You can configure alarm parameters and define triggering alarms as explained below:

To define alarms settings
1. Select Monitoring > Alarms > Settings tab.
2. Set the following parameters:

<table>
<thead>
<tr>
<th>Class</th>
<th>Alarm Description</th>
<th>Alarm ID</th>
<th>Assert Threshold (Msec)</th>
<th>Remit Threshold (Msec)</th>
<th>Scan Interval (Msec)</th>
<th>Trigger Redundancy</th>
<th>Add to Log</th>
<th>Send Trap</th>
</tr>
</thead>
<tbody>
<tr>
<td>High Temperature Failure</td>
<td>10</td>
<td>6</td>
<td>20000</td>
<td>20000</td>
<td>1000</td>
<td>false</td>
<td>true</td>
<td>true</td>
</tr>
<tr>
<td>Fan 1 Failure</td>
<td>11</td>
<td>6</td>
<td>5000</td>
<td>5000</td>
<td>1000</td>
<td>false</td>
<td>true</td>
<td>true</td>
</tr>
<tr>
<td>Fan 2 Failure</td>
<td>12</td>
<td>6</td>
<td>5000</td>
<td>5000</td>
<td>1000</td>
<td>false</td>
<td>true</td>
<td>true</td>
</tr>
<tr>
<td>Fan 3 Failure</td>
<td>13</td>
<td>6</td>
<td>5000</td>
<td>5000</td>
<td>1000</td>
<td>false</td>
<td>true</td>
<td>true</td>
</tr>
<tr>
<td>Fan 4 Failure</td>
<td>14</td>
<td>6</td>
<td>5000</td>
<td>5000</td>
<td>1000</td>
<td>false</td>
<td>true</td>
<td>true</td>
</tr>
<tr>
<td>Temperature Warning</td>
<td>15</td>
<td>6</td>
<td>20000</td>
<td>20000</td>
<td>1000</td>
<td>true</td>
<td>false</td>
<td>false</td>
</tr>
<tr>
<td>Temp/Voltage Communication</td>
<td>16</td>
<td>6</td>
<td>0</td>
<td>0</td>
<td>1000</td>
<td>true</td>
<td>false</td>
<td>false</td>
</tr>
<tr>
<td>Error</td>
<td>17</td>
<td>6</td>
<td>60000</td>
<td>60000</td>
<td>20000</td>
<td>false</td>
<td>true</td>
<td>true</td>
</tr>
<tr>
<td>LCD communication failure</td>
<td>18</td>
<td>6</td>
<td>0</td>
<td>0</td>
<td>1000</td>
<td>true</td>
<td>false</td>
<td>false</td>
</tr>
<tr>
<td>Power Supply 1 Failure</td>
<td>19</td>
<td>6</td>
<td>0</td>
<td>0</td>
<td>1000</td>
<td>true</td>
<td>false</td>
<td>false</td>
</tr>
<tr>
<td>Power Supply 2 Failure</td>
<td>20</td>
<td>6</td>
<td>0</td>
<td>0</td>
<td>1000</td>
<td>true</td>
<td>false</td>
<td>false</td>
</tr>
<tr>
<td>Front Panel Missing</td>
<td>21</td>
<td>6</td>
<td>0</td>
<td>0</td>
<td>5000</td>
<td>true</td>
<td>false</td>
<td>false</td>
</tr>
<tr>
<td>Front Panel Communication</td>
<td>22</td>
<td>6</td>
<td>0</td>
<td>0</td>
<td>5000</td>
<td>true</td>
<td>false</td>
<td>false</td>
</tr>
<tr>
<td>High Speed Fan</td>
<td>23</td>
<td>6</td>
<td>20000</td>
<td>20000</td>
<td>10000</td>
<td>true</td>
<td>false</td>
<td>false</td>
</tr>
<tr>
<td>Power Supply 1 Missing</td>
<td>24</td>
<td>6</td>
<td>0</td>
<td>0</td>
<td>10000</td>
<td>true</td>
<td>false</td>
<td>false</td>
</tr>
</tbody>
</table>

**NOTE:** Once you have changed any of the default values and sent them to the device (Apply), the Set Defaults button appears next to the alarm its parameters were changed.

- **Assert Threshold (Msec)** - a latency period indicated in milli seconds for this alarm. When a module discovers a condition that would normally cause it to assert this alarm, it waits for the time specified in the **Assert Threshold (Msec)** field before asserting the alarm.
- **Remit Threshold (Msec)** - a latency period indicated in milli seconds for this alarm. When a module discovers a condition that would normally cause it to remit this alarm, it waits for the time specified in the **Remit Threshold (Msec)** field before remitting the alarm.
- **Scan Interval (Msec)** - defines how often the device checks for the conditions that raise the alarm. This field allows you to define a break, in milli seconds, in checking for the conditions that raise the alarm.
- **Trigger Redundancy** - defines whether the alarm triggers a redundancy switch.
- **Add to Log** - defines whether to write the alarm to the log of active alarms.
- **Send Trap** - defines whether to send an SNMP trap when the alarm is raised.
6.4 Diagnosing and Analyzing Traffic

6.4.1 Saving Configuration

You can save the NSG 9000 configuration to a read-only file.

1. Select Monitoring > Diagnostics.

   Click Get Information

2. Click Get Information.

3. In the Save HTML Document dialog, browse to the required location for saving the configuration.

4. Click Save.

   The configuration of the device is saved as an XML file on your PC.

6.4.2 ASI and GbE Forwarding

NSG 9000 may duplicate the incoming content to an ASI port or to any GbE port that is defined as a mirroring port. Connect the mirroring port to devices that accept ASI or/and GbE input such as an MPEG analyzer. For cabling instructions, see NSG 9000 Installation and Hardware guide.

   NOTE: Use socket forwarding for diagnostic purposes only and not during normal operation.

   ➤ To forward to an ASI Port

   1. Select Monitoring > Diagnostics.

   2. Open the Probe Location list and select either of the following:

      ❑ Before Scrambler - to probe as a clear stream
      ❑ After Scrambler - to probe as a scrambled stream

© 2010 Harmonic Inc.
3. In ASI Forwarding section, open the Probed QAM list to select the QAM-RF channel to be forwarded for diagnosis.

To forward a GbE Input Port

NOTE: Disable socket forwarding during normal operation.

1. Select Monitoring > Diagnostics and focus on the IP Forwarding section.
2. To enable mirroring, select Enable Forwarding.

<table>
<thead>
<tr>
<th>IP Forwarding</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable Forwarding</td>
</tr>
<tr>
<td>Forwarding Level</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Sockets List</th>
</tr>
</thead>
<tbody>
<tr>
<td>Note: socket forwarding must be disabled during normal operation</td>
</tr>
<tr>
<td>GBE/MC IP Address</td>
</tr>
<tr>
<td>Add Socket</td>
</tr>
</tbody>
</table>

3. Open the Forwarding Level list and select whether to forward a port or a socket. If you select a socket, define its parameters in the Sockets List table.
4. Open the Source Port list and select the GbE port that inputs the required content.
5. Open the Destination Port list and select the port to mirror the source port.
6. In the Sockets List table, define the following:
   - GbE/MC IP Address - the destination GbE or Multicast IP address of the socket.
   - GbE Port - enter the UDP port
   - Source IP - enter the IP address of the port that streamed the socket into the device.
   - To delete the socket, select Delete.

6.5 Generating and Viewing Logs

You can view the following logs:
- Alarms log
- GbE Counters
- NGOD logs
- ISA logs

6.5.1 Alarms Log

The Alarms log displays the recent alarms in a chronological order. The log can display up to 100 alarms.

To view an updated log, refresh the log. You may view, refresh, clear or save the log.

To view the alarms log
1. Select Monitoring > Logs > Alarms Log.
2. To display the log, click View Log.
The log displays the alarms registered up to the time you generated the log and informs you of the following:

- # - a sequential number.
- Date - the date the alarm was issued.
- Time - the time the alarm was issued.
- Module - the module that raised the alarm.
- Description - a brief description of the alarm.
- State - indicates whether the alarm is raised.

To refresh alarms log

Since the Alarms log displays the alarms up to the time you generated the log, refresh it to view an updated log by performing the following:

- In the Alarms Log tab, once the alarms log is displayed, click Refresh Log.

The log is updated to display the latest alarms.

To clear the log

1. Select Monitoring > Logs > Alarms Log.
2. To clear the log, click Clear Log.

The currently displayed log disappears. Once you click View Log, a new log is generated. It includes alarms registered since the last clear log.

To save log to file

1. Select Monitoring > Logs > Alarms Log.
2. To save the log, click Export.
3. Select a location for saving the file and click Save.

The log is saved as an XML file in the location of your choice.
6.5.2 Monitoring the GbE Ports

The Counters page monitors the operation of the GbE ports.

Each GbE port is monitored for the following events:

Table 6-3: GbE Port Monitored Events

<table>
<thead>
<tr>
<th>Event</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Transmitted Management Packets</td>
<td>The number of legal management packets transmitted by the active GbE port.</td>
</tr>
<tr>
<td>Received Management Packets</td>
<td>The number of legal management packets received by the active GbE port.</td>
</tr>
<tr>
<td>UDP/IP Packet Sequence Errors</td>
<td>At least one UDP/IP packet is missing</td>
</tr>
<tr>
<td>CRC Errors</td>
<td>The number of Ethernet MAC CRC errors detected by the active GbE port.</td>
</tr>
<tr>
<td>L2TPv3 Out of Sequence Errors</td>
<td>Indicates the number of errors in the L2TPv3 Sequence parameter.</td>
</tr>
<tr>
<td>Unicast Byte Counter</td>
<td>Counts bytes of UDP/L2TP valid packets with destination IP equal to one of the input port self IPs. The counter does not count management packets.</td>
</tr>
<tr>
<td>Unicast Discard Byte Counter</td>
<td>Counts bytes of UDP/L2TP valid packets with destination IP equal to one of the input port self IPs, that are discarded due to non configured CAM. Does not count management packets.</td>
</tr>
</tbody>
</table>

Each time an event occurs, the counter of the event registers another incidence and updates the number of incidence. You may reset the counter when required, and upon reboot, all counters are reset.

To monitor GbE ports

1. Select Monitoring > Logs > Counters tab. View the following information:
   - Module - indicates the GbE port
   - Description - indicates each event
2. To reset a counter, click _____ in the required row.
3. To reset all counters, click Clear All Counters.

6.5.3 Monitoring the ISA Communication

To monitor the communication of ISA with NSG 9000, login as username config. See, 2.2.2 Logging Into the Device via IE on page 13.

To monitor ISA communication with NSG 9000
1. Select Monitoring > Logs > ISA RPC.

The following page appears:

<table>
<thead>
<tr>
<th>#</th>
<th>Time</th>
<th>From/To</th>
<th>Type</th>
<th>Function</th>
<th>Message Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>11/23/2009 18:48:08</td>
<td>NSG ----&gt; 10.49.2.26:715</td>
<td>TCP</td>
<td>createShellSession</td>
<td>XoutInfo [0x00000001 0x00000001] groupSessionStatus 306344233495375860-090020006 2353864536567586456100-0908020006 resultCode 8c5002000c</td>
</tr>
</tbody>
</table>

2. To start tracing the communication, click Start Tracing.

**NOTE:** Device reset does not cancel tracing. If you reset the device while tracing, when the device boots up, tracing continues and Data Logging appears in red in the title bar of the web page indicating that tracing is taking place.

3. To stop tracing, click Stop Tracing.
4. To view the communication, click Show Messages.
5. View the messages. The messages appear with the following parameters:
   - # - a sequential number
   - Time - the time and date of the message
   - From/To - indicates the sender and the address
   - Type - indicates the communication protocol via which the message was sent
   - Function - indicates the message purpose
   - Message Content - to read the resultCode parameter, click Result Code. A dialog that
lists and explains the available result codes opens.

6. To clear messages, click Clear Messages.

6.6 Viewing Available Reports

This version of the NSG 9000 web client allows you to view a report of the RF settings. To view global RF settings and RF module settings

1. Select Reports > RF Configuration.
2. To view RF module parameters, view the following:

<table>
<thead>
<tr>
<th>Module No. - Slot 1-9</th>
<th>QAM Index - See 3.9.2 Configuring/Viewing QAM-RF Parameters on page 41.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Module Type - NSG-8R1G</td>
<td>QAM Manager - See 3.9.2 Configuring/Viewing QAM-RF Parameters on page 41.</td>
</tr>
<tr>
<td>Symbol Rate</td>
<td>EIA Channel - See 3.9.2 Configuring/Viewing QAM-RF Parameters on page 41.</td>
</tr>
<tr>
<td>Constellation</td>
<td>Power Level - See 3.9.1 Configuring Module RF Ports on page 38.</td>
</tr>
<tr>
<td>QAM Placement</td>
<td>Interleaver - See 3.9.2 Configuring/Viewing QAM-RF Parameters on page 41.</td>
</tr>
<tr>
<td>RF Template</td>
<td>Spectral Inversion - See 3.9.2 Configuring/Viewing QAM-RF Parameters on page 41.</td>
</tr>
<tr>
<td>RF No.</td>
<td>Mute - See 3.9.2 Configuring/Viewing QAM-RF Parameters on page 41.</td>
</tr>
</tbody>
</table>

© 2010 Harmonic Inc. 106 NSG 9000
6.7 Clearing Configuration During Power Up

You can clear the configuration stored on the NSG 9000 during boot up. Use this option, in case the stored configuration is corrupted and prevents the device from booting up properly. Once you zap the device, it boots up with the factory defaults. To zap the device, use the control panel as explained below:

1. Boot up the device and follow the control panel messages.

2. Wait for the following message: Press <Esc> to Stop...(5)
   
   It appears after the message Loading...

3. To zap, that is to clear the configuration, click <Esc>. You have around two seconds to click <Esc>.
   
   The following message appears: Press <Enter> to zap...(5)
   
   If you do not click <Esc>, boot up process continues regularly.

4. Click <Enter>. You have around two seconds to click <Enter>. If you do not click <Enter>, boot up process continues regularly.
   
   The device zaps and reboots with factory defaults.

For detailed information about the control panel, see B.1 Using the Control Panel on page 109.
Appendix A
QAM Mapping Mode

A.1 NSG 9000 Emulation

To allow narrow casting networks to easily expand their services, and to streamline the integration of NSG 9000 in networks with 8108, 9116 topology, Harmonic provides NSG 9000 with 8108 and 9116 emulation capabilities. In addition NSG 9000 may emulate various applications such as 3x24, that is, an emulation of three units with 24xQAM-RF ports.

Each emulation results in a unique QAM mapping. Details of the QAM mapping of the following emulation modes are provided in this guide:

Table 6-4: Emulation Options and QAM Mapping Formula

<table>
<thead>
<tr>
<th>Emulated Devices</th>
<th>Explanation</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>NSG 8108 in bitmap mode</td>
<td>NSG 9000 operates as four and a half NSG 8108</td>
<td>$256^*\text{QAM Output}+\text{Service Id}$</td>
</tr>
<tr>
<td>NSG 8108 in encoded mode</td>
<td>NSG 9000 operates as four and a half NSG 8108</td>
<td>$256^*\text{QAM Output}+\text{Service Id}$</td>
</tr>
<tr>
<td>NSG 9116 in bitmap mode</td>
<td>NSG 9000 operates as two NSG 9116 and additional two QAM-RF ports. However, due to the bitmap mode, each GbE port is defined by two IP addresses to facilitate two virtual NSG 9116 devices.</td>
<td>$256^*2^{\text{QAM Output} - 1}+\text{Service Id}$</td>
</tr>
<tr>
<td>NSG 9116 in encoded mode</td>
<td>NSG 9000 operates as two NSG 9116 and additional two QAM-RF ports</td>
<td>$256^*\text{QAM Output}+\text{Service Id}$</td>
</tr>
<tr>
<td>3x24 emulation mapping mode</td>
<td>NSG 9000 operates as three NSG devices with 24xQAMs</td>
<td>$256^*\text{QAM Output}+\text{Service Id}$</td>
</tr>
</tbody>
</table>
Appendix B
Control Panel

B.1 Using the Control Panel

You can set preliminary configuration and control the NSG 9000 unit via its front panel. The
front panel includes a control panel comprised of a Liquid Crystal Display (LCD) and six
buttons as the following figure shows:

B.1.1 Control Panel Display

The 2-line, 16-character control panel display shows the screens, sub-screens, sub-screen
options, error messages, warnings and alarms. The control panel display is comprised of two
lines:

Line 1 - displays the name of the current screen/sub-screen or selected option.

Line 2 - displays the parameter value and all editing tasks are performed in this line. In editing
mode the cursor is blinking to indicate the selected character.

B.1.2 Control Panel Screen Concept

The control panel screens are organized in a hierarchical fashion to indicate that a main
screen contains sub-screens and sub-screen options. You may access a sub-screen only via
its main screen. The available main screens are as follows:

- **Power Up screen** - A main screen that appears as soon as the NSG 9000 boots up and after
  a thirty minutes of inactivity. The screen shows the company’s name, NSG 9000 type and IP
  address.

- **Network Config screen** - allows to access sub-screens for ETH configuration.

- **Setup screen** - allows to reset the device.

- **Alarm screen** - displays the last active alarm or warning. You can browse through the alarms
to view them.

- **Product Information screen** - via its sub-screens you can view information about the NSG
  9000.
The following table lists the main screens, their browsing sequence, sub-screens and their options:

<table>
<thead>
<tr>
<th>Screen</th>
<th>Browsing Sequence</th>
<th>Sub-Sequence</th>
<th>Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network Config</td>
<td>Down - Alarms</td>
<td>ETH1 IP</td>
<td>Edit ETH1</td>
</tr>
<tr>
<td></td>
<td>Up - Product Info.</td>
<td>ETH2 IP</td>
<td>Edit ETH2</td>
</tr>
<tr>
<td>Alarms</td>
<td>Down - Setup</td>
<td>Active alarms and warnings</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Up - Network Config</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Setup</td>
<td>Down - Product Info.</td>
<td>Reset</td>
<td>Reset device</td>
</tr>
<tr>
<td></td>
<td>Up - Alarms</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Product Info.</td>
<td>Down - Network Config</td>
<td>Unit Information</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Up - Setup</td>
<td>Main board Info.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Interface module Info.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Software Information.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Control panel hotkeys help</td>
<td></td>
</tr>
</tbody>
</table>

### B.1.2.1 Moving along the Screens

To move along the screens and sub-screens of the control panel, use the following buttons of the control panel keypad:

<table>
<thead>
<tr>
<th>Button</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Up &amp; Down</td>
<td>■ browse through the screens/sub-screens.</td>
</tr>
<tr>
<td></td>
<td>■ browse through sub-screen options.</td>
</tr>
<tr>
<td></td>
<td>■ while editing, browse through numerical characters.</td>
</tr>
<tr>
<td>Left &amp; Right</td>
<td>while editing, move the cursor along the line.</td>
</tr>
<tr>
<td>Enter</td>
<td>■ executes a selection of a screen/sub screen and of its available options.</td>
</tr>
<tr>
<td></td>
<td>■ quits an editing session and applies changes.</td>
</tr>
<tr>
<td>Esc</td>
<td>■ moves up a menu level.</td>
</tr>
<tr>
<td></td>
<td>■ quits an editing session without applying changes.</td>
</tr>
</tbody>
</table>

### B.1.2.2 Hotkeys

The hotkeys are a combination of up to three keys pressed simultaneously. The following table lists the available hotkeys and describes their functionality:

<table>
<thead>
<tr>
<th>Hotkey</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;Esc &amp; Up or Down&gt;</td>
<td>Adjusts the contrast of the display area.</td>
</tr>
<tr>
<td>&lt;Esc &amp; Right &amp; Left &gt;</td>
<td>Reset</td>
</tr>
<tr>
<td>Confirm with right arrow</td>
<td></td>
</tr>
</tbody>
</table>
B.1.3 Configuring Device Parameters

Configure the NSG 9000 unit only after boot up. The control panel allows you to configure the following:
- IP address, subnet mask and gateway of ETH1
- IP address and subnet mask of ETH2

To configure various parameters and to apply the changes, you are required to enter a password. This limitation allows authorized users only to change the NSG 9000 settings. The password is the following sequence of buttons: Left-Right Left-Right Up-Down Enter.

To configure device parameters:

1. Navigate to the required parameter and click <Enter> twice.
2. Enter the password.

   The screen name changes to Edit (screen name). A blinking cursor appears on the first character of the second line of the screen.

3. Start editing.
4. Do one of the following:
   - To quit the editing session and to apply changes, click <Enter>.
     The screen name appears without the word “Edit”.
     The newly configured parameter appears in the second line of the screen.

   - To quit the editing session without applying the changes, click <Esc>.
     The screen name appears without the word “Edit”.
     Unchanged parameters appear in the second line of the screen.
B.1.4 Reset the NSG 9000 Unit

Via the control panel you may reset the NSG 9000 unit when required.

⇒ To reset the NSG 9000 unit:
   - Do either of the following:
     - Navigate to the Reset NSG 9000 sub-screen of the Setup main screen and click <enter>,
     - Or,
     - Press <Esc & Right & Left > and press Right arrow.

Once boot up starts, the control panel displays the same messages as during power up. If
BOOTP is enabled, an additional message appears indicating that the NSG 9000
connects to the BOOTP server.

You can also clear the configuration stored on the NSG 9000 during boot up. See
6.7 Clearing Configuration During Power Up on page 107.

B.1.5 Viewing NSG 9000 Parameters

The control panel allows to view the following NSG 9000 parameters:
- Alarms and Warnings - up to 100 alarms/warnings
- NSG 9000 MAC address
- Product Information
- Control panel hotkeys

B.1.5.1 Viewing Alarms/Warnings

You may browse through the alarms/warnings to view them. If an alarm/warning is cancelled,
it disappears from the screen and the following alarm/warning is presented. If there are no
alarms/warnings, the message “No alarms/Warn” appears. You can view up to 100 alarms/
warnings.

⇒ To monitor alarms/Warnings
   1. Navigate to the Alarm screen.
      The screen displays the number of alarms and warnings (from left to right)
   2. Click <Enter>.
   3. Browse through the alarms/warnings, using the <Down or Up> keys.
      When a warning is displayed, the following sign appears at the top right corner of the LCD
display: (W).

B.1.5.2 Viewing ETH ports MAC Address

⇒ To monitor the ETH1 MAC Address
   1. Navigate to the Network Config screen and click <Enter>.
      The Ethernet Port 1 screen appears.
   2. Click <Enter>. The ETH1 IP Address screen appears.
   3. Click <Down or Up> until the ETH1 MAC Address screen appears.
To monitor the ETH2 MAC Address

1. Navigate to the Network Config screen and click <Enter>.
   The Ethernet Port 1 screen appears.
2. Click <Down or Up> to open the Ethernet Port 2 screen.
3. Once the Ethernet Port 2 screen appears, click <Enter>.
4. Click <Down or Up> until the ETH2 MAC Address screen appears.

B.1.5.3 Viewing Product Information

The Product Information screen is related to the following sub-screens:
- Chassis Info - view the serial number of the chassis
- DGBoard Info - view the DGBoard serial number and DGBoard FPGA number
- GbE Info - view GbE FPGA Version
- Slot Info - view per each slot, its type, version, serial number and FPGA
- Software Info - view firmware version
- LCD Hotkeys Help - allows to view the various available hotkeys

To view product information

1. Navigate to the Product Info. screen.
2. Click <Enter>.
3. Browse through the sub-screens and their related options using the <Down or Up> and <Enter> keys.

B.1.5.4 Viewing Hotkeys

1. Navigate to the Product Information screen.
2. Click <Enter>.
3. Click <Down or Up> until the Hotkey screen appears.
4. Click <Enter>.
5. Click <Down or Up> to view the hotkeys.
Appendix C
Standard ES Types and Descriptors

C.1 Standard Elementary Stream (ES) Types

The following standards are used to define types of elementary stream:

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0x0</td>
<td>ITU-T</td>
</tr>
<tr>
<td>0x1</td>
<td>ISO/IEC 11172 Video</td>
</tr>
<tr>
<td>0x2</td>
<td>ITU-T Rec. H.262</td>
</tr>
<tr>
<td>0x3</td>
<td>ISO/IEC 11172 Audio</td>
</tr>
<tr>
<td>0x4</td>
<td>ISO/IEC 13818-3 Audio</td>
</tr>
<tr>
<td>0x5</td>
<td>ITU-T Rec. H.222.0</td>
</tr>
<tr>
<td>0x6</td>
<td>ITU-T Rec. H.222.0</td>
</tr>
<tr>
<td>0x7</td>
<td>ISO/IEC 13522 MHEG</td>
</tr>
<tr>
<td>0x8</td>
<td>ITU-T Rec. H.222.0</td>
</tr>
<tr>
<td>0x9</td>
<td>ITU-T Rec. H.222.1</td>
</tr>
<tr>
<td>0xA</td>
<td>ISO/IEC 13818-6 type A</td>
</tr>
<tr>
<td>0xB</td>
<td>ISO/IEC 13818-6 type B</td>
</tr>
<tr>
<td>0xC</td>
<td>ISO/IEC 13818-6 type C</td>
</tr>
<tr>
<td>0xD</td>
<td>ISO/IEC 13818-6 type D</td>
</tr>
<tr>
<td>0xE</td>
<td>ISO/IEC 13818-1 auxiliary</td>
</tr>
<tr>
<td>0xF-0x7F</td>
<td>ITU-T Rec. H.222.0</td>
</tr>
<tr>
<td>0x80 - 0xFF</td>
<td>User Private</td>
</tr>
</tbody>
</table>

C.2 Standard ES and Program Descriptors (MPEG)

The following MPEG standards are used to extend the definitions of elementary stream and programs:

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0x2</td>
<td>Video stream descriptor</td>
</tr>
<tr>
<td>0x3</td>
<td>Audio stream descriptor</td>
</tr>
<tr>
<td>0x4</td>
<td>Hierarchy descriptor</td>
</tr>
</tbody>
</table>
C.3 Standard ES and Program Descriptors (DVB)

The following DVB standards are used to extend the definitions of elementary stream and programs:

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0x51</td>
<td>Mosaic descriptor</td>
</tr>
<tr>
<td>0x52</td>
<td>Stream identifier descriptor</td>
</tr>
<tr>
<td>0x56</td>
<td>Teletext descriptor</td>
</tr>
<tr>
<td>0x59</td>
<td>Subtitling descriptor</td>
</tr>
<tr>
<td>0x5F</td>
<td>Private data specifier</td>
</tr>
<tr>
<td>0x60</td>
<td>Service move descriptor</td>
</tr>
<tr>
<td>0x65</td>
<td>CA system descriptor</td>
</tr>
<tr>
<td>0x66</td>
<td>Data broadcast ID descriptor</td>
</tr>
</tbody>
</table>
Appendix D
EIA SDT and HRC Standards

The EIA (Electronic Industries Association) sets internationally recognized standards for standard frequencies (EIA SDT) and for Harmonic related carriers (EIA HRC).

Table 6-5: EIA SDT and HRC

<table>
<thead>
<tr>
<th>EIA Channel Number</th>
<th>STD (Zero Offset) MHz</th>
<th>HRC MHz</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>73.7500</td>
<td>73.7500</td>
</tr>
<tr>
<td>2</td>
<td>57.0000</td>
<td>55.7500</td>
</tr>
<tr>
<td>3</td>
<td>63.0000</td>
<td>61.7500</td>
</tr>
<tr>
<td>4</td>
<td>69.0000</td>
<td>67.7500</td>
</tr>
<tr>
<td>5</td>
<td>79.0000</td>
<td>79.7500</td>
</tr>
<tr>
<td>6</td>
<td>85.0000</td>
<td>85.7500</td>
</tr>
<tr>
<td>7</td>
<td>177.0000</td>
<td>175.7500</td>
</tr>
<tr>
<td>8</td>
<td>183.0000</td>
<td>181.7500</td>
</tr>
<tr>
<td>9</td>
<td>189.0000</td>
<td>187.7500</td>
</tr>
<tr>
<td>10</td>
<td>195.0000</td>
<td>193.7500</td>
</tr>
<tr>
<td>11</td>
<td>201.0000</td>
<td>199.7500</td>
</tr>
<tr>
<td>12</td>
<td>207.0000</td>
<td>205.7500</td>
</tr>
<tr>
<td>13</td>
<td>213.0000</td>
<td>211.7500</td>
</tr>
<tr>
<td>14</td>
<td>123.0000</td>
<td>121.7500</td>
</tr>
<tr>
<td>15</td>
<td>129.0000</td>
<td>127.7500</td>
</tr>
<tr>
<td>16</td>
<td>135.0000</td>
<td>133.7500</td>
</tr>
<tr>
<td>17</td>
<td>141.0000</td>
<td>139.7500</td>
</tr>
<tr>
<td>18</td>
<td>147.0000</td>
<td>145.7500</td>
</tr>
<tr>
<td>19</td>
<td>153.0000</td>
<td>151.7500</td>
</tr>
<tr>
<td>20</td>
<td>159.0000</td>
<td>157.7500</td>
</tr>
<tr>
<td>21</td>
<td>165.0000</td>
<td>163.7500</td>
</tr>
<tr>
<td>22</td>
<td>171.0000</td>
<td>169.7500</td>
</tr>
<tr>
<td>23</td>
<td>219.0000</td>
<td>217.7500</td>
</tr>
<tr>
<td>24</td>
<td>225.0000</td>
<td>223.7500</td>
</tr>
<tr>
<td>25</td>
<td>231.0000</td>
<td>229.7500</td>
</tr>
<tr>
<td>26</td>
<td>237.0000</td>
<td>235.7500</td>
</tr>
<tr>
<td>EIA Channel Number</td>
<td>STD (Zero Offset) MHz</td>
<td>HRC MHz</td>
</tr>
<tr>
<td>-------------------</td>
<td>----------------------</td>
<td>----------</td>
</tr>
<tr>
<td>27</td>
<td>243.0000</td>
<td>241.7500</td>
</tr>
<tr>
<td>28</td>
<td>249.0000</td>
<td>247.7500</td>
</tr>
<tr>
<td>29</td>
<td>255.0000</td>
<td>253.7500</td>
</tr>
<tr>
<td>30</td>
<td>261.0000</td>
<td>259.7500</td>
</tr>
<tr>
<td>31</td>
<td>267.0000</td>
<td>265.7500</td>
</tr>
<tr>
<td>32</td>
<td>273.0000</td>
<td>271.7500</td>
</tr>
<tr>
<td>33</td>
<td>279.0000</td>
<td>277.7500</td>
</tr>
<tr>
<td>34</td>
<td>285.0000</td>
<td>283.7500</td>
</tr>
<tr>
<td>35</td>
<td>291.0000</td>
<td>289.7500</td>
</tr>
<tr>
<td>36</td>
<td>297.0000</td>
<td>295.7500</td>
</tr>
<tr>
<td>37</td>
<td>303.0000</td>
<td>301.7500</td>
</tr>
<tr>
<td>38</td>
<td>309.0000</td>
<td>307.7500</td>
</tr>
<tr>
<td>39</td>
<td>315.0000</td>
<td>313.7500</td>
</tr>
<tr>
<td>40</td>
<td>321.0000</td>
<td>319.7500</td>
</tr>
<tr>
<td>41</td>
<td>327.0000</td>
<td>325.7500</td>
</tr>
<tr>
<td>42</td>
<td>333.0000</td>
<td>331.7500</td>
</tr>
<tr>
<td>43</td>
<td>339.0000</td>
<td>337.7500</td>
</tr>
<tr>
<td>44</td>
<td>345.0000</td>
<td>343.7500</td>
</tr>
<tr>
<td>45</td>
<td>351.0000</td>
<td>349.7500</td>
</tr>
<tr>
<td>46</td>
<td>357.0000</td>
<td>355.7500</td>
</tr>
<tr>
<td>47</td>
<td>363.0000</td>
<td>361.7500</td>
</tr>
<tr>
<td>48</td>
<td>369.0000</td>
<td>367.7500</td>
</tr>
<tr>
<td>49</td>
<td>375.0000</td>
<td>373.7500</td>
</tr>
<tr>
<td>50</td>
<td>381.0000</td>
<td>379.7500</td>
</tr>
<tr>
<td>51</td>
<td>387.0000</td>
<td>385.7500</td>
</tr>
<tr>
<td>52</td>
<td>393.0000</td>
<td>391.7500</td>
</tr>
<tr>
<td>53</td>
<td>399.0000</td>
<td>397.7500</td>
</tr>
<tr>
<td>54</td>
<td>405.0000</td>
<td>403.7500</td>
</tr>
<tr>
<td>55</td>
<td>411.0000</td>
<td>409.7500</td>
</tr>
<tr>
<td>56</td>
<td>417.0000</td>
<td>415.7500</td>
</tr>
<tr>
<td>57</td>
<td>423.0000</td>
<td>421.7500</td>
</tr>
<tr>
<td>EIA Channel Number</td>
<td>STD (Zero Offset) MHz</td>
<td>HRC MHz</td>
</tr>
<tr>
<td>-------------------</td>
<td>----------------------</td>
<td>---------</td>
</tr>
<tr>
<td>58</td>
<td>429.0000</td>
<td>427.7500</td>
</tr>
<tr>
<td>59</td>
<td>435.0000</td>
<td>433.7500</td>
</tr>
<tr>
<td>60</td>
<td>441.0000</td>
<td>439.7500</td>
</tr>
<tr>
<td>61</td>
<td>447.0000</td>
<td>445.7500</td>
</tr>
<tr>
<td>62</td>
<td>453.0000</td>
<td>451.7500</td>
</tr>
<tr>
<td>63</td>
<td>459.0000</td>
<td>457.7500</td>
</tr>
<tr>
<td>64</td>
<td>465.0000</td>
<td>463.7500</td>
</tr>
<tr>
<td>65</td>
<td>471.0000</td>
<td>469.7500</td>
</tr>
<tr>
<td>66</td>
<td>477.0000</td>
<td>475.7500</td>
</tr>
<tr>
<td>67</td>
<td>483.0000</td>
<td>481.7500</td>
</tr>
<tr>
<td>68</td>
<td>489.0000</td>
<td>487.7500</td>
</tr>
<tr>
<td>69</td>
<td>495.0000</td>
<td>493.7500</td>
</tr>
<tr>
<td>70</td>
<td>501.0000</td>
<td>499.7500</td>
</tr>
<tr>
<td>71</td>
<td>507.0000</td>
<td>505.7500</td>
</tr>
<tr>
<td>72</td>
<td>513.0000</td>
<td>511.7500</td>
</tr>
<tr>
<td>73</td>
<td>519.0000</td>
<td>517.7500</td>
</tr>
<tr>
<td>74</td>
<td>525.0000</td>
<td>523.7500</td>
</tr>
<tr>
<td>75</td>
<td>531.0000</td>
<td>529.7500</td>
</tr>
<tr>
<td>76</td>
<td>537.0000</td>
<td>535.7500</td>
</tr>
<tr>
<td>77</td>
<td>543.0000</td>
<td>541.7500</td>
</tr>
<tr>
<td>78</td>
<td>549.0000</td>
<td>547.7500</td>
</tr>
<tr>
<td>79</td>
<td>555.0000</td>
<td>553.7500</td>
</tr>
<tr>
<td>80</td>
<td>561.0000</td>
<td>559.7500</td>
</tr>
<tr>
<td>81</td>
<td>567.0000</td>
<td>565.7500</td>
</tr>
<tr>
<td>82</td>
<td>573.0000</td>
<td>571.7500</td>
</tr>
<tr>
<td>83</td>
<td>579.0000</td>
<td>577.7500</td>
</tr>
<tr>
<td>84</td>
<td>585.0000</td>
<td>583.7500</td>
</tr>
<tr>
<td>85</td>
<td>591.0000</td>
<td>589.7500</td>
</tr>
<tr>
<td>86</td>
<td>597.0000</td>
<td>595.7500</td>
</tr>
<tr>
<td>87</td>
<td>603.0000</td>
<td>601.7500</td>
</tr>
<tr>
<td>88</td>
<td>609.0000</td>
<td>607.7500</td>
</tr>
<tr>
<td>EIA Channel Number</td>
<td>STD (Zero Offset) MHz</td>
<td>HRC MHz</td>
</tr>
<tr>
<td>--------------------</td>
<td>-----------------------</td>
<td>---------</td>
</tr>
<tr>
<td>89</td>
<td>615.0000</td>
<td>613.7500</td>
</tr>
<tr>
<td>90</td>
<td>621.0000</td>
<td>619.7500</td>
</tr>
<tr>
<td>91</td>
<td>627.0000</td>
<td>625.7500</td>
</tr>
<tr>
<td>92</td>
<td>633.0000</td>
<td>631.7500</td>
</tr>
<tr>
<td>93</td>
<td>639.0000</td>
<td>637.7500</td>
</tr>
<tr>
<td>94</td>
<td>645.0000</td>
<td>643.7500</td>
</tr>
<tr>
<td>95</td>
<td>93.0000</td>
<td>91.7500</td>
</tr>
<tr>
<td>96</td>
<td>99.0000</td>
<td>97.7500</td>
</tr>
<tr>
<td>97</td>
<td>105.0000</td>
<td>103.7500</td>
</tr>
<tr>
<td>98</td>
<td>111.0000</td>
<td>109.7500</td>
</tr>
<tr>
<td>99</td>
<td>117.0000</td>
<td>115.7500</td>
</tr>
<tr>
<td>100</td>
<td>651.0000</td>
<td>649.7500</td>
</tr>
<tr>
<td>101</td>
<td>657.0000</td>
<td>655.7500</td>
</tr>
<tr>
<td>102</td>
<td>663.0000</td>
<td>661.7500</td>
</tr>
<tr>
<td>103</td>
<td>669.0000</td>
<td>667.7500</td>
</tr>
<tr>
<td>104</td>
<td>675.0000</td>
<td>673.7500</td>
</tr>
<tr>
<td>105</td>
<td>681.0000</td>
<td>679.7500</td>
</tr>
<tr>
<td>106</td>
<td>687.0000</td>
<td>685.7500</td>
</tr>
<tr>
<td>107</td>
<td>693.0000</td>
<td>691.7500</td>
</tr>
<tr>
<td>108</td>
<td>699.0000</td>
<td>697.7500</td>
</tr>
<tr>
<td>109</td>
<td>705.0000</td>
<td>703.7500</td>
</tr>
<tr>
<td>110</td>
<td>711.0000</td>
<td>709.7500</td>
</tr>
<tr>
<td>111</td>
<td>717.0000</td>
<td>715.7500</td>
</tr>
<tr>
<td>112</td>
<td>723.0000</td>
<td>721.7500</td>
</tr>
<tr>
<td>113</td>
<td>729.0000</td>
<td>727.7500</td>
</tr>
<tr>
<td>114</td>
<td>735.0000</td>
<td>733.7500</td>
</tr>
<tr>
<td>115</td>
<td>741.0000</td>
<td>739.7500</td>
</tr>
<tr>
<td>116</td>
<td>747.0000</td>
<td>745.7500</td>
</tr>
<tr>
<td>117</td>
<td>753.0000</td>
<td>751.7500</td>
</tr>
<tr>
<td>118</td>
<td>759.0000</td>
<td>757.7500</td>
</tr>
<tr>
<td>119</td>
<td>765.0000</td>
<td>763.7500</td>
</tr>
<tr>
<td>EIA Channel Number</td>
<td>STD (Zero Offset) MHz</td>
<td>HRC MHz</td>
</tr>
<tr>
<td>--------------------</td>
<td>-----------------------</td>
<td>---------</td>
</tr>
<tr>
<td>120</td>
<td>771.0000</td>
<td>769.7500</td>
</tr>
<tr>
<td>121</td>
<td>777.0000</td>
<td>775.7500</td>
</tr>
<tr>
<td>122</td>
<td>783.0000</td>
<td>781.7500</td>
</tr>
<tr>
<td>123</td>
<td>789.0000</td>
<td>787.7500</td>
</tr>
<tr>
<td>124</td>
<td>795.0000</td>
<td>793.7500</td>
</tr>
<tr>
<td>125</td>
<td>801.0000</td>
<td>799.7500</td>
</tr>
<tr>
<td>126</td>
<td>807.0000</td>
<td>805.7500</td>
</tr>
<tr>
<td>127</td>
<td>813.0000</td>
<td>811.7500</td>
</tr>
<tr>
<td>128</td>
<td>819.0000</td>
<td>817.7500</td>
</tr>
<tr>
<td>129</td>
<td>825.0000</td>
<td>823.7500</td>
</tr>
<tr>
<td>130</td>
<td>831.0000</td>
<td>829.7500</td>
</tr>
<tr>
<td>131</td>
<td>837.0000</td>
<td>835.7500</td>
</tr>
<tr>
<td>132</td>
<td>843.0000</td>
<td>841.7500</td>
</tr>
<tr>
<td>133</td>
<td>849.0000</td>
<td>847.7500</td>
</tr>
<tr>
<td>134</td>
<td>855.0000</td>
<td>853.7500</td>
</tr>
<tr>
<td>135</td>
<td>861.0000</td>
<td>859.7500</td>
</tr>
<tr>
<td>136</td>
<td>867.0000</td>
<td>865.7500</td>
</tr>
<tr>
<td>137</td>
<td>873.0000</td>
<td>871.7500</td>
</tr>
<tr>
<td>138</td>
<td>879.0000</td>
<td>877.7500</td>
</tr>
<tr>
<td>139</td>
<td>885.0000</td>
<td>883.7500</td>
</tr>
<tr>
<td>140</td>
<td>891.0000</td>
<td>889.7500</td>
</tr>
<tr>
<td>141</td>
<td>897.0000</td>
<td>895.7500</td>
</tr>
<tr>
<td>142</td>
<td>903.0000</td>
<td>901.7500</td>
</tr>
<tr>
<td>143</td>
<td>909.0000</td>
<td>907.7500</td>
</tr>
<tr>
<td>144</td>
<td>915.0000</td>
<td>913.7500</td>
</tr>
<tr>
<td>145</td>
<td>921.0000</td>
<td>919.7500</td>
</tr>
<tr>
<td>146</td>
<td>927.0000</td>
<td>925.7500</td>
</tr>
<tr>
<td>147</td>
<td>933.0000</td>
<td>931.7500</td>
</tr>
<tr>
<td>148</td>
<td>939.0000</td>
<td>937.7500</td>
</tr>
<tr>
<td>149</td>
<td>945.0000</td>
<td>943.7500</td>
</tr>
<tr>
<td>150</td>
<td>951.0000</td>
<td>949.7500</td>
</tr>
</tbody>
</table>
### Table 6-5: EIA SDT and HRC

<table>
<thead>
<tr>
<th>EIA Channel Number</th>
<th>STD (Zero Offset) MHz</th>
<th>HRC MHz</th>
</tr>
</thead>
<tbody>
<tr>
<td>151</td>
<td>957.000</td>
<td>955.7500</td>
</tr>
<tr>
<td>152</td>
<td>963.000</td>
<td>961.7500</td>
</tr>
<tr>
<td>153</td>
<td>966.000</td>
<td>967.7500</td>
</tr>
<tr>
<td>154</td>
<td>972.000</td>
<td>973.7500</td>
</tr>
<tr>
<td>155</td>
<td>978.000</td>
<td>979.7500</td>
</tr>
<tr>
<td>156</td>
<td>984.000</td>
<td>985.7500</td>
</tr>
<tr>
<td>157</td>
<td>990.000</td>
<td>991.7500</td>
</tr>
<tr>
<td>158</td>
<td>996.000</td>
<td>997.7500</td>
</tr>
</tbody>
</table>
Symbols
- 16

A
alarm indicator 15
alarm list 94
alarm parameters setting 100
alarms view 93
alarms configuration 100
alarms log 102
Apply button 17
ASI port 101
ASI/GbE monitoring 8
assigning a license 45

B
barker channels 63
bitrate view 86
Bridging 34
button
Apply 17
Done 17

C
CA descriptor location 81
CAS 79
enable 81
global parameters 80
overview 79
setting parameters 80
changing parameter values 17
chassis 18
chassis properties 23
clearing configuration 107
clearing configuration during power up 107
communication ECMG and device 83
compliance and approval 2
configuring Ethernet ports 11, 22
configuring the device 17
constellation 18
control 109
control panel 109
configuring the NSG 112
display 109
hotkeys 110
keypad 110
screens 109
counters 104
CP Duration 81
CWG 79

D
D6 protocol 49
defining global parameters 80
defleting rows in a table 17
device name 18, 23
device utilization 86
diagnosing and analyzing traffic 101
Done button 17
DTI client 33
DTI flow 35
DTI port 33
redundancy 33
duplicate input streams 101
DVB SCR scrambling 79
DVB scrambling 81
defining 81
DVB scrambling mode 81
DVB standards 115
dynamic extraction of input 7

E
ECM 84
ECM expiration 85
expiration of ECM 80
ECMG 79, 83
ECMG Failover Retries 81
EdgeCluster 23
EdgeCluster technology 51
EIS 79, 83
enable CAS 81
enabling an RF-QAM port 18
enabling RF port 41
encryption mode 81
ERS proxy 80
ES types 114
ETH 18
ETH1 and ETH2 22
Ethernet ports 11
configuration 22
expiration of ECM 85

F
factory defaults 107
Fast 34
fields
greyed out 17
firmware upgrade 20
forwarding GbE port 101
Freerun 34

G
gbE 18
GbE monitoring 8
GbE port forwarding 101
GbE ports
defining properties 27
monitoring 104
general chassis parameters 18
generating logs 102
greyed out fields 17

H
Holdover 34
hotkeys 110
I
import configuration 19
incoming services 90
input bitrate 7, 90
input Format 7
IP address 28
IP unicast or multicast 7
ISA
monitoring 105
ISA message content 105
ITU-T Annex 18
L
licenses 44
adding 47
assigning 45
summary 46
Liquid Crystal Display 109
local time offset 25
logs
  generating 102
M
main features 7
management interfaces 9
M-CMTS session 74
Monitoring
  Hotkeys 113
monitoring
  device status 86
  device utilization 86
monitoring alarms/warnings 112
monitoring device utilization 86
monitoring ETH1 MAC Address 112
monitoring GbE ports 104
monitoring ISA 105
monitoring NSG 9000 status and slarms 93
monitoring the NSG 112
moving along screens 110
MPEG standards 114
N
notification 33
notifications 99
NSG 9000 14
NSGTM 6
NTP 18
NTP server 25
O
output bitrate 8
output information 91
P
paradigm 59
parameter values
  changing 17
  pass through 63
  password 13, 18
  PAT 59
  PID
    routing 66
  Platform page 18
  PM license 44
  PMT 59
  PMT Interval 59
  Port
    RF enabling 41
power level 18
preliminary configuration 109
Privacy Mode 79
  defining parameters 85
  overview 80
Privacy mode 81
privacy mode license 44
product information 113
Q
QAM license 44
QAM manager 18
QAM parameters 18
R
R6 protocol 49
random 59
redundancy 51
reports 106
resetting the NSG 112
resultCode 105
RF enable 41
RF parameters
  viewing 90
RF-QAM 18
routing a PID 66
routing a service 65
routing table 18
routing table parameters 26
S
SAT 60
SCG 84
SCG parameters 84
SCS 79
service information
  view 89
  service view 86
  session 74
  session based 81
  defining parameters 82
setting CAS parameters 80
setting device time 25
setting global parameters 80
slots 31
SNMP 24
symbol rate 18
T
tier based 81
  defining parameters 82
time
  setting 25
time zone 25
title bar 15
tracing 105
U
upgrading the firmware 20
using DTI clock 33
V
viewing traffic 89
VOD 80
VODS 85
W
Warmup 33
warning list 98
Index

web client 14
Z
zapping 107