Manual Part No. 28-0392

September, 2014

Copyright © 2000—9/19/14 Harmonic Inc. All rights reserved. Omneon, and the Omneon logo are trademarks of Harmonic Inc.

© 2014 Harmonic Inc. All rights reserved. Harmonic, the Harmonic logo, and other Harmonic products mentioned are trademarks, registered trademarks or service marks of Harmonic Inc. in the United States and other countries. Dolby, Dolby Digital, Dolby Digital Plus and Dolby E are registered trademarks of Dolby Laboratories. Implementations of AAC and HE-AAC by Fraunhofer IIS. Other company, product and service names mentioned herein may be trademarks or service marks of their respective owners. All product and application features and specifications are subject to change at Harmonic’s sole discretion at any time and without notice.

Disclaimer

Harmonic reserves the right to alter the equipment specifications and descriptions in this publication without prior notice. No part of this publication shall be deemed to be part of any contract or warranty unless specifically incorporated by reference into such contract or warranty. The information contained herein is merely descriptive in nature, and does not constitute a binding offer for sale of the product described herein. Harmonic assumes no responsibility or liability arising from the use of the products described herein, except as expressly agreed to in writing by Harmonic. The use and purchase of this product do not convey a license under any patent rights, copyrights, trademark rights, or any intellectual property rights of Harmonic. Nothing hereunder constitutes a representation or warranty that using any products in the manner described herein will not infringe any patents of third parties.

Third-Party Product Trademarks

Adobe® After Effects®, Photoshop®, Flash® Professional, Premiere®
Avid® Media Composer®
Dolby® E, Dolby Digital, Dolby Digital Plus
Jünger Audio™
Apple® QuickTime®,
Microsoft® Mediaroom®,
Microsoft® PlayReady®,
DOCSIS® 3.0
Start Over® TV

Third-Party Copyright Notes

Dolby is a registered trademark of Dolby Laboratories. Dolby Digital, Dolby Digital Plus, Dolby Pulse, aacPlus, AC-3, and Dolby E are trademarks of Dolby Laboratories.
Level Magic and Jünger are trademarks of Jünger Audio Studiotechnik GmbH.
MPEG Audio technology licensed from Fraunhofer IIS http://www.iis.fraunhofer.de/amm/
PitchBlue® is a registered trademark of Vigor Systems.
QuickTime and the QuickTime logo are trademarks or registered trademarks of Apple Computer, Inc., used under license therefrom.

Trademark Acknowledgments

Harmonic and all Harmonic product names are trademarks of Harmonic Inc. All other trademarks are the property of their respective owners.
The software described in this document is furnished under a license agreement or nondisclosure agreement. The software may be used or copied only in accordance with the terms of those agreements.

May be covered by one or more of U.S. Patents No. 6,571,351; 6,696,996; 6,545,721; 6,574,225; 6,895,003; 6,522,649; 6,643,702; foreign counterparts and pending patent applications.
This system is distributed with certain other software that may require disclosure or distribution of licenses, copyright notices, conditions of use, disclaimers and/or other matter. Use of this system or otherwise fulfilling their conditions constitutes your acceptance of them, as necessary. Copies of such licenses, notices, conditions, disclaimers and/or other matter are available in any one of the following locations: the LEGAL NOTICES AND LICENSES directory of the distribution disk of the software, the root directory of the hard disk drive of the Products, or by contacting us at support@harmonicinc.com.

Notice

Information contained in this guide is subject to change without notice or obligation. While every effort has been made to ensure that the information is accurate as of the publication date, Harmonic Inc. assumes no liability for errors or omissions. In addition, Harmonic Inc. assumes no responsibility for damages resulting from the use of this guide.

License Agreement and Limited Warranty

1. AGREEMENT: This is a legal agreement ("Agreement") between you ("you" or "your") and Harmonic, or its appropriate local affiliate ("Harmonic", "we", "us" or "our"). Use of our products and any updates thereto purchased or validly obtained by you (the "Products"), and/or the Software (as defined below) (collectively, the "System"), constitutes your acceptance of this Agreement. "Use" includes opening or breaking the seal on the packet containing this Agreement, installing or downloading the Software as defined below or using the Software preloaded or embedded in your System. As used herein, the term "Software" means the Harmonic owned software and/or firmware used in or with the Products and embedded into, provided with or loaded onto the
Products in object code format, but does not include, and this Agreement does not address, any third-party or free or open source software separately licensed to you ("Third Party Software"). If you do not agree to this Agreement, you shall promptly return the System with a dated receipt to the seller for a full refund.

2. LICENSE: Subject to the terms and conditions of this Agreement including payment, we hereby grant you a nonexclusive, nontransferable license to use the object code version of the Software embedded into, provided solely for use with or loaded onto the Product, and the accompanying documentation ("Documentation") for your internal business purposes. The Software and any authorized copies are owned by us or our suppliers, and are protected by law, including without limitation the copyright laws and treaties of the U.S.A. and other countries. Evaluation versions of the Software may be subject to a time-limited license key.

3. RESTRICTIONS: You (and your employees and contractors) shall not attempt to reverse engineer, disassemble, modify, translate, create derivative works of, rent, lease (including use on a time-sharing, applications service provider, service bureau or similar basis), loan, distribute, sublicense or otherwise transfer the System, in whole or part except to the extent otherwise permitted by law. The Software may be operated on a network only if and as permitted by its Documentation. You may make one (1) back up copy of the object code of the Software for archival purposes only. Evaluation Software will be run in a lab, nonproductive environment. Results of any benchmark or other performance tests may not be disclosed to any third party without our prior written consent. Title to and ownership of the Software and Documentation, and all copyright, patent, trade secret, trademark, and other intellectual property rights in the System, shall remain our or our licensors’ property. You shall not remove or alter any copyright or other proprietary rights notice on the System. We reserve all rights not expressly granted.

4. LIMITED WARRANTY: (a) Limited Warranty. We warrant to you that, commencing on your receipt of a Product and termination 1 year thereafter, the System will perform substantially in accordance with its then-current appropriate Documentation. The Product including replacement items consist of new, used or previously-installed components. (b) Remedies. If the System fails to comply with such warranty during such period, as your sole remedy, you must return the same in compliance with our product return policy, and we shall, at our option, repair or replace the System, provide a workaround, or refund the fees you paid. Replacement Systems are warranted for the original System’s remaining warranty period. (c) Exclusions. EVALUATION SOFTWARE IS LICENSED ON AS-IS BASIS AND SUBJECT TO 4d. We will have no obligation under this limited warranty, if the Products or Software are: (i) damaged by improper handling or installation; (ii) modified or repaired by you or a party other than a Harmonic authorized representative; (iii) not used in compliance with our product return policy, or (iv) not used for the purpose for which it was designed.

5. LIMITATION OF LIABILITY: WE AND OUR AFFILIATES, SUPPLIERS, LICENSORS, OR SALES CHANNELS (“REPRESENTATIVES”) SHALL NOT BE LIABLE TO YOU FOR ANY SPECIAL, INCIDENTAL, CONSEQUENTIAL, PUNITIVE, OR EXEMPLARY DAMAGES OF ANY KIND, INCLUDING BUT NOT LIMITED TO LOST REVENUES, PROFITS OR SAVINGS, OR THE COST OF SUBSTITUTE GOODS, HOWEVER CAUSED, UNDER CONTRACT, TORT, BREACH OF WARRANTY, NEGLIGENCE, OR OTHERWISE. EVEN IF WE WERE ADVISED OF THE POSSIBILITY OF SUCH LOSS OR DAMAGES. NOTWITHSTANDING ANY OTHER PROVISIONS OF THIS AGREEMENT, WE AND OUR REPRESENTATIVES’ TOTAL LIABILITY TO YOU ARISING FROM OR RELATING TO THIS AGREEMENT OR THE SYSTEM SHALL BE LIMITED TO THE TOTAL PAYMENTS TO US UNDER THIS AGREEMENT FOR THE SYSTEM. THE FOREGOING LIMITATIONS SHALL NOT APPLY TO DEATH OR PERSONAL INJURY TO PERSONS OR TANGIBLE PROPERTY IN ANY JURISDICTION WHERE APPLICABLE LAW PROHIBITS SUCH LIMITATION. YOU ARE SOLELY RESPONSIBLE FOR BACKING UP YOUR DATA AND FILES, AND HEREBY RELEASE US AND OUR REPRESENTATIVES FROM ANY LIABILITY OR DAMAGES DUE TO THE LOSS OF ANY SUCH DATA OR FILES. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO SUCH EXCLUSIONS MAY NOT APPLY TO YOU.

6. CONFIDENTIALITY: Information in the System and the associated media, as well as the structure, organization and code of the Software, are proprietary to us and contain valuable trade secrets developed or acquired at great expense to us or our suppliers. You shall not disclose to others or utilize any such information except as expressly provided herein, except for information (i) which you received from a third party which is not subject to confidentiality obligations; (ii) generally available to the public; (iii) lawfully received by you from a third party prior to your receipt of the System; or (iv) required by law to be disclosed.

7. SUPPORT: Updates, upgrades, fixes, maintenance or support for the System (an “Upgrade”) after the limited warranty period may be available at separate fee. Any Upgrades shall be subject to this Agreement, except for additional or inconsistent terms we specify. Upgrades do not extend the limited warranty period.

8. TERM; TERMINATION: The term of this Agreement shall continue unless terminated in accordance with this Section. We may terminate this Agreement at any time upon default by you of the license provisions of this Agreement, or any other material default by you of this Agreement not cured with thirty (30) days after written notice thereof. You may terminate this Agreement any time by terminating use of the System. Except for the first sentence of Section 2 ("License") and for Section 4a(1) ("Limited Warranty"), all provisions of this Agreement shall survive termination of this Agreement. Upon any such termination, you shall certify in writing such termination and non-use to us.

9. EXPORT CONTROLS: You agree that the Products and Software will not be shipped, transferred, or exported into any country or used in any manner prohibited by the United States Export Administration Act or any other export laws, restrictions, or regulations (the “Export Laws”). You will indemnify, defend and hold Harmonic and its Subsidiaries or its licensors harmless from any liability, loss, damage, cost or expense (including reasonable legal fees and expenses) arising from your violation of any such laws.

10. U.S. GOVERNMENT RIGHTS: The Software and the documentation which accompanies the Software are "Commercial Items," as that term is defined at 48 C.F.R. §2.101, consisting of "Commercial Computer Software and "Commercial Computer Software Documentation," as such terms are used in 48 C.F.R. §12.212 or 48 C.F.R. §227.7202-1 as applicable. Consistent with 48 C.F.R. §12.212 or 48 C.F.R. §§227.7202-1 through 227.7202-4, as applicable, the Commercial Computer Software and Commercial Computer Software Documentation are being licensed to U.S. Government as end users (i) only as Commercial Items and (ii) with only those rights as are granted to all other end users pursuant to the terms and conditions herein Harmonic, 4300 North First Street, Santa Clara, CA 95054 U.S.A.

11. GENERAL: You shall not assign, delegate or sublicense your rights or obligations under this Agreement, by operation of law or otherwise, without our prior written consent, and any attempt without such consent shall be void. Subject to the preceding sentence, this Agreement binds and benefits permitted successors and assigns. This Agreement is governed by California law, without regard to its conflicts of law principles. The U.N. Convention on Contracts for the International Sale of Goods is disclaimed. If any claim arises out of this Agreement, the parties hereby submit to the exclusive jurisdiction and venue of the federal and state courts located in Santa Clara County, California. In addition to any other rights or remedies, we shall be entitled to injunctive and other equitable relief, without posting bond or other security, to prevent any material breach of this Agreement. We may change the terms, conditions and pricing
relating to the future licensing of our Systems and other intellectual property rights, including this Agreement, from time to time. No waiver will be implied from conduct or failure to enforce rights nor effective unless in a writing signed on behalf of the party against whom the waiver is asserted. If any part of this Agreement is found unenforceable, the remaining parts will be enforced to the maximum extent permitted. There are no third-party beneficiaries to this Agreement. We are not bound by additional and/or conflicting provisions in any order, acceptance, or other correspondence unless we expressly agree in writing. This Agreement is the complete and exclusive statement of agreement between the parties as to its subject matter and supersedes all proposals or prior agreements, verbal or written, advertising, representations or communications concerning the System.

Every reasonable attempt has been made to comply with all licensing requirements for all components used in the system. Any oversight is unintentional and will be remedied if brought to the attention of Harmonic at support@harmonicinc.com.

Documentation Conventions
This guide may use some special symbols and fonts to call your attention to important information. The following symbols appear throughout this guide:

![Danger Symbol](image)

**DANGER:** The Danger symbol calls your attention to information that, if ignored, can cause physical harm to you.

![Caution Symbol](image)

**CAUTION:** The Caution symbol calls your attention to information that, if ignored, can adversely affect the performance of your Harmonic product, or that can make a procedure needlessly difficult.

![Laser Danger Symbol](image)

**LASER DANGER:** The Laser symbol and the Danger alert call your attention to information about the lasers in this product that, if ignored, can cause physical harm to you.

![Note Symbol](image)

**NOTE:** The Note symbol calls your attention to additional information that you will benefit from heeding. It may be used to call attention to an especially important piece of information you need, or it may provide additional information that applies in only some carefully delineated circumstances.

![Important Symbol](image)

**IMPORTANT:** The Important symbol calls your attention to information that should stand out when you are reading product details and procedural information.

![Tip Symbol](image)

**TIP:** The Tip symbol calls your attention to parenthetical information that is not necessary for performing a given procedure, but which, if followed, might make the procedure or its subsequent steps easier, smoother, or more efficient.

In addition to these symbols, this guide may use the following text conventions:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Typed Command</td>
<td>Indicates the text that you type in at the keyboard prompt.</td>
</tr>
<tr>
<td><code>&lt;Ctrl&gt;, &lt;Ctrl&gt;+&lt;Shift&gt;</code></td>
<td>A key or key sequence to press.</td>
</tr>
<tr>
<td><strong>Links</strong></td>
<td>The <em>italics in blue</em> text to indicate Cross-references, and hyperlinked cross-references in online documents.</td>
</tr>
<tr>
<td><strong>Bold</strong></td>
<td>Indicates a button to click, or a menu item to select.</td>
</tr>
<tr>
<td><strong>ScreenOutput</strong></td>
<td>The text that is displayed on a computer screen.</td>
</tr>
<tr>
<td><strong>Emphasis</strong></td>
<td>The <em>italics</em> text used for emphasis and document references.</td>
</tr>
</tbody>
</table>

**NOTE:** You require Adobe Reader or Adobe Acrobat version 6.0 or later to open the PDF files. You can download Adobe Reader free of charge from www.adobe.com.
Contents

Introduction ...................................................................................................................... 1
Spectrum System Documentation Suite ........................................................................... 1
    Locating the Latest Documentation on the Harmonic Website ..................................... 1
Technical Support ........................................................................................................... 3
    Useful Information when Contacting Technical Support ................................................ 3

Chapter 1: Onboard Playout Control Configuration Overview .................................. 5
Onboard Playout Control Configuration Overview .......................................................... 5
    ChannelPort System Configuration Overview ............................................................. 5
    MediaPort 7000 Configuration Overview .................................................................... 5

Chapter 2: Spectrum Onboard Playout Control ......................................................... 7
OPC Workflow Overview ................................................................................................. 7
About Traffic and Billing Services .................................................................................... 8
About Spectrum OPC Playlists .......................................................................................... 8
Loading a Spectrum OPC Playlist .................................................................................... 8
    About Time Delays when Loading Playlists .................................................................... 8
Retrieving a Spectrum As-run List .................................................................................... 9
Configuring Error Thresholds ......................................................................................... 10
About Media Fetch ........................................................................................................... 11
About BXF Support .......................................................................................................... 11
Additional OPC Terms and Concepts .............................................................................. 11
    Primary Events ............................................................................................................. 11
    Primary Event Start Mode ......................................................................................... 12
    Primary Event End Mode ........................................................................................... 13
    Other Primary Event Fields ......................................................................................... 13
    Secondary Events ....................................................................................................... 14
    Secondary Event Start Mode ....................................................................................... 14
    Secondary Event End Mode ......................................................................................... 15
    Other Secondary Event Fields .................................................................................... 15
    OPC Interactive Controls ........................................................................................... 16

Chapter 3: Installing PlayoutTool .................................................................................. 17
System Requirements ...................................................................................................... 17
    Windows ...................................................................................................................... 17
    Macintosh Operating System ....................................................................................... 17
System Compatibility ....................................................................................................... 17
Installing PlayoutTool ...................................................................................................... 17
    Installing Adobe Air ................................................................................................. 17
    Installing PlayoutTool ............................................................................................... 17

Chapter 4: Using PlayoutTool ....................................................................................... 19
Configuring the PlayoutTool Connection and Channel Group(s) .................................. 19
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using PlayoutTool</td>
<td>22</td>
</tr>
<tr>
<td>Channel Group View</td>
<td>22</td>
</tr>
<tr>
<td>Channel List View</td>
<td>22</td>
</tr>
<tr>
<td>Viewing Channel Selectors</td>
<td>24</td>
</tr>
<tr>
<td>Viewing the Channel Status Area</td>
<td>24</td>
</tr>
<tr>
<td>Viewing On-Air Primaries and Secondaries</td>
<td>26</td>
</tr>
<tr>
<td>Viewing the Event List</td>
<td>28</td>
</tr>
<tr>
<td>Viewing Event Details</td>
<td>29</td>
</tr>
<tr>
<td>Viewing Channel Alarms</td>
<td>33</td>
</tr>
<tr>
<td>Viewing Diagnostic Logs</td>
<td>34</td>
</tr>
<tr>
<td>Using Channel Override</td>
<td>35</td>
</tr>
<tr>
<td>Using Mixer Override</td>
<td>36</td>
</tr>
<tr>
<td>Using ARC Override</td>
<td>37</td>
</tr>
<tr>
<td>Editing Events in PlayoutTool</td>
<td>37</td>
</tr>
<tr>
<td>Enabling Editing Mode</td>
<td>38</td>
</tr>
<tr>
<td>Inserting Primary Events</td>
<td>38</td>
</tr>
<tr>
<td>Inserting Secondary Events</td>
<td>38</td>
</tr>
<tr>
<td>Editing Secondary Event Text Fields</td>
<td>39</td>
</tr>
<tr>
<td>Inserting a Playlist</td>
<td>39</td>
</tr>
<tr>
<td>Loading a Playlist</td>
<td>39</td>
</tr>
<tr>
<td>Deleting Primary/Secondary Events</td>
<td>40</td>
</tr>
<tr>
<td>PlayoutTool Keyboard Shortcuts</td>
<td>40</td>
</tr>
<tr>
<td>Chapter 5: Using ScheduleTool</td>
<td>43</td>
</tr>
<tr>
<td>Connecting to ScheduleTool</td>
<td>43</td>
</tr>
<tr>
<td>Selecting a Channel</td>
<td>44</td>
</tr>
<tr>
<td>Viewing Channel Properties</td>
<td>44</td>
</tr>
<tr>
<td>Configuring the Default Values for Schedule Events</td>
<td>45</td>
</tr>
<tr>
<td>Creating, Editing, and Saving a Schedule</td>
<td>45</td>
</tr>
<tr>
<td>Saving a Schedule to a Subdirectory</td>
<td>46</td>
</tr>
<tr>
<td>Using Find Material to Add Events to a Schedule</td>
<td>47</td>
</tr>
<tr>
<td>Selecting Event Blocks</td>
<td>47</td>
</tr>
<tr>
<td>Configuring Schedule Metadata</td>
<td>47</td>
</tr>
<tr>
<td>Viewing and Editing the Event List</td>
<td>47</td>
</tr>
<tr>
<td>Viewing and Editing Event Details</td>
<td>49</td>
</tr>
<tr>
<td>Saving a Schedule for a Different Channel</td>
<td>50</td>
</tr>
<tr>
<td>Viewing Logs (for MediaDeck 7000 only)</td>
<td>50</td>
</tr>
<tr>
<td>Clearing Local Settings</td>
<td>50</td>
</tr>
<tr>
<td>About Start Times in ScheduleTool</td>
<td>51</td>
</tr>
<tr>
<td>ScheduleTool Keyboard Shortcuts</td>
<td>51</td>
</tr>
<tr>
<td>Appendix A: Contacting the Technical Assistance Center</td>
<td>53</td>
</tr>
</tbody>
</table>
Introduction

This document provides the following in-depth information for using the Spectrum Onboard Playout Control (OPC) feature.

- Introduction (this section) provides the following topics:
  - Spectrum System Documentation Suite
  - Technical Support
- Chapter 1, Onboard Playout Control Configuration Overview provides an overview of configuring a ChannelPort or MediaPort 7000 channel for Onboard Playout Control.
- Chapter 2, Spectrum Onboard Playout Control provides an overview of the Spectrum Onboard Playout Control feature.
- Chapter 3, Installing PlayoutTool provides instructions for installing PlayoutTool.
- Chapter 4, Using PlayoutTool provides instructions for using the OPC monitoring tool, PlayoutTool.

Spectrum System Documentation Suite

The table below describes the documents which comprise the Spectrum System Documentation Suite.

<table>
<thead>
<tr>
<th>Spectrum (MediaDirector 2201, 2202, 2251, 2252, MediaCenter, MediaPort 5000, MediaPort 7000, ChannelPort)</th>
<th>Provides this information...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spectrum System Installation and Hardware Reference Guide</td>
<td>System installation  Software installation and upgrade details  Orientation to system components including MediaDirectors, MediaCenters, MediaPorts, ChannelPorts, and MediaStores  Troubleshooting system components  Specifications for system components</td>
</tr>
<tr>
<td>Spectrum System Protocol Reference Guide</td>
<td>Command sets and preroll parameters for controlling MediaDirectors  The Harmonic implementation of FTP server</td>
</tr>
<tr>
<td>Spectrum Quick Reference Guides</td>
<td>Front and back panel views of Spectrum devices  LED assignments and legends</td>
</tr>
<tr>
<td>Spectrum ChannelPort Template Authoring Guide</td>
<td>ChannelPort template authoring</td>
</tr>
<tr>
<td>Spectrum ChannelPort Tools User Guide</td>
<td>Using ChannelPort tools</td>
</tr>
<tr>
<td>Spectrum Component Replacement Guide</td>
<td>Component replacement instructions for all Spectrum devices</td>
</tr>
<tr>
<td>Spectrum and MediaDeck Release Notes</td>
<td>Last minute information regarding a product release</td>
</tr>
<tr>
<td>--------------------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td><strong>Spectrum MediaDeck 7000</strong></td>
<td><strong>Provides this information...</strong></td>
</tr>
<tr>
<td>Spectrum MediaDeck 7000 Installation Guide</td>
<td>System installation</td>
</tr>
<tr>
<td>Spectrum and MediaDeck Release Notes</td>
<td>Last minute information regarding a product release</td>
</tr>
</tbody>
</table>
| Spectrum MediaDeck 7000 Read Me First | • Passwords for downloading MediaDeck and SystemManager files  
                                       | • Instructions for obtaining and installing the license file for SystemManager  
                                       | • Installation overview                              |
| **Spectrum (MediaDirector 2100, 2101, 2102, 2102B, MediaPort 1000, 3000, 4000, 6000 Series)** | **Provides this information...**                 |
| This document...                     | Provides this information...                     |
| Omneon Spectrum System Getting Started Guide | • System installation  
                                           | • Software installation and upgrade details         |
| Omneon Spectrum System Hardware Orientation Guide | • Orientation to system components including MediaPorts, and MediaStores  
                                                   | • Troubleshooting system components  
                                                   | • Specifications for system components             |
| Omneon Spectrum System Protocol Reference Guide | • Command sets and preroll parameters for controlling MediaDirectors  
                                                      | • The Harmonic implementation of FTP server         |
| Omneon Spectrum Quick Reference Guides | • Front and back panel views of Spectrum devices  
                                           | • LED assignments and legends                      |
| **Omneon MediaDeck**                 | **Provides this information...**                 |
| This document...                     | Provides this information...                     |
| Omneon MediaDeck User Guide          | • System installation  
                                           | • Upgrade instructions  
                                           | • Orientation to system components                 |
| Omneon MediaDeck Installation Guide  | System installation                              |
| Spectrum and MediaDeck Release Notes | Last minute information regarding a product release |
| Omneon MediaDeck Read Me First       | • Passwords for downloading MediaDeck and SystemManager files  
                                           | • Instructions for obtaining and installing the license file for SystemManager  
                                           | • Installation overview                              |


- **Release Notes**: Spectrum_v.x.x.x_ReleaseNotes.pdf
- **All other components of the Spectrum System Documentation Suite**: MediaDeckAndSpectrum-v.x.x.x-Documentation.exe
For ChannelPort templates, tools, and documentation, as well as Onboard Playout Control tools and documentation: ChannelPortTemplatesAndTools-v.x.x.x-SWandDoc.exe.


For the SystemManager documentation, navigate to: ftp://ftp.omneon.com/updates/omneon/current/SystemManager

SystemManager documents are packaged SystemManager-v.x.x.x-Documentation.exe.

Acrobat® Reader® is needed to view the product documentation. Download this for free from: http://www.adobe.com

All files on the Support Server are password protected. Contact Technical Support if you need assistance with unlocking the files.

Locating the Latest Documentation on the Harmonic Website

The latest documentation can be found at http://www.harmonicinc.com/documents-detail.

Technical Support

For information on contacting Harmonic Technical Support, refer to Appendix A, Contacting the Technical Assistance Center.

Useful Information when Contacting Technical Support

In order to assist Technical Support, review the following information:

- What version of firmware is installed on your system?
  From the Home tab, click the Upgrade Firmware icon in the left-hand column to display the Upgrade Firmware page. The firmware version for each device is shown in the Current Firmware Version column.

- What version of SystemManager software is installed?
  From SystemManager, click the Help tab. The version is shown in the Server Software section of the page.

- Which Windows operating system is running on the SystemManager client PC?
  a. From Windows, click the Start button, and then click Run.
  b. In the Open field, type: winver, and then press Enter to open the About Windows dialog box, which shows the version number.

- How much memory is installed on the SystemManager platform? (for example, 256 MB, 512 MB, or 1 GB)
  a. From Windows, click the Start button, and then click Run.
  b. In the Open field, type: winver and then press Enter to open the About Windows dialog box. Look for the line that reads, “Physical memory available to Windows.”

- Please provide the manager.oda file from the SystemManager platform or client PC
  Technical Support may request that you email the manager.oda file, which contains configuration information for your system. This file is located on the SystemManager platform at D:\Omneon\Manager\omdb, or if you are using a client PC with a single C: partition, it will be in the same directory on the C: drive.
What is the model and serial number of the hardware involved?
- For Spectrum and MediaDeck devices: from the Home tab, click the Upgrade Firmware icon in the left-hand column to display the Upgrade Firmware page. Both MediaDirectors and MediaDecks are listed in the MediaDirectors section. Find the Model Numbers and Serial Numbers listed in their respective columns.
- Scroll down to the MediaPorts section to view the Model Numbers and Serial Numbers for MediaPorts and MediaDeck Modules.
- For Harmonic MediaGrid Devices: Click the Servers & Switches icon in the left-hand column. From the Servers and Switches page, in the Name column, click the link for the Harmonic MediaGrid device to open the Properties page for that device.
- For ProXchange devices: Click the ProXchange Servers icon in the left-hand column. From the Servers page, in the Name column, click the link for the ProXchange device to open the Properties page for that device.
- For ProBrowse devices: Click the ProBrowse Servers icon in the left-hand column. From the Servers page, in the Name column, click the link for the ProBrowse device to open the Properties page for that device.
- For MAS devices: Click the MAS Servers icon in the left-hand column. From the Servers page, in the Name column, click the link for the MAS device to open the Properties page for that device.

For Spectrum Systems
- What is the name of the Player that is being used?
  From SystemManager, click the Player Configuration link in the left-hand column, and then click the name of the MediaDirector or MediaDeck. The Player List page for that device appears. The names and status of all players are listed.
- What file format and bit rate is the Player configured for? (for example, MPEG, DV, or IMX?)
  a. From SystemManager, click the Player Configuration link in the left-hand column, and then click the name of the MediaDirector or MediaDeck. The Player List page for that device appears.
  b. From the player list, click the Properties link to view all the details for a player.
- If the problem is related to Ingest or Playout of a clip, what is the Clip ID involved?
  The clip name or clip ID should be indicated by whatever software application you are using to play or record video. For Omneon ClipTool, clip names are displayed in the clip management area of the ClipTool main window.
- What brand of Automation, if any, is being used for control?
- Is the Automation using VDCP or API for communication control?
Chapter 1
Onboard Playout Control Configuration Overview

Onboard Playout Control Configuration Overview

Spectrum Onboard Playout Control (OPC), including PlayoutTool, works in coordination with a Playout Channel running on a Spectrum video server that you configure using SystemManager. For information on installing a ChannelPort module, refer to the Spectrum Installation and Hardware Reference Guide. For information on installing a ChannelPort or MediaPort 7000 module in a Spectrum System, refer to the Spectrum Installation and Hardware Reference Guide.

The following sections provide an overview for configuring a ChannelPort or a MediaPort 7000 for Onboard Playout Control:

- ChannelPort System Configuration Overview
- MediaPort 7000 Configuration Overview

ChannelPort System Configuration Overview

Harmonic recommends that you configure your ChannelPort system in the following order:

1. **System**: If you wish to enable Enhanced Channel mode on your ChannelPort, do so before configuring your channels. Otherwise, the ChannelPort will operate in Standard Channel mode. See “Enabling Enhanced Channel Mode” in the Harmonic SystemManager User Guide.

2. **Channel**: Configure the basic parameters for your ChannelPort channel, including master control switcher settings, audio profiles, independent branding, or serial port settings required for automation. See “Configuring a ChannelPort Channel” and “Configuring an Audio Profile” in the Harmonic SystemManager User Guide for more information.

3. **Player**: See “Player Configuration” in the Harmonic SystemManager User Guide for help with configuring a player. Note that if you wish to use Onboard Playout Control (OPC) for player control, configure your player to use “Harmonic Playout” for control.

4. **Graphics**: Make sure your graphic templates follow Harmonic guidelines so they can be played on the ChannelPort. Configure FXTool if you plan to use it. See the Spectrum ChannelPort Template Authoring Guide.

5. **Onboard Playout Control (OPC)**: Configure any OPC features and tools that you wish to use. For help with configuring the Playout Channel, Traffic and Billing, or Media Fetch, see “Video Server Services Configuration” in the Harmonic SystemManager User Guide. For information on creating and monitoring playlists with ScheduleTool and PlayoutTool, see the Spectrum Playout User Guide (this guide). For information on configuring PreviewTool, refer to the Spectrum ChannelPort Tools User Guide.

6. **GPIO**: If using GPIO, configure the ChannelPort GPIO triggers and then map them to ChannelPort channel events or Playout Channel events. See “Configuring ChannelPort GPIO Triggers” in the Harmonic SystemManager User Guide.

7. **EAS**: If using an EAS, make sure the ChannelPort is connected to the EAS as described in the installation instructions, and then configure the EAS settings. See “Configuring a ChannelPort Channel” in the Harmonic SystemManager User Guide.

MediaPort 7000 Configuration Overview

Harmonic recommends that you configure your MediaPort 7000 in the following order:
1. **Player**: Configure your players according to the instructions in “Player Configuration” in the *Harmonic SystemManager User Guide*. Note that if you wish to use Onboard Playout Control (OPC) for player control, configure your player to use “Harmonic Playout” for control.

2. **Onboard Playout Control (OPC)**: Configure any OPC features and tools that you wish to use. For information on configuring the Playout Channel, Traffic and Billing, and Media Fetch, see “Video Server Services Configuration” in the *Harmonic SystemManager User Guide*. For information on creating and monitoring playlists with ScheduleTool and PlayoutTool, see the *Spectrum Playout User Guide* (this guide).

3. **GPIO**: Configure GPIO settings on the MediaPort 7000 and map those GPIO triggers to any player settings or OPC settings you wish to configure. See “Configuring GPIO” in the *Harmonic SystemManager User Guide*. 


Chapter 2
Spectrum Onboard Playout Control

Onboard Playout Control (OPC) is an optional, licensed Spectrum system feature that provides unattended playout of clips and graphics driven by a channel's traffic schedule. OPC controls the Playout Channel and graphics plane of a Spectrum system, but it is not an automation system: each instance of OPC controls only the channel for which it has been configured.

OPC consists of software present on a Spectrum system (MediaCenter, MediaDirector, or MediaDeck 7000) plus a tool for monitoring channels, PlayoutTool (see Chapter 4, Using PlayoutTool for more information), and a tool for creating and modifying traffic schedules, ScheduleTool (see Chapter 5, Using ScheduleTool).

Media Fetch, also an optional, licensed feature is available for use with OPC. Refer to About Media Fetch for more information.

This chapter includes the following sections:

- OPC Workflow Overview
- About Traffic and Billing Services
- About Spectrum OPC Playlists
- Retrieving a Spectrum As-run List
- Configuring Error Thresholds
- About Media Fetch
- Additional OPC Terms and Concepts

OPC Workflow Overview

The following steps provide an overview for getting started with Onboard Playout Control:

1. Configure the ChannelPort channel for Onboard Playout Control.
   - If you are using a ChannelPort, refer to ChannelPort System Configuration Overview in Chapter 1, Onboard Playout Control Configuration Overview for instructions.
   - If you are using a MediaPort 7000, refer to MediaPort 7000 Configuration Overview in Chapter 1, Onboard Playout Control Configuration Overview for instructions.

   **NOTE:** The playout channel of a MediaPort 7000 can be configured for OPC, but a MediaPort 7000 cannot play graphic secondaries.

2. Your traffic and billing department creates a playlist that must adhere to the Spectrum OPC playlist schema. Refer to About Spectrum OPC Playlists for more information.

3. Copy the playlist to the Playlist folder on the Spectrum video server. Refer to About Spectrum OPC Playlists for more information.

4. Once all the events in the playlist have been executed, you can retrieve your as-run list from the as-run folder on the Spectrum video server. Refer to Retrieving a Spectrum As-run List for more information.
About Traffic and Billing Services

When you enable traffic and billing services in SystemManager, you enable the use of the playlist and as-run folders, which is an integral part of the OPC feature. After enabling traffic and billing, you can override the default locations of playlist and as-run folders.

Refer to About Spectrum OPC Playlists for more information about playlists and the playlist folder. Refer to Retrieving a Spectrum As-run List for more information about as-run lists and the as-run folder.

Refer to “Enabling Traffic and Billing Services” in the SystemManager User Guide for instructions on enabling/disabling traffic and billing services.

About Spectrum OPC Playlists

The Spectrum OPC playlist is an XML file that contains information about primary and secondary events that are scheduled to be played at a certain time. This information is set by your traffic services department.

The ChannelPortTemplatesAndTools-v7.7.0.0-SWandDoc package contains a sample OPC playlist as well as an XML schema document (.xsd) for creating an OPC playlist. The OPC .xsd file contains the rules for ensuring your playlist will be a “valid” .xml file.

IMPORTANT: Playlist must conform to the Spectrum OPC Playlist schema.

For an example of an OPC playlist, refer to OPC_playlist_example.xml.

For the OPC playlist schema, refer to OPC_playlist.xsd.

Loading a Spectrum OPC Playlist

Harmonic has provided a default location on your Spectrum video server for loading your playlists. The default location is shown in the following path:

```
\<IP address>\<file system>\traffic\<serial number>\playlists
```

- IP address: The IP address of your Spectrum video server (MediaDirector, MediaCenter, or MediaDeck 7000).
- The <file system> default name is fs0.
- Serial number: The serial number of your Spectrum video server (MediaDirector, MediaCenter, or MediaDeck 7000).

TIP: You can find the IP address of the Spectrum video server by navigating to the Properties page for that device in SystemManager. For details, refer to “Viewing Spectrum Video Server Properties” in the SystemManager User Guide.

To load a playlist via the filesystem:
1. Click Start, and in the search field type in the IP address of your MediaDirector, MediaCenter, or MediaDeck 7000.
2. Open the file system folder.
3. Open the traffic folder.
4. Open the folder with the serial number of your MediaDirector, MediaCenter, or MediaDeck 7000.
5. Open the playlists folder.
6. Copy your playlist to this location.
7. To monitor the playlist when it runs, use PlayoutTool. Refer to Chapter 4, Using PlayoutTool for instructions.

If you want to configure and use a playlist folder that is not the default folder, see “Configuring a Playout Channel” and “Enabling Traffic and Billing” in the SystemManager User Guide.

About Time Delays when Loading Playlists

Delay when Playlists Loaded from Folder to OPC

The Spectrum traffic system regularly polls the playlists folder and loads newly discovered Spectrum OPC playlists onto the OPC. After you copy a playlist to the playlists folder, it may take at least ten seconds for the playlist to be loaded from the playlists folder onto the OPC, at which point it can be monitored in PlayoutTool.

Delay when New Playlist Replaces Playlist On Air

If you load a playlist that is meant to replace a playlist that is currently live, it may take up to 30 seconds after the end of the current primary event before events from the new playlist replace events from the running playlist.

NOTE: The thirty-second delay is in addition to the ten-second delay that may occur when the playlist is loaded from the playlist folder to the OPC.

The OPC identifies a point in the future where events from the new playlist can replace events from the running playlist without any on-air disruption. The first event to be replaced will be after that next event (the event after the current on-air event), and at least 30 seconds from, the current on-air event.

For example, if the current primary event is set to play for an hour, events from the new playlist will not start until that primary event and the event following it are complete. However, if the current primary event is about to end, and is followed by several short primary events, the first event to be replaced will be the one that after the next event and has a start time that is at least 30 seconds in the future from the end of the current primary event.

Retrieving a Spectrum As-run List

An as-run list is a log, created by OPC, of executed primary and secondary events. They contain the same data as your playlists, but they also include the actual times and durations of played events. In addition, any failures or errors that occurred during playout are noted in as-run lists.

Harmonic has provided a default location on your Spectrum video server where as-run lists are stored after OPC creates them. The default location is shown in the following path:

\<IP address>\<file system>\traffic\<serial number>\asruns

- IP address: The IP address of your Spectrum video server (MediaDirector, MediaCenter, or MediaDeck 7000).
Tip: You can find the IP address of the Spectrum video server by navigating to the Properties page for that device in SystemManager. For details, refer to “Viewing Spectrum Video Server Properties” in the SystemManager User Guide.

- The <file system> default name is `fs0`.
- Serial number: The serial number of your Spectrum video server (MediaDirector, MediaCenter, or MediaDeck 7000).

Tip: You can find the serial number of the Spectrum video server by navigating to the Properties page for that device in SystemManager. For details, refer to “Viewing Spectrum Video Server Properties” in the SystemManager User Guide.

To retrieve an as-run list via the filesystem:
1. Click Start, and in the search field type in the IP address of your MediaDirector, MediaCenter, or MediaDeck 7000.
2. Open the file system folder.
3. Open the traffic folder.
4. Open the folder with the serial number of your MediaDirector, MediaCenter, or MediaDeck 7000.
5. Open the asruns folder.

Note: Once they are created, as-run lists are kept in this location for 45 days. After 45 days, they will be deleted from the Spectrum system.

If you want to configure and use an as-run folder that is not the default folder, see “Configuring a Playout Channel” and “Enabling Traffic and Billing” in the SystemManager User Guide.

Configuring Error Thresholds

To prevent the Spectrum system from creating playlist alarms before a playlist is finalized, you can configure the error thresholds.

For example, you may load a playlist to the playlist folder on the Spectrum video server before all the media clips are prepared. If this playlist is sent to OPC before the media clips are ready, you will see errors in the Spectrum Syslog or in the PlayoutTool Channel Status area or Event List area.

The following error thresholds can be configured in SystemManager:

- Playlist Warning Threshold (hh:mm:ss): If there is a problem in the playlist (for example, missing material or a schedule gap), this is the amount of time before the Event Start when the Spectrum system will generate a warning.
- Playlist Error Threshold (hh:mm:ss): If there is a problem in the playlist (for example, missing material or a schedule gap), this is the amount of time before the Event Start when the Spectrum system will generate an error.
- Schedule Gap Error Threshold (seconds): If there is a schedule gap in the playlist that is greater than the threshold, the Spectrum system will generate an error.
- Schedule Overlap Error Threshold (seconds): If there is a schedule overlap in the playlist that is greater than the threshold, the Spectrum system will generate an error.
Generate Error on Empty Playlist: If there are not enough events in the playlist to extend past the time indicated in the Playlist Error Threshold field, the Spectrum system will generate an error.

For more instructions on configuring error thresholds, refer to “Configuring a Playout Channel” in the SystemManager User Guide.

For more information on viewing alarms in PlayoutTool, refer to Chapter 4, Using PlayoutTool.

About Media Fetch

Media Fetch is an optional, licensed feature that extends the functionality of OPC. After it is configured, Media Fetch uses File Transfer Protocol (FTP) to automatically retrieve material that is scheduled to be played. Up to four remote data stores can be configured for Media Fetch.

Each Playout Channel instance needs to be configured for Media Fetch.

As an extension of OPC, Media Fetch sequences transfers so that material needed earliest is transferred ahead of material needed later.

Spectrum systems support Media Fetch only when it is used in conjunction with OPC. It is not possible to use Media Fetch with any other playout control or automation system.

For instructions on configuring Media Fetch, refer to “Configuring the Media Fetch Service” in the SystemManager User Guide.

About BXF Support

With Spectrum 7.7 and later, OPC supports playlists in standard BXF format. This means you may load a BXF playlist to your playlist folder (shown in the Traffic and Billing section of the “Playout Channel Properties” page in SystemManager) and the OPC playout channel will interpret it. You may also configure the Traffic and Billing settings to generate as-run files in BXF format. In this case, Spectrum will generate two as-run files, one in BXF format and a second in an OPC-compatible format.

For instructions on modifying the playlist path or as-run format, see “Configuring Traffic and Billing” in the SystemManager 6.1 User Guide.

Additional OPC Terms and Concepts

The following terms and concepts summarize the rules that govern the execution of an OPC playlist.

Primary Events

There are several types of primary events:

- **Primary (video) event**: The primary video material is a clip from a Spectrum player, an external input feed, or the internal color generator.

- **Comment event**: These events provide additional information but do not contribute to the video output.
  - **Break Header event**: This is a specialized type of comment event that does not contribute to the video output.
  - **Program Header event**: A specialized type of comment event that does not contribute to the video output.
Schedule Header event: These events are automatically inserted at the start of each schedule, and are used to mark the boundaries between schedules. Like comment events, they do not contribute to the video output.

Status event: This type of event is added to the as-run file by OPC to record important information about the executed playlist.

Primary Event Start Mode

Primary events are executed, or “taken to-air”, based on their Start Mode and the state of the current on-air primary event. There are several types of Primary Event Start Modes:

- Fixed Start Mode
- Follow Start Mode
- Manual Start Mode
- External Start Mode

Fixed Start Mode

A Fixed start mode event is taken to air at its scheduled start date/time. If the current on-air event has not completed when the Fixed start event is due, the current on-air event will be preempted (and truncated). If there are events before the Fixed start event that have not yet gone to air, they will be skipped. Note that event date/times are in UTC in an OPC playlist file, but are displayed/edited in the local channel timezone in PlayoutTool.

If a Fixed start mode event is not yet due when the current event ends, the Black Gap Filler event will be taken.

OPC looks ahead at the next five events in the playlist. The Fixed start event must be within this five-event look ahead in order to be taken. Comments, headers, status events, and dropped events are not included in the five-event limit.

OPC acts on the next Fixed start event in the playlist, ignoring subsequent Fixed start events until the first has gone on-air. This could result in a situation where a subsequent Fixed start event becomes overdue (its scheduled time has passed) before it becomes the next Fixed start event.

An overdue Fixed start event is treated as a Follow start event for switching purposes.

A Fixed start event can be taken to air early by a Take Next command from the operator.

Follow Start Mode

A Follow Start Mode event is taken to air when the current on-air event ends.

If there is no on-air event, or the on-air event has a Manual or External End mode, the next Follow event will not be automatically taken to air. A Take Next command will be required to advance the playlist.

A Follow Start Mode event can be taken to air early by a Take Next command from the operator.

Manual Start Mode

A Manual Start Mode event will not be automatically taken to air when the current on-air event ends. When the current on-air event ends, the output will be switched to the default MCS source (if configured) and playlist execution will stop until a Take Next command is issued by the operator.
An upcoming Fixed start event can cause a Manual start event to be skipped before it is taken.

**External Start Mode**

Like a Manual Start Mode event, an External Start Mode event will not automatically be taken to air when the current on-air event ends. The output will be switched to the default MCS source (if configured) and playlist execution will stop until an External Cue is received.

**NOTE:** External cues are driven by your Event Manager (GPI) Input configuration. Refer to "Configuring a Playout Channel" in the Harmonic SystemManager User Guide for instructions on configuring Event Manager Input.

An External Cue will not start an event unless the event has External Start Mode.

An upcoming Fixed start event can cause an External start event to be skipped before it is taken.

An External Start Mode event can also be started by a Take Next command from the operator.

**Primary Event End Mode**

The end of a primary event is determined by the End Mode field. There are three Primary Event End Modes:

- **Duration End Mode**
- **Manual End Mode**
- **External End Mode**

**Duration End Mode**

A primary event with Duration End Mode will end when the scheduled duration for the event expires. If the next event is a Follow start event, it will be taken immediately. If the next event is a Manual or External start event, the output will be switched to the default MCS source (if configured) until a manual trigger is received from the operator. If the next event is a Fixed start event that has not yet come due, the Black Gap Filler event will be taken.

**Manual End Mode**

A primary event with Manual End Mode will remain on-air until a Take Next command is received from the operator, or it is preempted by an upcoming Fixed start event.

**External End Mode**

A primary event with External End Mode will remain on-air until an External Cue is received, a Take Next command is issued by the operator, or it is preempted by an upcoming Fixed start event.

An External Cue will not end an event unless the event has External End Mode.

**NOTE:** External cues are driven by your Event Manager (GPI) Input configuration. Refer to "Configuring a Playout Channel" in the Harmonic SystemManager User Guide for instructions on configuring Event Manager Input.

**Other Primary Event Fields**

The following primary event fields are also used to control the channel output:
- **Expected Start Time (scheduled start time):** determines when Fixed start events are taken.
- **Source:** determines the MCS input to be switched to air (Player, External Input, Color Generator).
- **Material:** determines the video clip to be played when the source is Player, or the color to be displayed when the source is Color Generator.
- **SOM:** determines the starting point for playback of video clips (mark in, offset from the start of the clip, or absolute timecode).
- **Transition:** determines the fade or mix transition to be used between primary events.
- **Duration:** determines the length of time that a primary event stays on-air when the event has Duration End Mode; also used as an approximation of how the event stays on-air for other End Modes.

**Secondary Events**

Secondary events are always associated with a primary event, and they are always executed with timing that is relative to their primary event. There are two types of secondary events:

- **Graphics event:** These events cause graphics templates to be loaded, faded up, faded down, and unloaded.
- **Comment event:** These events provide additional information but do not contribute to the video output.

**Secondary Event Start Mode**

The timing of the start of a secondary event is determined by an offset from the start or end of the primary event to which it is attached. There are two Secondary Event Start Modes:

- **Offset From Start Mode**
- **Offset From End Mode**

**Offset From Start Mode**

The secondary event will go to air at a time offset relative to the start of its primary event. The amount of the offset is specified in the Start Offset field. Negative values are used to specify that the secondary event is scheduled to start before the start of the primary event, and positive values are used to specify that the secondary event is scheduled to start after the start of the primary event.

Secondary events can only extend into (overlap) a single preceding and/or following primary event.

Negative start offsets can only be honored if the start time of the primary event is predictable (for example, if it is a Fixed start event, or it is a Follow event and there is an event with a Duration end type on-air).

**Offset From End Mode**

The secondary event will go to air at a time offset relative to the end of its primary event. The amount of the offset is specified in the Start Offset field. Negative values are used to specify that the secondary event is scheduled to start before the end of the primary event, and positive values used to specify that the secondary event is scheduled to start after the end of the primary event.
Secondary events can only extend into (overlap) a single preceding and/or following primary event.

**Secondary Event End Mode**

There are three Secondary Event End Modes:

- *Duration End Mode*
- *Offset From Start End Mode*
- *Offset From End Mode*

**Duration End Mode**

The secondary event will end after the time specified in the Duration field has passed.

Secondary events can only extend into (overlap) a single preceding and/or following primary event.

**Offset From Start End Mode**

The secondary event will end at a time offset relative to the start of its primary event. The amount of the offset is specified in the End Offset field. Negative values are used to specify that the secondary event is scheduled to end before the start of the primary event, and positive values are used to specify that the secondary event is scheduled to end after the start of the primary event.

A secondary event cannot “end before it starts”. Invalid combinations of Start Mode/Start Offset, Duration, and End Mode/End Offset will be flagged as an error.

**Offset From End Mode**

The secondary event will end at a time offset relative to the end of its primary event. The amount of the offset is specified in the End Offset field. Negative values are used to specify that the secondary event is scheduled to end before the end of the primary event, and positive values used to specify that the secondary event is scheduled to end after the end of the primary event.

A secondary event cannot “end before it starts.” Invalid combinations of Start Mode/Start Offset, Duration, and End Mode/End Offset will be flagged as errors.

**Other Secondary Event Fields**

The following secondary event fields are also used to control the channel output:

- **Material**: determines the graphics template to be loaded, faded up, faded down, or unloaded.
- **Fade In Rate**: determines the graphics fade in rate—cut, slow, medium, or fast.
- **Fade Out Rate**: determines the graphics fade out rate—cut, slow, medium, or fast.
- **Text Updates**: used to populate text boxes in graphics templates, with optional time offset from the start of the secondary event.
- **Stop Animation Lead Time**: used to trigger a stop animation at a specified time before the end of the secondary event.
OPC Interactive Controls

For complete overview of the OPC PlayoutTool and its interactive controls, refer to Chapter 4, Using PlayoutTool
Chapter 3
Installing PlayoutTool

This chapter includes installation instructions for PlayoutTool, a monitoring tool for the Spectrum Onboard Playout Control (OPC) feature.

This chapter includes the following sections:

- System Requirements
- Installing PlayoutTool

System Requirements

Before installing PlayoutTool, your computer must conform to the following minimum requirements:

Windows

- 2.33GHz or faster x86-compatible processor or Intel® Atom™ 1.6GHz or faster processor for netbooks
- Windows XP Home, Professional, or Tablet PC Edition with Service Pack 3; Windows Server 2003; Windows Server 2008; Windows Vista Home Premium, Business, Ultimate, or Enterprise (including 64-bit editions) with Service Pack 2; or Windows 7
- 512MB of RAM (1GB recommended)

Macintosh Operating System

- Intel Core™ Duo or faster processor
- Macintosh OS X v10.6, v10.7, or v10.8
- 512MB of RAM (1GB recommended)

System Compatibility

PlayoutTool 7.7 is compatible Spectrum version 7.7 and greater.

Installing PlayoutTool

The following installation instructions are for Windows operating systems. The installation process for Macintosh OS X may vary slightly.

Installing Adobe Air

Adobe® Air® is required to install and run PlayoutTool. If you do not already have Adobe Air installed, you can download the latest version for free at http://get.adobe.com/air/.

Installing PlayoutTool

To install PlayoutTool:

1. Open the Flexapps folder located in the ChannelPortTemplatesAndTools-v7.7.0.0-SWandDoc.exe.
2. Locate the PlayoutTool installer icon, as shown in Figure 3–1.

![PlayoutTool Installer Icon](image1)

**Figure 3–1: PlayoutTool Installer Icon**

3. Double-click the PlayoutTool installer icon to open the PlayoutTool installation dialog, as shown in Figure 3–2.

![PlayoutTool Installation Dialog](image2)

**Figure 3–2: PlayoutTool Installation Dialog**

4. Choose an installation location, and click **Continue** to complete the installation of PlayoutTool.

Refer to Chapter 4, *Using PlayoutTool* to begin using PlayoutTool.
Chapter 4
Using PlayoutTool

PlayoutTool is a tool for controlling Playout Channels licensed for Spectrum Onboard Playout Control (OPC), which allows for automatic execution of a playlist derived from a traffic schedule.

For instructions on configuring the Spectrum Playout Channel, refer to “Configuring a Playout Channel” in the SystemManager User Guide.

Choose from the following topics:
- Configuring the PlayoutTool Connection and Channel Group(s)
- Using PlayoutTool
- Using Channel Override
- Using Mixer Override
- Using ARC Override
- Editing Events in PlayoutTool
- PlayoutTool Keyboard Shortcuts

Configuring the PlayoutTool Connection and Channel Group(s)

The first time you run PlayoutTool, you will encounter a series of configuration windows in which you will need to configure your connection and set up your Channel Group(s).

A Channel Group consists of any channels on your Spectrum video server(s) that you have a logical reason for grouping together.

**NOTE:** Only three PlayoutTool clients may view the same channel at the same time. If a fourth client attempts to view the same channel, the channel timeline will not appear in PlayoutTool and a system error will be generated.

To configure the connection and Channel Group(s):
1. Start PlayoutTool.
2. In the Home Window, click New Group.
NOTE: If you are installing PlayoutTool for the first time, you will be prompted to configure Channel Groups. Click Yes to continue.

After clicking New Group, the Configure Channel Group dialog box opens.

3. In the Group Name field, type in a unique name for your Channel Group.
4. Click New Channels.

After clicking New Channels, the Include Channels in Group dialog box opens.

5. In the Video Server field, type in the host IP address of the connected Spectrum video server. This may be the MediaDeck 7000 in which the ChannelPort or MediaPort is installed, or, if the ChannelPort or MediaPort is installed in a MediaPort 7000, the host IP address of the connected MediaDirector or MediaCenter.
Chapter 4 Using PlayoutTool

Configuring the PlayoutTool Connection and Channel Group(s)

**TIP:** You can find the host IP address for the Spectrum video server by navigating to the Properties page for that device in SystemManager. For details, refer to “Viewing Spectrum Video Server Properties” in the SystemManager User Guide.

When PlayoutTool has confirmed the host, the button next to the **Host** box will turn green and a list of available channels will be displayed.

![Include Channels in Group Dialog Box](image)

**Figure 4–3: Include Channels in Group Dialog Box**

6. From the **Include** column, select the check box for each channel you want to add to your new Channel Group.

**NOTE:** When adding a channel to a channel group, make sure the channel is in the same frame rate family (for example, 29.97/59.94, or 25/50) as the other channels in the group. This is so that the channels can share a timescale on the multi-channel horizontal timeline display.

7. Click **OK**.

**TIP:** The Channel Icons that appear in PlayoutTool are default images. You can add channel-specific icons when you configure your Spectrum Playout Channel settings in SystemManager.

After you include channels in your new Channel Group, you will return to the **Configure Channel Group** dialog box. From this dialog box, you can choose to edit channels, add new channels from the same or a different MediaDirector, or delete channels.

To connect to this new Channel Group when you launch PlayoutTool, select **Auto connect to this group on application start**.

8. When you are finished configuring the channel group, click **OK**.

You will return to the **Home Window**. Your new Channel Group(s) and assigned channels will be listed. From this window, you can choose to edit a Channel Group, create a Channel Group, or delete a Channel Group.

9. To connect to a Channel Group, select a group and click **Connect**.
Using PlayoutTool

The following topics provide an overview of the PlayoutTool user interface. Choose from the following:

- Channel Group View
- Channel List View
- Viewing Channel Selectors
- Viewing the Channel Status Area
- Viewing On-Air Primaries and Secondaries
- Viewing the Event List
- Viewing Event Details
- Viewing Channel Alarms
- Viewing Diagnostic Logs

**TIP:** You can show/hide views by clicking Views from the menu bar.

Channel Group View

After you connect to a Channel Group, the Channel Group view will open, as shown in the following figure.

![Channel Group View](image)

**Figure 4–4: Channel Group View**

The Channel Group view shows Summary Status icons for each channel. The Summary Status icons reveal information about primary/secondary material status, connection states, alarm states and severity, as well information about timing, data, and playlist errors.

To open a particular channel (the Channel List View), click on one of the channel tabs at the top of the window.

Channel List View

The following figure shows the Channel List view.
To open the Channel List view, click on any channel tab after connecting to your channel group. If you have already loaded a playlist (refer to Chapter 2, “Spectrum Onboard Playout Control”), you will see the playlist executing when you open this view. If you have not yet loaded a playlist, refer to Loading a Playlist for instructions.

![Channel List View](image)

**Figure 4–5: Channel List View**

The following table explains the areas of the Channel List view.

**Table 4–1: Channel List View Areas**

<table>
<thead>
<tr>
<th>Area</th>
<th>UI Name</th>
</tr>
</thead>
</table>
| A    | Channel Selectors  
Refer to Viewing Channel Selectors for more information. |
| B    | Channel Status Area  
Refer to Viewing the Channel Status Area for more information |
| C    | On-air Primaries and Secondaries  
Refer to Viewing On-Air Primaries and Secondaries for more information |
Viewing Channel Selectors

Each Channel selector shows the following:

- The name of the channel as reported by discovery calls to the Spectrum video server.
- The summary status of the channel. Channel summary status is represented by the following colors:
  - Grey: Channel status is “Normal.”
  - Yellow: Channel status is “Info.”
  - Amber: Channel status is “Warning.”
  - Red: Channel status is “Alarm,” or the TCP link to the ChannelPort or MediaPort is disconnected.

To view a channel, click the tab for that channel.

Viewing the Channel Status Area

The following figure shows the status icons of the Channel Status area.
When viewing channel status icons, please remember the following:

- A tooltip contains the status of each icon.
- When a channel has an error, the area behind the relevant icon will change color to match the severity of the error. The colors correspond to the error colors listed in Viewing Channel Selectors.

The available icon status for each feature is as follows:

- **License, Error, and Material statuses**
  - The following apply to Playout License, Primary Material, Secondary Material, Timing Errors, Data Errors, and Playlist Errors.
    - **Good**: The channel is licensed for operation, no error exists, or no material is missing.
    - **Missing**: Material is missing somewhere in the loaded schedule.
    - **Warning**: Missing material is scheduled within the warning region or an error is scheduled within the warning region.
    - **Alarm**: The channel is not licensed for operation, missing material is scheduled within the alarm region, or an error is scheduled in the alarm region.
    - **Unknown**: The status of the license has not been determined, the status of missing material has not been determined, or the status of an error cannot be determined. (You may see this status for a short time after a channel has been restarted.)

- **Connection statuses**
  - The following apply to connection statuses for Player, Graphics, MCS, Media Fetch, and Event Manager.
    - **Idle** (icon not shown): The channel is not configured, or a feature is not configured for this channel.
Good: The connection with the feature is normal.

Alarm: The connection with the feature is not normal.

Unknown: The connection status of the feature has not been determined. (You may see this status for a short time after a channel has been restarted.)

Channel Activity statuses

The following apply to activity statuses for Channel Override, Mixer Override, and EAS:

Idle (icon not shown): The channel is not configured.

Off: The feature is not active.

On: The feature is active.

Unknown: The status of the feature is unknown. (You may see this status for a short time after a channel has been restarted.)

For information on configuring the ChannelPort Master Control Switch (MCS), refer to “Configuring a ChannelPort Channel” in the SystemManager User Guide.

For information on configuring Media Fetch, refer to “Configuring the Media Fetch Service” in the SystemManager User Guide.

For information on configuring players, refer to “Player Configuration” in the SystemManager User Guide.

For information configuring an EAS, refer to “Configuring a ChannelPort Channel” in the SystemManager User Guide.

Viewing On-Air Primaries and Secondaries

The On-Air Primary and Secondaries area shows a timeline view, which runs in realtime, of the primary video layer and the eight secondary video layers.

When a video is loaded and faded up on the primary event layer, the file name and a countdown are displayed in the left-hand On-Air events column.

To collapse or expand the list of secondary events, click the plus/minus sign at the bottom-right corner of the box showing the file name and countdown.

NOTE: If your video server is configured with a MediaPort 7000, you can only monitor primary events. The Playout Channel will ignore any secondary events scheduled for playout on a MediaPort 7000.
Figure 4–7: On-Air Primaries and Secondaries Area

Note that events may show a black triangle in the upper right- or left-hand corners to indicate the transition type at the beginning or end of the event. Hover over each event to view details on the material and transition type, which may include cut, or slow (s), medium (m), or fast (f) fade.

To change your view of the timeline, from the menu bar, click Timeline. You can zoom in and out on the timeline, as well as scroll toward the past or future.

Click the Control Mode button to activate the following control buttons, which can be used to control the Playout Channel:

- **Take Next**: Plays the next primary event.
- **Drop Next**: Skips the next primary event.
- **Hold Next**: Holds the current primary event on-air. Hold Next can be canceled by toggling the Hold Next button or by clicking Take Next. If the duration of the current on-air event has not expired when the Hold Next button is toggled off, the primary event will remain on-air for its remaining duration. If the duration of the primary event expires while Hold Next is active, toggling the Hold Next button off will cause the next primary event to be taken.
- **Channel Override**: Refer to Using Channel Override for instructions on using the Channel Override feature.
- **Mixer Override**: Refer to Using Mixer Override for instructions on using the Mixer Override feature.
- **ARC Override**: Refer to Using ARC Override for instructions on using the ARC Override feature.

**TIP**: These controls are also available by clicking Playlist Control from the menu bar.
Viewing the Event List

The Event List area displays a list of on-air and upcoming events to be handled by the OPC. If your video server is configured with a ChannelPort, you can monitor primary and secondary events (but only primary events on MediaPort 7000).

The following figure shows the Event List area.

![Event List Area](image)

- **Primary/Graphic Secondary Event Details** (not all details shown in image)
- **Primary Event (teal, blue when selected)**
- **Secondary Events View**
- **Secondary Event (purple, blue when selected)**
- **Enable Editing**

Figure 4–8: Event List Area

When viewing the Event List, please remember the following:

- The Event List area shows current and upcoming events.
- As events are played, they will be removed from the Event List area.
- To toggle secondary event view on or off, click the **Secondary Event View** button (or, from the menu bar, click **View > Show Secondaries**).
- When primary or secondary events are selected in the Event List area, their details are shown in the Primary Event Details/Graphics Secondary Details area. Refer to **Viewing Event Details** for more information.
- To toggle editing mode on or off, click the **Enable Editing** button (or, from the menu bar, click **Edit > Edit Mode**). For more information about Editing events in PlayoutTool, refer to **Editing Events in PlayoutTool**.
- To **Find** any Primary or Secondary event value in the Event List or Event Details, click **Edit > Find**. The **Find** dialog box provides the following:
  - **Field**: select the Field you wish to search.
  - **Find**: type or select the Find value.
  - **Direction**: select the direction in the Event list PlayoutTool will search.
  - **Matching Rules**: for text searches, select **Match Case** and/or **Match Whole Field**.
For a list of primary event icons that appear in the Event List area, refer to *Viewing Primary Event Icons and Status*.

For a list of secondary event icons that appear in the Event List area, refer to *Viewing Secondary Event Icons and Status*.

**Viewing Primary Event Icons and Status**

The following table shows primary event icons and their statuses.

**Table 4–2: Primary Event Icons**

<table>
<thead>
<tr>
<th>Primary Detail</th>
<th>Icon</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Secondary Availability</td>
<td><img src="image" alt="Icon" /></td>
<td>No secondaries</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Icon" /></td>
<td>Secondaries present</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Icon" /></td>
<td>Secondaries present with errors</td>
</tr>
<tr>
<td>Error Summary</td>
<td><img src="image" alt="Icon" /></td>
<td>Primary or associated secondaries has errors</td>
</tr>
</tbody>
</table>

**Viewing Secondary Event Icons and Status**

The following table shows secondary event icons and their statuses.

**Table 4–3: Secondary Event Icons**

<table>
<thead>
<tr>
<th>Secondary Detail</th>
<th>Icon</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Error Summary</td>
<td><img src="image" alt="Icon" /></td>
<td>Secondary has an error</td>
</tr>
</tbody>
</table>

**Viewing Event Details**

The details of primary and secondary events can be viewed in the Primary Event Details/Graphics Secondary Details area.

The Primary Event Details/Graphics Secondary Details area can be shown or hidden by clicking and sliding the expander located between the Primary Event Details/Graphics Secondary Details area and the Event List area.

**Viewing Primary Event Details**

The Primary Details area displays a list of fields that contain information about primary events.

**To view the details of a primary event:**

1. Click *Details Display*.
2. Click on a primary event.

**To close the Primary Event Details area,** click the *Expand/Hide Detail Display* button.

The following figure shows the Primary Details area.
The following table shows primary event icons and status that appear in the Primary Event Details Area.

**Table 4–4: Primary Event Details Icons**

<table>
<thead>
<tr>
<th>Primary Detail</th>
<th>Icon</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Event Overdue</td>
<td><img src="image" alt="Event Overdue Icon" /></td>
<td>Primary or secondary event is overdue</td>
</tr>
<tr>
<td>Gap/Overlap Error</td>
<td><img src="image" alt="Gap/Overlap Error Icon" /></td>
<td>Primary or secondary event has gap or overlap; text field shows amount of gap or overlap</td>
</tr>
<tr>
<td>Material Availability</td>
<td><img src="image" alt="Material Availability Icon" /></td>
<td>Primary material availability unknown</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Material Availability Icon" /></td>
<td>Primary material available</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Material Availability Icon" /></td>
<td>Primary material not available</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Material Availability Icon" /></td>
<td>Primary material not playable</td>
</tr>
</tbody>
</table>
Viewing Secondary Event Details

The Graphics Secondary Event Details area displays a list of fields that contain information about secondary events.

To view the details of a secondary event:

1. Click the Secondary Events View button.
2. Click Details Display.
3. Click on a secondary event.

To close the Graphics Secondary Event Details area, click the Expand/Hide Detail Display button.

The following figure shows the Graphics Secondary Details area.

<table>
<thead>
<tr>
<th>Primary Detail</th>
<th>Icon</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Media Transfer Status</td>
<td>![Icon]</td>
<td>Transfer status unknown</td>
</tr>
<tr>
<td></td>
<td>![Icon]</td>
<td>Media location queried</td>
</tr>
<tr>
<td></td>
<td>![Icon]</td>
<td>Media not located</td>
</tr>
<tr>
<td></td>
<td>![Icon]</td>
<td>Media located</td>
</tr>
<tr>
<td></td>
<td>![Icon]</td>
<td>Transfer requested</td>
</tr>
<tr>
<td></td>
<td>![Icon]</td>
<td>Media transferring</td>
</tr>
<tr>
<td></td>
<td>![Icon]</td>
<td>Media transferred</td>
</tr>
<tr>
<td>Data Error</td>
<td>![Icon]</td>
<td>A field in the event has invalid data</td>
</tr>
</tbody>
</table>
Figure 4–10: Graphics Secondary Detail Area

The following table shows secondary event icons and status that appear in the Secondary Event Details Area.

Table 4–5: Secondary Event Details Icons

<table>
<thead>
<tr>
<th>Primary Detail</th>
<th>Icon</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Starts too Soon Error</td>
<td>![Icon]</td>
<td>Secondary starts too soon</td>
</tr>
<tr>
<td>Secondary Conflict Error</td>
<td>![Icon]</td>
<td>Secondary conflicts with another secondary</td>
</tr>
<tr>
<td>Ends too Late Error</td>
<td>![Icon]</td>
<td>Secondary ends too late (too much overhang)</td>
</tr>
<tr>
<td>Ends before Starts Error</td>
<td>![Icon]</td>
<td>Secondary ends before its start (negative duration error)</td>
</tr>
<tr>
<td>Starts too Soon Error</td>
<td>![Icon]</td>
<td>Secondary starts too soon</td>
</tr>
<tr>
<td>Material Availability</td>
<td>![Icon]</td>
<td>Secondary material availability unknown</td>
</tr>
<tr>
<td></td>
<td>![Icon]</td>
<td>Secondary material available</td>
</tr>
<tr>
<td></td>
<td>![Icon]</td>
<td>Secondary material not available</td>
</tr>
<tr>
<td></td>
<td>![Icon]</td>
<td>Secondary material not playable</td>
</tr>
</tbody>
</table>
Table 4–5: Secondary Event Details Icons

<table>
<thead>
<tr>
<th>Primary Detail</th>
<th>Icon</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Media Transfer Status</td>
<td></td>
<td>Transfer status unknown</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Icon" /></td>
<td>Media location queried</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Icon" /></td>
<td>Media not located</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Icon" /></td>
<td>Media located</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Icon" /></td>
<td>Transfer requested</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Icon" /></td>
<td>Media transferring</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Icon" /></td>
<td>Media transferred</td>
</tr>
<tr>
<td></td>
<td><img src="image" alt="Icon" /></td>
<td>Transfer error</td>
</tr>
<tr>
<td>Data Error</td>
<td><img src="image" alt="Icon" /></td>
<td>A field in the event has invalid data</td>
</tr>
</tbody>
</table>

Viewing Channel Alarms

When a channel has an alarm, the Channel Alarms button will change color. The colors correspond to the error colors listed in Viewing Channel Selectors.

To open the Channel Alarm view, click **Channel Alarms**.

The following figure shows the Channel List Alarm view.

![Figure 4–11: Channel List Alarm View](image)

In the Channel Alarms view, the following control buttons are available:

- **Select All**: Click to select all log entries.
- **Copy to Clipboard**: Click to copy the log.
Chapter 4 Using PlayoutTool

Channel Alarm status is represented by the following colors:

- Green: Channel Alarm status is for “Info”
- Yellow: Channel Alarm status is “Warning.”
- Amber: Channel Alarm status is “Failure.”
- Red: Channel Alarm status is “Critical.”

To close the Channel Alarms view, click the **Expand/Hide Detail Display** button.

**Viewing Diagnostic Logs**

The PlayoutTool diagnostic log displays logs created by PlayoutTool. Note that it does not display logs created by ChannelPort, the ChannelPort Playout Channel, OPC, or the MediaPort Playout Channel.

To open the Log View Window, from the menu bar, click **File > View Diagnostic Logs**.

The following figure shows the Log View Window.

![Log View Window](image)

**Figure 4–12: Log View Window**

In the Log View Window, the following control buttons are available:

- **Clear**: Click to clear all entries from the log.
- **Select All**: Click to select all log entries.
- **Copy to Clipboard**: Click to copy the log.
- **OK**: Click to close the Log View Window.
Using Channel Override

Channel Override gives you the ability, if any undesirable material appears on-air, to quickly take a channel to black and to optionally display a pre-configured graphics template (for example, a “Technical Difficulties” graphic). After overriding the playlist on the channel, you can load a revised/corrected playlist to the Playout Channel, start the playlist running, and put the playlist back on-air by canceling the override.

Refer to Chapter 2, “Spectrum Onboard Playout Control” for information about loading a playlist to the Playout Channel.

Note that if Mixer Override is active for a playout channel, you must toggle it off before you can activate Channel Override, and vice-versa.

Activating Channel Override

When you activate Channel Override, the following events occur (not necessarily in this order):

- The Master Control Switcher (MCS) on the ChannelPort switches to a player that puts the default “black” clip on air.
- If configured, a graphic template for playlist overrides is put on-air, on the configured layer. Refer to “Configuring a Playout Channel” in the SystemManager User Guide for more information.

**NOTE:** If OPC is running on a MediaPort 7000, no graphics template can be added in the event of a playlist override. If Channel Override is activated on a MediaPort channel, a “black” clip will be put on air.

- A status event is logged in the as-run log to record when the override was activated. Refer to Chapter 2, “Spectrum Onboard Playout Control” for information about the as-run log.
- An alarm is added in PlayoutTool to report Channel Override is active. Refer to Viewing Channel Alarms for more information.
- The Channel status indicates Channel Override is active. Refer to Viewing the Channel Status Area for information on viewing the Channel status.
- A log message is added to Syslog on the Spectrum video server.
- The as-run status of all on-air events (primary and secondary) indicates a failure (for example, “Preempted”).

When you cancel Channel Override, the following events occur (not necessarily in this order):

- The primary event that would have been on-air is “joined in progress” but graphics secondary events that would have been on-air are not re-joined.
- If used, the graphics template for the playlist override is cut down.
- An alarm is added in PlayoutTool to report the override has ended.
- The Channel status indicates Channel Override is canceled. The Channel Status icon will return to its default state, which is gray.
- A log message will be added to Syslog on the Spectrum video server.

To activate Channel Override:

1. Click the **Control Mode** button to enable control of PlayoutTool.
2. Click the **Channel Override** button.
3. Load a revised playlist.
   Refer to Chapter 2, “Spectrum Onboard Playout Control” for instructions on loading
   playlists to the Playout Channel.
4. Click the **Channel Override** button again to cancel the override and rejoin events in the
   revised playlist.

### Using Mixer Override

Mixer Override gives you the ability, if needed, to quickly switch one mixer source with
another. For example, if one source is playing clips from a player, you can override that setting
and force the mixer to display a live external input.

The possible inputs for the Mixer Override depend on whether you are in Standard Channel
or Enhanced Channel mode. However, regardless of which mode you are in, you can only
have one input configured for Mixer Override per Playout Channel.

Note that if Channel Override is active for a playout channel, you must toggle it off before you
can activate Mixer Override, and vice-versa.

Refer to “Configuring a Playout Channel” in the *SystemManager User Guide* for more
information on configuring Mixer Override.

**NOTE:** Once you activate Mixer Override, it will run until you cancel it.

### Activating Mixer Override

When you activate Mixer Override, the following events occur (not necessarily in this order):

- The Master Control Switcher (MCS) on the ChannelPort switches to a different player, an
  external input, optional graphic, or the color generator.
- A status event is logged in the as-run log to record when the override was activated.
  Refer to Chapter 2, “Spectrum Onboard Playout Control” for information about the as-run
  log.
- An alarm is added in PlayoutTool to report Mixer Override is active. Refer to *Viewing
  Channel Alarms* for more information.
- The Channel status indicates Mixer Override is active. Refer to *Viewing the Channel Status
  Area* for information on viewing the Channel status.
- A log message is added to Syslog on the Spectrum video server.
- The as-run status of all on-air events (primary and secondary) indicates a failure (for
  example, “Preempted”).

When you cancel Mixer Override, the following events occur (not necessarily in this order):

- The primary event that would have been on-air is “joined in progress.”
- An alarm is added in PlayoutTool to report the override has ended.
- The Channel status indicates Mixer Override is canceled. The Channel Status icon will
  return to its default state, which is gray.
- A log message will be added to Syslog on the Spectrum video server.
- Secondary events that would have been in progress are not rejoined when the override is
  canceled.

**To activate Mixer Override:**

1. Click the **Control Mode** button to enable control of PlayoutTool.
2. Click the **Mixer Override** button.

3. Click the **Mixer Override** button again to cancel the override and rejoin events in the revised playlist.

## Using ARC Override

ARC Override gives you the ability, if needed, to quickly override the aspect ratio of a clip playing on the Primary Event layer. For example, if a clip playing on the Primary Event layer is has an aspect ratio of 4:3 it can be quickly upconverted to 16:9 if the ARC Override settings in SystemManager are configured as such.

Refer to “Configuring a Playout Channel” in the *SystemManager User Guide* for more information on configuring ARC Override.

### Activating ARC Override

When you activate ARC Override, the following events occur (not necessarily in this order):

- The ARC Override settings from SystemManager are applied and the aspect ratio of the clip is converted accordingly.
- A status event is logged in the as-run log to record when the override was activated. Refer to Chapter 2, “Spectrum Onboard Playout Control” for information about the as-run log.
- An alarm is added in PlayoutTool to report ARC Override is active. Refer to *Viewing Channel Alarms* for more information.
- The Channel status indicates ARC Override is active. Refer to *Viewing the Channel Status Area* for information on viewing the Channel status.
- A log message is added to Syslog on the Spectrum video server.

When you cancel ARC Override, the following events occur (not necessarily in this order):

- The next clip plays at its normal aspect ratio.
- An alarm is added in PlayoutTool to report the override has ended.
- The Channel status indicates ARC Override is canceled. The Channel Status icon will return to its default state, which is gray.
- A log message will be added to Syslog on the Spectrum video server.

**To activate ARC Override:**

**NOTE:** When you activate ARC Override on a clip, it is only active for the duration of that clip.

1. Click the **Control Mode** button to enable control of PlayoutTool.
2. Click the **ARC Override** button.
3. Click the **ARC Override** button again to cancel the override and rejoin events in the revised playlist.

## Editing Events in PlayoutTool

Enabling editing mode in PlayoutTool allows you manipulate the placement of events on a timeline, and also allows you to add or delete future events on a schedule. You can also edit “Blocks,” which are primary events that have secondary events assigned to them.

When you enable editing, the following functions are available:
Cut, Copy, Paste, and Delete Events/Blocks
- Insert primary/secondary events, as well as primary/secondary event comments
- Insert Playlists
- Change future events in the Event List area
- Edit text fields of secondary events (where applicable)

Choose from the following topics:

- Enabling Editing Mode
- Inserting Primary Events
- Inserting Secondary Events
- Deleting Primary/Secondary Events
- Editing Secondary Event Text Fields
- Inserting a Playlist
- Loading a Playlist

Enabling Editing Mode

You enable editing by clicking Edit > Edit Mode from the menu bar, or by clicking the Enable Editing button located below the Event Lists area.

Inserting Primary Events

When you insert a primary event it is placed directly above the currently selected event. Inserting a primary event only creates a space for an event in the schedule. You must fill in the details of the event as needed.

To insert a Primary Event:

NOTE: An error icon will appear and not clear until the event is properly edited.

1. Enable editing mode. Refer to Enabling Editing Mode for instructions.
2. From the menu bar, click Edit > Insert Event > Primary.
3. From the Event List area, click the Material field (marked by red), and type in the Material ID of the primary event.
4. Click the Duration field (marked by red), and set the Duration of the primary event.
5. Click other fields to edit them as needed.

Inserting Secondary Events

You can insert secondary events under primary events. The newly inserted event will be placed on the layer that you assign when you edit the event.

To insert a Secondary Event:

1. Enable editing mode. Refer to Enabling Editing Mode for instructions.
2. From the menu bar, click Edit > Insert Event > Secondary Graphics.
3. From the Event List area, click the Material field (marked by red), and type in the Material ID of the secondary event.
4. To assign the layer the event will appear on, click the Layer field, and set the layer number.
5. Click other fields to edit them as needed.

**Editing Secondary Event Text Fields**

If you have a secondary event that has editable text fields, you can make changes to those text fields from PlayoutTool.

**To edit the text fields of a Secondary Event:**
1. Enable editing mode. Refer to *Enabling Editing Mode* for instructions.
2. Select the secondary event that has the text field(s) you want to edit.
3. Click **Detail Display**.
4. In the **Graphics Secondary Details** pane, scroll down to **Text Updates** settings.
5. In the **Text** box, type in new text, and select the corresponding **Box** number for the text.
6. If necessary, alter the **Offset** time.
7. Click **Add**.
8. Repeat Steps 5-6 to edit additional text fields in the template as necessary.

**Inserting a Playlist**

You can insert a playlist on any Playout Channel that is running. For example, if you have a block of programming that needs to be replaced, you can select and delete that block (refer to *Deleting Primary/Secondary Events*), and then insert a new playlist to play in the deleted slot, provided the start time of the new playlist matches the start time of the deleted events.

You can also insert a new playlist to “follow” the currently executing playlist.

**To insert a playlist:**
1. Enable editing mode. Refer to *Enabling Editing Mode* for instructions.
2. If necessary, delete any events that need to be replaced.
3. From the menu bar, click **Edit > Insert Playlist**.
4. Navigate to the playlist you want to insert, and click **Open**.

**NOTE:** The start mode of the playlist will determine if any more manual intervention is needed. If the playlist has a manual start mode, you will need to enable Control Mode and click Take Next at the appropriate time.

**NOTE:** When inserting a playlist, PlayoutTool ignores the channel name and schedule start date/time metadata from the playlist file (xml file), but does check the frame rate. If there is a frame rate mismatch, the events will not be inserted.

After the inserted playlist executes, the inserted events will be included in the as-run file for the schedule. For instructions on retrieving the as-run file, refer to “Retrieving a Spectrum As-run List” in Chapter 2, “Spectrum Onboard Playout Control.”

**Loading a Playlist**

Loading a playlist applies only to channels that are not running (in other words, channels that are stopped.) When you stop a channel, you “flush” the channel of any remaining playlists. When you load a new playlist on a stopped channel, you can allow the playlist to start at its assigned time, manually execute the playlist from the beginning, or “join” the playlist in real time.

When you use the “join” function, PlayoutTool will ignore any previously scheduled events in the playlist.
Consider the following examples:

If you are demonstrating PlayoutTool functionality at a trade show, and matching your playlist to real time is not important, you can simply enable Control Mode, load your playlist, click Start, and allow the playlist to execute as is.

However, if you have a stopped channel and need the playlist to match real time (for example, it’s almost 6 pm, and event X is scheduled in the playlist to air at 6 pm), you can enable Control Mode, load the playlist, and click Join to start the playlist in real time.

When you use join functionality, PlayoutTool will ignore any previously scheduled events in the playlist.

To load a playlist:
1. Click Control Mode (or from the menu bar, click Playlist Control > Control Mode), to enable Control Mode.
2. From the menu bar, click Playlist Control > Stop to stop the channel.
3. Click Playlist Control > Load.
4. Navigate to the playlist you want to insert, and click Open.
5. Depending on your needs, choose from one of the following to start the playlist:
   - Click Playlist Control > Start > Take Next.
   - Click Playlist Control > Join.

After the inserted playlist executes, an as-run file will be created and sent to the asrun folder. For instructions on retrieving the as-run file, refer to “Retrieving a Spectrum As-run List” in Chapter 2, “Spectrum Onboard Playout Control.”

Deleting Primary/Secondary Events

When you delete a primary/secondary event, the event is deleted from the playlist and is no longer available for pasting if it has been copied.

To delete a Primary/Secondary Event:
1. Enable editing mode. Refer to Enabling Editing Mode for instructions.
2. Select the event you want to delete.
3. From the menu bar, click Edit > Delete Event/Block.
4. In the confirmation dialog box, click Yes.

PlayoutTool Keyboard Shortcuts

The following table shows keyboard shortcuts available in PlayoutTool.

<table>
<thead>
<tr>
<th>Key Stroke</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl/Cmd + B</td>
<td>start block</td>
</tr>
<tr>
<td>Ctrl/Cmd + C</td>
<td>copy</td>
</tr>
<tr>
<td>Ctrl/Cmd + E</td>
<td>enable Edit Mode</td>
</tr>
<tr>
<td>Ctrl/Cmd + F</td>
<td>find</td>
</tr>
<tr>
<td>Ctrl/Cmd + I</td>
<td>insert primary event</td>
</tr>
<tr>
<td>Ctrl/Cmd + K</td>
<td>enable Control Mode</td>
</tr>
<tr>
<td>Key Stroke</td>
<td>Function</td>
</tr>
<tr>
<td>----------------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>Ctrl/Cmd + L</td>
<td>view diagnostic logs</td>
</tr>
<tr>
<td>Ctrl/Cmd + V</td>
<td>paste</td>
</tr>
<tr>
<td>Ctrl/Cmd + X</td>
<td>cut</td>
</tr>
<tr>
<td>Ctrl/Cmd + [</td>
<td>scroll timeline towards past</td>
</tr>
<tr>
<td>Ctrl/Cmd + ]</td>
<td>scroll timeline towards future</td>
</tr>
<tr>
<td>Ctrl/Cmd + \</td>
<td>return timeline to now</td>
</tr>
<tr>
<td>Ctrl/Cmd + -</td>
<td>timeline zoom out</td>
</tr>
<tr>
<td>Ctrl/Cmd + =</td>
<td>timeline zoom in</td>
</tr>
<tr>
<td>Ctrl/Cmd + DEL</td>
<td>delete event/block</td>
</tr>
<tr>
<td>Cmd + H (Mac OS X only)</td>
<td>hide application</td>
</tr>
<tr>
<td>Cmd + M (Mac OS X only)</td>
<td>minimize application</td>
</tr>
<tr>
<td>Cmd + O (Mac OS X only)</td>
<td>open file</td>
</tr>
<tr>
<td>Cmd + Q (Mac OS X only)</td>
<td>quit</td>
</tr>
<tr>
<td>Alt + Ctrl/Cmd + A</td>
<td>move to channel alarms and events</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + B</td>
<td>cancel block</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + C</td>
<td>copy event/block</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + E</td>
<td>move to event list</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + F</td>
<td>replace</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + I</td>
<td>insert comment</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + O</td>
<td>insert playlist</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + S</td>
<td>start playlist</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + T</td>
<td>start dictation</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + V</td>
<td>paste event/block</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + X</td>
<td>cut event/block</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + .</td>
<td>move to detail display</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + -</td>
<td>show previous channel</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + =</td>
<td>show next channel</td>
</tr>
<tr>
<td>Ctrl + Alt + DEL</td>
<td>delete</td>
</tr>
<tr>
<td>Cmd + D (Mac OS X only)</td>
<td>toggle dock</td>
</tr>
<tr>
<td>Cmd + H ((Mac OS X only)</td>
<td>hide others</td>
</tr>
<tr>
<td>Key Stroke</td>
<td>Function</td>
</tr>
<tr>
<td>------------</td>
<td>----------</td>
</tr>
<tr>
<td>Ctrl/Cmd + Shift + A</td>
<td>show channel alarms and events</td>
</tr>
<tr>
<td>Ctrl/Cmd + Shift + G</td>
<td>show secondaries</td>
</tr>
<tr>
<td>Ctrl/Cmd + Shift + H</td>
<td>hide bottom pane</td>
</tr>
<tr>
<td>Ctrl/Cmd + Shift + I</td>
<td>insert secondary event</td>
</tr>
<tr>
<td>Ctrl/Cmd + Shift + .</td>
<td>show detail display</td>
</tr>
<tr>
<td>Cmd + Shift + / (Mac OS X only)</td>
<td>show help</td>
</tr>
<tr>
<td>Cmd + Shift + 4 (Mac OS X only)</td>
<td>screen capture, area to file</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + Shift + A</td>
<td>enable Arc Override</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + Shift + C</td>
<td>clear playlist</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + Shift + F</td>
<td>find next error</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + Shift + H</td>
<td>enable Hold Next</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + Shift + I</td>
<td>insert secondary comment</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + Shift + J</td>
<td>join playlist</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + Shift + L</td>
<td>load playlist</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + Shift + M</td>
<td>enable Mixer Override</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + Shift + N</td>
<td>drop next</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + Shift + P</td>
<td>enable Channel Override</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + Shift + S</td>
<td>stop playlist</td>
</tr>
<tr>
<td>Ctrl/Cmd + Alt + Shift + T</td>
<td>take next</td>
</tr>
</tbody>
</table>
Chapter 5
Using ScheduleTool

ScheduleTool is a web-based application for creating and modifying traffic schedules to use with a Playout Channel on a Spectrum system. ScheduleTool runs on any Spectrum video server with a ScheduleTool license and version 7.6 or later, and can be accessed via the Google Chrome* web browser.

Choose from the following topics:

- Connecting to ScheduleTool
- Selecting a Channel
- Viewing Channel Properties
- Configuring the Default Values for Schedule Events
- Creating, Editing, and Saving a Schedule
- Viewing and Editing the Event List
- Viewing and Editing Event Details
- Saving a Schedule for a Different Channel
- Viewing Logs (for MediaDeck 7000 only)
- Clearing Local Settings
- About Start Times in ScheduleTool
- ScheduleTool Keyboard Shortcuts

Connecting to ScheduleTool

ScheduleTool supports the Google Chrome browser on a Windows* or Macintosh* client computer.

**NOTE:** No other browsers are supported at this time.

To connect to ScheduleTool:

1. Open your web browser, and then type the IP address of your Spectrum video server in the address bar.
2. Log in using the default user name (user) and password (user). Once you are logged in, you may change your password as described in the next section.
3. From the Harmonic landing page, click the button for ScheduleTool to open it.

Changing Your Password

To change the log in password:

1. Click the profile icon in the upper right-hand corner of the management window, and then select Change Password.
2. From the Change Password dialog box, in the Old Password field, enter the current password, and then enter the new password in the New Password and Confirm Password fields.
3. Click OK.
Selecting a Channel

When you first open ScheduleTool, you may select one or more playout channels from your video server to add to your ScheduleTool channel list.

To select a channel:

1. Click **Select**. The Select Channel dialog box appears. From this dialog box, you can add a playout channel to your list, view details of a playout channel, or remove a playout channel from your list.

2. Click **Add Channel** to add a playout channel to your list of channels. In the Add Channel Dialog box, you can change the selected video server, add a playout channel, and view details for each playout channel. See the following figure.

![Figure 5–1: Adding a Channel](image)

**NOTE:** If you attempt to add a channel from an unlicensed video server, a message will appear indicating that ScheduleTool is not supported on that video server.

3. Click **Add** to add the channel to your channel list, and then click **Select**.

**Viewing Channel Properties**

The playout channel provides control for players and graphics. Note that many playout channel properties are configured with SystemManager (see “Configuring a Playout Channel” in the *Harmonic SystemManager User Guide*).

To view properties of a playout channel:

1. From either the **Select Channel** or the **Add Channel** dialog box, click **Details**. The **Channel Properties** dialog box appears.
From this dialog, you may view several playout channel properties. Note that the transitions shown in this dialog can be configured from the Playout Channel Properties page in SystemManager (see “Configuring a Playout Channel” in the Harmonic SystemManager User Guide).

Configuring the Default Values for Schedule Events

ScheduleTool allows you to configure the default values for primary and secondary events that you add to your schedule.

To configure default values for events:

1. Click Channel > Set Default Values to open the Set Default Values dialog box (see the following figure).

![Set Default Values For Chan-D9_01046-1-1 on 10.10.54.127](image)

Figure 5–2: Configuring default values for a playout channel

2. Under **Primary**, configure the default values for primary events, including:
   - **Source**: select a mixer source to be used by this channel.
   - **Start Mode**: select between Follow, Fixed, External, or Manual.
   - **End Mode**: select between Duration or External, or Manual.
   - **Transition**: select a transition type. This menu will contain the list of transitions configured for the selected playout channel in SystemManager or MediaDeck 7000 Management. If the playout channel is mapped to a MediaPort, only one transition, “Cut,” will be available.

3. Under **Graphics**, configure the default values for secondary events including:
   - **Start Mode**: select between OffsetFromStart, or OffsetFromEnd.
   - **End Mode**: select between OffsetFromStart, or OffsetFromEnd.
   - **Fade In**: select between Cut, Fast, Medium, or Slow.
   - **Fade Out**: select between Cut, Fast, Medium, or Slow.
   - **Layer Number**: select a graphics layer (between 1 and 8).

   **NOTE**: Graphics options are only available for ChannelPort channels.

4. Click Close.

Creating, Editing, and Saving a Schedule

When you first open a channel there will be no schedule selected. You may create schedule or open an existing one.
For an explanation of the start time format, and information on start time parameters, see *About Start Times in ScheduleTool*.

**To create a schedule:**

1. Click **File > Create**. ScheduleTool automatically inserts a primary event in the Event List.
2. Edit the primary event by clicking in the fields in the Event List or by opening the Detail Display view and editing the details. See *Viewing and Editing the Event List* and *Viewing and Editing Event Details*. Note that the top row of headings in the Event List applies to primary events, and the second row of headings in the Event List applies to secondary events.
3. Insert additional primary or secondary events as needed by clicking **Edit > Insert Event**. Note that ScheduleTool inserts a new or primary or secondary event above the existing event. To insert a primary or secondary event at the bottom of the list, click **End of List > Edit > Insert Event**.

**NOTE:** Secondary events are only available for ChannelPort channels.

4. Use the following tools from the **Edit** menu to modify your schedule as needed:
   - **Find Material**: allows you to select clips or templates on your Spectrum video server and them to your primary or secondary events. See *Using Find Material to Add Events to a Schedule*.
   - **Find or Replace**: allows you to find and replace any event value in the Event List or Event Details. The Find or Replace dialog box provides the following:
     - **Field**: select the Field you wish to search.
     - **Find**: type or select the Find value.
     - **Replace**: type or select the Replace value.
     - **Direction**: select the direction ScheduleTool will find and replace.
     - **Matching Rules**: for text searches, select *Match Case* and/or *Match Whole Field*.
     - Click one of the following: **Find Next**, **Replace**, **Replace and Find Next**, or **Replace All**.
   - **Cut, Copy, Paste or Delete**: you may cut, copy, paste, or delete individual events or blocks of events. For instructions on selecting blocks of events, see *Selecting Event Blocks*.
   - **Time Ripple**: ensures that the times for all events ripple consecutively from the top of the schedule. Select an event in your schedule, and then click **Edit > Time Ripple**.
5. Save the schedule to your Spectrum video server.
   a. Click **File > Save** or **Save As**.
   b. Type a file name and then click **OK**.

By default, the schedule is saved to */fs0/playout/<video server name>/schedules.*

**NOTE:** Simply creating and saving a schedule with ScheduleTool will not cause that schedule to be loaded by OPC. For instructions on loading a schedule (which is loaded the same way as a playlist), see *Loading a Playlist* in the “Using PlayoutTool” chapter.

**Saving a Schedule to a Subdirectory**

Note that you may save the file to a subdirectory of the default path: */fs0/playout/<video server name>/schedules.*

**To save a schedule to a subdirectory:**

1. Click **File > Save As**.
In the **File Name** field, type the name of the subdirectory, a forward slash, and then the file name: `<subdirectory name>/<file name>`.

3. Click **OK**.

To open the schedule later, click **File > Open**, and navigate to the subdirectory name.

### Using Find Material to Add Events to a Schedule

You may add material to your primary and secondary events with the **Find Material** feature, which allows you to select clips or graphic templates on your Spectrum video server and add them to your primary or secondary events.

#### To use Find Material:

1. Select an event and click **Edit > Find Material**.
2. From the Find Material dialog box, you may search for Primary (clips) or Secondary (graphic template) material on your video server using the search functions. Click the **Clips** or **Templates** tab.
3. Click the clip or graphic template you wish to add, and then click **OK**. If the event details have not already been modified, the details for the selected clip or template will automatically populate the Event List and Detail Display fields once it is added.

### Selecting Event Blocks

You may cut, copy, paste or delete individual events or blocks of events.

#### To select a block of events:

1. Select the first event in the block, and then click **Edit > Start Block**.
2. Select the last event the block, and then click the desired Edit operation (cut, copy, paste, or delete).
3. Click **Edit > Cancel Block**.

### Configuring Schedule Metadata

In order for the playout channel to load a schedule, the schedule metadata must be configured with a valid start time. If the start time is not valid, the playout channel will not load the schedule. For an explanation of the start time format, and information on start time parameters, see *About Start Times in ScheduleTool*.

#### To configure schedule metadata:

1. In the **Schedule Metadata** fields at the top of the ScheduleTool page, configure the following:
   - **Schedule Name**: type the name of schedule.
   - **Schedule Start**: type the date and time of the schedule.
2. Click **OK**.

### Viewing and Editing the Event List

When you add primary and secondary events to your schedule, they are displayed in the Event List. The following diagram describes the Event List view (note that not all event details are shown).
Figure 5–3: Event List

The Event List provides frequently-used event details for primary and secondary events. You may edit these details by clicking in the corresponding fields, or by opening the Detail Display and selecting an event in the schedule.

To configure the Event List view:

1. Click the View menu.
2. Select or de-select the following:
   - Show Secondaries: select to show secondary events.
   - Show Detail Display: select to show the Detail Display, which provides all event details. You may also click the down-arrow below the event list to open the Detail Display.

For the complete list of configurable details, see Viewing and Editing Event Details.

Viewing Primary Event Icons and Status

The following table shows primary event icons.

Table 5–1: Primary Event Icons

<table>
<thead>
<tr>
<th>Primary Detail</th>
<th>Icon</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Secondary Availability</td>
<td>![Icon]</td>
<td>No secondaries</td>
</tr>
<tr>
<td></td>
<td>![Icon]</td>
<td>Secondaries present</td>
</tr>
</tbody>
</table>
Viewing and Editing Event Details

You may edit event details directly in the Event List by clicking in the corresponding fields, or by opening the Detail Display and selecting an event in the schedule. From the Detail Display, you may configure details as follows.

NOTE: For an explanation of the start time format, and information on start time parameters, see About Start Times in ScheduleTool.

For primary events:

- **Scheduled Start Time**: Enter a start time for the event.

  NOTE: If the Scheduled Start Time is within one hour prior to, or two hours after a daylight savings time (DST) transition, ScheduleTool will display a time zone abbreviation near the Scheduled Start Time field. If this abbreviation appears in black, you may click it to toggle the time zone, and specify if the event starts before or after the time transition.

- **Event Title**: Type the title for the event.

- **Transition Type**: Select a transition type. This menu will contain the list of transitions configured for the selected playout channel in SystemManager or MediaDeck 7000 Management. If the playout channel is mapped to a MediaPort, only one transition, “Cut,” will be available.

- **Start of Material**: Click to open a Start of Material dialog box, which allows you to select a Start of Material mode (Mark In, Offset, or Timecode) and enter an offset or timecode as needed.

- **Material**: Enter the material name or use Find Material to locate a clip or template. See Using Find Material to Add Events to a Schedule.

- **Duration**: Enter a duration for the event.

- **End Mode**: Select between Duration, Manual, or External.

- **Event Description**: Type a description of the event.

- **Start Mode**: Select between Follow, Fixed, Manual, or External.

- **Source Name**: Select a mixer source.

  NOTE: The following event details may not be edited at this time: “Rating,” “Material Type,” and “Segment.”

For secondary events:

- **Material**: Enter the material name or use Find Material to locate a clip or template. See Using Find Material to Add Events to a Schedule

- **Start Mode**: Select between OffsetFromStart or OffsetFromEnd.

- **End Mode**: Select from Duration, OffsetFromStart, or OffsetFromEnd.

- **Layer**: Select a graphics layer (between 1 and 8).

- **Start Offset**: Enter a start offset for the event.

- **End Offset**: Enter an end offset for the event.

- **Duration**: Enter a duration for the event.
Fade In Rate: Select between Cut, Fast, Medium, or Slow.

Fade Out Rate: Select between Cut, Fast, Medium, or Slow.

Stop Animation Lead Time: Double-click to open a dialog box, which allows to enable or disable this feature, and to specify the offset between the end of the selected secondary event and the start of an “outro” sequence.

Event Description: Type a description of the event.

Event Title: Type the title for the event.

Add Text Update (button): Click to configure dynamic text boxes for use with templates that include dynamic text. Up to 255 text updates may be added for each secondary event. Configure the following:
- Box #: Type the number that corresponds to the dynamic text field in the template.
- Offset (optional): Enter the desired offset from the start of the selected secondary event using the following format: +/- hh:mm:ss;ss.
- Text: Type the text to be displayed.

**Saving a Schedule for a Different Channel**

In some cases, you may want to save a schedule to be used by more than one channel. This may be useful, for example, if you want to configure a backup channel.

**To save a schedule for a different channel than the original:**
1. Open the schedule that you wish to save to a different channel.
2. Click Channel > Select to open the Select Channel dialog box.
3. Note that a warning appears in the bottom of the dialog box. Click the X at the right of the warning to proceed.
4. Select different channel from your channel list, or click Add to add a new channel, and then click Select.
5. With the new channel open, save the schedule with a different name by clicking File > Save as, and typing the new name of the schedule.
6. Click OK.

**NOTE:** Simply creating and saving a schedule with ScheduleTool will not cause that schedule to be loaded by OPC. For instructions on loading a schedule (which is loaded the same way as a playlist), see *Loading a Playlist* in the “Using PlayoutTool” chapter.

**Viewing Logs (for MediaDeck 7000 only)**

At this time, you may view logs of ScheduleTool operation for troubleshooting purposes on the MediaDeck 7000 but no other Spectrum video server.

**To view logs:**
1. Click Help > View Diagnostic Logs.

**Clearing Local Settings**

To clear all local ScheduleTool settings, such as the channel list, channel values, schedule modifications, and lists of recently opened schedules or files, use the clear local settings features. Note that this feature also clears any open schedule, including unsaved changes.
To clear local settings:
1. Click Help > Clear local settings, and then click Clear.

About Start Times in ScheduleTool

Start Time Format

With Spectrum 7.7 and later, make sure to enter your local time for event and schedule start times. ScheduleTool displays event and schedule times in the local time zone configured for the channel, and then automatically converts them into universal time (UTC) for use with OPC.

If you wish to view time zone details, including previous Pacific Standard Time (PST) and Next Pacific Daylight Time (PDT), click Select Channel > Details.

Start Time Parameters

NOTE: Simply creating and saving a schedule with ScheduleTool will not cause that schedule to be loaded by OPC. For instructions on loading a schedule (which is loaded the same way as a playlist), see Loading a Playlist in the “Using PlayoutTool” chapter.

Please note the following important points when setting Start Time parameters for your schedules.

When OPC loads a schedule for playout, it performs the following checks:

- If a schedule start date/time is set to more than 24 hours in the past, the schedule will not be loaded.
- If there is one or more schedules already loaded, and a new schedule is configured with a start date/time earlier than the first loaded schedule in the event list, then the new schedule will not be loaded. This is to prevent disruption of the currently running schedule.
- If there are no schedules loaded, the new schedule will be “advanced” (past events will be deleted, and the current event will be added to the playlist based on each event’s scheduled date/time).
- If the schedule matches one that has already been loaded (meaning both the schedule name and schedule start date/time match exactly) then the loaded schedule will be replaced with the new one. Note that the first schedule in the event list can only be partially replaced: future events will be replaced; past events cannot be replaced; the on-air event will not be replaced; the next event will not be replaced; and any future events with a start time within 30 seconds of the current time will not be replaced.

ScheduleTool Keyboard Shortcuts

The following table shows keyboard shortcuts available in ScheduleTool.

<table>
<thead>
<tr>
<th>Key Stroke</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + Alt + N</td>
<td>create schedule</td>
</tr>
<tr>
<td>Ctrl + Alt + O</td>
<td>open schedule</td>
</tr>
<tr>
<td>Ctrl + B</td>
<td>start block</td>
</tr>
<tr>
<td>Ctrl + Alt + B</td>
<td>cancel block</td>
</tr>
<tr>
<td>Key Stroke</td>
<td>Function</td>
</tr>
<tr>
<td>-----------------------</td>
<td>---------------------------------</td>
</tr>
<tr>
<td>Ctrl + Alt + X</td>
<td>cut event/block</td>
</tr>
<tr>
<td>Ctrl + Alt + C</td>
<td>copy event/block</td>
</tr>
<tr>
<td>Ctrl + Alt + V</td>
<td>paste event/block</td>
</tr>
<tr>
<td>Ctrl + Backspace</td>
<td>delete event/block</td>
</tr>
<tr>
<td>Ctrl + I</td>
<td>insert event</td>
</tr>
<tr>
<td>Ctrl + Shift + I</td>
<td>insert secondary event (graphic)</td>
</tr>
<tr>
<td>Ctrl + Alt + F</td>
<td>find</td>
</tr>
<tr>
<td>Ctrl + Alt + R</td>
<td>replace</td>
</tr>
<tr>
<td>Ctrl + M</td>
<td>find material</td>
</tr>
<tr>
<td>Ctrl + Alt + D</td>
<td>set default channel values</td>
</tr>
<tr>
<td>Ctrl + Alt + T</td>
<td>time ripple</td>
</tr>
<tr>
<td>Ctrl + Alt + S</td>
<td>save file</td>
</tr>
<tr>
<td>Ctrl + Alt + Shift + S</td>
<td>save file as</td>
</tr>
<tr>
<td>Ctrl + Alt + Q</td>
<td>close</td>
</tr>
</tbody>
</table>
Appendix A
Contacting the Technical Assistance Center

Harmonic Global Service and Support has many Technical Assistance Centers (TAC) located globally but virtually co-located where our customers can obtain technical assistance or request on-site visits from the Regional Field Service Management team. The TAC operates a Follow-The-Sun support model to provide Global Technical Support anytime, anywhere, through a single case management and virtual telephone system. Depending on time of day, anywhere in the world, we will receive and address your calls or emails in one of our global support centers. The Follow-the-Sun model greatly benefits our customers by providing continuous problem resolution and escalation of issues around the clock.

Table A–1: For Distribution and Delivery (Legacy Harmonic) Products

<table>
<thead>
<tr>
<th>Region</th>
<th>Telephone Technical Support</th>
<th>E-mail</th>
</tr>
</thead>
<tbody>
<tr>
<td>Americas</td>
<td>888.673.4896 or 408.490.6477</td>
<td><a href="mailto:support@harmonicinc.com">support@harmonicinc.com</a></td>
</tr>
<tr>
<td>EMEA</td>
<td>+44.1252.555.450</td>
<td><a href="mailto:support.emea@harmonicinc.com">support.emea@harmonicinc.com</a></td>
</tr>
<tr>
<td>Asia Pacific – Other Territories</td>
<td>+852.3713.9300</td>
<td><a href="mailto:hongkongtechsupport@harmonicinc.com">hongkongtechsupport@harmonicinc.com</a></td>
</tr>
<tr>
<td>India</td>
<td>+44.1252.555.450</td>
<td><a href="mailto:support.emea@harmonicinc.com">support.emea@harmonicinc.com</a></td>
</tr>
<tr>
<td>Russia</td>
<td>+7.495.926.4608</td>
<td><a href="mailto:rusupport@harmonicinc.com">rusupport@harmonicinc.com</a></td>
</tr>
<tr>
<td>Africa</td>
<td>+44.1252.555.450</td>
<td><a href="mailto:support.emea@harmonicinc.com">support.emea@harmonicinc.com</a></td>
</tr>
<tr>
<td>Mainland China</td>
<td>+86.10.8391.3313</td>
<td><a href="mailto:chinatechsupport@harmonicinc.com">chinatechsupport@harmonicinc.com</a></td>
</tr>
</tbody>
</table>

Table A–2: For Production and Playout (Legacy Omneon and Rhozet) Products

<table>
<thead>
<tr>
<th>Region</th>
<th>Telephone Technical Support</th>
<th>E-mail</th>
</tr>
</thead>
<tbody>
<tr>
<td>Americas</td>
<td>888.673.4896 or 408.490.6477</td>
<td><a href="mailto:omneon.support@harmonicinc.com">omneon.support@harmonicinc.com</a></td>
</tr>
<tr>
<td>EMEA</td>
<td>+44.1252.555.450</td>
<td><a href="mailto:omneonemeasupport@harmonicinc.com">omneonemeasupport@harmonicinc.com</a></td>
</tr>
<tr>
<td>Asia Pacific – Other Territories</td>
<td>+65.6542.0050</td>
<td><a href="mailto:apacsupport@harmonicinc.com">apacsupport@harmonicinc.com</a></td>
</tr>
<tr>
<td>Japan</td>
<td>+81.3.5565.6737</td>
<td><a href="mailto:japansupport@harmonicinc.com">japansupport@harmonicinc.com</a></td>
</tr>
<tr>
<td>China - Mainland</td>
<td>+86.10.8391.3313</td>
<td><a href="mailto:chinasupport@harmonicinc.com">chinasupport@harmonicinc.com</a></td>
</tr>
<tr>
<td>Russia and CIS</td>
<td>+7.495.926.4608</td>
<td><a href="mailto:rusupport@harmonicinc.com">rusupport@harmonicinc.com</a></td>
</tr>
</tbody>
</table>
The Harmonic Inc. support website is:
http://www.harmonicinc.com/content/technical-support

The Harmonic Inc. Distribution and Delivery product software downloads site is:
ftp://ftp.harmonicinc.com

The Harmonic Inc. Playout and Production software downloads site is:

The Harmonic Inc. corporate address is:
Harmonic Inc.
4300 North First St.
San Jose, CA 95134, U.S.A.
Attn: Customer Support

The corporate telephone numbers for Harmonic Inc. are:
Tel. 1.800.788.1330 (from the U.S. and Canada)
Tel. +1.408.542.2500 (outside the U.S. and Canada)
Fax.+1.408.542.2511