# Contents

**Introduction** .................................................. 1
Locating the Latest Documentation on the Omneon Web Site .......................... 1
Technical Support .................................................. 2
Useful Information when Contacting Technical Support .............................. 3

**Chapter 1 Installing ContentManager** .................................. 9
System Requirements .................................................. 9
System Compatibility ................................................ 9
Software Installation ................................................ 10
  Downloading and Installing MediaGrid Windows FSD ....................... 10
  Installing Microsoft .NET Framework Version 2.0 .................... 11
  Installing ContentManager ..................................... 11
  ContentManager Licensing ................................... 12

**Chapter 2 Using ContentManager** .................................... 15
Starting ContentManager ............................................ 15
  About Permissions and User Accounts ................................ 15
  Starting ContentManager ........................................ 16
  Mounting a MediaGrid .......................................... 17
User Interface and Menu Overview ..................................... 18
  Main Window ................................................... 19
  File Menu ..................................................... 21
  Edit Menu ..................................................... 22
  View Menu ..................................................... 23
  Tools Menu ..................................................... 24
  Help Menu ..................................................... 26
Access Control Lists (ACLs) ........................................ 26
  ACL Attributes ................................................ 27
  How ACLs Work ................................................ 28
  Setting ACLs .................................................. 28
Replication for Files and Directories ..................................... 32
  Setting ACLs and Replication Factors for Groups of Files or Directories ......... 33
Directory Quotas ................................................... 34
  Setting Directory Quotas .................................... 34
  Directory Reservations ...................................... 35
Omneon MediaTools are low cost, easy-to-use utilities, designed to ensure greater operability for broadcast customers. ContentManager™ is tightly integrated with the Omneon MediaGrid System, which runs on Windows, Mac OS, and Linux platforms.

The ContentManager application is used for setting, reviewing and changing attributes on associated files, directories, and user permissions of the MediaGrid. Note that ContentManager automatically detects if the MediaGrid system uses RAID (ContentServer 3000/ContentStore 3160) or replication (ContentServer 1000/2000 series) architecture and presents a different set of options for each.

You can use ContentManager to:

- **View and edit Access Control Lists (ACLs):** View and edit the user and group access for a single clip, file or directory. You can also select multiple items and apply changes to each. Refer to Access Control Lists (ACLs).

- **Set and change replication factors** (for MediaGrid replication systems, ContentServer 1000/2000, only): Set a file- or directory-level replication factor for data protection and access bandwidth purposes to ensure data is replicated an appropriate number of times (up to 14). Refer to Replication for Files and Directories.

- **Connect to multiple MediaGrid systems:** You can connect to multiple MediaGrid systems simultaneously.

- **Set Quotas or Reservations in a MediaGrid System:** With Quotas, you can set a size limit on directories in a MediaGrid system. With Reservations, you can reserve disk space for directories in a MediaGrid system.

- **Troubleshoot system issues:** A comprehensive logging feature provides the details needed to troubleshoot system issues. Activity logs record all information related to file and user operations.

This guide provides installation and operating instructions in the following sections:

- Installing ContentManager
- Using ContentManager

**Locating the Latest Documentation on the Omneon Web Site**

The latest product technical documentation, as well as information provided for older releases, is available at:

http://omneon/service-support/documentation/
Technical Support

Omneon provides many ways for you to obtain technical support. In addition to contacting your Distributor, System Integrator, or Omneon Account Manager, you can contact the Omneon Technical Support department as follows:

For support in the Americas:

- Telephone (Toll Free): +1(888) OVN SPT1 (686 7781)
- Telephone (Local): +1(408) 585 5200
- Fax: +1 (408) 490 7390
- Email: support@omneon.com
- http://www.omneon.com/service-support

For support in Europe, Middle East, and Africa:

- Telephone: +44 1256 347 401
- Fax: +44 (0) 1256 347 410
- Email: emeasupport@omneon.com
- http://www.omneon.com/service-support

For support in Russia and CIS

- Telephone Number: +7 495 506 5981
- Fax: +7 495 937 8290
- Email: RUsupport@omneon.com
- http://www.omneon.com/service-support

For support in Japan:

- Telephone: +81 3 5565 6737
- Fax: +81 3 5565 6736
- Email: japansupport@omneon.com
- http://www.omneon.com/service-support

For support in China (mainland):

- Telephone: +86 10 6581 9198
Useful Information when Contacting Technical Support

In order to assist Omneon Technical Support, review the following information:

• **What version of firmware is installed on your system?**

  From the Home tab, click the **Upgrade Firmware** icon in the left-hand column to display the Upgrade Firmware page. The firmware version for each device is shown in the **Current Firmware Version** column.

• **What version of SystemManager software is installed?**

  From SystemManager, click the Help tab. The version is shown in the **Server Software** section of the page.

• **Which Windows operating system is running on the SystemManager client PC?**

  1. From Windows, click the Start button, and then click Run.

  2. In the **Open** field, type: winver, and then press **Enter** to open the About Windows dialog box, which shows the version number.

• **How much memory is installed on the SystemManager platform?** (for example, 256 MB, 512 MB, or 1 GB)

  1. From Windows, click the Start button, and then click Run.

  2. In the **Open** field, type: winver and then press **Enter** to open the About Windows dialog box. Look for the line which reads “Physical memory available to Windows.”
• **Please provide the manager.oda file from the SystemManager platform or client PC**

Omneon Technical Support may request that you email the manager.oda file, which contains configuration information for your system. This file is located on the SystemManager platform at D:\Omneon\Manager\omdb, or if you are using a client PC with a single C: partition, it will be in the same directory on the C: drive.

• **What is the model and serial number of the hardware involved?**

  - For Spectrum and MediaDeck devices: from the SystemManager **Home** tab, click the **Upgrade Firmware** icon in the left-hand column to display the **Upgrade Firmware** page. Both MediaDirectors and MediaDecks are listed in the **MediaDirectors** section. Find the Model Numbers and Serial Numbers listed in their respective columns.

  Scroll down to the **MediaPorts** section to view the Model Numbers and Serial Numbers for MediaPorts and MediaDeck Modules.

  - For Omneon MediaGrid Devices: Click the **Servers & Switches** icon in the left-hand column. From the Servers and Switches page, in the **Name** column, click the link for the Omneon MediaGrid device to open the **Properties** page for that device.

  - For ProXchange devices: Click the ProXchange Servers icon in the left-hand column. From the **Servers** page, in the **Name** column, click the link for the ProXchange device to open the **Properties** page for that device.

  - For ProBrowse devices: Click the ProBrowse Servers icon in the left-hand column. From the **Servers** page, in the **Name** column, click the link for the ProBrowse device to open the **Properties** page for that device.

  - For MAS devices: Click the MAS Servers icon in the left-hand column. From the Servers page, in the **Name** column, click the link for the MAS device to open the **Properties** page for that device.

**For Spectrum Systems**

• **What is the name of the Player that is being used?**

From SystemManager, click the **Player Configuration** link in the left-hand column, and then click the name of the MediaDirector or MediaDeck. The **Player List** page for that device appears. The names and status of all players are listed.

• **What file format and bit rate is the Player configured for? (for example, MPEG, DV, IMX?)**

1. From SystemManager, click the **Player Configuration** link in the left-hand column, and then click the name of the MediaDirector or MediaDeck. The **Player List** page for that device appears.

2. From the player list, click the **Properties** link to view all the details for a player.

• **If the problem is related to Ingest or Playout of a clip, what is the Clip ID involved?**

The clip name or clip ID should be indicated by whatever software application you are using to play or record video. For Omneon ClipTool, clip names are displayed in the clip management area of the ClipTool main window.
• What brand of Automation, if any, is being used for control?
• Is the Automation using VDCP or API for communication control?
• What other third party device (for example, Tandberg* or Snell and Wilcoxon*) is involved?

For Omneon MediaGrid Systems

For failures with the Omneon MediaGrid client:
• What operating system is running on the client computer?
• What applications are you using?
• What version of the Omneon MediaGrid FSD is installed?

To determine the FSD version on Windows:
1. From the Control dialog box, click the Add/Remove Programs icon.
2. Locate the Omneon MediaGrid File System Driver entry and click the link, which says Click here for support information. The version is displayed.

To determine the FSD version on Macintosh:
1. Select Find from the File menu.
2. Click Applications in the Finder sidebar of the Searching “This Mac” window.
3. Double-click the Connect to MediaGrid icon to open the Connect to Omneon MediaGrid dialog box.

To determine the FSD version on Linux:
Use the following command: tail /proc/sys/omfs*

• Please supply an error message, screen capture, or description of the symptom
• Is the issue repeatable? If so, what is the procedure to reproduce the issue?
• Please supply log files for the client FSD and ContentBridge FSD

Once you are able to reproduce the issue, Omneon Technical Support may ask you to provide log files from the client computers or the ContentBridge. The following instructions describe how to turn on logging on a client system.

IMPORTANT: Do not perform the following procedures unless directed by Omneon Technical Support.

To enable logging for a Windows client:
1. Add two registry parameters to the O mRdr registry key:
   HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\O mRdr\Parameters
   • D WORD “debug” with value 1
   • D WORD “LogFile” with value 1
2. For debug to take effect, make sure the client is mounted to the Omneon MediaGrid system.

3. For LogToFile to take effect, run the “taillog” executable and redirect the output to a file. From the Start menu, click Run, and paste the location of taillog.exe and desired location of the log file into the Open field, as shown in this example: “C:\ Program Files\ Omneon\ Omneon MediaGrid\ taillog.exe” > c:\ clxxxxxx-1.log

   In this example, the log file will be created at the c:\ directory.

4. Reproduce the issue, and then collect all log files from taillog and the omxxx.log from the WinFSD installed directory.

5. Once you have collected the log files make sure to delete the LogToFile parameter from the registry, otherwise it will have a negative impact on performance.

**To enable logging for a Macintosh client:**

1. Run the following command to ensure that the debug level is set to default:
   ```bash
   sudo sysctl -w debug.omfs=3
   ```

2. Reproduce problem.


**To collect log messages for a Linux client:**

   Collect /var/log/messages.

   Omneon may also wish to collect the current configured Linux FSD parameters. Access these by entering the following command:
   ```bash
   cat /proc/sys/omfs*
   ```

**To collect log messages for the ContentBridge:**

   Locate the log file at:/var/log/omneon/remote/ <IP address of ContentBridge>.

- **What was the time of the failure?**

For information on the time of failure, navigate to the View Alarms page in SystemManager. To open the View Alarms page, click the Diagnostics tab, and then click the View Alarms icon in the left-hand column.

**For failures with the Omneon MediaGrid cluster:**

- **What is the name of the device that experienced the failure?**

From SystemManager, click the Servers & Switches icon in the left-hand column to access the Servers & Switches page. Device names are listed in the Name column.

- **Please provide an error message and/ or a description of the symptom**

- **Is this failure affecting clients or other systems?**

- **Please provide the appropriate log file or remote access to the device**
The Omneon MediaGrid provides logs files for all of the core services. Omneon Technical support may wish to view one of these logs to determine the root cause of the problem. The following three log files are used most often when troubleshooting. These files are located on the ContentDirector at /var/log/omneon/remote.

- **ssmd**: SliceServer Manager
- **mdscore**: MetaData Server
- **startup**: Core Omneon MediaGrid Services Startup and Shutdown
CHAPTER 1
Installing ContentManager

This section provides information about installing ContentManager. The following topics are covered:

- System Requirements
- System Compatibility
- Software Installation
- ContentManager Licensing

IMPORTANT: A File System Driver and Microsoft .NET Framework version 2.0 must be installed on your system to use ContentManager. Refer to Software Installation for instructions.

System Requirements

Prior to installing ContentManager, your PC must conform to the following minimum requirements, and must be connected by Ethernet to your facility’s LAN:

- Pentium 4 or equivalent CPU
- At least 1 gigabyte (GB) of RAM
- 20GB hard drive
- At least 5 Megabytes of free disk space
- Windows® XP Professional
- MediaGrid Windows FSD (File System Driver) 2.1 installed*
- Microsoft .NET Framework version 2.0 installed*
- Display resolution should be set to 1152 x 864 minimum
- 100 BaseT (Gigabit Ethernet recommended)

*Refer to the Software Installation instructions.

System Compatibility

ContentManager 3.0 is compatible with Omneon MediaGrid Release 3.0 and later.
Software Installation

The following items are included with the ContentManager application:

- ContentManager Release Notes
- ContentManager User's Guide (this guide)

Two additional items must be installed on your system prior to installing ContentManager:

- MediaGrid Windows FSD 3.0.1. This is the File System Driver, provided as a separate file from Omneon.
- Microsoft .NET framework version 2.0 (from the Microsoft Web site). This may already be installed on your system.

Before you begin, make sure that the computer on which the ContentManager application will be installed is started and connected by Ethernet to your Omneon ContentDirector when running the application. It is also highly recommended that you exit all Windows programs at this point.

Complete the following installation procedures in order to install the ContentManager components:

- Downloading and Installing MediaGrid Windows FSD
- Installing Microsoft .NET Framework Version 2.0
- Installing ContentManager

Downloading and Installing MediaGrid Windows FSD

Follow these steps to download and install the File System Driver. For the latest information about the Windows FSD, refer to the Release Notes for the Omneon MediaGrid Windows FSD.

To download the Windows FSD:

1. Go to the following directory on the Omneon Support server:

   http://support.omneon.com/Updates/Omneon/Current/MediaGrid/WinFSD/3.0.1

   The full download consists of a single file:

   - WinFSD-v3.0.1.0-32bit.exe / WinFSD-v3.0.1.0-32bit.msi
   - WinFSD-v3.0.1.0-64bit.exe / WinFSD-v3.0.1.0-64bit.msi

   **IMPORTANT:** Make sure to download the version that matches your computer’s processor. If your Windows computer uses a 32-bit processor, download WinFSD-v3.0.0.0-32bit.exe/WinFSD-v3.0.0.0-32bit.msi. If your Windows computer uses a 64-bit processor, download WinFSD-v3.0.0.0-64bit.exe/WinFSD-v3.0.0.0-64bit.msi.

2. Open the file or save it to a location on the client platform.

   The password protected files unpack into the current working directory, or the directory chosen, on the client computer.

To install the Windows FSD:
IMPORTANT: You must have administrator privileges to install the Omneon MediaGrid FSD on Windows

Prior to installing the Omneon MediaGrid FSD for Windows, make sure of the following:

• No application is running on the computer.
• No network shares are open on the computer. If installing the Omneon MediaGrid FSD for Windows from a network location, always copy the installation file to a local directory before beginning the installation.
• All network drive maps to an Omneon MediaGrid server are unmapped. To do this, right-click the mapped network drive and then select the “Disconnect” menu option.
• Uninstall the previous version of the Omneon MediaGrid FSD for Windows if you are upgrading from a prior version. Select Start > Control Panel > Add or Remove Programs to remove the previous version. Restart your computer if instructed to do so.

1. Log on to the system as administrator.
2. Navigate to the location of the WinFSD<version#>.msi file on the client platform.
3. Double-click the WinFSD<version#>.msi icon to begin the installation.
4. Follow the instructions to install the software on the client platform.
5. Restart the computer to complete the installation.

Installing Microsoft .NET Framework Version 2.0

Microsoft .NET Framework version 2.0 must be installed on your system to use ContentManager. The .NET Framework is a key component required to use most new Windows platform applications, including ContentManager.

Prior to installing the .NET Framework, check to see if it is already installed on your system.

1. Use Windows Explorer to navigate to the following location on your system:
   C:\WINDOWS\Microsoft.NET\Framework
2. If you see a v.2.0.x folder you do not need to install .NET Framework.

   Follow these steps if .NET Framework is not installed on your system

1. Go to www.microsoft.com and then search for “.NET Framework 2.0” to locate the installer.
2. Follow the steps to download and install .NET Framework version 2.0 on your system.

Installing ContentManager

Complete the following steps to install the ContentManager application on your PC.
1. If you have not already done so, open the **ContentManager.zip** file that you downloaded from the Omneon support Web site, and extract the files using the password provided by Technical Support. Contact Technical Support if you need assistance.

**NOTE:** Locate the latest ContentManager.zip file at ftp://ftp.omneon.com//Updates/Omneon/Current/MediaGrid/ContentManager

2. Locate the **ContentManager** executable file icon from the ContentManager.zip folder.

3. Double-click the **ContentManager** icon to begin the installation.

4. Click **Next** and then follow the steps to install ContentManager.

   This completes the ContentManager installation procedure. Refer to **Using ContentManager** to begin using the application.

**ContentManager Licensing**

A license file (provided by Omneon) supplies the licenses for the ContentManager components. This file is installed on the Omneon SystemManager computer.

One license is required for each instance of ContentManager that is in use. These are “floating licenses” so any connected computer can run the application, until the total number of purchased (and licensed) copies are active.

For example: If you have purchased four ContentManager licenses and you have installed the product on 20 computers, you can run up to four instances of ContentManager at any one time. The remaining 16 installations cannot run the tool until one of the first four exits.
A variety of dialog boxes may appear at startup time if the application encounters licensing issues (for example, the license server is down, the license file cannot be found, all licenses are used, etc.). The figure below shows examples of some of the possible messages you may encounter.

Follow the directions in these dialog boxes and/or contact your Network Administrator as required to resolve any issues that arise. Contact Omneon Sales to purchase additional licenses.
CHAPTER 2
Using ContentManager

This section covers the operation of the Omnecn ContentManager application. Refer to the Introduction for an overview of the ContentManager features. Choose from the following topics:

- **Starting ContentManager**
  Instructions on starting the ContentManager application and mounting a MediaGrid system.

- **User Interface and Menu Overview**
  An introduction to the ContentManager Main application window and a description of each menu and its commands.

This section also includes detailed instructions on using the ContentManager features, including:

- **Access Control Lists (ACLs)**
- **Replication for Files and Directories**
- **Directory Quotas**
- **Directory Reservations**
- **Viewing File Slice Information**
- **Viewing Logs**

**Starting ContentManager**

This section provides instructions on starting and using ContentManager.

**About Permissions and User Accounts**

Before starting ContentManager, note the following points:

- You must log on to the computer that you will use to run ContentManager as an administrator in order for ContentManager to write log files.

- In order to change Quotas and Reservations for a MediaGrid directory using ContentManager, you must be logged on to the MediaGrid system as an administrator. Refer to the Omnecn MediaGrid Installation and Configuration Guide for log on instructions. For information about Quotas and Reservations, refer to Directory Quotas and Directory Reservations.

- To set up permissions and change ownership for individual files or directories, refer to Access Control Lists (ACLs).
**Starting ContentManager**

A ContentManager icon is placed on your desktop during installation of the program. Use the following steps to operate ContentManager for the first time. To use ContentManager after first-time setup, just double-click the desktop icon.

1. Double-click the **ContentManager** icon.

2. Click **Specify the License Server**, and then click **Next**.

3. Enter the IP address or host name of the license server on the **FLEXlm License Finder** screen and then click **Next**.
4. ContentManager accesses the license server and verifies availability of licenses. If licenses are available, the following screen displays:

5. Click Finish to begin using ContentManager.

   Contact your Network Administrator as required to resolve any issues that arise. Contact Omneon Sales to purchase additional licenses.

**Mounting a MediaGrid**

The MediaGrid system that ContentManager browses must be joined to your Windows domain to edit access control lists and replication factors. See “Joining a MediaGrid Cluster to a Windows Domain” in the MediaGrid Installation and Configuration Guide for more information.
You can connect to multiple MediaGrid systems simultaneously and browse each to edit ACLs and set replication factors on both directories and files.

1. With ContentManager started, select Mount MediaGrid from the File menu to access a specific MediaGrid.

2. Enter the path to the MediaGrid in the following format: `\[dnsname]\[file system]`

3. Click the OK button.

4. Enter the username and password for the MediaGrid.

5. Click the OK button to log on to the MediaGrid.

The MediaGrid file system displays in the Directories pane on the Main window.

**User Interface and Menu Overview**

This section describes the ContentManager Main window, and provides an overview of each menu and its commands. The following topics are covered:

- Main Window
- File Menu
- Edit Menu
- View Menu
- Tools Menu
Main Window

The ContentManager Main window provides a central control panel for selecting the directories and files for which you want to edit ACLs and replication factors. The figure below shows a sample Main window.

NOTE: For MediaGrid RAID systems (ContentServer 3000/ContentStore 3160), the Rep column, which shows replication factor, in the main window will not display.

Following are descriptions of each section above.

Menu Bar

The Menu Bar provides menus for File, Edit, View, Tools, and Help, which are used to operate the ContentManager application. Refer to File Menu, Edit Menu, View Menu, Tools Menu, and Help Menu for complete details.

Toolbar

The Toolbar provides shortcuts for commonly used ContentManager tasks.
1. **Up**: Click the Up icon to go up one level.

2. **List View**: Click the List View icon to display the file name and extension of the MediaGrid’s contents in a list.

3. **Details View**: Click the Details View icon to display detailed information for the selected MediaGrid’s contents (name and type of file, Replication Factor, if an ACL exists, size of the file, and date modified). Refer to **Contents Pane** for more information.

4. **ACL**: Click the ACL icon to edit the Access Control List for the selected item.

5. **Replication** (for MediaGrid replication systems, ContentServer 1000/2000 series, only): Click the Replication icon to edit the Replication Factor for the selected item.

6. **Help**: Click the Help icon to open ContentManager help.

---

**Tree View**

The Tree View, shown in the left-hand pane of the Main window, displays all the available MediaGrid systems. This is where you select the files or directories for modification of ACLs and replication factors on specific MediaGrid systems. You can connect to multiple MediaGrid systems simultaneously and browse each for directories or files to edit.

**Contents Pane**

The Contents Pane shows all of the files and subdirectories present on the selected MediaGrid directory. The leftmost folder shown in the Tree View is the MediaGrid root directory.

Click the **Details View** or **List View** Toolbar icons to show or hide the file and directory details. Click any of the Contents Pane column headings to sort the contents by the column selected.
Note that **soft links** are shown in green text in the Contents Pane. Place the mouse pointer over a soft link to view the path of the file to which the soft link refers.

The contents pane displays the following information:

- **Name**: the name of the file or directory.
- **Type**: the type of file (for example, .m2v, .aiff, .mov, .mxf, .log).
- **Class**: No longer supported.
- **Rep** (for MediaGrid replication systems, ContentServer 1000/2000 series, only): the file's or directory's current replication factor. An asterisk is placed next to a directory's replication factor if the replication factor is inherited. You can change the replication factor directly in the Contents Pane by double-clicking the number in the Rep column and then entering a new number.
- **ACL**: This column shows whether an ACL exists for the file or directory. YES is shown if an ACL exists (either Deny or Allow); dashes (---) display if the ACL is Inherited.
- **Slice Size**: the slice size of the file.
- **Size**: the size of the file.
- **Quota**: the size limit that has been set on a MediaGrid directory.
- **Reservation**: indicates the amount of space reserved on a MediaGrid directory.
- **Modified**: the date the file or directory was last modified.

**File Menu**

The File menu contains the following options:
• **Mount MediaGrid**: Click to add a specific MediaGrid to the Tree View. Refer to [Mounting a MediaGrid](#) for details.

• **Unmount**: Click to unmount a MediaGrid file system and remove it from the Tree View.

• **Exit**: Click to close the ContentManager application.

### Edit Menu

The **Edit** menu contains the following options:

*ACL*: Click to modify the file's or directory's access control list.

*Replication* (for MediaGrid replication systems, ContentServer 1000/2000 series, only): Click to change the file's or directory's replication factor.

*Quota*: Click to set a size limit on a file system size or to remove a previously set quota. Refer to [Setting Directory Quotas](#) for more information.

*Reservation*: Click to reserve an amount of disk space for a directory. Refer to [Directory Reservations](#) for more information.

*Class*: No longer supported.

*View Slices*: Click to see the number of slices of a file, along with its replication factor (if applicable) and location. Refer to [Viewing File Slice Information](#).

*Select All*: Click to select all directories and/or files in the Contents pane.
• **Invert Selection**: Click to reverse what is selected in the Contents pane. For example, if there are 10 files in the Contents pane and only one is selected, click **Invert Selection** to deselect the file and select the other nine files.

**View Menu**

The **View** menu contains the following options:

<table>
<thead>
<tr>
<th>View</th>
<th>Tools</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Refresh</td>
<td>F5</td>
<td></td>
</tr>
<tr>
<td>List</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Details</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Modify Clip Essence Files</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Current Log...</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Debug On</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Verification Reports...</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- **Refresh**: Click to display the latest view of the accessible files and directories.
- **List**: Click to display the selected MediaGrid's contents without details.
- **Details**: Click to see each file's and directory's details (Type, Rep, ACL, Size, Modified).
- **Modify Clip Essence Files**: Click to determine the action taken on the essence files when a .mov is modified.
- **Current Log**: Click to display the current log file.
- **Debug On**: Click to display debug messages in the log file.
- **Verification Reports**: Click to open the **Verification Reports** dialog box. This dialog box displays the logs created from running the **Verify Replication** tool. For information on the **Verify Replication** tool, refer to the **Tools Menu**.
- Click **View Deficient Files** to view files that failed the verification test and to save the results as a text file.
- Click **Delete** to delete the selected file.

**Tools Menu**

The **Tools** menu contains the following options:

<table>
<thead>
<tr>
<th>Tools</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Verify Replication…</td>
<td>CTRL + F</td>
</tr>
<tr>
<td>Show All Quotas…</td>
<td></td>
</tr>
<tr>
<td>Show All Reservations…</td>
<td></td>
</tr>
</tbody>
</table>

- **Verify Replication**: Click to open the Verify Replication dialog. This tool checks every file in the selected folder(s) to verify whether the actual replication factor matches the requested replication factor.

**Note**: For MediaGrid RAID systems, the Verify Replication tool can be used to identify missing slices.
To verify the selected folders recursively (which includes all sub folders), check **Recurse on subdirectories**, otherwise leave that option blank, and then click **Start** to begin verifying.

Files with incorrect replication factors are listed in the white pane of the dialog. Double-click the file with incorrect replication to view the **View Slices** dialog box for the selected file. Refer to **Viewing File Slice Information** for more information.

- **Show All Quotas**: Click to display the **All Quotas** dialog box.

This dialog box shows all the quotas on the file system. To edit the quota, either double-click the item shown in the **Path** column, or select it and click **View Info**.

- **Show All Reservations**: Click to display the **All Reservations** dialog box, shown below.
This dialog box shows all the reservations on the file system. To edit the reservation, either double-click the item shown in the Path column, or select it and click View Info.

**Help Menu**

The Help menu contains the following options:

- **Show Help**: Click to open ContentManager help.

- **Licensing**: Click to view the current license server used by ContentManager.

- From the Licensing dialog box, click the Reset License Server button to clear the license server. ContentManager must be restarted to enter a new license server. You may want to note the current license server before resetting this information.

- **About**: Click to show the version, date and copyright information for ContentManager.

**Access Control Lists (ACLs)**

Both the Omneon ContentManager application and the MediaGrid Windows FSD for Microsoft
Windows Explorer allow you to create Access Control Lists (ACLs) to set user- and group-level security for the various Omneon MediaGrid files and directories. These ACLs are stored on the ContentDirector. Once ACLs are created, when users attempt to access files, MediaGrid checks access against the ACL for each file. ACLs provide security preferences for each individual Access Control Entry (ACE).

The Omneon MediaGrid system receives user and group information from the Active Directory or LDAP server. It also uses the domain controller to authenticate the users. The ContentManager and the MediaGrid Windows FSD access this user and group information when you use either of them to create ACLs. The ContentManager application and MediaGrid Windows FSD also receive the ACLs when either mounts an Omneon MediaGrid file system, and then they contact the ContentDirector to resolve user names.

**ACL Attributes**

The following attributes can be defined for files and directories:

- **File**: includes the following operations
  - **FileRead**: Allows the file to be read.
  - **FileWrite**: Allows the file to be changed, appended or truncated (but not necessarily deleted).
  - **FileExecute**: Depending on the client operating system, may allow the file to be executed.

- **Directory**: includes the following operations:
  - **List**: Allows the names and attributes of files stored in the directory to be read. In order to access a file, in addition to requiring appropriate permissions on that file, a user needs List permission to all the parent directories of that file.
  - **Delete**: Allows files to be deleted (from a directory). As with Unix, the file itself need not be writable.
  - **Rename**: Allows files to be renamed.
  - **Create**: Allows new files and directories to be created.
  - **FileRead**: When inherited by files, allows the file to be read. There is no other effect on the directory.
  - **FileWrite**: When inherited by files, allows the file to be changed, appended or truncated (but not necessarily deleted).
  - **FileExecute**: When inherited by files, may allow the file to be executed.

- **File or Directory**: includes the following operations:
  - **WriteSysMetaData**: Allows changes to a file’s ACL, ownership or replication factor (if applicable).
  - **WriteUserMetaData**: Allows changes to a file’s “user data” (keys and values).
How ACLs Work

For any particular operation, MediaGrid checks the file's ACL entries for one that refers to an operation in the above table, (for example, “FileWrite”). If such an entry is found, the Allow or Deny action is applied. If the action is Inherit, the ACL for the directory in which the file resides is checked. If that directory’s action is Inherit, its parent directory is checked, and so on. The operation is denied if an Allow entry is not found. The Inherit action is assumed for any file or directory without entries. The root directory cannot inherit. Read the following sections to learn how to set up ACLs, then continue to About the Ordering of ACEs within an ACL for tips on ordering ACEs and some examples.

Setting ACLs

- With ContentManager started, select the file or directory you want to edit. There are three ways to select a file or directory:
  - Select ACL from the Edit menu with the file or directory highlighted.
  - Click the ACL icon on the Toolbar with the file or directory highlighted.
  - Right-click the file or directory and then select Edit ACL.

The ACL Editor dialog box provides permissions that can be customized for each user. Permissions that are checked correspond to the Action setting. The above example shows an ACL for a file. If a directory is selected, then additional permissions for List, Delete, Rename, and Create are available. Refer to Access Control Lists (ACLs) for descriptions of each permission.
1. Select the permission for each user by clicking the corresponding check box.

2. Select the **Action** by clicking the **Action** field and selecting one of the following:
   - **Allow**: allow the user control of the checked permissions.
   - **Deny**: deny the user control of the checked operations.
   - **Inherit**: use the permissions of the parent directory.

   **Tip**: Press SHIFT-click with the mouse pointer over a check box to select or clear all the check boxes for the selected access control entry (ACE).

3. Click the **Apply** button to apply your changes, or click **Cancel** to cancel any changes and close the dialog box. Click the **OK** button to confirm the changes that you made.

**ACL Editor Screen Options**

- Click the **Change** button from the **Owner** field to change a directory or file owner. You must have permission to change the file's system metadata in order to change the owner.
- Click the **Up** and **Down** arrow buttons to move an entry (ACE) up or down in the ACL. See **About the Ordering of ACEs within an ACL** for information on how to order ACEs.
- Click the **Minus** (-) button to remove an ACE from the ACL.
- Click the **Plus** (+) button to add users or groups to the ACL.
- Click the **Effective Permissions** button to view the actual permissions a user or group has, excluding all permissions inherited from a parent directory.

**Adding Users and Groups**

ContentManager allows you to easily add users and groups of users to any file or directory ACL. The computer on which ContentManager is installed must be logged in to your domain controller (security server) to add users and groups.

1. Open the ACL to which you want to add a user or group of users.
2. Click the **Plus** (+) button on the ACL Editor screen.
From the resulting screen, select the available users from the domain controller.

1. Click the + sign to expand a category.
2. Add users or groups by clicking the **Add** button with the user or group selected.
3. Click the **Close** button when you have finished adding users or groups.

No permissions are granted for the added user(s) until you check them on the ACL Editor screen.

**About Users, Groups and Special Security Identifiers (SIDs)**

Following are descriptions of the available user and group options.

- **User**: users who are part of the domain.
- **Group**: groups of users that are set up in the domain.
- **Special**: These SIDs are placed in ACLs to match users or groups of users who may not be members of lists. The following Special SIDs are available:
  - **AllSID**: any user (authenticated or not) is effectively a member of this group, and, therefore, matches an ACL entry that specifies “all”. Use AllSID to match all users.
  - **OwnerSID**: matches the owner of a file. Use OwnerSID to match a user of any session who is the owner of a file.
• **NoneSID**: this is the SID for an unauthenticated user, and should not be used to match a user ("none" is an invalid SID in an ACL).

• **GuestSID**: "guest" is the ACL equivalent of "none". A "guest" SID in an ACL only matches against an unauthenticated user. Use GuestSID to match a user of any session who has not authenticated.

**NOTE**: Since it would be rare to allow access only to an unauthenticated user, "guest" is typically only used for "deny" entries. For example, if you wanted to allow access only to authenticated users, you would have an ACL of "deny guest", followed by "allow all".

### About the Ordering of ACEs within an ACL

- ACLs are checked in order from top to bottom. If a match is found, then checking immediately stops. For example, in the ACL shown in the following diagram, the ACE for “SNV-ENG\guest” will never be used because the first ACE already applies for every user.

To make this ACL effective, “SNV-ENG\guest” should be moved to the top using the Up arrow, as shown in the following diagram.
• Note that the **Inherit** action means that the ACE acquires the permissions of all the ACEs from parent directories. For example, if an ACE with **Inherit** is followed by an ACE with **Deny**, and the parent directory has an **Allow**, then the **Allow** will take precedence and negate the **Deny**. As a result, it is always best to put any ACE with **Inherit** at the bottom of the ACL.

• If multiple ACEs exist for a user, ContentManager combines the permissions from each ACE into a single ACE and removes the redundant or unnecessary ACE(s). The unneeded ACEs are removed when you click the **OK** or **Apply** buttons.

## Replication for Files and Directories

**NOTE:** This section only applies to MediaGrid replication systems (ContentServer 1000/2000 series), not RAID systems.

Each file and directory can be duplicated within the MediaGrid system to ensure data protection and for access bandwidth purposes. The number of copies, or the “replication factor,” can be up to 14.

The replication factor is set on the root directory of a file system and then inherited by child directories. A file inherits the replication factor from its parent directory only at the time of file creation. Thereafter, changes in replication factor of the directory do not affect pre-existing files. Once a file is created, the replication factor is specific to each file and must be changed on a file-by-file basis.

It is recommended that you set the replication factor to at least 2 for data protection of your critical files and directories. A replication factor of 1 means that there is only one instance of a file or directory on the MediaGrid system. A failure of any single ContentServer or drive in the system that stores any part of a file with a replication factor of 1 will render that file unrecoverable.

Follow these steps to set replication factors.

1. Select the file or directory you want to edit. There are three ways to select a file or directory:
   • Select **Replication** from the **Edit** menu with the file or directory highlighted, or
   • Click the **Replication** icon on the Toolbar with the file or directory highlighted, or
   • Right-click the file or directory and then select **Edit Replication**.

   **NOTE:** The **Inherit** check box displays when editing a directory’s replication factor, and allows you to set the replication factor to Inherit.

2. Enter the desired Replication Factor (1-14).

3. Click the **OK** button to set the replication factor.
The number that you enter represents the desired replication factor. Several factors affect the completion progress; if not completed immediately, the replication factor is reached at the earliest possible opportunity.

If there are an insufficient number of ContentServers with available storage, the MediaGrid retains the desired replication factor until this is resolved, either by addition of ContentServers or by deletion of existing content.

### Setting ACLs and Replication Factors for Groups of Files or Directories

ACLs and Replication Factors can be changed for a group of directories or files at the same time.

1. Display the directories or files that you want to edit.
2. Click the **Type** column in the Contents Pane to sort the items by type, as shown below.

3. Within the Contents Pane, hold down the SHIFT key and then click the group of items that you want to change.

**To change the Replication Factor:**

a. With the items selected, as shown above, click the **Replication** icon on the Toolbar.

b. Enter the Replication Factor for the group of items.
To edit the ACLs:

a. With the items selected, as shown above, click the ACL icon on the Toolbar.
b. Set the ACLs as desired. Refer to Access Control Lists (ACLs) for details.
c. Click OK on the ACL Editor screen when you have finished.

Directory Quotas

The Quota feature allows a system administrator to set a size limit on all ContentServer directories in a MediaGrid system. Once set, the disk space used by all files in that directory and in all of its subdirectories cannot exceed the quota setting. Once full, any operation that could increase the size of the directory is prohibited.

The following apply to quotas:

- Quotas can only be set or removed by a client with system administrative privileges.
- A maximum of 64 quotas can be set within one file system.

Setting Directory Quotas

Directory quotas can be modified by any user who has permission to do so. Follow these steps to set a directory quota.

1. Select the directory for which you want to set a quota.

2. Select Quota from the Edit menu, or right-click the directory and then select Edit Quota.

3. Enter the size limit, in gigabytes, that you would like to set for the directory.

4. Click OK.

**NOTE:** Quota checks are performed when writing to files. Once the quota limit is exceeded, the space used must be reduced below the quota level before further writes are allowed.

To remove a quota:

1. Select the directory for which you want to remove the quota.

2. Select Quota from the Edit menu, or right-click the directory and then select Quota.
3. Select **No Limit** and then click **OK**.

**Directory Reservations**

The Reservation feature allows a system administrator to “reserve” an amount of disk space for a directory, which guarantees that all files and subdirectories within the directory have at least that amount of space available. Once a reservation is set, the file system checks every write, or any other operation that uses disk space, and validates that the operation will not affect the “reserved” space (that is, the operation will not create a “reservation conflict”).

The following rules apply to reservations:

- Reservations can only be set or removed by a client with system administrative privileges.
- A directory that has been reserved cannot be deleted or renamed while it carries the reservation. In order to delete or rename the directory, you must first remove the reservation, and then perform the operation. Once the operation is complete, the reservation can be reset.
- A maximum of 128 directories can be reserved within one file system.
- A reservation cannot be set on a directory that is either a subset or superset of an existing reservation. For example, if there is a reservation on /testfs/dir1/dir2, then a reservation cannot be set on /testfs/dir1, or on /testfs/dir1/dir2/dir3.
- The following will result in a “reservation error” message:
  - Attempting to set a reservation on a directory in which there is not sufficient space for that reservation.
  - Attempting an operation, such as writing to or replicating files, that would use more disk space than is reserved for a directory.

**Setting Reservations**

**To set a reservation:**

1. Select the directory for which you want to set a reservation.

2. Select **Reservations** from the **Edit** menu, or right-click the directory and then select **Edit Reservation**.

3. Enter the size limit, in gigabytes, that you would like to set for the directory.
4. Click **OK**.

   **To remove a reservation:**

1. Select the directory for which you want to remove the reservation.
2. Select **Reservations** from the **Edit** menu, or right-click the directory and then select **Edit Reservation**.
3. Select **No Reservation** and then click **OK**.

### Viewing File Slice Information

All files stored on a MediaGrid system reside on the system’s ContentServers. Each file splits into one or more “slices” when stored, with each slice stored on another ContentServer. With slices and replication, multiple ContentServers can access any slice of any file. Slices can be any of the following sizes: 256 KB, 512 KB, 1 MB, 2 MB, 4 MB and 8 MB.

Follow these steps to view the number of slices, replication factor and location of a file.

1. Expand a directory or subdirectory so that files are displayed in the Contents Pane.
2. Select the file that you would like to view.
3. Select **View Slices** from the **Edit** menu, or right-click the file and then select **View Slices**.

The **Slice Counts** dialog box presents the following information about the file:

- **Slice #**: the number of slices in the file. Slice 0 is the first slice in the file, slice 1 is the second, and so on. The number of slices in a file depends on the size of the file and the slice size of the file.
• **Actual Rep**: the replication factor based on the number of ContentServers on which the slice resides.

• **ContentServers**: the ContentServers (with IDs shown) within a MediaGrid cluster that store the replication. In the example above, each replication is on three ContentServers: 0, 1 and 2.

• Click **Show All** to see all of the slices for the selected file.

![Slice Counts dialog box](image)

• Click **Show Deficient Slices** to see the slices that have replication factors that do not match the replication factor that you requested, as shown above. Deficient slices typically occur when there are not enough ContentServers to accommodate the requested replication factor.

A replication can have one of three different background colors, as described below:

• **White** indicates that the number of slices replicated matches the replication factor.

• **Yellow** indicates that the number of slices replicated is one less than the replication factor.

• **Orange** indicates that the number of replicated slices is less than the replication factor by at least two.

To refresh the list in the Slice Counts dialog box, click **Refresh**, or press **F5**.

### Viewing Logs

ContentManager activity is recorded and stored in a log file, which is located in a subdirectory of the ContentManager program. To view the current log file, select **Logging** from the **View** menu and then select **Open Log**.

You can also view a log file by using Windows Explorer to navigate to the **Program Files** directory. Go to the **Omneon\ContentManager\logs** subdirectory. An example is shown below.
The comprehensive log file provides the details needed to troubleshoot system issues. All information related to file and user operations is recorded and shown in each log. Log level severity can be set to record all minor or major events within a file system to facilitate quick identification of errors and issues.

Each log file contains the date and time of the day's ContentManager activity, the logging level, user name and a description of the activity. The logging levels are:

- **A**: Audit
- **D**: Debug
- **E**: Error
# Index

## A
- About ContentManager 26
- ACL Attributes 27
- ACL Editor screen buttons 29
- ACL, Edit Menu 22
- ACLs
  - adding users and groups 29
  - Allow action setting 29
  - editing 28
  - for multiple files and directories 33
  - how ACLs work 28
  - setting 28
- Allow action setting 29

## C
- Contact Omneon 2
- ContentManager
  - features 1
  - installing 9, 11, 12
  - licenses 12
  - logs 37
  - Main Window 19
  - starting 16

## D
- Deficient slices 37
- Deny action setting 29
- Details, View Menu 23
- Directory quotas 1, 34
- Directory, change owner 29

## E
- Edit Menu 22
- Exit ContentManager 22

## F
- File Menu 21, 22
- File, change owner 29
- FLEXlm License 12

## G
- Groups, adding to ACLs 29

## H
- Help Menu 26

## I
- Inherit action setting 29
- Installation 9, 11, 12
- Invert selection 23

## L
- License server, clear 26
- Licensing, Help menu 26
- List 23
- Log files 37
- Logging levels 38

## M
- Main Window 19
- Main Window, Tree View 20
- MediaGrid
  - mounting 17
  - mounting, unmounting from File menu 22
- Menu Bar 19
- Modify Clip Essence Files 23

## O
- Omneon
  - Technical Support 2

## Q
- Quota, Edit Menu 22
- Quotas, setting 34

## R
- Refresh 23
- Replication factor 32
  - actual 37
  - for multiple files and directories 33
  - setting 32
- Replication, Edit Menu 22
- Reservation, Edit Menu 22

## S
- Show Help 26
- Slice count 36