Spectrum

Spectrum X™ and ChannelPort™
RELEASE 8.1

Template Authoring Guide
Manual Part No. 28-0375

February, 2016

Copyright © 2000—2016 Harmonic Inc. All rights reserved. Omneon, and the Omneon logo are trademarks of Harmonic Inc.

Disclaimer
Harmonic reserves the right to alter the equipment specifications and descriptions in this publication without prior notice. No part of this publication shall be deemed to be part of any contract or warranty unless specifically incorporated by reference into such contract or warranty. The information contained herein is merely descriptive in nature, and does not constitute a binding offer for sale of the product described herein. Harmonic assumes no responsibility or liability arising from the use of the products described herein, except as expressly agreed to in writing by Harmonic. The use and purchase of this product do not convey a license under any patent rights, copyrights, trademark rights, or any intellectual property rights of Harmonic. Nothing hereunder constitutes a representation or warranty that using any products in the manner described herein will not infringe any patents of third parties.

Third-Party Product Trademarks
Adobe® After Effects®, Photoshop®, Flash® Professional, Premiere®
Avid® Media Composer®
Dolby® E, Dolby Digital, Dolby Digital Plus
Jünger Audio™
Apple® QuickTime®
Microsoft® Mediaroom®
Microsoft® PlayReady®
DOCSIS® 3.0
Start Over® TV

Third-Party Copyright Notes
Dolby is a registered trademark of Dolby Laboratories. Dolby Digital, Dolby Digital Plus, Dolby Pulse, aacPlus, AC-3, and Dolby E are trademarks of Dolby Laboratories.
Level Magic and Jünger are trademarks of Jünger Audio Studiotechnik GmbH.
MPEG Audio technology licensed from Fraunhofer IIS http://www.iis.fraunhofer.de/amm/
PitchBlue® is a registered trademark of Vigor Systems.
QuickTime and the QuickTime logo are trademarks or registered trademarks of Apple Computer, Inc., used under license therefrom.

Trademark Acknowledgments
Harmonic and all Harmonic product names are trademarks of Harmonic Inc. All other trademarks are the property of their respective owners.
The software described in this document is furnished under a license agreement or nondisclosure agreement. The software may be used or copied only in accordance with the terms of those agreements.

Third-Party Product Trademarks

© 2016 All rights reserved.
2. LICENSE: Subject to the terms and conditions of this Agreement (including payment), we hereby grant you a nonexclusive, nontransferable license to use the object code version of the Software embedded into, provided solely for use with or loaded onto the Product, and the accompanying documentation ("Documentation") for your internal business purposes. The Software and any authorized copies are owned by us or our suppliers, and are protected by law, including without limitation the copyright laws and treaties of the U.S.A. and other countries. Evaluation versions of the Software may be subject to a time-limited license key.

3. RESTRICTIONS: You land your employees and contractors shall not attempt to reverse engineer, disassemble, modify, translate, create derivative works of, rent, lease, license use on a timesharing, applications service provider, service bureau or similar basis, loan, distribute, sublicense or otherwise transfer the System, in whole or part except to the extent otherwise permitted by law. The Software may be operated on a network only if and as permitted by its Documentation. You may make one (1) back up copy of the object code of the Software for archival purposes only. Evaluation Software will be run in a lab, nonproductive environment. Results of any benchmark or other performance tests may not be disclosed to any third party without our prior written consent. Title to and ownership of the Software and Documentation, and all copyright, patent, trade secret, trademark and other intellectual property rights in the System, shall remain our or our licensors' property. You shall not remove or alter any copyright or other proprietary rights notice on the System. We reserve all rights not expressly granted.

4. LIMITED WARRANTY: (a) Limited Warranty. We warrant to you that, commencing on your receipt of a Product and terminating 1 year thereafter, the System will perform substantially in accordance with its then-current appropriate Documentation. The Product including replacements/ may consist of new, used or previously-installed components. (b) Remedies. If the System fails to comply with such warranty during such period, you must return the same in compliance with our product return policy, and we shall, at our option, repair or replace the System, provide a workaround, or refund the fees you paid. Replacement Systems are warranted for the original System's remaining warranty period. (c) Exclusions. EVALUATION SOFTWARE IS LICENSED ON AS-IS BASIS AND SUBJECT TO 4th. We will have no obligation under this limited warranty due to: negligence, misuse or abuse of the System, such as unusual physical or electrical stress, misuse or accidents, use of the System other than in accordance with the Documentation, modifications, alterations or repairs to the System made by a party other than us or our representative; the combination, operation or use of the System with equipment, devices, software or data not supplied by us; any third party hardware or Third Party Software, whether or not provided by us; any failure other than by us to comply with handling, operating, environmental, storage or maintenance requirements for the System or Documentation, including, without limitation, temperature or humidity ranges. (d) Disclaimers. We are not responsible for any software, firmware, information, or data contained in, stored on, or integrated with any Product returned to us for repair or replacement. SUCH LIMITED WARRANTY IS IN LIEU OF, AND WE SPECIFICALLY DISCLAIM, ANY AND ALL OTHER WARRANTIES, WHETHER EXPRESS, IMPLIED OR STATUTORY, INCLUDING, BUT NOT LIMITED TO, ANY IMPLIED WARRANTIES OF SATISFACTORY QUALITY, MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR NONINFRINGEMENT, EVEN IF WE WERE ADVISED OF THE POSSIBILITY OF SUCH LOSS OR DAMAGES. NOTWITHSTANDING ANY OTHER PROVISIONS OF THIS AGREEMENT, WE AND OUR REPRESENTATIVES' TOTAL LIABILITY TO YOU ARISING FROM OR RELATING TO THIS AGREEMENT OR THE SYSTEM SHALL BE LIMITED TO THE TOTAL PAYMENTS TO US UNDER THIS AGREEMENT FOR THE SYSTEM. THE FOREGOING LIMITATIONS SHALL NOT APPLY TO DEATH OR PERSONAL INJURY TO PERSONS OR TANGIBLE PROPERTY IN ANY JURISDICTION WHERE APPLICABLE LAW PROHIBITS SUCH LIMITATIONS. WE ARE SOLELY RESPONSIBLE FOR BACKING UP YOUR FILES, AND HEREBY RELEASE US AND OUR REPRESENTATIVES FROM ANY LIABILITY OR DAMAGES DUE TO THE LOSS OF ANY SUCH DATA OR FILES. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO SUCH EXCLUSIONS MAY NOT APPLY TO YOU.

5. LIMITATION OF LIABILITY: WE AND OUR AFFILIATES, SUPPLIERS, LICENSORS, OR SALES CHANNELS ("REPRESENTATIVES") SHALL NOT BE LIABLE TO YOU FOR ANY SPECIAL, INCIDENTAL, CONSEQUENTIAL, PUNITIVE, OR EXEMPLARY DAMAGES OF ANY KIND, INCLUDING BUT NOT LIMITED TO LOST PROFITS, OR SAVINGS, OR THE COST OF SUBSTITUTE GOODS, HOWEVER CAUSED, UNDER CONTRACT, TORT, BREACH OF WARRANTY, NEGLIGENCE, OR OTHERWISE, EVEN IF WE WERE ADVISED OF THE POSSIBILITY OF SUCH LOSS OR DAMAGES. NOTWITHSTANDING ANY OTHER PROVISIONS OF THIS AGREEMENT, WE AND OUR REPRESENTATIVES' TOTAL LIABILITY TO YOU ARISING FROM OR RELATING TO THIS AGREEMENT OR THE SYSTEM SHALL BE LIMITED TO THE TOTAL PAYMENTS TO US UNDER THIS AGREEMENT FOR THE SYSTEM. THE FOREGOING LIMITATIONS SHALL NOT APPLY TO DEATH OR PERSONAL INJURY TO PERSONS OR TANGIBLE PROPERTY IN ANY JURISDICTION WHERE APPLICABLE LAW PROHIBITS SUCH LIMITATIONS.

6. CONFIDENTIALITY: Information in the System and the associated media, as well as the structure, organization and code of the Software, are proprietary to us and contain valuable trade secrets developed or acquired at great expense to us or our suppliers. You shall not disclose to others or utilize any such information except as expressly provided herein, except for information lawfully received by the user from a third party which is not subject to confidentiality obligations; generally available to the public without breach of this Agreement; lawfully known to the user prior to its receipt of the System; or required by law to be disclosed.

7. SUPPORT: Updates, upgrades, fixes, maintenance or support for the System (an "Upgrade") after the limited warranty period may be available at separate terms and fees from us. Any Upgrades shall be subject to this Agreement, except for additional or inconsistent terms we specify. Upgrades do not extend the limited warranty period.

8. TERM: TERMINATION: The term of this Agreement shall continue unless terminated in accordance with this Section. We may terminate this Agreement at any time upon default by you of the license provisions of this Agreement, or any other material default by you of this Agreement not cured with thirty-30 days after written notice thereof. You may terminate this Agreement any time by terminating use of the System. Except for the first sentence of Section 2 ("License") and for Section 4(a) ("Limited Warranty"), this Agreement shall survive termination of this Agreement. Upon any such termination, you shall certify in writing such termination and non-use to us.

9. EXPORT CONTROL: You agree that the Products and Software will not be shipped, transferred, or exported into any country or used in any manner prohibited by the United States Export Administration Act or any other export laws, restrictions, or regulations (the "Export Laws"). You will indemnify, defend and hold us harmless from any and all claims arising therefrom or relating thereto. In addition, if the Products or Software are identified as export controlled items under the Export Laws, you represent and warrant that you are not a citizen, or otherwise located within, an embargoed nation including without limitation Iran, Iraq, Syria, Sudan, Libya, Cuba, North Korea, and Serbia and that you are not otherwise prohibited under the Export Laws from receiving the Software. All rights to the Products and Software are granted on condition that such rights are forfeited if you fail to comply with the terms of this Agreement.

10. U.S. GOVERNMENT RIGHTS: The Software and the Documentation which we supply to you could be "Commercial Items", as defined at 48 C.F.R. §2.101, consisting of "Commercial Computer Software" and "Commercial Computer Software Documentation," as such terms are used in 48 C.F.R. §§2.101 and 48 C.F.R. §227.702, as applicable. Consistent with 48 C.F.R. §§2.101 and 48 C.F.R. §§227.702-1 through 227.702-4, as applicable, the Commercial Computer Software and Commercial Computer Software Documentation are being licensed to U.S. Government as end users (i) only as Commercial Items and (ii) with only those rights as are granted to all other end users pursuant to the terms and conditions herein. HENRY C. SIMONSON, JR., NOVEMBER 1ST, 1989, 95134 USA.

11. GENERAL: You shall not assign, delegate or sublicense your rights or obligations under this Agreement, by operation of law or otherwise, without our prior written consent, and any attempt without such consent shall be void. Subject to the preceding sentence, this Agreement binds and benefits permitted successors and assigns. This Agreement is governed by California law, without regard to its conflicts of law principles. The United States Code of Administrative Contracts for the International Sale of Goods is disclaimed. If any claim arises out of this Agreement, the parties hereby submit to the exclusive jurisdiction and venue of the federal and state courts located in Santa Clara County, California. In addition to any other rights or remedies, we shall be entitled to injunctive and other equitable relief, without posting bond or other security, to prevent any material breach of this Agreement. We may change the terms, conditions and pricing relating to the future licensing of our Systems and other intellectual property rights, including this Agreement,
from time to time. No waiver will be implied from conduct or failure to enforce rights nor effective unless in a writing signed on behalf of the party against whom the waiver is asserted. If any part of this Agreement is found unenforceable, the remaining parts will be enforced to the maximum extent permitted. There are no third-party beneficiaries to this Agreement. We are not bound by additional and/or conflicting provisions in any order, acceptance, or other correspondence unless we expressly agree in writing. This Agreement is the complete and exclusive statement of agreement between the parties as to its subject matter and supersedes all proposals or prior agreements, verbal or written, advertising, representations or communications concerning the System.

Every reasonable attempt has been made to comply with all licensing requirements for all components used in the system. Any oversight is unintentional and will be remedied if brought to the attention of Harmonic at support@harmonicinc.com.

Documentation Conventions

This guide may use some special symbols and fonts to call your attention to important information. The following symbols appear throughout this guide:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="danger.png" alt="DANGER" /></td>
<td>The Danger symbol calls your attention to information that, if ignored, can cause physical harm to you.</td>
</tr>
<tr>
<td><img src="caution.png" alt="CAUTION" /></td>
<td>The Caution symbol calls your attention to information that, if ignored, can adversely affect the performance of your Harmonic product, or that can make a procedure needlessly difficult.</td>
</tr>
<tr>
<td><img src="laser_danger.png" alt="LASER DANGER" /></td>
<td>The Laser symbol and the Danger alert call your attention to information about the lasers in this product that, if ignored, can cause physical harm to you.</td>
</tr>
<tr>
<td><img src="note.png" alt="NOTE" /></td>
<td>The Note symbol calls your attention to additional information that you will benefit from heeding. It may be used to call attention to an especially important piece of information you need, or it may provide additional information that applies in only some carefully delineated circumstances.</td>
</tr>
<tr>
<td><img src="important.png" alt="IMPORTANT" /></td>
<td>The Important symbol calls your attention to information that should stand out when you are reading product details and procedural information.</td>
</tr>
<tr>
<td><img src="tip.png" alt="TIP" /></td>
<td>The Tip symbol calls your attention to parenthetical information that is not necessary for performing a given procedure, but which, if followed, might make the procedure or its subsequent steps easier, smoother, or more efficient.</td>
</tr>
</tbody>
</table>

In addition to these symbols, this guide may use the following text conventions:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Typed Command</td>
<td>Indicates the text that you type in at the keyboard prompt.</td>
</tr>
<tr>
<td><code>&lt;Ctrl&gt;</code>, <code>&lt;Ctrl&gt;</code>+&lt;Shift&gt;</td>
<td>A key or key sequence to press.</td>
</tr>
<tr>
<td>Links</td>
<td>The <em>italics in blue</em> text to indicate Cross-references, and hyperlinked cross-references in online documents.</td>
</tr>
<tr>
<td>Bold</td>
<td>Indicates a button to click, or a menu item to select.</td>
</tr>
<tr>
<td>ScreenOutput</td>
<td>The text that is displayed on a computer screen.</td>
</tr>
<tr>
<td>Emphasis</td>
<td>The <em>italics</em> text used for emphasis and document references.</td>
</tr>
</tbody>
</table>

**NOTE:** You require Adobe Reader or Adobe Acrobat version 6.0 or later to open the PDF files. You can download Adobe Reader free of charge from www.adobe.com.
# Contents

**Introduction** ........................................................................................................... 1  
Spectrum System Documentation Suite ................................................................. 2  
  Locating the Latest Documentation on the Harmonic Website ......................... 3  
Technical Support .................................................................................................... 3  
  Useful Information when Contacting Technical Support ................................. 3  

**Chapter 1: Installation and Configuration Overview** .......................... 5  
Spectrum X and ChannelPort Installation Overview ........................................... 5  
Spectrum X and ChannelPort System Configuration Overview ...................... 5  
  Determining a Port Number ............................................................................... 6  
  Verifying and Creating the Graphics Directory on the Video Server ............. 7  

**Chapter 2: Installing and Using the Template Authoring Package** 10  
About the Template Authoring Package ............................................................... 10  
Installing the Template Authoring Package ......................................................... 10  
About Creating Templates ..................................................................................... 11  
  Supported File Types ......................................................................................... 11  
  Template Raster Sizes ....................................................................................... 12  
  About Blank Harmonic Templates .................................................................. 12  
  About Sample Harmonic Templates ................................................................. 12  
  About Harmonic Widgets .................................................................................. 23  

**Chapter 3: Using Harmonic Templates** ...................................................... 25  
Getting Started with Harmonic Templates .......................................................... 25  
  Using a Blank Harmonic Template ................................................................. 25  
  Using a Sample Harmonic Template ................................................................ 26  
Applying a Widget to Your Flash Project .............................................................. 27  
  Customizing the Widget’s ActionScript ............................................................. 28  
Working with Harmonic Text Field Widgets ...................................................... 28  
  Resizing Dynamic Text Fields ........................................................................ 28  
  Naming Multiple Instances of a Dynamic Text Field ...................................... 29  
Using the Harmonic Advanced Text Widgets ..................................................... 30  
Configuring Three-Point Animations ................................................................. 31  
About Dynamically Loading Files in a Template .............................................. 33  
Using the Harmonic Live Audio Voiceover Template ....................................... 34  
About Open Caption Templates ......................................................................... 35  

**Chapter 4: Using Custom Templates** ......................................................... 36  
Setting Up a Custom Template ............................................................................. 36  
  Configuring Flash Professional ........................................................................ 36  
  Applying ActionScript Code to the Custom Template ...................................... 38  
  Customizing ActionScript Code ...................................................................... 40  
Adding an Event Listener for Accessing Flash Stage Properties ...................... 41
Contents

Applying a Widget to Your Flash Project ....................................................... 41
  Customizing the Widget’s ActionScript ................................................... 42
Using the Harmonic Advanced Text Widgets .............................................. 43
About Controlling the MovieClip Timeline ............................................... 44
Customizing a Text Field Template ........................................................ 44
Setting Up Multiple, Unique Text Fields ..................................................... 45
  Reconfiguring the Text Field Widget Properties ....................................... 45
  Copying a Reconfigured Text Field Widget for Additional Instances ........... 46
About Dynamically Loading Files in a Template ........................................ 48

Chapter 5: Creating Flash Videos and .mp4 (MPEG-4) Files ....................... 49
Creating a Flash Video File with Alpha .................................................... 49
  Creating a Flash Video File with Alpha Using Adobe Media Encoder .......... 49
  Creating a Flash Video File with Alpha Using Adobe After Effects ............ 52
Creating an .mp4 (MPEG-4) File ............................................................... 56
  Creating an .mp4 (MPEG-4) File Using Adobe Media Encoder ................. 57
  Creating an .mp4 (MPEG-4) File Using Adobe After Effects .................. 59

Chapter 6: Creating .zip Files .................................................................... 63
Creating .zip Files for Playback on Spectrum X or ChannelPort ................ 63
  Supported File Types .............................................................................. 63
  Important Notes about Creating .zip Files ............................................. 63
  Creating a .zip File Playlist ................................................................. 64
Loading a .zip file on the Spectrum X or ChannelPort .............................. 64
Limitations when Working with .zip Files .................................................. 65

Chapter 7: DVE Authoring ........................................................................ 66
Harmonic DVE Template Overview ............................................................ 66
Understanding Harmonic DVE Templates .................................................. 67
  About the Blank Harmonic DVE Template ............................................ 67
  About the Blank Harmonic Dual DVE Template .................................... 68
  About DVE Layers .................................................................................. 68
  Src Region Layer ................................................................................... 69
  Dst Region Layer ................................................................................... 70
Using the Blank Harmonic DVE Template ............................................... 72
Using the Blank Harmonic Dual DVE Template ........................................ 75
Viewing DVE Templates ........................................................................... 80
Configuring Additional DVE Template Properties .................................... 80
  Editing ActionScript to Control DVE Properties .................................. 80
  About the enable Property ...................................................................... 82
  About the srcSelect Property ............................................................... 82
  About the enableHPT Property ............................................................. 83
  About the dveBlendMode Property ........................................................... 84
  About the stackPos Property .................................................................. 85
  About the relativePos Property ............................................................. 85
Creating a Border on a DVE ..................................................................... 86
Creating a Full-screen Slate Reveal ............................................................ 86
Contents

Using Audio Duck and Mix Widgets in a Dual DVE Template ......................... 87

Chapter 8: Creating a Monitor Out Template ........................................... 89
  Setup ......................................................................................... 89
  Class Structure ........................................................................ 89
  Customizing the Timecode ...................................................... 90
  Customizing Everything Else .................................................. 90

Chapter 9: Using External Key/Fill ....................................................... 92
  About External Key/Fill ........................................................... 92
    About Key/Fill Templates and Module Inputs .......................... 92
  Using External Key/Fill ............................................................ 93
  Key/Fill Limitations, Restrictions, and Notes ............................ 94

Chapter 10: Independent Branding ...................................................... 95
  About Independent Branding .................................................... 95
  Naming Primary and Secondary Templates ............................... 95

Chapter 11: Authoring Guidelines ....................................................... 97
  Performance Guidelines Overview ............................................ 97
    About the Flash Renderer Types .......................................... 97
  Performance Considerations .................................................. 97
    Graceful Degradation ......................................................... 98
    Gradient Fills ...................................................................... 98
    Static Bitmap ...................................................................... 99
    Embedded Video .................................................................. 99
    Text .................................................................................... 99
    About the Pixel Area of a Template ..................................... 100
  Audio Performance ............................................................... 100
  Best Practices for Great Performance ...................................... 101
  Troubleshooting Tips .............................................................. 101
    Encountering Problems when Loading Graphic Templates ..... 101
    Encountering Problems when Playing Graphic Templates .......... 102

Appendix A: Contacting the Technical Assistance Center ................. 104
Introduction

Congratulations on choosing a Spectrum Integrated Channel Playout Platform. Spectrum X™ and ChannelPort™ ensure the cost-effective deployment of new SD and HD television channels by integrating branding and master control switching with clip playback in a device that is fully compatible with all Spectrum components. Spectrum X and ChannelPort fit seamlessly into existing production and playout infrastructures, reducing complexity and cutting the time it takes to launch new services. Rich multilayer graphics, digital video effects, and dynamic text can be layered over programming, and support for a broad range of automation systems, as well as Emergency Alert System (EAS) support, offers you the freedom to employ the workflow of your choice.

This document provides the following in-depth information for using the Spectrum X and ChannelPort:

- Introduction (this section) provides the following topics:
  - Spectrum System Documentation Suite
  - Technical Support
- Chapter 1, Installation and Configuration Overview provides instructions for installing and configuring your Spectrum X or ChannelPort.
- Chapter 2, Installing and Using the Template Authoring Package provides an overview and instructions for installing and using the Harmonic Template Authoring Package.
- Chapter 3, Using Harmonic Templates provides instructions for working with sample Harmonic templates to play on your Spectrum X or ChannelPort.
- Chapter 4, Using Custom Templates provides instructions for creating custom templates to play on your Spectrum X or ChannelPort.
- Chapter 5, Creating Flash Videos and .mp4 (MPEG-4) Files provides instructions for creating templates encoded as .flv and .mp4 files.
- Chapter 6, Creating .zip Files provides instructions for creating bundled .zip files that can be played on your Spectrum X or ChannelPort.
- Chapter 7, DVE Authoring provides instructions and other guidelines for authoring DVE templates to be played on your Spectrum X or ChannelPort.
- Chapter 8, Using External Key/Fill provides an overview of how files located in the Template Authoring Package can be used to enable External/Key Fill inputs on your Spectrum X or ChannelPort.
- Chapter 9, Independent Branding provides an overview of the Independent Branding feature.
- Chapter 10, Authoring Guidelines provides guidelines for authoring graphics to play on your Spectrum X or ChannelPort.

For information on installing and using the template authoring tools, please refer to the Spectrum X and ChannelPort Tools User Guide.
Spectrum System Documentation Suite

The table below describes the documents which comprise the Spectrum System Documentation Suite.

<table>
<thead>
<tr>
<th>This document...</th>
<th>Provides this information...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spectrum System Installation Guide</td>
<td>• System installation</td>
</tr>
<tr>
<td></td>
<td>• Software installation and upgrade details</td>
</tr>
<tr>
<td></td>
<td>• Orientation to system components</td>
</tr>
<tr>
<td></td>
<td>• Troubleshooting system components</td>
</tr>
<tr>
<td></td>
<td>• Specifications for system components</td>
</tr>
<tr>
<td>Spectrum Component Replacement Guides</td>
<td>Component replacement instructions for Spectrum devices</td>
</tr>
<tr>
<td>Spectrum Quick Reference Guides and the Spectrum MediaDeck Installation Guide</td>
<td>• Front and back panel views of Spectrum devices</td>
</tr>
<tr>
<td></td>
<td>• LED assignments and legends</td>
</tr>
<tr>
<td></td>
<td>• Quick start steps</td>
</tr>
<tr>
<td>Spectrum X and ChannelPort Tools User Guide</td>
<td>• Using FXTool and PreviewTool</td>
</tr>
<tr>
<td>Polaris Play: Playlist User Guide</td>
<td>• Polaris Play: Playlist Control Overview</td>
</tr>
<tr>
<td></td>
<td>• Using Polaris Play: Scheduler</td>
</tr>
<tr>
<td></td>
<td>• Using Polaris Play: Playlist</td>
</tr>
<tr>
<td>Spectrum X and ChannelPort Template Authoring Guide</td>
<td>• Spectrum X and ChannelPort template authoring</td>
</tr>
<tr>
<td>Spectrum Release Notes</td>
<td>Last minute information regarding a product release</td>
</tr>
<tr>
<td>Spectrum Media and Wrapper Formats</td>
<td>Supported clip types and wrapper formats</td>
</tr>
<tr>
<td>Spectrum MediaDeck 7000 Read Me First</td>
<td>• Passwords for downloading MediaDeck and SystemManager files</td>
</tr>
<tr>
<td></td>
<td>• Instructions for obtaining and installing the license file for SystemManager</td>
</tr>
<tr>
<td></td>
<td>• Installation overview</td>
</tr>
<tr>
<td>Spectrum System Protocol Reference Guide</td>
<td>• Command sets and preroll parameters for controlling Spectrum servers</td>
</tr>
<tr>
<td></td>
<td>• The Harmonic implementation of FTP server</td>
</tr>
</tbody>
</table>

All items are packaged in self-extracting files and available for download from the Harmonic website. Contact Harmonic Technical Support for login information.

Spectrum documents are in .pdf and are packaged in Spectrum-v<version#>-Documentation.exe.

- **Release Notes**: Spectrum_v.x.x.x_ReleaseNotes.pdf
- **All other components of the Spectrum System Documentation Suite**: MediaDeckAndSpectrum-v.x.x.x-Documentation.exe
For Spectrum X and ChannelPort templates, tools, and documentation, as well as Polaris Play: Playlist Control tools and documentation: HarmonicTemplatesAndTools-v.x.x.x-SWandDoc.exe.

SystemManager documents are packaged SystemManager-v.x.x.x-Documentation.exe.

Acrobat® Reader® is needed to view the product documentation. Download this for free from: http://www.adobe.com

Locating the Latest Documentation on the Harmonic Website
The latest documentation can be found at http://www.harmonicinc.com/documents-detail.

Technical Support
For information on contacting Harmonic Technical support, refer to Appendix A, Contacting the Technical Assistance Center.

Useful Information when Contacting Technical Support
In order to assist Harmonic Technical Support, review the following information:

- **What version of firmware is installed on your system?**
  From the SystemManager Home tab, click the Upgrade Firmware icon in the left-hand column to display the Upgrade Firmware page. The firmware version for each device is shown in the Current Firmware Version column.

- **What version of SystemManager software is installed?**
  From SystemManager, click the Help tab. The version is shown in the Server Software section of the page.

- **Which Windows operating system is running on the SystemManager client PC?**
  a. From Windows, click the Start button, and then click Run.
  b. In the Open field, type: winver, and then press Enter to open the About Windows dialog box, which shows the version number.

- **How much memory is installed on the SystemManager platform?**
  You can find the amount memory in the System Properties dialog. For example, in Windows 7:
  a. Click the Start button.
  b. Right-click Computer.
  c. Select Properties.
  c. In the System section, next to Installed memory (RAM), you can see the amount of RAM your computer has.

- **Please provide the manager.oda file from the SystemManager platform or client PC**
  Harmonic Technical Support may request that you email the manager.oda file, which contains configuration information for your system. This file is located on the SystemManager platform at D:\Omneon\Manager\omdb, or if you are using a client PC with a single C: partition, it will be in the same directory on the C: drive.

- **What is the model and serial number of the hardware involved?**
  Log in to SystemManager to find the following information.
For Spectrum and MediaDeck devices: from the **Home** tab, click the **Upgrade Firmware** icon in the left-hand column to display the **Upgrade Firmware** page. Both MediaDirectors and MediaDecks are listed in the **MediaDirectors** section. Find the Model Numbers and Serial Numbers listed in their respective columns.

Scroll down to the **MediaPorts** section to view the Model Numbers and Serial Numbers for MediaPorts and MediaDeck Modules.

For Omneon MediaGrid Devices: Click the **Servers & Switches** icon in the left-hand column. From the Servers and Switches page, in the **Name** column, click the link for the Omneon MediaGrid device to open the **Properties** page for that device.

For ProXchange devices: Click the ProXchange Servers icon in the left-hand column. From the **Servers** page, in the **Name** column, click the link for the ProXchange device to open the **Properties** page for that device.

For ProBrowse devices: Click the ProBrowse Servers icon in the left-hand column. From the **Servers** page, in the **Name** column, click the link for the ProBrowse device to open the **Properties** page for that device.

For MAS devices: Click the MAS Servers icon in the left-hand column. From the **Servers** page, in the **Name** column, click the link for the MAS device to open the **Properties** page for that device.

**For Spectrum Systems**

- **What is the name of the Player that is being used?**
  
  From SystemManager, click the **Player Configuration** link in the left-hand column, and then click the name of the MediaDirector or MediaDeck. The **Player List** page for that device appears. The names and status of all players are listed.

- **What file format and bit rate is the Player configured for? (for example, MPEG, DV, or IMX?)**
  
  a. From SystemManager, click the **Player Configuration** link in the left-hand column, and then click the name of the MediaDirector or MediaDeck. The **Player List** page for that device appears.

  b. From the player list, click the **Properties** link to view all the details for a player.

- **If the problem is related to Ingest or Playout of a clip, what is the Clip ID involved?**
  
  The clip name or clip ID should be indicated by whatever software application you are using to play or record video. For Omneon ClipTool, clip names are displayed in the clip management area of the ClipTool main window.

- **What brand of Automation, if any, is being used for control?**

- **Is the Automation using VDCP or API for communication control?**
Chapter 1
Installation and Configuration Overview

Spectrum X and ChannelPort Installation Overview

For information on installing a Spectrum X as part of a Spectrum System, refer to the Spectrum System Installation Guide.

The ChannelPort module can be installed in a MediaDeck 7000 or a MediaPort 7000. When the ChannelPort module is installed in a MediaDeck 7000 or a MediaPort 7000, it can be connected to an automation system and an Emergency Alert system (EAS).

For information on installing a ChannelPort module in a MediaDeck 7000, refer to the MediaDeck 7000 User Guide. For information on installing a ChannelPort module in a MediaPort 7000 as part of a Spectrum System, refer to the Spectrum System Installation Guide.

Spectrum X and ChannelPort System Configuration Overview

Harmonic recommends that you configure your system in the following order:

1. **System**: If you wish to enable Enhanced Channel mode on your Spectrum X or ChannelPort, do so before configuring your channels. Otherwise, the ChannelPort will operate in Standard Channel mode. See “Enabling Enhanced Channel Mode” in the Harmonic SystemManager User Guide.

2. **Channel**: Configure the basic parameters for your Spectrum X or ChannelPort channel, including master control switcher settings, audio profiles, independent branding, or serial port settings required for automation. See “Configuring a Spectrum X or ChannelPort Channel” and “Configuring an Audio Profile” in the Harmonic SystemManager User Guide for more information.

3. **Player**: See “Player Configuration” in the Harmonic SystemManager User Guide for help with configuring a player. Note that if you wish to use Playlist Control for player control, configure your player to use “Harmonic Playout” for control.

4. **Graphics**: Make sure your graphic templates follow Harmonic guidelines so they can be played on the Spectrum X or ChannelPort. See the Spectrum X and ChannelPort Template Authoring Guide. Configure FXTool if you plan to use it. See the Spectrum X and ChannelPort Tools User Guide (this guide).

5. **Playlist Control**: Configure any features and tools that you wish to use. For help with configuring the Playout Channel, Traffic and Billing, or Polaris Play: MediaFetch, see “Video Server Services Configuration” in the Harmonic SystemManager User Guide. For information on creating and monitoring playlists with Polaris Play: Scheduler and Polaris Play: Playlist, see the Polaris Play: Playlist User Guide. For information on configuring PreviewTool, refer to the Spectrum X and ChannelPort Tools User Guide (this guide).

6. **GPIO**: If using GPIO, configure the Spectrum X or ChannelPort GPIO triggers and then map them to channel events or Playout Channel events. See “Configuring GPIO Triggers” in the Harmonic SystemManager User Guide.

7. **EAS**: If using an EAS, make sure the Spectrum X or ChannelPort is connected to the EAS as described in the installation instructions, and then configure the EAS settings. See “Configuring a Spectrum X or ChannelPort Channel” in the Harmonic SystemManager User Guide.
Determining a Port Number

If you are using a Spectrum X or ChannelPort to preview graphics with FXTool or using it with an automation system, you will need to identify the port number for the channel you wish to use. Note that FXTool and automation systems use different protocols—FXTool uses “Network Automation” and most automation systems use “Serial Automation.” Refer to Table 1–1 to identify the necessary port for use with FXTool or automation.

If you are using a Spectrum X, or a ChannelPort in a system with a MediaCenter or MediaDirector, you can find the port number in SystemManager: Navigate to the Properties page for your video server, and then scroll down to the Private Ethernet Interfaces section to view the “com” label for the associated Ethernet port. For details, refer to “Private Ethernet Interfaces” in the SystemManager User Guide. If your ChannelPort module is connected to a Spectrum MediaDeck 7000, the module on the left (when looking from the back) is com 0, and the module on the right is com 1.

Each Spectrum X and ChannelPort module supports two channels (A and B). Once you know the Ethernet port that the device is connected to, and the channel that you will be using, refer to Table 1–1.

Table 1–1: Spectrum X and ChannelPort Port Numbers

<table>
<thead>
<tr>
<th>Module IP</th>
<th>Channel</th>
<th>Port Number for FXTool</th>
<th>Port Number for Automation</th>
</tr>
</thead>
<tbody>
<tr>
<td>com 0</td>
<td>A</td>
<td>9100</td>
<td>9000</td>
</tr>
<tr>
<td>com 0</td>
<td>B</td>
<td>9101</td>
<td>9001</td>
</tr>
<tr>
<td>com 1</td>
<td>A</td>
<td>9102</td>
<td>9002</td>
</tr>
<tr>
<td>com 1</td>
<td>B</td>
<td>9103</td>
<td>9003</td>
</tr>
<tr>
<td>com 2</td>
<td>A</td>
<td>9104</td>
<td>9004</td>
</tr>
<tr>
<td>com 2</td>
<td>B</td>
<td>9105</td>
<td>9005</td>
</tr>
<tr>
<td>com 3</td>
<td>A</td>
<td>9106</td>
<td>9006</td>
</tr>
<tr>
<td>com 3</td>
<td>B</td>
<td>9107</td>
<td>9007</td>
</tr>
<tr>
<td>com 4</td>
<td>A</td>
<td>9108</td>
<td>9008</td>
</tr>
<tr>
<td>com 4</td>
<td>B</td>
<td>9109</td>
<td>9009</td>
</tr>
<tr>
<td>com 5</td>
<td>A</td>
<td>9110</td>
<td>9010</td>
</tr>
<tr>
<td>com 5</td>
<td>B</td>
<td>9111</td>
<td>9011</td>
</tr>
<tr>
<td>com 6</td>
<td>A</td>
<td>9112</td>
<td>9012</td>
</tr>
<tr>
<td>com 6</td>
<td>B</td>
<td>9113</td>
<td>9013</td>
</tr>
<tr>
<td>com 7</td>
<td>A</td>
<td>9114</td>
<td>9014</td>
</tr>
<tr>
<td>com 7</td>
<td>B</td>
<td>9115</td>
<td>9015</td>
</tr>
<tr>
<td>com 8</td>
<td>A</td>
<td>9116</td>
<td>9016</td>
</tr>
<tr>
<td>com 8</td>
<td>B</td>
<td>9117</td>
<td>9017</td>
</tr>
<tr>
<td>com 9</td>
<td>A</td>
<td>9118</td>
<td>9018</td>
</tr>
</tbody>
</table>
Table 1–1: Spectrum X and ChannelPort Port Numbers

<table>
<thead>
<tr>
<th>Module IP</th>
<th>Channel</th>
<th>Port Number for FXTool</th>
<th>Port Number for Automation</th>
</tr>
</thead>
<tbody>
<tr>
<td>com 9</td>
<td>B</td>
<td>9119</td>
<td>9019</td>
</tr>
<tr>
<td>com 10</td>
<td>A</td>
<td>9120</td>
<td>9020</td>
</tr>
<tr>
<td>com 10</td>
<td>B</td>
<td>9121</td>
<td>9021</td>
</tr>
<tr>
<td>com 11</td>
<td>A</td>
<td>9122</td>
<td>9022</td>
</tr>
<tr>
<td>com 11</td>
<td>B</td>
<td>9123</td>
<td>9023</td>
</tr>
<tr>
<td>com 12</td>
<td>A</td>
<td>9124</td>
<td>9024</td>
</tr>
<tr>
<td>com 12</td>
<td>B</td>
<td>9125</td>
<td>9025</td>
</tr>
<tr>
<td>com 13</td>
<td>A</td>
<td>9126</td>
<td>9026</td>
</tr>
<tr>
<td>com 13</td>
<td>B</td>
<td>9127</td>
<td>9027</td>
</tr>
<tr>
<td>com 14</td>
<td>A</td>
<td>9128</td>
<td>9028</td>
</tr>
<tr>
<td>com 14</td>
<td>B</td>
<td>9129</td>
<td>9029</td>
</tr>
<tr>
<td>com 15</td>
<td>A</td>
<td>9130</td>
<td>9030</td>
</tr>
<tr>
<td>com 15</td>
<td>B</td>
<td>9131</td>
<td>9031</td>
</tr>
</tbody>
</table>

Verifying and Creating the Graphics Directory on the Video Server

The graphics directory (gfx.dir) is where you store the graphic templates you have authored. Spectrum X and ChannelPort are configured to look for a folder called “gfx.dir” in your video server file system when it retrieves graphic templates for preview or play.

Verifying the Graphics Directory on the Video Server

With software release 7.1.0.0, gfx.dir is created automatically in the video server file system when a Spectrum X or ChannelPort is installed in a Spectrum system.

If you want your graphics directory to have a name other than “gfx.dir,” refer to Renaming the Graphics Directory Folder (Optional) for instructions.

Creating the Graphics Directory on the Video Server

With software release 7.0.0.0, gfx.dir is not created automatically in the video server file system. You must manually create gfx.dir in your file system.

To create gfx.dir:
1. From SystemManager, click the Disk Utilities icon in the left-hand column to open the Disk Utilities page.
2. From the Disk Utilities page, click the hyperlink for your video server to open the corresponding Disk Utilities page.
3. In the Logical View area, click Explore Filesystemfile://..., as shown in Figure 1–1.
4. When prompted, enter the user name and password for your video server file system. The root directory of the video server file system will appear in a new Explorer window.

**NOTE:** If the root directory does not appear or a message appears indicating the browser is unable to connect, you may need to add the IP address of your SystemManager to the list of trusted sites in Internet Explorer.

- From Internet Explorer, click **Tools > Internet Options > Security > Trusted Sites** > **Sites** to open the **Trusted sites** dialog box.
- In the **Add this website to the zone** field, enter your SystemManager IP address (preceded by “http://”), and then click **Add**.
- Click **Close** and then click **OK**. Retry the Explore Filesystem link.

5. Using Windows Explorer, create a new folder named *gfx.dir* on the root directory of the file system.
Renaming the Graphics Directory Folder (Optional)

If you wish to name the graphics directory something other than gfx.dir, you must modify the properties page for each channel to direct it to the new location for your graphic templates.

To configure the new graphics directory folder name in SystemManager:

1. Click the Configuration tab to display the Configuration page and System Diagram.
2. Click the link or icon for your ChannelPort or Spectrum X to open the Properties page.
3. Click the Configure Channel A button to open the properties page for that channel.
4. In the Effect Configuration area, locate the Effects Folder field, and type the new name of the graphics directory.
5. Click Apply, and then click Done.
6. On the Properties page, click Configure Channel B, and repeat Step 4 and Step 5.
Chapter 2
Installing and Using the Template Authoring Package

This chapter includes the following sections:

- About the Template Authoring Package
- Installing the Template Authoring Package
- About Creating Templates

About the Template Authoring Package

The Template Authoring Package contains all the files you need to make the graphics you author playable on the Spectrum X or ChannelPort. The Template Authoring Package can be downloaded as a .zip file at https://harmonic.force.com/SWAccess/SWDownloadLogin

**IMPORTANT:** The templates and files included in the Spectrum template authoring package are examples only, and are provided as is. Harmonic assumes no responsibility or liability if the provided templates do not work as expected in expanded workflows.

The Template Authoring Package contains the following folders:

- **External-key-fill**: Contains the external Key/Fill files (extkeyfill.ekf), graphics assets that, when loaded onto a layer, enable the playout of Key/Fill input. For information on using the external Key/Fill feature, refer to Chapter 9, Using External Key/Fill.
- **Project**: Contains the ActionScript files written by Harmonic that are needed to play a template.
- **Samples**: Contains the Sources folder and the Templates folder.
  - **Sources**: Contains .fla files of the sample Harmonic templates and blank Harmonic templates for each supported raster size.
  - **Templates**: Contains .swf files of the sample Harmonic templates for each supported raster size.
- **Widgets**: Contains the Harmonic Widget Library. Harmonic widgets are Flash symbols created by Harmonic for building templates. For more information, refer to About Harmonic Widgets.

Installing the Template Authoring Package

For ease of use, Harmonic recommends that you store the Template Authoring Package in the same location you store your Flash projects.

**To install the Template Authoring Package:**

1. Navigate to https://harmonic.force.com/SWAccess/SWDownloadLogin
2. Enter your credentials to log in.
3. Navigate to the Spectrum downloads page, and download Spectrum-v8.1.0.0-Software.zip.
Along with Spectrum firmware, the ChannelPortTemplatesAndTools-v8.1.0.0-SWandDoc.exe contains the Harmonic Template Authoring Package and installers for the FXTool and FXTool Help and PreviewTool and PreviewTool Help. Refer to the Spectrum X and ChannelPort Tools User Guide for more information on installing FXTool and PreviewTool.

4. Unzip the Harmonic-template-authoring.zip file, and set a destination path on your computer.

The destination path can be any location from which you want to work (for example, C:\Users\<yourname>\Desktop\ChannelPortProjects\Harmonic-template-authoring).

NOTE: You will need to access the Project folder in the Template Authoring Package throughout the procedures in this guide.

About Creating Templates

The Template Authoring Package contains blank Harmonic .fla files and sample Harmonic .fla files for each supported raster size. Refer to Getting Started with Harmonic Templates in Chapter 3, Using Harmonic Templates for more information about using Adobe® Flash® Professional CS6 to turn a Harmonic .fla file into a .swf file that will play on the Spectrum X or ChannelPort. If you want to create a custom .swf file that does not use one of the Harmonic .fla files, you must first properly configure Flash Professional and the ActionScript settings for your project. Refer to Setting Up a Custom Template in Chapter 4, Using Custom Templates for more instructions.

Spectrum X and ChannelPort also support graphic templates encoded as Flash Video (.flv) files with alpha (transparency) and MPEG-4 (.mp4) files using Adobe Media Encoder CS6 or Adobe After Effects® CS6. Refer to Chapter 5, Creating Flash Videos and .mp4 (MPEG-4) Files for more information.

Supported File Types

Spectrum X and ChannelPort support the following file types:

Bundled Files

Spectrum X and ChannelPort will play out files bundled in a .zip file. For more information, refer to Chapter 6, Creating .zip Files.

Graphics

- .swf (Shockwave Flash Movie)
- .flv (Flash Video)
- .mp4 (MPEG-4)
- .png (Portable Network Graphic)
- .jpg/.jpeg (Joint Photographic Experts Group)
- .tga (Targa Graphic)
- .gif (Graphical Interchange Format)
- .bmp (Bitmap Image)
- .tif/.tiff (Tagged Image File)

NOTE: JPEG file compression and planar formats within .tif files are not supported.
Audio

- .wav (Waveform Audio File Format)
- .aiff (Audio Interchange File Format)

**NOTE:** Playback of audio embedded in a .swf file is not supported.

For best performance, Harmonic recommends the following audio settings: 48 kHz, 24-bit, up to 16 channels.

Template Raster Sizes

The blank .fla files, blank .swf files, sample Harmonic .fla files, and Harmonic .swf files are available in the following raster sizes:

- 1080p60, 1920X1080
- 1080p50, 1920X1080
- 1080i60, 1920x1080
- 1080i50, 1920x1080
- 720p60, 1280x720
- 720p50, 1280x720
- 625-16x9, 1024x576
- 625-4x3, 768x576
- 525-16x9, 864x486
- 525-4x3, 648x486

**NOTE:** With Spectrum 8.0 and later, it is possible to load templates with raster sizes that are smaller than the full screen resolution and position them on the screen using the Oxtel command Set Image Position (G).

About Blank Harmonic Templates

You should use a blank Harmonic template to create a project from scratch. A blank Harmonic template is a .fla file that has already been configured with the necessary ActionScript settings but contains no objects on the Flash stage. After you copy a blank .fla file to the Project folder in the Template Authoring directory, you can open it in Flash Professional and edit, or add visual elements to, the template, and then publish it as a .swf file that can be played on the Spectrum X or ChannelPort. A blank template is provided for each supported raster size.

About Sample Harmonic Templates

The Sources folder, located in the Template Authoring Package, contains the sample Harmonic .fla files described in this section. After you copy a sample .fla file to the Projects folder, you can publish it in Flash as a .swf file and then play it. Each sample Harmonic .fla file is available in each raster size supported by Spectrum X and ChannelPort.
Dual DVE Side-by-Side Template

The following sample Harmonic template contains the Harmonic Dual DVE Component widgets and a .jpeg image file for the background. For a complete overview and instructions on creating DVE templates, refer to Chapter 7, DVE Authoring.

The Dual DVE Side-by-Side Template begins with a full-screen video, and then “squeezes” the video back toward the left side of the screen. As the video is “squeezed” back, a blue background image appears, and a second DVE is introduced from the bottom right-hand side of the screen.

*Figure 2–1* shows the Dual DVE Side-by-Side template with the DVEs in place.

Figure 2–1: Dual DVE Side-by-Side Template

The Dual DVE Side-by-Side template contains several layers of Flash animation, as shown in *Figure 2–2*

![Flash Layers](image)

Figure 2–2: Dual DVE Side-by-Side Flash Layers

DVE Squeezeback Template

The following sample Harmonic template contains the Harmonic DVE widgets and a graphics folder that contains several .png files and a collection of movie clips. For a complete overview and instructions on creating DVE templates, refer to Chapter 7, DVE Authoring.
The DVE Squeezeback template begins with a full-screen video, and then “squeezes” the video back toward the top-left portion of the screen. As the video is “squeezed back” a border and the Harmonic logo slide in to frame the video.

*Figure 2–3* shows a 1280x720 video affected by the sample Harmonic DVE Squeezeback Template.

![DVE Squeezeback Template](image)

*Figure 2–3: DVE Squeezeback Template*

The DVE Squeezeback template contains several layers of Flash animation, as shown in *Figure 2–6*.

![DVE Squeezeback Flash Layers](image)

*Figure 2–4: DVE Squeezeback Flash Layers*

**Dynamic Text Field Templates**

The following sample Harmonic templates contain Harmonic Text Field widgets that can be updated after the template has been loaded on the Spectrum X or ChannelPort. Refer to *Working with Harmonic Text Field Widgets* in *Chapter 3, Using Harmonic Templates* for more information on Dynamic Text fields.

- Dynamic Text Banner

  *Figure 2–5* shows the second text field of the Dynamic Text Banner (or Now, Next, Later) template.
The Dynamic Text Banner template contains several layers of Flash animation, as shown in Figure 2–6.

Figure 2–6: Dynamic Text Banner Flash Layers

- Full-page Dynamic Text Banner

Figure 2–7 shows the Full-Page Dynamic Text Banner template. This template contains multiple instances of the Harmonic Text Field widget and uses a .jpeg image file for the background. Refer to Naming Multiple Instances of a Dynamic Text Field for more information on working with multiple instances of the Harmonic Text Field widget.
In the Full-page Dynamic Text Banner template, the dynamic text field containing the time animates from the left, and the dynamic text field animates from the right.

The Full-page Dynamic Text Banner template contains several layers of Flash animation, as shown in Figure 2–8.

Countdown Template

The following sample Harmonic template contains the Harmonic Text Field widget and the Harmonic Countdown widget. After the template is loaded a numeric value, in seconds, can be entered in the text field of the template. When the countdown is complete, the template will hide its contents.
Figure 2–9: Countdown Template

The Countdown template contains several layers of Flash animation, as shown in Figure 2–10.

Figure 2–10: Countdown Template Flash Layers

Regulatory Templates

The following sample Harmonic templates are regulatory templates that contain a single .png image file that has been placed on the Flash stage. Each regulatory template uses only one static layer in Flash.

Figure 2–11 shows the TV-Y template.
In addition to the TV-Y template, the Template Authoring Package contains the following regulatory templates:

- Closed Captioning
- TV-14
- TV-MA
- E/I (Educational and Informational)

**Emergency Alert System (EAS) Templates**

The following sample Harmonic templates are EAS templates that contain the Harmonic TextScroll Widget. Each regulatory template uses only one static layer in Flash. For more information on connecting a Spectrum X or ChannelPort to an EAS, refer to “Connecting a ChannelPort or Spectrum X to an Emergency Alert System” in the *MediaDeck 7000 User Guide* and the *Spectrum Installation Hardware and Reference Guide*.

*Figure 2–12* shows the EAS Warning template.
In addition to the EAS Warning template, the Template Authoring Package contains the following EAS templates:

- EAS Watch
- EAS Advisory

**NOTE:** EAS templates are placed on graphics layer 8 (the highest layer) to ensure they are not obscured by other graphics. If your Spectrum X or ChannelPort is configured to support an EAS, do not use layer 8 for other graphics. Refer to *Spectrum X and ChannelPort Tools User Guide* for instructions on previewing graphics.

**Pillar Boxes Template**

The following sample Harmonic template is a Pillar Boxes template that contains two .png image files (one for the left side and one for the right side of the screen) that have been manipulated on the Flash stage. The pillar box template uses one static layer in Flash.

*Figure 2–13* shows the Pillar Boxes template.
Logo Loop Templates

The Template Authoring Package contains two examples of the Logo Loop template. One Logo Loop template contains a Flash video, and the other contains a sequence of .png image files that have been placed on the Flash stage. The logo loop template uses one layer of animation in Flash.

*Figure 2–14* shows a Logo Loop template in which the blue animation that traces the letters of the Harmonic logo has been captured toward the end of the loop.

*Figure 2–14: Logo Loop Template*

When played, the animation will continue to loop until it is stopped.
Three-point Animation Template

The following sample Harmonic template is a Three-point Animation template that contains a Flash video. To create a loop on a three-point animation template, refer to *Configuring Three-Point Animations* for instructions.

The Three-point Animation template has an intro section, a loop section, and an outro section that display the following animations:

1. The laser animation slides in from the right of the screen.
2. When the laser animation reaches the left boundary of the template, it reverses its direction, and the Harmonic logo appears on the screen.
3. The laser animation slides in from the right of the screen again. When it reaches the left boundary of the template, it reverses direction, and the Harmonic logo disappears from the screen.

*Figure 2–15* shows the Three-point Animation template in the second part of its animation.

![Image of a bird in flight](image)

*Figure 2–15: Three-Point Animation Template*

The Three-Point Animation template contains several layers of Flash animation, as shown in *Figure 2–16*.

![Image of Flash layers](image)

*Figure 2–16: Three-Point Animation Flash Layers*
RSS News Ticker

The following sample Harmonic template is a RSS News Ticker template that contains the Harmonic Clock widget, the Harmonic Text Scroll widget, and a static .png image file that have been placed on the Flash stage.

You can update the text field of the RSS News Ticker template when you preview the template using FXTool or Preview Tool. Refer to the Spectrum X and ChannelPort Tools User Guide for further instructions.

*Figure 2–17* shows the RSS News Ticker sample template.

![RSS News Ticker Template](image)

*Figure 2–17: RSS News Ticker Template*

The RSS News Ticker template contains several layers of Flash animation, as shown in *Figure 2–18*.

![RSS News Ticker Flash Layers](image)

*Figure 2–18: RSS News Ticker Flash Layers*

Live Audio Voiceover Template

The Harmonic live audio voiceover template contains the Harmonic Live Audio Voiceover widget. This template is intended for use only with live audio voiceover and not with recorded audio. When this template is faded up, it allows the input of the AES channel to supersede any other audio that is active on the Spectrum X or ChannelPort.

The audio voiceover template may be used in conjunction with the Harmonic EAS templates.
About Harmonic Widgets

The Harmonic Template Widget Library contains Flash symbols created by Harmonic that can be added to Flash projects.

Once the widget is in your Flash project library, it can be dragged onto the stage and manipulated in your project. For example, you can re-size the widget or change its font, text size, or text color.

After you save your project in the Project folder in the Template Authoring Package, you can edit the ActionScript code of the widget to customize its behavior.

Refer to Applying a Widget to Your Flash Project in Chapter 3, Using Harmonic Templates for instructions on using Harmonic widgets.

Harmonic Clock

The Harmonic Clock widget contains ActionScript code that will update the clock accordingly once it is placed in a Flash project.

Harmonic Text Field

The Harmonic Text Field widget contains Actionscript code that allows the text field to be updated dynamically (for example, via an automation system) when the template is running on a Spectrum X or ChannelPort. Refer to Working with Harmonic Text Field Widgets in Chapter 3, Using Harmonic Templates for more information.

Harmonic Text Scroll

The Harmonic Text Scroll widget contains the same ActionScript code as the Harmonic Text Field widget, but also contains Actionscript that scrolls the text across the text field. The speed and orientation of this scroll (right-to-left, left-to-right) can be controlled through the ActionScript code.

Harmonic Advanced Text Field and Advanced Text Scroll

The Harmonic Advanced Text Field and Advanced Text Scroll widgets should be used for languages that contain complex characters or right-to-left or bi-directional text. These widgets contain ActionScript code that supports Adobe’s Text Layout Framework. Refer to Using the Harmonic Advanced Text Widgets in Chapter 3, Using Harmonic Templates for more information.

Harmonic Countdown

The Harmonic Countdown widget contains ActionScript code that allows a text field to be updated (for example, via an automation system) with a numeric value, in seconds, that will countdown to zero when the template is loaded, and the layer is faded up.

Refer to Customizing the Widget’s ActionScript in Chapter 3, Using Harmonic Templates or Customizing the Widget’s ActionScript in Chapter 4, Using Custom Templates.

IMPORTANT: Editing the ActionScript is an advanced procedure, and errors could make the template incapable of being played. Some widgets contain commentary for editing the ActionScript code correctly.

Harmonic Voiceover

This widget contains ActionScript code that controls the live audio voiceover mixer.
Harmonic DVE Components

Located inside the DVE Components folder, these DVE widgets contain ActionScript code that provides various functionality for the DVE template. For a complete overview and instructions on creating DVE templates, refer to Chapter 7, DVE Authoring.

Harmonic DVE Src Preview Region

This widget contains ActionScript code that represents the input to the DVE in the Flash Desktop environment.

Harmonic DVE Src Region

This widget contains ActionScript code that controls the crop functionality of the DVE.

Harmonic DVE Dst Region

This widget contains ActionScript code that controls the scale and position functionality the DVE.

Harmonic DVE Audio Duck Level and Audio Mix Level

These widgets contain ActionScript code that maps the audio duck level and audio mix level of a DVE, in decibels, to the alpha value of the widget. When used in conjunction, the Audio Duck Level widget can be used to lower the background audio of the DVE, and the Audio Mix Level widget can be used to raises new audio to the DVE.

When an audio widget is applied to a template, the decibel level is controlled by the alpha settings of the widget. Refer to the following table:

<table>
<thead>
<tr>
<th>Alpha Value</th>
<th>Decibel (dB)</th>
<th>Audio Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>0.0</td>
<td>-100 dB</td>
<td>no volume</td>
</tr>
<tr>
<td>0.5</td>
<td>-50 dB</td>
<td>low volume</td>
</tr>
<tr>
<td>1.0</td>
<td>0 dB</td>
<td>full volume</td>
</tr>
</tbody>
</table>

Versions of the widgets are also available for Dual DVE templates. For example instructions on using these widgets in a dual DVE template, refer to Using Audio Duck and Mix Widgets in a Dual DVE Template.

Dual DVE Components

The Dual DVE Components folder contains two additional folders: one folder with DVE widgets for DVE 0, and one folder with DVE widgets for DVE 1. These DVE widgets contain Actionscript code that provides functionality for the Dual DVE template. For a complete overview and instructions on creating DVE templates, refer to Chapter 7, DVE Authoring.
Chapter 3
Using Harmonic Templates

This chapter includes the following sections:

- Getting Started with Harmonic Templates
- Applying a Widget to Your Flash Project
- Working with Harmonic Text Field Widgets
- Using the Harmonic Advanced Text Widgets
- Configuring Three-Point Animations
- About Dynamically Loading Files in a Template
- Using the Harmonic Live Audio Voiceover Template
- About Open Caption Templates

Getting Started with Harmonic Templates

You can use the blank Harmonic .fla files or the sample Harmonic .fla files to author graphics in Adobe® Flash® Professional CS6. When you begin a new project with a blank Harmonic .fla file or a sample Harmonic .fla file, you must copy the .fla file to the Project folder in the Template Authoring Package. The Project folder contains the necessary ActionScript code that allows your project to be played.

NOTE: Before you start a project using Harmonic templates, please read Chapter 11, Authoring Guidelines for information on authoring graphics that play correctly.

If you wish to create a custom template that does not use one of the Harmonic .fla files, please refer to Chapter 4, Using Custom Templates for instructions.

Using a Blank Harmonic Template

The Template Authoring Package contains blank Harmonic .fla files for building a template from scratch. After a blank Harmonic .fla file is published as a .swf file and copied to the graphics directory (gfx.dir) on the video server, it can be played on the Spectrum X or ChannelPort. Refer to About Blank Harmonic Templates in Chapter 2, Installing and Using the Template Authoring Package for more information about blank Harmonic templates.

IMPORTANT: Before using a blank Harmonic .fla file, verify your raster size and frame rate.

To use a blank template:
1. From the Template Authoring Package, open the Samples folder.
2. Open the Sources folder.
3. Open the folder for the raster size and frame rate you want to work in, and copy the blank .fla file from that folder into the Project folder.
4. In Flash Professional, open the blank .fla file you copied to the Project folder.
5. Add visual elements to the template as desired.
CAUTION: Do not use the following characters in the file name of your template: \ / " % #.

7. Click File > Publish to publish your file as a .swf file. The published .swf file will be saved in the Project folder.

8. Copy the .swf file from the Project folder to your configured graphics directory (gfx.dir by default) on the video server.

After you copy the .swf file to the graphics directory (gfx.dir) on the video server, it can be played. For information on configuring gfx.dir, refer to Verifying and Creating the Graphics Directory on the Video Server in Chapter 1, Installation and Configuration Overview.

Using a Sample Harmonic Template

The Template Authoring Package contains sample Harmonic .fla files you can view or modify for a template. After a sample Harmonic .fla file is published as a .swf file and copied to the graphics directory (gfx.dir) on the video server, it can be played. Refer to About Sample Harmonic Templates in Chapter 2, Installing and Using the Template Authoring Package for more information about sample Harmonic templates.

IMPORTANT: Before using a sample Harmonic template, verify your raster size and frame rate.

Sample Harmonic templates come in either a single file or multiple files within a folder (for example, the dynamic text field templates contain multiple files). Make sure when using a sample Harmonic template with multiple files, that all the files within the folder are copied to the Project folder in the Template Authoring Package.

To use a sample Harmonic template:

1. From the Template Authoring package, open the Samples folder.
2. Open the Sources folder.
3. Open the folder for the raster size and frame rate you want to work in, and copy the sample .fla file from that folder to the Project folder.

IMPORTANT: If the .fla file is in a folder with other files that support it, you must copy all the supporting files to the Project folder as well.

4. In Flash Professional, open the sample .fla file you copied to the Project folder.
5. View, edit, or add visual elements to the template as desired.

CAUTION: Do not use the following characters in the file name of your template: \ / " % #.

7. Click File > Publish to publish your file as a .swf file. The published .swf file will be saved to the Project folder.

8. Copy the .swf file from the Project folder to your configured graphics directory (gfx.dir by default) on the video server.

After you copy the .swf file to the graphics directory (gfx.dir) on your video server, it can be played. For information on configuring gfx.dir, refer to Verifying and Creating the Graphics Directory on the Video Server in Chapter 1, Installation and Configuration Overview.
Applying a Widget to Your Flash Project

The Harmonic Template Widget Library contains Flash symbols created by Harmonic that can be added to Flash projects.

Refer to About Harmonic Widgets in Chapter 2, Installing and Using the Template Authoring Package for more information about the Harmonic Template Widget Library.

To apply a widget to an existing project:

1. Click File > Open and open the Template Authoring Package.
2. Open the Widgets folder, and open the HarmonicTemplateWidgetLibrary.
3. In Flash, if the Library tab is not available, click Window > Library.
4. Select the Library tab.
5. Select HarmonicTemplateWidgetLibrary.fla from the library drop-down menu, as shown in Figure 3–1.

![Figure 3–1: Library Tab Drop-Down Menu](image)

6. Copy the Harmonic widget you need from the Widget Library.
7. Open the Library drop-down menu to open your Flash project library.
8. Paste the Harmonic widget into your Flash project library.

Once the widget is in your Flash project library, it can be dragged onto the stage and manipulated in your project. For example, you can re-size the text field widget or change its font, text size, and text color.


**CAUTION:** Do not use the following characters in the file name of your template: \ / " % #.

10. Click File > Publish to publish your file as a .swf file.

    The published .swf file will be saved to the Project folder.

11. Copy the .swf file from the Project folder to your configured graphics directory (gfx.dir by default) on the video server.

After you copy the .swf file to the graphics directory (gfx.dir) on your video server, it can be played on the Spectrum X or ChannelPort. For information on configuring gfx.dir, refer to Verifying and Creating the Graphics Directory on the Video Server in Chapter 1, Installation and Configuration Overview.
Customizing the Widget's ActionScript

After you save your Flash project in the Project folder in the Template Authoring Package, the ActionScript code that controls the widget can be edited to customize the behavior of the widget.

NOTE: Your Flash project must be saved in the Project folder in order to edit the ActionScript.

To edit the Widget's ActionScript:
1. In your Flash project, if the Library tab is not available, click Window > Library.
2. Select the Library tab.
3. Right-click the widget, and select Edit Class.

An ActionScript file will appear that can be manipulated as needed.

IMPORTANT: Editing the ActionScript is an advanced procedure, and errors could make the template incapable of being played. Some widgets contain commentary for editing the ActionScript code correctly.

Working with Harmonic Text Field Widgets

Please note the following about working with Harmonic text field widgets:

- Size the text field to match the longest text string you expect that field to display.
- You must embed any fonts you intend to use in your Flash project. This will ensure that they render correctly.
- You can add filters, such as a drop shadow, but be aware that these filters may cause the template to have a longer render time as the filters render.
- The internal text field of the text field widget has an instance name of “harmonicTextField,” as shown in Figure 3–2. Do not change this instance name or the text field type (for example, Classic Text, Dynamic Text). If you do, the widget will not function correctly.

Resizing Dynamic Text Fields

The Harmonic Dynamic Text Field widget is a Flash MovieClip that contains a 100 × 100 text field. To change the size of a dynamic text field, you must open the MovieClip and edit the width and height of the contained text field. If you edit the size of the container MovieClip instead of the text field, Flash will stretch the rendered fonts and thus distort your graphic.

To edit a text field within a MovieClip:
1. Set up your Flash project. Refer to Getting Started with Harmonic Templates and Applying a Widget to Your Flash Project for instructions.
2. Drag the Harmonic Text Field widget to the stage.
3. Select the widget, and select the Properties tab, as shown in Figure 3–2.
4. In the properties dialog box, resize the text field as needed.

**IMPORTANT:** Always edit the internal text field to set the size of the dynamic text field. Always edit the container MovieClip component to set the position of the text field and to use it in motion tweens.

**Naming Multiple Instances of a Dynamic Text Field**

In some cases, you may have several instances of the same dynamic text field template in use in one project (for example, a Now, Next, and Later template). Any time you have multiple instances of the same dynamic text field in use in one project, you need to give each instance of the text field its own name.

All dynamic text fields must have an instance name that adheres to the following rules:

- The instance name for each field must start with the word, “field.”
- The instance name must be followed by a number that indicates the box number for the field.
- Optionally, you can include a label in the instance name to help identify the field. Add an underscore (_) after the number, and then enter the label text.

The following example shows a valid template field instance name:

`field3_Later`

**To name a text field:**

1. Set up your Flash project. Refer to *Getting Started with Harmonic Templates* and *Applying a Widget to Your Flash Project* for instructions.

**NOTE:** The Template Authoring Package contains a sample dynamic text field template in the Sample templates folder.

2. Drag the Harmonic Text Field widget to the stage.
3. Click the widget, and select Properties.
4. In the Instance field, type in the new instance name. Follow the supplied conventions to name the instance.
5. Repeat Step 2 to Step 4 to name additional instances of the Harmonic TextField widget used in your project.

Using the Harmonic Advanced Text Widgets

The Harmonic Advanced Text widgets should be used for languages that contain complex characters or right-to-left or bi-directional text.

The Harmonic Template Widget Library contains two Advanced Text widgets—the Harmonic Advanced Text Field and the Harmonic Advanced Text Scroll. These widgets can replace the regular text field or text scroll widgets in any Harmoninc template that uses a text field or text scroll widget.

**IMPORTANT:** Before using a sample Harmonic template, verify your raster size and frame rate.

To use a Harmonic Advanced Text widget in a Harmonic template:

1. Set up your Flash project. Refer to Getting Started with Harmonic Templates for instructions.

**IMPORTANT:** If the .fla file is in a folder with other files that support it, you must copy all the supporting files to the Project folder as well.

2. Open the Widget Library and copy the Harmonic Advanced Text widget you want to use to your project library. Refer to Applying a Widget to Your Flash Project for instructions.

3. In the Flash timeline, unlock the layer containing the text scroll, and select the text scroll widget on the Flash stage.

4. Click Window > Properties, and in the Properties dialog box, click Swap.

5. In the Swap Symbol dialog box, select the Harmonic Advanced Text widget, and click OK, as shown in Figure 3–3.

![Figure 3–3: Swapping the Widget](image)

6. On the Flash stage, resize the Harmonic Advanced Text Widget as needed.

7. Click File > ActionScript Settings to display the Advanced ActionScript 3.0 Settings dialog box.

8. Click the Library path tab.

9. In the Runtime Shared Library Settings area, from the Default Linkage drop-down menu, select Merged into code, as shown in Figure 3–4.
1. Save your file.

CAUTION: Do not use the following characters in the file name of your template: \ / " % #.

11. Click File > Publish to publish your file as a .swf file.

   The published .swf file will be saved to the Project folder.

12. Copy the .swf file from the Project folder to your configured graphics directory (gfx.dir by default) on the video server.

After you copy the .swf file to the graphics directory (gfx.dir) on your video server, it can be played on the Spectrum X or ChannelPort. For information on configuring gfx.dir, refer to Verifying and Creating the Graphics Directory on the Video Server in Chapter 1, Installation and Configuration Overview.

Configuring Three-Point Animations

You can design templates to have an intro section, a loop section, and an outro section (in other words, a three-point animation). The template will play the intro and then stay on the loop section until it receives a command to play the outro. To enable this functionality, you must provide the following frame labels in Flash:

- A frame label called “loop start” on the first frame of the looped section.
- A frame label called “loop end” on the last frame of the looped section.

To set up three-point animation loop frame labels:

1. Set up your Flash project. Refer to Getting Started with Harmonic Templates for instructions.

   NOTE: The Template Authoring Package contains a sample three-point animation in the Sample templates folder.

2. Click Insert > Timeline > Layer to add a new layer to the project.
3. Double-click the new layer, and give it a title (for example, “Loop”).
4. On the first frame of the loop section (in other words, the first frame after the end of the introduction), right-click the timeline and select Insert Keyframe, as shown in Figure 3–5.
Chapter 3 Using Harmonic Templates

Configuring Three-Point Animations

Figure 3–5: Add Keyframe

5. Click Window > Properties > Label, and type “loop start” in the Name box, as shown in Figure 3–6.

Figure 3–6: Loop Start Properties

The label, “loop start,” will appear in the timeline, as shown in Figure 3–7.

Figure 3–7: Loop Start Label

6. Add a blank keyframe on the last frame of the loop section (in other words, the last frame before the start of the outro).

7. Click Window > Properties > Label, and type “loop end” in the Name box, as shown in Figure 3–8.
Chapter 3 Using Harmonic Templates

About Dynamically Loading Files in a Template

In some cases, you may want to update the text field of a template with the contents of a text file or dynamically load an image file into a template. To do so, the file must first be stored in the graphics directory (gfx.dir) on the video server.

Before the template can dynamically access such a file, the ActionScript code of the template needs to be edited. Specifically, the pseudo-directory “templates” must be prepended to the path of the file being loaded from gfx.dir.

For example, if you wanted to update the text field of a template with the contents of file named “credits.txt,” the ActionScript would need to be edited to use the path “templates/credits.txt” to load the file.

IMPORTANT: Editing the ActionScript is an advanced procedure, and errors could make the template incapable of being played. Some widgets contain commentary for editing the ActionScript code correctly.

CAUTION: Do not use the following characters in the file name of your template: \ / “ % #.

Figure 3–8: Loop End Properties

The label, “loop end,” will appear in the timeline.

8. View, edit, or add visual elements to the template as desired.


10. Click File > Publish to publish your file as a .swf file.

   The published .swf file will be saved to the Project folder.

11. Copy the .swf file from the Project folder to your configured graphics directory (gfx.dir by default) on the video server.

After you copy the .swf file to the graphics directory (gfx.dir) on your video server, it can be played on the Spectrum X or ChannelPort. For information on configuring gfx.dir, refer to Verifying and Creating the Graphics Directory on the Video Server in Chapter 1, Installation and Configuration Overview.
Using the Harmonic Live Audio Voiceover Template

The Harmonic Live Audio Voiceover template contains the Harmonic Live Audio Voiceover widget. This template is intended for use only with live audio voiceover and not with recorded audio. When this template is faded up, it allows the input of the AES channel to supercede any other audio that is active on the Spectrum X or ChannelPort.

For more information on connecting AES input or Emergency Alert System (EAS) input, refer to the Spectrum System Installation Guide.

The audio voiceover template may be used in conjunction with the Harmonic EAS templates.

IMPORTANT: Before using a sample Harmonic template, verify your raster size and frame rate.

To use the Harmonic Live Audio Voiceover template:

To use a sample Harmonic template:

1. From the Template Authoring package, open the Samples folder.
2. Open the Sources folder.
3. Open the folder for the raster size and frame rate you want to work in, and copy the sample live-audio-voiceover .fla file from that folder to the Project folder.
4. In Flash Professional, open the live-audio-voiceover .fla file you copied to the Project folder.
5. Save your file.

NOTE: When the Live Audio Voiceover template is open in Flash Professional, you will see a graphic, as shown in Figure 3–9. When the template is loaded, it will be transparent.

Figure 3–9: Harmonic Live Audio Voiceover Template

6. Click File > Publish to publish your file as a .swf file.

The published .swf file will be saved to the Project folder.

7. Copy the .swf file from the Project folder to your configured graphics directory (gfx.dir by default) on the video server.

After you copy the .swf file to the graphics directory (gfx.dir) on your video server, it can be loaded on the Spectrum X or ChannelPort and control the AES input or be used in conjunction with an EAS template.

If you do not want to use the Harmonic Live Audio Voiceover template, but want to use the Live Audio Voiceover widget, follow the steps in Applying a Widget to Your Flash Project.
About Open Caption Templates

With Spectrum 7.6 and later, Harmonic provides support for playing out open captions on the ChannelPort. In addition, Harmonic provides sample open caption templates, as .swf files, and the source code, as .fla files, for each template.

Once you have installed the template authoring package (see Installing the Template Authoring Package), locate the Harmonic-provided open caption templates here:

Harmonic-template-authoring.zip\samples\templates\anysize\OpenCaptions

Inside this folder you will find .swf files, which are open caption templates for various languages.

Locate the source code for the open caption templates here:

Harmonic-template-authoring.zip\samples\sources\anysize\OpenCaptions

Inside each sub-folder you will find .fla files, which are the sources for the open caption templates.
Setting Up a Custom Template

If you want to create a custom template that does not use one of the Harmonic .fla files included in the Template Authoring Package, you must first properly configure Adobe® Flash® Professional CS6 and the ActionScript settings for your custom project. If your custom project does not contain the necessary ActionScript code, you will not be able to play it on the Spectrum X or ChannelPort.

**NOTE:** Before you start a project using a custom template, please read Chapter 11, Authoring Guidelines for information on authoring graphics that play correctly.

**IMPORTANT:** In order to play your custom template, you must first properly configure Flash Professional and the ActionScript settings for your project. Follow the procedures in this section in order. The Spectrum X or ChannelPort will not play a custom template that is not properly configured.

Configuring Flash Professional

Spectrum X and ChannelPort support .swf files that are compatible with Flash Player 10.3. When starting a new project, you need to configure Flash Professional to support Flash Player 10.3 as well as ActionScript 3.0.

**To configure Flash Professional:**

1. Click File > New to create a new Flash Professional project. The New Document dialog box will appear.
2. Under Type, select ActionScript 3.0.
3. Set the appropriate width, height, and frame rate for the project, as shown in Figure 4–1.
4. Click OK.

NOTE: All templates should be authored at Progressive frame sizes, and the frame rate should be set to 50 or 60 frames per second. Refer to Template Raster Sizes in Chapter 2, Installing and Using the Template Authoring Package for a list of supported raster sizes.

5. Click File > Publish Settings to bring up the Publish Settings dialog box, as shown in Figure 4–2.

6. From the Player drop-down box, select Flash Player 10.3.

7. Click OK.

8. Save your project. Harmonic recommends that you save your project in the Project folder in the Template Authoring Package.

CAUTION: Do not use the following characters in the file name of your template: \ / " % #.
Applying ActionScript Code to the Custom Template

When you create a new template in Flash Professional, you create a file with the extension .fla. When you publish the .fla file, a new file is created with the extension .swf. In order for your template to be controlled by Spectrum X or ChannelPort, the .swf file needs to contain specific ActionScript code that has been written by Harmonic. This section describes how to apply the ActionScript code to your custom template.

To apply ActionScript code to the .fla file:

1. In Flash Professional, select File > ActionScript Settings to display the Advanced ActionScript 3.0 Settings dialog box.
2. In the Document Class field, type SampleHarmonicTemplate, as shown in Figure 4–3.
3. Select the Source path tab, and click the Browse to Path icon to browse to the location (folder) where you saved your template, and select that location (folder).

**NOTE:** Harmonic recommends that you save your project in the Project folder in the Template Authoring Package.

The file name extension will appear, as shown in Figure 4–3.

4. Select the Library path tab, and click the Add New Path icon, as shown in Figure 4–4.
5. Click the Browse to Path icon to browse to the location (folder) where you saved your template, and select that location (folder).

The file name extension will appear, as shown in Figure 4–4.

**IMPORTANT:** Do not delete any of files already located under the Library Path. Doing so could cause the template not to play.
6. To check your settings, click the check mark icon to the right of the Document Class field. A dialog box will appear indicating that the definition of the document class was found in the correct folder, as shown in Figure 4–5.

![Figure 4–5: Definition for Class Found Dialog Box](image)

7. Before you complete your project, click File > Publish to publish your project as a .swf file.

Your published .swf file will now be a valid Harmonic template.

8. Copy the .swf file from the Project folder to your configured graphics directory (gfx.dir by default) on the video server.

After you copy the .swf file to the graphics directory (gfx.dir) on your video server, it can be played on the Spectrum X or ChannelPort. For information on configuring gfx.dir, refer to Verifying and Creating the Graphics Directory on the Video Server in Chapter 1, Installation and Configuration Overview.
Customizing ActionScript Code

In some cases, you may want your template to have customized behavior. For example, you may want the command that starts the template’s animation to trigger a customized action in the template. Implementing a customized action in a template involves the following:

- Edit the Document class field, and give it a unique name (for example, “CustomTemplate”).
- Customize the ActionScript of the “CustomTemplate” class.

To customize the ActionScript:
1. Set up your Flash project. Refer to Configuring Flash Professional and Applying ActionScript Code to the Custom Template for instructions.
2. Click File > ActionScript Settings.
3. In the Document class field, type in a new, unique name, for example “CustomTemplate,” and click the pencil icon, as shown in Figure 4–6.

![Figure 4–6: CustomTemplate Document Class](image)

5. Change the public class portion of the file to read “CustomTemplate.”
6. Change the extends portion of the file to read “HarmonicTemplate.”
7. Type in the custom functionality, as shown in Figure 4–7.

![Figure 4–7: CustomTemplate ActionScript](image)

8. Save the file as “CustomTemplate.as.”
Adding an Event Listener for Accessing Flash Stage Properties

When you load a template, the Spectrum X or ChannelPort controls when the template is added to the Flash stage. This is different from the Flash player, where the .swf file is attached to the stage immediately. Your ActionScript code cannot access properties of the stage properties, such as the width or height, until the template has been added to the Flash stage. To detect when the template has been put on the Flash stage, add an event listener to your ActionScript code.

To add an event listener:
1. Set up your Flash project. Refer to Configuring Flash Professional, Applying ActionScript Code to the Custom Template, and Customizing ActionScript Code for instructions.
2. In the ActionScript file, change the class portion of the file to read “CustomTemplate,” and change the extends portion of the file to read “SampleHarmonicTemplate.”
3. Add the event listener for accessing Flash Stage properties by extending the ActionScript code, as shown in Figure 4–8.

Applying a Widget to Your Flash Project

The Harmonic Template Widget Library contains Flash symbols created by Harmonic that can be added to template projects authored in Flash.

Refer to About Harmonic Widgets in Chapter 2, Installing and Using the Template Authoring Package for more information about the Harmonic Template Widget Library.

To apply a widget to an existing project:
1. Click File > Open and open the Template Authoring Package.
2. Open on the Widgets folder, and open the HarmonicTemplateWidgetLibrary.
3. In Flash Pro, if the Library tab is not available, click Window > Library.
4. Select the Library tab.
5. Select HarmonicTemplateWidgetLibrary.fla from the library drop-down menu, as shown in Figure 4–9.
6. Copy the Harmonic widget you need from the **Widget Library**.

7. Open the **Library** drop-down menu to open your Flash project library.

8. Paste the Harmonic widget into your Flash project library.

   Once the widget is in your Flash project library, it can be dragged onto the stage and manipulated in your project. For example, you can re-size the text field widget or change its font, text size, and text color.


   **CAUTION:** Do not use the following characters in the file name of your template: \ / " % #.

10. Click **File > Publish** to publish your file as a .swf file.

    The published .swf file will be saved to the **Project** folder.

11. Copy the .swf file from the **Project** folder to your configured graphics directory (gfx.dir by default) on the video server.

After you copy the .swf file to the graphics directory (gfx.dir) on your video server, it can be played on the Spectrum X or ChannelPort. For information on configuring gfx.dir, refer to **Verifying and Creating the Graphics Directory on the Video Server** in *Chapter 1, Installation and Configuration Overview*.

### Customizing the Widget's ActionScript

After you save your Flash project in the **Project** folder in the Template Authoring Package, the ActionScript code that controls the widget can be edited to customize the behavior of the widget.

**NOTE:** Your Flash project must be saved in the **Project** folder in order to edit the ActionScript.

**To edit the Widget's ActionScript:**

1. In your Flash project, if the **Library** tab is not available, click **Window > Library**.

2. Select the **Library** tab.

3. Right-click the widget, and select **Edit Class**.

   An ActionScript file will appear that can be manipulated as needed.
**IMPORTANT:** Editing the ActionScript is an advanced procedure, and errors could make the template incapable of being played. Some widgets contain commentary for editing the ActionScript code correctly.

### Using the Harmonic Advanced Text Widgets

The Harmonic Advanced Text widgets should be used for languages that contain complex characters or right-to-left or bi-directional text.

The Harmonic Template Widget Library contains two Advanced Text widgets—the Harmonic Advanced Text Field and the Harmonic Advanced Text Scroll. These widgets can be added to any custom template.

**IMPORTANT:** Before using a sample Harmonic template, verify your raster size and frame rate.

#### To use a Harmonic Advanced Text widget in a Harmonic template:

1. Set up your Flash project. Refer to Configuring Flash Professional and Applying ActionScript Code to the Custom Template for instructions.
2. Open the Widget Library and copy the Harmonic Advanced Text widget you want to use to your project library. Refer to Applying a Widget to Your Flash Project for instructions.
3. Drag the Harmonic Advanced Text widget to the Flash stage and manipulate it as needed.
4. Click File > ActionScript Settings to display the Advanced ActionScript 3.0 Settings dialog box.
5. Click the Library path tab.
6. In the Runtime Shared Library Settings area, from the Default Linkage drop-down menu, select Merged into code, as shown in Figure 4–10.

![Figure 4–10: ActionScript Adjustments](image)

7. Save your file.

**CAUTION:** Do not use the following characters in the file name of your template: \ / * % #.

8. Click File > Publish to publish your file as a .swf file.

   The published .swf file will be saved to the Project folder.
9. Copy the .swf file from the **Project** folder to your configured graphics directory (gfx.dir by default) on the video server.

After you copy the .swf file to the graphics directory (gfx.dir) on your video server, it can be played on the Spectrum X or ChannelPort. For information on configuring gfx.dir, refer to [Verifying and Creating the Graphics Directory on the Video Server](#) in Chapter 1, Installation and Configuration Overview.

### About Controlling the MovieClip Timeline

All Harmonic templates are derived from the Flash MovieClip class. The Spectrum X or ChannelPort controls the main timeline of a template in response to Oxtel commands. For example, after loading a template, the Spectrum X or ChannelPort stops the main timeline if the layer is invisible, and then starts the timeline once the layer starts fading in. If the template contains customized ActionScript code that tries to control the main timeline using methods such as “stop();” “play();” or “gotoAndPlay();,” Spectrum X or ChannelPort will not be able to control the timeline. This can lead to unexpected behavior, and template animations may not play correctly.

To avoid conflicts, create MovieClip objects for any animations that you wish to control from within the template. These objects have their own timelines, and their animations can be controlled through ActionScript to achieve the desired effects.

### Customizing a Text Field Template

Please note the following about working with Harmonic text field widgets:

- Size the text field to match the longest text string you expect that field to display.
- You must embed any fonts you intend to use in your Flash project. This will ensure that they render correctly.
- You can add filters, such as a drop shadow, but be aware that these filters may cause the template to have a longer render time as the filters render.

**To set up a custom text field:**

1. Set up your Flash project. Refer to Configuring Flash Professional, Applying ActionScript Code to the Custom Template, and Applying a Widget to Your Flash Project.
2. Copy the Harmonic Text Field widget from the library, and paste it into your Flash project library.
3. Rename the Harmonic Text Field widget (for example, “Custom Text Field”).
4. Open the Advanced ActionScript 3.0 Settings dialog box for “Custom Text Field” and rename the class in the Document class name (for example, “CustomTextField”).
5. Select the **Source path** tab, and click the **Browse to Path** icon to browse to the **Project** folder in the Template Authoring Package, and select that location.
6. Select the **Library path** tab, and click the **Browse to Path** icon to browse to the **Project** folder in the Template Authoring Package, and select that location.

**NOTE:** If you are storing your project file in the same location as the Harmonic Template Authoring Package, you can type a period.

Once the widget is in your Flash project library, it can be dragged onto the stage and manipulated. You can re-size the text field and change the display properties (for example the font, text size, and text color).
IMPORTANT: The internal text field has an instance name of “harmonicTextField.” Do not change this instance name or the text field type (Classic Text, Dynamic Text) because if you do, the widget will not function correctly.

Setting Up Multiple, Unique Text Fields

In some cases, you may want to set up several instances of a text field in one project but want each text field to be unique (for example, each text field needs to have a different function, shape, or font). To do this you must first reconfigure the Harmonic Text Field widget, and then copy that reconfigured widget for as many instances as you want. After you've copied the widgets, you can alter the text fields as needed.

Reconfiguring the Text Field Widget Properties

To reconfigure the widget properties:

1. Set up your Flash project. Refer to Configuring Flash Professional and Applying a Widget to Your Flash Project.
3. Select Advanced.
4. Type in a new, unique name for this symbol (for example, “CustomTextField_01”)
5. Select the Export for ActionScript check box.
6. Right-click the Class field, copy the text “SampleHarmonicTextField,” and then paste that text into the Base Class field, as shown in Figure 4–11.

Figure 4–11: Renaming the Base Class

7. In the Class field, type in a new, unique name, for example “CustomTextField_1,” and click OK.
An error message will appear indicating that a definition for the class could not be found in the class path, as shown in Figure 4–12.

Figure 4–12: No Definition for Class Found Warning

8. Click OK.

9. You will need to extend the ActionScript file for the custom template. To extend the ActionScript file:
   a. Right-click the widget symbol, and select Edit Class. An ActionScript file will appear.
   b. Edit the extends portion of the file to read, “SampleHarmonicTextField,” as shown in Figure 4–13.

   Figure 4–13: Extending the ActionScript File (Continued)

   c. Save the edited ActionScript file in the same location as your .fla file.

The widget can now be copied for additional instances.

Copying a Reconfigured Text Field Widget for Additional Instances

To copy a reconfigured widget:
1. Right-click on the reconfigured widget in the library, and select Duplicate. The Symbol Properties dialog will appear.
2. Type in a new, unique name for this symbol (for example, “CustomTextField_2”).
3. Select the Export for ActionScript check box.
4. Right-click the Class field, copy the text “SampleHarmonicTextField,” and then paste that text into the Base Class field, as shown in Figure 4–14.
5. In the Class field, type in a new unique name (for example, “CustomHarmonicTextField_2”), and click OK.

An error message will appear indicating that a definition for the class could not be found in the class path, as shown in Figure 4–15.

6. Click OK.

7. You will need to extend the ActionScript file for the custom template. To extend the ActionScript file:
   a. Right-click the widget symbol, and select Edit Class. An ActionScript file will appear.
   b. Edit the extends portion of the file to read “SampleHarmonicTextField.”
   c. Name and save the edited ActionScript file in the same location as your .fla file.

To create additional copies of the text field widget, repeat Step 1 through Step 7.

Once you have copied the number of text fields you need, the text fields can be placed on the stage and manipulated.
About Dynamically Loading Files in a Template

In some cases, you may want to update the text field of a template with the contents of a text file or dynamically load an image file into a template. To do so, the file must first be stored in the graphics directory (gfx.dir) on the video server.

Before the template can dynamically access such a file, the ActionScript code of the template needs to be edited. Specifically, the pseudo-directory “templates” must be prepended to the path of the file being loaded from gfx.dir.

For example, if you wanted to update the text field of a template with the contents of file named “credits.txt,” the ActionScript would need to be edited to use the path “templates/credits.txt” to load the file.

**IMPORTANT:** Editing the ActionScript is an advanced procedure, and errors could make the template incapable of being played. Some widgets contain commentary for editing the ActionScript code correctly.
Chapter 5
Creating Flash Videos and .mp4 (MPEG-4) Files

This chapter includes the following sections:

- Creating a Flash Video File with Alpha
- Creating an .mp4 (MPEG-4) File

In addition to supporting graphic templates that have been authored with Adobe® Flash® Professional CS6 and published as .swf files, Spectrum X and ChannelPort also support templates encoded as Flash Video (.flv) files with alpha (transparency) and MPEG-4 (.mp4) files using Adobe Media Encoder CS6 or Adobe After Effects® CS6.

Creating a Flash Video File with Alpha

You can use Media Encoder or After Effects to encode a large sequence of image files (for example, .tga files) that will be exported as a .flv file with alpha that can be played as a graphic template.

This section contains the following procedures:

- Creating a Flash Video File with Alpha Using Adobe Media Encoder
- Creating a Flash Video File with Alpha Using Adobe After Effects

Creating a Flash Video File with Alpha Using Adobe Media Encoder

1. In Media Encoder, click File > Add Source, and choose the necessary file(s) from the Open dialog box.

   NOTE: If you are adding an image sequence, in the Open dialog box, click the first file in the sequence, and select the Enable Sequence check box.

2. From the Format drop-down menu, select FLV.
3. From the Preset drop-down menu, select the appropriate resolution and frame rate, and click OK.
4. Click FLV to open the Export Settings dialog box, and in the Export Settings area, configure the following settings:
   a. Select the check box for Export Video.
   b. If you do not want to export audio with your file, clear the check box for Export Audio.
5. Make sure the check boxes for **Use Maximum Render Quality** and **Use Frame Blending** are cleared (default).

6. Select the **Filters** tab, and make sure the check box for **Gaussian Blur** is cleared (default).

7. Select the **Video** tab, and configure the following settings:
   a. Select the check box for **Encode Alpha Channel**.
   b. Make sure the check box for **Resize Video** is cleared (default) or is set to the target resolution.
   c. From the **Frame Rate** drop-down menu, select the frame rate that matches the target frame rate.
   d. Make sure the check box for **Render at Maximum Depth** is cleared (default).
8. From the Video tab, scroll down to the Bitrate Settings, and make sure the check box for VBR is selected (default).

9. From the Video tab, scroll down to the Advanced Settings, and configure the following settings:
   a. Select the check box for Set Key Frame Distance, and set the Key Frame Distance to 72.

   **NOTE:** A key frame distance of 72 frames is suitable for most videos; however, you may adjust the key frame distance based on the content of the video. For instance, for motion heavy video, a shorter key frame distance increases the visual quality. Bear in mind that a shorter key frame distance also results in a larger file size, while a longer key frame distance reduces the file size.
   
   b. Select the check box for Simple Profile.
      a. Make sure the Undershoot [% target] is set to 90 (default).
      b. From the Quality drop-down box, select Best.

10. If you want to include Audio with your file, make sure the Export Audio check box is selected, click the Audio tab, and configure the following settings.
    a. In the Basic Audio Settings area, for Output Channels, make sure Stereo is selected (default).
    b. In the Bitrate Settings area, from the Bitrate drop-down menu, select 128 (default).

11. Click OK.

12. From the Queue area, click Start Queue.
You can view the encode process from the Current Encode area.

13. When your encode is complete, copy the .flv file to your configured graphics directory (gfx.dir by default) on the video server.

After you copy the .flv file to the graphics directory (gfx.dir) on the video server, it can be played on the Spectrum X or ChannelPort. For information on configuring gfx.dir, refer to Verifying and Creating the Graphics Directory on the Video Server in Chapter 1, Installation and Configuration Overview.

Creating a Flash Video File with Alpha Using Adobe After Effects

1. In After Effects, select Composition > New Composition.
2. Select the appropriate resolution, frame rate, and duration, and click OK.

NOTE: If you are adding an image sequence, in the Open dialog box, click the first file in the sequence, and select the Enable Sequence check box.

4. In the Project area, right-click the imported sequence, and select Interpret Footage > Main to open the Interpret Footage dialog box.

5. In the Interpret Footage dialog box, make sure the field for Assume this frame rate matches the frame rate configured in Step 2.

6. Drag your new composition to the Render Queue area.

7. From the Output Module drop-down menu, select FLV with Alpha.

8. Click FLV with Alpha to open the Output Module Settings dialog box, and configure the following settings:

   a. Select the check box for Include Source XMP Metadata.

   b. If you do not want to export audio with your file, clear the check box for Audio Output.
9. In the Video Output area, from the Color drop-down menu, select Straight (Unmatted).
10. In the Video Output area, click Format Options to open the FLV Options dialog box.
11. In the Bitrate Settings area, configure the following settings:
   a. Select VBR bitrate encoding.
   b. Set the Bitrate to 5,404 kbps.

12. In the Advanced Settings area, configure the following settings:
   a. Select the check box for Set Key Frame Distance, and set the Key Frame Distance to 72.

   **NOTE:** A key frame distance of 72 frames is suitable for most videos; however, you may adjust the key frame distance based on the content of the video. For instance, for motion heavy video, a shorter key frame distance increases the visual quality. Bear in mind that a shorter key frame distance also results in a larger file size, while a longer key frame distance reduces the file size.

   b. Select the check box for Simple Profile.
   c. From the Quality drop-down menu, select Best.

13. If you want to include Audio with your file, make sure the Audio Output check box is selected, and click Format Options.
   a. Click the Audio tab.
   b. In the Bitrate Settings area, from the Bitrate drop-down menu, select 128 (default).

14. Click OK twice to close the FLV Options dialog box and the Output Module Settings dialog box.

15. Select the Render Queue tab, and double-click the Output To field to name the file.

   **NOTE:** If the Render Queue tab is not available, click Window > Render Queue. The Render Queue tab will appear at the bottom of the screen.

16. Select the Render check box for your composition, and click Render.

![](image)

**Figure 5–7: Render Check Box**

17. When your encode is complete, copy the .flv file to your graphics directory (gfx.dir by default) on the video server.

After you copy the .flv file to the graphics directory (gfx.dir) on the video server, it can be played on the Spectrum X or ChannelPort. For information on configuring gfx.dir, refer to **Verifying and Creating the Graphics Directory on the Video Server** in Chapter 1, **Installation and Configuration Overview**.
Creating an .mp4 (MPEG-4) File

The format .mp4 (MPEG-4) is a wrapper format for a video file that has been encoded with the H.264 encoding process. You can use Adobe Media Encoder CS6 or Adobe After Effects CS6 to encode a large sequence of image files (for example, .tga files) as an .mp4 file that can be played as a full-screen opaque graphic template or video.

Figure 5–8 shows a sample method of layering graphics using an .mp4 file and other template types.

![Layering .mp4 File](image-url)
This section contains the following procedures:

- Creating an .mp4 (MPEG-4) File Using Adobe Media Encoder
- Creating an .mp4 (MPEG-4) File Using Adobe After Effects

Creating an .mp4 (MPEG-4) File Using Adobe Media Encoder

1. In Media Encoder, click File > Add, and choose the necessary file(s) from the Open dialog box.

   **NOTE:** If you are adding an image sequence, in the Open dialog box, click the first file in the sequence, and select the Enable Sequence check box.

2. From the Format drop-down menu, select H.264 (Legacy).
3. Click H.264 (Legacy) to open the Export Settings dialog box, and in the Export Settings area, configure the following settings:
   a. Select the check box for Export Video.
   b. If you do not want to export audio with your file, clear the check box for Export Audio.
4. Select the Filters tab, and make sure the check box for Gaussian Blur is cleared (default).

![Export Settings Dialog Box](image)

Figure 5–9: Export Settings Dialog Box

5. Select the Multiplexer tab, and configure the following settings:
   a. From the Multiplexing drop-down menu, select MP4.
   b. From the Stream Compatibility drop-down menu, select Standard.
6. Select the Video tab, and configure the following settings:
   a. In the Basic Video Settings area, from the Profile drop-down menu, select Main.
   b. From the Level drop-down menu, select 4.1.
   c. From the Frame Rate drop-down menu, select the appropriate frame rate.
      If necessary, change the Frame Width (the Frame Height changes automatically based on your selection).
   d. Make sure the check box for Render at Maximum Depth is cleared (default).
   e. In the Bitrate Settings area, from the Bitrate Encoding drop-down menu, select VBR, 1 Pass.
   f. Set the Target Bitrate to 32 Mbps.
   g. Set the Maximum Bitrate to 40 Mbps.
   h. In the Advanced Settings area, make the check box for Set Key Frame Distance is cleared (default).
7. Click OK.

8. If you want to include Audio with your file, make sure the Export Audio check box is selected, click the Audio tab, and configure the following settings:
   a. In the Audio Format Settings area, for Audio Format, select AAC (default).
   b. In the Basic Audio Settings area, from the Codec drop-down menu, make sure AAC is selected (default).
   c. From the Output Channels drop-down menu, select Stereo (default).
   d. From the Frequency drop-down menu, select 48 kHz (for best performance).
   e. From the Audio Quality drop-down menu, select High (default).
   f. In the Bitrate Settings area, from the Bitrate drop-down menu, select 56 (default).
   g. In the Advanced Settings area, for Precendence, select Frequency (default).

9. Click OK.

10. From the Queue area, click Start Queue.

   You can view the encode process from the Current Encode area.

11. When your encode is complete, copy the MPEG-4 file to your graphics directory (gfx.dir by default) on the video server.

After you copy the MPEG-4 file to the graphics directory (gfx.dir) on the video server, it can be played on the Spectrum X or ChannelPort. For information on configuring gfx.dir, refer to Verifying and Creating the Graphics Directory on the Video Server in Chapter 1, Installation and Configuration Overview.

Creating an .mp4 (MPEG-4) File Using Adobe After Effects

1. In After Effects, select Composition > New Composition.

2. Select the appropriate resolution, frame rate, and duration, and click OK.

**NOTE:** If you are adding an image sequence, in the Open dialog box, click the first file in the sequence, and select the Enable Sequence check box.

4. In the Project area, right-click the imported sequence, and select Interpret Footage > Main to open the Interpret Footage dialog box.

5. In the Interpret Footage dialog box, make sure the field for Assume this frame rate matches the frame rate configured in Step 2.

6. Drag your new composition to the Render Queue area.

7. From the Output Module drop-down menu, select H.264.

8. Click H.264 to open the Output Module Settings dialog box, and configure the following settings:
   a. Select the check box for Include Source XMP Metadata.
   b. If you do not want to export audio with your file, clear the check box for Audio Output.
9. In the Video Output area, click Format Options to open the H.264 Options dialog box.

10. Click the Multiplexer tab, and configure the following settings:
   a. From the Multiplexing drop-down menu, select MP4 (default).
   b. From the Stream Compatibility drop-down menu, select Standard (default).
11. Click the Video tab, and configure the following settings:
   a. In the Bitrate Settings area, for Bitrate Encoding, select VBR, 1 Pass.
   b. For Target Bitrate [Mbps], select 32.
   c. For Maximum Bitrate [Mbps], select 40.

![Figure 5–15: Video Tab](image)

12. If you want to include Audio with your file, make sure the Audio Output check box is selected, and from the drop-down menu, select 48.000 KHz (for best performance).
   a. Click Format Options.
   b. In the Basic Audio Settings area, from the Codec drop-down menu, select AAC (default).
      a. From the Audio Quality drop-down menu, select High (default).
      b. In the Advanced Settings area, for Precedence, select Frequency.
13. Click OK twice to close the H.264 Options dialog box and the Output Module Settings dialog box.
14. Select the Render Queue tab, and double-click the Output To field to name the file.

**NOTE:** If the Render Queue tab is not available, click Window > Render Queue. The Render Queue tab will appear at the bottom of the screen.

15. Select the Render check box for your composition, and click Render.
16. When your encode is complete, copy the .mp4 file to your graphics directory (gfx.dir by default) on the video server.

After you copy the .flv file to the graphics directory (gfx.dir) on the video server, it can be played on the Spectrum X or ChannelPort. For information on configuring gfx.dir, refer to Verifying and Creating the Graphics Directory on the Video Server in Chapter 1, Installation and Configuration Overview.
Chapter 6
Creating .zip Files

This chapter includes the following sections:

- Creating .zip Files for Playback on Spectrum X or ChannelPort
- Loading a .zip file on the Spectrum X or ChannelPort
- Limitations when Working with .zip Files

In addition to the file types listed in Supported File Types, Spectrum X and ChannelPort also support playout of files that have been bundled in a .zip file. When packaging files in a .zip file, you can also include a playlist to specify the order in which the files will be played.

For example, if you have a .zip file that contains three .flv files—an intro, a loop, and an outro—and you want the loop to play five times before the outro is played, you can specify both the order of appearance and the number of loops in the playlist, and Spectrum X or ChannelPort will play the files accordingly.

Creating .zip Files for Playback on Spectrum X or ChannelPort

Before creating your .zip files, please review the following sections:

- Supported File Types
- Important Notes about Creating .zip Files
- Creating a .zip File Playlist

Supported File Types

The following file types can be bundled into a .zip file to be played out:

- .flv
- .mp4
- .jpeg (or .jpg)
- .bmp
- .tga
- .png
- .tiff (or .tif)

NOTE: For image files, playout is dependent on the primary video frame rate. If no play count is specified in a playlist, the image will play out at the default value—which is one full frame time.

Important Notes about Creating .zip Files

To create your .zip files, you can use any .zip file tool and any combination of the supported file types.

While you can put as many files as you want in your .zip file, Spectrum X or ChannelPort will only play the FIRST THREE files, so Harmonic recommends building .zip files with only files you want to play.
It’s also important to note that if there is no playlist specifying the order of playout, the order of playout cannot be guaranteed due to variations of bundling methods between ZIP creation tools. Essentially, your files may be rearranged when your .zip file is created, and if there is no playlist, Spectrum X or ChannelPort will play the first file it finds, which may or may not be the file you intended to play first. This may apply to the second and third files as well.

**Example .zip file**

The following is an example of the contents of a .zip file created to contain .flv files for a three-point animation and a playlist:

```
/fs0/gfx.dir/ThreePoint.zip/
    Playlist.txt
    intro.flv
    loop.flv
    outro.flv
```

**IMPORTANT:** If you choose to have each .flv in a different folder in the .zip file, be sure you include only one playlist at the top of the directory.

Harmonic also strongly recommends that if you put each file in a different folder, make sure that each file has a unique name, so the desired file plays at the appropriate time.

**Creating a .zip File Playlist**

When you create a playlist for your .zip file, you need to use the .txt file format and save the file as playlist.txt.

**IMPORTANT:** Do not use any other characters or naming conventions for the .zip file playlist. And if you include a playlist in your .zip file, make sure there is only one playlist file.

Make sure your playlist meets the following constraints:

- There should be only one line of text per file to be played.
- Each line of text contains the file name, and, if necessary, a play count descriptor (playcount (n)) or an end mode descriptor (end(still)) or (end (disappear)).
- Add a space and then two dashes between the file name and the descriptor; add a space between the descriptor and the value.
- If needed, you can comment the playlist using #.

**NOTE:** The ZIP renderer ignores case when matching file names.

The following is an example playlist, using the three-point animation example from above:

```
#this is an example playlist

intro.flv
loop.flv --playcount 5
outro.flv --end disappear
```

**Loading a .zip file on the Spectrum X or ChannelPort**

When your .zip file is ready, simply copy it to your configured graphics directory (gfx.dir by default) on your video server. (For information on configuring gfx.dir, refer to Verifying and Creating the Graphics Directory on the Video Server in Chapter 1, Installation and Configuration Overview.)
After you copy the .zip file to the graphics directory, it can be placed on any layer and played. You can preview your .zip files using FXTool or PreviewTool by loading the .zip file like any other template.

Limitations when Working with .zip Files

Please note the following limitations when creating .zip files:

- Your Spectrum X or ChannelPort only has so much memory for (pre)loaded graphics, and this total amount is shared by all layers of a given channel. The amount of memory used by a single (pre)loaded file is computed from the size of the file as it exists in the graphics directory. For .zip files, this value is based on the size of the .zip file and not the value of the unbundled files. In other words, when the files are unbundled, there may not be enough memory to play the files correctly.

- For 720p outputs, make sure any video files bundled in the .zip file have an even number of frames.
This chapter contains the following sections:

- Harmonic DVE Template Overview
- Understanding Harmonic DVE Templates
- Using the Blank Harmonic DVE Template
- Using the Blank Harmonic Dual DVE Template
- Viewing DVE Templates
- Configuring Additional DVE Template Properties
- Creating a Border on a DVE
- Creating a Full-screen Slate Reveal
- Using Audio Duck and Mix Widgets in a Dual DVE Template

Harmonic DVE Template Overview

This chapter describes how to create templates that control one or two Digital Video Effects (DVE) that can be run on the Spectrum X or ChannelPort. The templates that control the DVE(s) must be authored using Adobe® Flash® Professional CS6. Harmonic recommends starting with one of the blank Harmonic DVE templates that has been provided in the Harmonic Template Authoring Package.

NOTE: The procedures in this chapter refer to the blank Harmonic DVE and Dual DVE templates. Blank DVE templates are supplied in each frame rate and raster size in the Harmonic Template Authoring Package. For information about the Template Authoring Package, refer to Chapter 2, Installing and Using the Template Authoring Package.

A DVE is a digital video effect where the video is cropped by the SrcRegion, scaled and positioned by the DstRegion, and then composited with the underlying video.

When a DVE template is played on the Spectrum X or ChannelPort, it can contain video from a clip, the Mixer output, or an External input. When you preview your DVE templates in the desktop Flash environment, the Src Preview represents the input to the DVE.

Figure 7–1 illustrates these concepts for a single DVE.
Figure 7–1: DVE Overview

Figure 7–1 shows only a single DVE, but if your Spectrum X or ChannelPort has been configured for Enhanced Channel mode, you may have up to two DVEs loaded at once, either as two DVEs in a single template or as single DVEs in two templates. A Dual DVE template, for each frame rate and raster size, can be found in the Template Authoring Package.

NOTE: For information about configuring Enhanced Channel mode, which is a licensed feature, refer to "Enabling Enhanced Channel Mode" in the Harmonic SystemManager User Guide.

Dual DVE templates contain the same components as single DVE templates.
The Source (Src) Preview, Source (Src) Region, and Destination (Dst) Region are discussed in Understanding Harmonic DVE Templates.

Understanding Harmonic DVE Templates

The following sections explain the components of the blank Harmonic DVE and Dual DVE templates.

About the Blank Harmonic DVE Template

The blank Harmonic DVE template contains four layers in the Flash Professional timeline, as shown in Figure 7–2.

Figure 7–2: DVE Template Layers

The blank Harmonic DVE template also contains the following Harmonic DVE Template Widgets: the Harmonic DVE Src Preview Region widget, the Harmonic DVE Src Region widget, and the Harmonic DVE Dst Region widget.
About the Blank Harmonic Dual DVE Template

The blank Harmonic Dual DVE template contains several layers in the Flash Professional timeline, as shown in Figure 7–3.

![Figure 7–3: Dual DVE Template Layers](image)

The blank Harmonic Dual DVE template also contains the following Harmonic Dual DVE Template Widgets separated into folders for each DVE: the Harmonic DVE Src Preview Region widget, the Harmonic DVE Src Region widget, and the Harmonic DVE Dst Region widget.

For more information about DVE widgets and the Harmonic Template Widget Library, refer to About Harmonic Widgets in Chapter 2, Installing and Using the Template Authoring Package.

**IMPORTANT:** In order for a DVE template to run correctly, all widgets must be present in the first frame of the template.

About DVE Layers

Please read through the following sections before getting started:

- **Actions Layer**
- **Src Preview Layer**
- **Src Region Layer**
- **Dst Region Layer**

Actions Layer

The *actions* layer contains ActionScript code that controls DVE properties. These properties are discussed in detail in Configuring Additional DVE Template Properties.

For instructions on editing the *actions* layer, refer to Editing ActionScript to Control DVE Properties.

Src Preview Layer

The *src preview* layer represents the input to the DVE; in other words, it represents the video that will be affected by the DVE template. In the sample Harmonic DVE templates, the *src preview* layer is represented by a test pattern, as shown in Figure 7–4.
The input to the DVE depends on the module you are using and the channel mode you have configured. Refer to the following table:

<table>
<thead>
<tr>
<th>ChannelPort 8100 Module</th>
<th>ChannelPort 8200 Module or Spectrum X</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Standard Channel</strong></td>
<td><strong>Enhanced Channel</strong></td>
</tr>
<tr>
<td>Player</td>
<td>Player A, B</td>
</tr>
<tr>
<td>External In</td>
<td>External In 1 - 2</td>
</tr>
<tr>
<td>Mixer Output</td>
<td>Mixer Output</td>
</tr>
<tr>
<td><strong>Standard Channel</strong></td>
<td><strong>Enhanced Channel</strong></td>
</tr>
<tr>
<td>Player</td>
<td>Player A, B</td>
</tr>
<tr>
<td>External In</td>
<td>External In 1 - 6</td>
</tr>
<tr>
<td>Mixer Output</td>
<td>Mixer Output</td>
</tr>
</tbody>
</table>

For information about the DVE srcSelect Property, refer to *About the srcSelect Property*.

Since the src preview layer is a preview of the input of the DVE, its screen resolution should match the screen resolution of the stage. Note that in each blank DVE template, the src preview layer for each template is already properly configured for the corresponding raster size, and the layer is locked.

**NOTE:** In the Dual DVE template, each DVE has its own Src Preview layer.

### Src Region Layer

The src region layer represents the portion of the Src Preview that will be active in the DVE. Essentially, the Src Region is the result of the Src Preview being cropped.

**IMPORTANT:** The Src Region should never be larger than the Src Preview.

The following properties of the Src Region are used to crop the DVE:
- **x**: the x position of the crop
- **y**: the y position of the crop
- **Width**: the width of the crop region
- **Height**: the height of the crop region

These properties can be accessed by clicking **Window > Properties**, and then selecting the src region layer from the timeline.

*Figure 7–5* shows a Src Region cropped to the center 4x3 region of a 16x9 input.
Chapter 7 DVE Authoring Understanding Harmonic DVE Templates

© 2016 Harmonic Inc. All rights reserved. 70 Template Authoring Guide, Release 8.1

Figure 7–5: Cropped Src Region

For instructions on configuring the Src Region to crop a DVE, refer to Using the Blank Harmonic DVE Template.

NOTE: In the Dual DVE template, each DVE has its own Src Region layer.

Once the Src Region of the DVE is defined, it can be scaled and defined, the Dst Region can be scaled and positioned.

IMPORTANT: If your primary graphics format is NTSC, there may be closed captioning (CC) present on line 21 of SDI input or from IMX clips. The full 486 line Src Region will include these lines. To avoid including these lines in the DVE, crop off the top three lines of the source using the Src Region. Line 0 is above the CC. Line 1 corresponds to line 21, and line 2 corresponds to line 284 (CC in field 2).

To crop the top three lines of the source, in the Properties dialog box for both the Src and Dst Regions, change the y axis value to 3 and the Height value to 483.

Dst Region Layer

The dst region layer defines how Src Regions are scaled and positioned in a DVE template.

IMPORTANT: The Dst Region should never be larger than the Src Region.

The following properties of the Dst Region are used to scale and position the DVE:

- x: the x position of the scaler output
- y: the y position of the scaler output
- Width: the width of the scaler output
- Height: the height of the scaler output
- Alpha: the alpha value of the DVE

These properties can be accessed by clicking Window > Properties, and then selecting the dst region layer from the timeline.

Figure 7–6 shows the Dst Region of the 4x3 Src Region from the previous example scaled and positioned in the lower right-hand corner of the screen.

NOTE: The Dst Region layer is marked by a blue transparency. If necessary, this layer can be hidden until you are ready to use it. In the timeline, select the Dst Region layer, and click the show/hide button under the eye.
Figure 7–6: Dst Region Scaled and Positioned

For instructions on scaling and positioning the Dst Region, refer to *Using the Blank Harmonic DVE Template*.

*Figure 7–7* shows the Dual DVE Dst Regions of the 4x3 Src Region scaled and positioned in the lower corners of the screen.

**NOTE:** The Dst Region layer of DVE 0 is marked by a blue transparency; the DST Region layer of DVE 1 is marked by a green transparency. If necessary, these layers can be hidden until you are ready to use them. In the timeline, select the Dst Region layers, and click the show/hide button under the eye.

Figure 7–7: Dual DVE Dst Region Scaled and Positioned

**DVE Output in the Desktop Flash Environment**

Once the Src Region is cropped and the Dst Region is scaled and positioned, a DVE has been created. *Figure 7–8* shows the cropped, scaled, and positioned DVE from the examples above as seen in the desktop Flash environment.
Figure 7–9 shows the cropped, scaled, and positioned Dual DVEs from the examples above as seen in the desktop Flash environment.

Using the Blank Harmonic DVE Template

The Template Authoring Package contains blank Harmonic DVE .fla files you can modify for your DVE project. After a blank Harmonic DVE .fla file is published as a .swf file and copied to the graphics directory (gfx.dir) on the video server, it can be played on the Spectrum X or ChannelPort.

NOTE: The Template Authoring Package also contains sample Harmonic DVE templates you can view. Refer to About Sample Harmonic Templates in Chapter 2, Installing and Using the Template Authoring Package for more information about sample Harmonic templates.
The following procedure explains how to use a blank Harmonic DVE .fla file to crop a 16:9 image to a 4:3 image and position that on the bottom right corner of the screen, as discussed in *Understanding Harmonic DVE Templates*.

**IMPORTANT:** Before using an Harmonic template, verify your raster size and frame rate.

**To use a Blank Harmonic DVE template:**
1. From the Template Authoring Package, open the **Samples** folder.
2. Open the **Sources** folder.
3. Open the folder for the raster size and frame rate you want to work in, and copy the **blank-dve** .fla file from that folder to the **Project** folder.
4. In Flash Professional, open the **blank-dve** .fla file you copied to the **Project** folder.

**TIP:** To hide the Dst Region until you are ready to configure it, in the timeline, click the show/hide button under the eye.

5. Use the Src Region to define the crop area.
   a. In the timeline, click **src region**.
   b. On the Flash stage, select the Src Region.
   c. Click and drag the corner of the free transform box to set the 4x3 area.
6. In the timeline, for all layers, right-click the last frame of the Dual DVE transition, and select **Insert Frame**, as shown in *Figure 7–10*.

![Figure 7–10: Setting Final Frames of DVE](image)

7. In the timeline, click **dst region**.

**TIP:** If the Dst Region was previously hidden, in the timeline, click the show/hide button under the eye.

8. In the timeline of the **dst region** layer, right-click the timeline, and select **Create Motion Tween**.
9. Click and drag the blue transparency to animate, or scale and position, the Dst Region, as illustrated by *Figure 7–11*.
10. Set the animation to stop on the last frame (otherwise, the DVE transition will continually loop).
   a. In the Timeline of the actions layer, right-click the last frame and select Insert Blank Keyframe.
   b. Right-click the newly created blank keyframe and select Actions.
   c. In the ActionScript editor, on line 1, type `stop();`, as shown in Figure 7–12.
   d. Close the ActionScript editor.

11. In the Timeline of the actions layer, right-click the last frame and select Insert Blank Keyframe, as shown in

12. If you have not already done so, save your file.

13. Click File > Publish to publish your file as a .swf file.

   The published .swf file will be saved to the Project folder.

14. Copy the .swf file from the Project folder to your configured graphics directory (gfx.dir by default) on the video server to preview it using Fxtool or PreviewTool.

   **NOTE:** Unless you change the properties of the Actions layer, the DVE template will display the SDI Input the first time it is played. For instructions on changing the properties of the Actions layer, refer to Configuring Additional DVE Template Properties.
Using the Blank Harmonic Dual DVE Template

**NOTE:** To play a Dual DVE Template, your Spectrum X or ChannelPort must be configured for Enhanced Channel, which is a licensed feature. Refer “Enabling Enhanced Channel Mode” in the *Harmonic SystemManager User Guide.*

To take advantage of Dual DVE functionality, you can create two single DVE templates, and load each template on a different graphics layer to control the DVEs. To author individual DVE templates, refer to *Using the Blank Harmonic DVE Template.*

However, the Template Authoring Package contains blank Harmonic Dual DVE .fla files that you can modify to control two DVEs from a single template. After a blank Harmonic Dual DVE .fla file is published as a .swf file and copied to the graphics directory (gfx.dir) on the video server, it can be played on the Spectrum X or ChannelPort.

Dual DVE templates are available in each supported raster size and frame rate.

**NOTE:** The Template Authoring Package also contains sample Harmonic Dual DVE templates you can view. Refer to *About Sample Harmonic Templates* in Chapter 2, *Installing and Using the Template Authoring Package* for more information about sample Harmonic templates.

The following procedure explains how to use a blank Harmonic Dual DVE .fla file to create a “side-by-side” DVE effect.

**IMPORTANT:** Before using an Harmonic template, verify your raster size and frame rate.

To use a Blank Harmonic Dual DVE template:
1. From the Template Authoring Package, open the *Samples* folder.
2. Open the *Sources* folder.
3. Open the folder for the raster size and frame rate you want to work in, and copy the *blank-dual-dve* .fla file from that folder to the *Project* folder.
4. In Flash Professional, open the *blank-dual-dve* .fla file you copied to the Project folder.

   As shown in *Figure 7–13,* the timeline will contain the SrcPreview, SrcRegion, and DstRegion layers for each DVE.

   ![Figure 7–13: Dual DVE Template Layers](image)

The Dual DVE template will appear on the Flash stage, as shown in *Figure 7–14.*
5. Position the DVE 0 Dst Region off to the left side of the stage.

TIP: The DVE 0 Dst Region is marked by a blue transparency.

a. In the timeline, click dve 0 dst region.

b. On the Flash stage, select DVE 0 Harmonic Dst Region.

c. Click and drag the object to the left side of the screen.

6. Resize DVE 1 Dst Region to fill the entire Flash stage.

TIP: The DVE 1 Dst Region is marked by a green transparency.

a. In the timeline, click dve 1 dst region.

b. On the Flash stage, select DVE 1 Harmonic Dst Region.

c. In the Properties tab, set the x axis value to 0, the y axis value to 0, the width value to the horizontal size of the stage, and the height value to the vertical size of the stage. (To open the Properties tab, click Window > Properties.)

Your stage should appear as shown in Figure 7–15.
7. In the timeline, for all layers, right-click the last frame of the Dual DVE transition, and select **Insert Frame**, as shown in *Figure 7–16*.

![Figure 7–16: Inserting the DVE Transition Frames](image)

8. Create the transition for DVE 1.
   a. In the timeline of the **dve 1 dst region** layer, right-click the timeline and select **Create Motion Tween**.
   b. On the last frame, size and position the **dve 1 dst region**, as shown in *Figure 7–17*.
      
      The orange line represents the path of DVE 1.

![Figure 7–17: Positioning DVE 1 Dst Region](image)

9. Create the transition for DVE 0.
   a. In the timeline of the **dve 0 dst region** layer, right-click the timeline and select **Create Motion Tween**.
   b. On the last frame, position the **dve 0 dst region**, as shown in *Figure 7–18*.
      
      The orange line represents the path of DVE 0.
10. If you have not already done so, save your file.
11. Set the animation to stop on the last frame (otherwise, the DVE transition will continually loop).
   a. In the Timeline of the actions layer, right-click the last frame and select Insert Blank Keyframe, as shown in Figure 7–19.
   b. Right-click the newly created blank keyframe and select Actions.
   c. In the ActionScript editor, on line 1, type `stop();`, as shown in Figure 7–20.
d. Close the ActionScript editor.

12. Select the sources for each DVE.
   a. In the timeline of the actions layer, right-click the first frame and select Actions.

   ![Figure 7–21: Selecting the Actions Layer](image)

   b. In the ActionScript editor, locate the commented out ActionScript code titled DVE Source Select.
   c. Uncomment the Source Select that you want for DVE 0 and DVE 1, as shown in Figure 7–22.

   ![Figure 7–22: Uncommenting the DVE Source Select](image)

   The input to the DVE can be an External input, a clip player, or the output of the mixer.

d. Close the ActionScript editor.

13. Click File > Publish to publish your file as a .swf file.
The published .swf file will be saved to the Project folder.

14. Copy the .swf file from the Project folder to your configured graphics directory (gfx.dir by default) on the video server to preview it using FXTool or PreviewTool.

**Viewing DVE Templates**

DVE templates can be viewed using FXTool and PreviewTool. For instructions on installing, configuring, and using FXTool and PreviewTool to view templates, refer to the *Spectrum X and ChannelPort Tools User Guide*.

**NOTE:** To view Dual DVE templates, your Spectrum system must be configured for Enhanced Channel. Refer to “Enabling Enhanced Channel Mode” in the *Harmonic SystemManager User Guide*.

Before copying DVE templates to the graphics directory, DVE templates can be previewed in the Flash environment, as previously discussed in this chapter. Note that when previewed in the Flash environment, the DVE input will be represented by the test pattern of the Src Preview.

**Configuring Additional DVE Template Properties**

Harmonic DVE templates contain ActionScript code that can be edited to control various properties of the DVEs.

*Editing ActionScript to Control DVE Properties* explains how to access and edit the ActionScript code to control these properties.

The following sections provide overviews of DVE template properties:

- About the enable Property
- About the srcSelect Property
- About the enableHPT Property
- About the dveBlendMode Property
- About the stackPos Property

**Editing ActionScript to Control DVE Properties**

To edit the ActionScript code:

1. From the Template Authoring Package, open the Samples folder.
2. Open the Sources folder.
3. Open the folder for the raster size and frame rate you want to work in, and copy the blank-dve or blank-dual-dve .fla file from that folder to the Project folder.
4. In Flash Professional, open the blank-dve or blank-dual-dve .fla file you copied to the Project folder.
5. Edit your DVE template as desired.
6. In the DVE template timeline, on the actions layer, right-click the first frame, as shown in Figure 7–23.
7. Select **Actions**.

**NOTE:** You can also access the ActionScript by selecting the **actions** layer and then **Window > Actions**.

An ActionScript file will appear, as shown in *Figure 7–24*.

8. To edit a property of the DVE template, uncomment that property, as shown in *Figure 7–25*.
Figure 7–25: Editing the ActionScript to Uncomment a Property

In this example, the boolean value for enabling/disabling the DVE Hole Punch Technology (HPT) has been uncommented to "false." In this case, the HPT is disabled.

NOTE: The ActionScript code has been commented to reveal the default values for each property.

10. If you have not already done so, save your file.
11. Click File > Publish to publish your file as a .swf file.

   The published .swf file will be saved to the Project folder.
12. Copy the .swf file from the Project folder to your configured graphics directory (gfx.dir) on the video server to preview it using FXTool or PreviewTool.

About the enable Property

This DVE property is a boolean property (True or False) that enables/disables the DVE.

- **True**: the DVE is enabled.
- **False**: the DVE is disabled.

By default, this property is enabled.

About the srcSelect Property

This DVE property controls the input source of the DVE.

- **SRC_UNSPECIFIED**: the source is unspecified.
- **SRC_PLAYER**: the source is a player.
  - **SRC_PLAYER_A**: For Enhanced Channel mode, the source is Player A.
  - **SRC_PLAYER_B**: For Enhanced Channel mode, the source is Player B.
- **SRC_EXTERNAL_IN**: the source is an external input.
  - **SRC_EXTERNAL_IN_1** - **SRC_EXTERNAL_IN_6**: For an 8200 series module configured for Enhanced Channel mode, the source can be one of six external inputs.
For an 8100 series module configured for Enhanced Channel mode, the source can be one of two external inputs.

- **SRC_MIXER_OUTPUT**: the source is the mixer output.

By default, this property is set to SRC_UNSPECIFIED. However, the first time a DVE template is used, it will display an External Input.

**About the enableHPT Property**

This DVE property is a boolean property that enables/disables the DVE Hole Punch Technology (HPT).

- **True**: the DVE HPT is enabled.
- **False**: the DVE HPT is disabled.

**About enableHPT**

When a DVE template is loaded on a graphics layer, a region in all the graphics layers below that template is cleared so that the DVE can be seen. This functionality is called Hole Punch Technology (HPT).

For example, refer to Figure 7–26. If a DVE template is loaded on graphics layer 3 with HPT enabled, a transparent region will be created in graphics layer 2 and 1. Essentially graphic layers 2 and 1 will be “under” the DVE and thusly not visible. Any templates placed on graphic layers 4 through 8 will be visible “above” the DVE.

![Figure 7–26: DVE HPT Enabled](image)

By default, this property is set to “True” (enabled).
About the dveBlendMode Property

This DVE property controls how alpha is applied to the DVE.

- **BLEND_WITH_VIDEO**: the alpha value of the Dst Region is applied to the DVE and affects how the DVE blends with the underlying video.

  For example, if a DVE template is loaded on graphics layer 1, and the dveBlendMode is set to BLEND_WITH_VIDEO, the DVE will blend with the video layer. The amount of blending is dependent on the alpha value set on the Dst Region, as shown in Figure 7–27.

![Figure 7–27: DVE Blend with Video Enabled](image)

- **BLEND_WITH_GRAPHICS**: the inverse of the alpha value of the Dst Region is applied to the DVE, and the inverse of the alpha value is applied to the regions of the lower layers affected by the DVE. The DVE alpha value is set to 100% to achieve a semi-transparent DVE over graphics.

  For example, if a DVE template is loaded on graphics layer 2, and the dveBlendMode is set to BLEND_WITH_GRAPHICS, the DVE will blend with the full-screen slate loaded on graphics layer 1, and the video layer will be totally obscured. The amount of blending is dependent on the alpha value set on the Dst Region, as shown in Figure 7–28.

![Figure 7–28: DVE Blend With Graphics Enabled](image)

By default, this property is set to BLEND_WITH_VIDEO.
NOTE: To control the alpha value when authoring a DVE, click the Dst Region on the Flash stage, and then click Windows > Properties > Color Effect, and from the Style drop-down menu, select Alpha.

About the stackPos Property

This DVE property controls where the DVE is located relative to other graphics in the template.

- **AUTO_STACK_POS**: the DVE will be positioned depending on where the DST Region layer is located in the timeline of the template.
- **BOTTOM_MOST_STACK_POS**: the DVE will be positioned below all other graphics in the template. Any graphics above the DVE will be seen.
- **TOP_MOST_STACK_POS**: the DVE will be positioned above all other graphics in the template. Any graphics below the DVE will not be seen.

By default, this property is set to AUTO_STACK_POS.

For example, in the blank Harmonic DVE template, the DST Region is by default the first layer in the timeline, as shown in Figure 7–29.

![Figure 7–29: DST Region in Template Timeline](image)

If no changes are made, the DST Region will be set by the auto-stack property to the TOP_MOST_STACK_POS. If a new layer is placed above the DST Region, the DST Region will be set by the auto-stack property to the BOTTOM_MOST_STACK_POS.

The stackPos property can be used to create a border on a DVE or to create a full-screen slate reveal.

When Dual DVEs are used with other graphics in a template, and both DVEs have the same stack position (in other words, if both DVEs are above or below other graphics), the stackPos property will determine the stacking order of the DVEs in relation to the other graphics in the template.

About the relativePos Property

NOTE: This property only applies when Dual DVE templates are used with other graphics in the template, and both DVEs have the same stack position (in other words, if both DVEs are above or below other graphics in the template).

This DVE property is an integer property that defines the stacking position of a DVE relative to the other DVE in the template.
- AUTO_RELATIVE_POS: the DVEs will be positioned depending on where the DST Region layer for each DVE is located in the timeline of the Dual DVE template. For example, if the `dve 0 dst region` is above the `dve 1 dst region` in the timeline of the template, DVE 0 will be stacked above DVE 1.

- RELATIVE_POS_0: the DVE will be positioned above the other DVE in the template.

- RELATIVE_POS_1: the DVE will be positioned below the other DVE in the template.

Creating a Border on a DVE

A DVE template can be authored to contain a border around the DVE. This border graphic must be contained in a separate layer on the timeline of the DVE template. The Dst Region should be set to the bottom-most stack position. Refer to *About the stackPos Property* for more information.

**To create a border on a DVE:**

1. From the Template Authoring package, open the **Samples** folder.
2. Open the **Sources** folder.
3. Open the folder for the raster size and frame rate you want to work in, and copy the `blank-dve.fla` file from that folder to the **Project** folder.
4. In Flash Professional, open the `blank-dve.fla` file you copied to the **Project** folder.
5. Edit and animate (scale and position) the Dst Region as desired.
6. Right-click the first frame of the **actions** layer, and select **Actions**. An ActionScript file will open.
7. In the ActionScript file, uncomment the entry for `BOTTOM_MOST_STACK_POSITION`.
8. In the timeline, create a new layer above the Dst Region layer, and call it “border.”
9. Edit and animate the border to match the editing and animation of the Dst Region.
10. If you have not already done so, save your file.
11. Click **File > Publish** to publish your file as a .swf file.

The published .swf file will be saved to the **Project** folder.
12. Copy the .swf file from the **Project** folder to your configured graphics directory (`gfx.dir`) on the video server to preview it using FXTool or PreviewTool.

**TIP:** You can also create borders on the DVEs in the Harmonic Dual DVE templates. Repeat **Step 5** through **Step 9** for the second DVE.

When this DVE template is played, the border will appear above the DVE.

Creating a Full-screen Slate Reveal

A DVE template can be authored to reveal a full-screen slate. The Dst Region should be set to the top-most stack position. Refer to *About the stackPos Property* for more information.

**To create a full-screen slate reveal:**

1. From the Template Authoring package, open the **Samples** folder.
2. Open the **Sources** folder.
3. Open the folder for the raster size and frame rate you want to work in, and copy the `blank-dve.fla` file from that folder to the **Project** folder.
4. In Flash Professional, open the `blank-dve.fla` file you copied to the **Project** folder.
5. Edit and animate (scale and position) the Dst Region as desired.
6. Right-click the first frame of the actions layer, and select Actions. An ActionScript file will open.
7. In the ActionScript file, remove the comments in front of the entry for TOP_MOST_STACK_POSITION.
8. If you have not already done so, save your file.
9. Click File > Publish to publish your file as a .swf file.
   The published .swf file will be saved to the Project folder.
10. Copy the .swf file from the Project folder to your configured graphics directory (gfx.dir) on the video server to preview it using FXTool or PreviewTool.

   **IMPORTANT:** When using FXTool or PreviewTool to preview the full-screen slate reveal, place the DVE template on a layer above the full-screen slate template.

---

### Using Audio Duck and Mix Widgets in a Dual DVE Template

The following procedure explains how to use a blank Harmonic Dual DVE .fla file in conjunction with the Audio Duck and Mix widgets to create a template in which the audio can be lowered in one DVE and raised in the other.

Consider the following example:

DVE 1 is active, full-screen with audio. DVE 0 comes in from the left-side of the screen and causes DVE 1 to “squeeze back.” When DVE 0 comes in, its audio is “mixed” in, and the audio of DVE 1 is “ducked.” After a few moments, DVE 0 is “squeezed off” the screen, and DVE 1 returns to full screen. When DVE 0 is removed, its audio is “ducked,” and the audio of DVE 1 is “mixed” back in.

When an audio widget is applied to a template, the decibel level is controlled by the alpha settings of the widget. Refer to the following table:

<table>
<thead>
<tr>
<th>Alpha Value</th>
<th>Decibel (dB)</th>
<th>Audio Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>0 dB</td>
<td>full volume</td>
</tr>
<tr>
<td>0.0</td>
<td>-100 dB</td>
<td>no volume</td>
</tr>
<tr>
<td>0.5</td>
<td>-50 dB</td>
<td>low volume</td>
</tr>
</tbody>
</table>

The sample Harmonic dual-dve-side-by-side template already contains the audio widgets.

**IMPORTANT:** Before using an Harmonic template, verify your raster size and frame rate.

---

**To use a Blank Harmonic Dual DVE template:**
1. From the Template Authoring Package, open the Samples folder.
2. Open the Sources folder.
3. Open the folder for the raster size and frame rate you want to work in, and copy the blank-dual-dve .fla file from that folder to the Project folder.
4. In Flash Professional, open the blank-dual-dve .fla file you copied to the Project folder.
5. Click File > Open and open the Template Authoring Package.
6. Open the Widgets folder, and open the HarmonicTemplateWidgetItemLibrary.
   If the Library tab is not available, click Window > Library.
7. Select the Library tab, select HarmonicTemplateWidgetLibrary.fla from the library drop-down menu, as shown in Figure 7–30.

Figure 7–30: Library Tab Drop-Down Menu

8. From the Dual DVE Components folder in the Widget Library open the DVE 0 and DVE 1 folders, copy the Audio Duck and Mix Level widgets, and paste them into the corresponding folder in your Dual DVE project library.

9. Drag each audio widget for each DVE just off the Flash stage. (If you do place them on the stage, the widgets will not be displayed on the output of the Spectrum X or ChannelPort.)

10. If you want to create an audio effect (in other words, make the audio slowly fade in or out), add a new layer in the timeline and create a motion tween for the widget.

11. To set the decibel levels, adjust the alpha for each widget (refer to the table at the beginning of this procedure):
   a. Select each widget you want to adjust, and click Window > Properties.
   b. Select Color Effect, and from the Style drop-down menu, select Alpha.
   c. Set the alpha as desired.

12. Make any other changes you need, and save your work.

13. Click File > Publish to publish your file as a .swf file.

   The published .swf file will be saved to the Project folder.

14. Copy the .swf file from the Project folder to your configured graphics directory (gfx.dir) on the video server to preview it using FXTool or PreviewTool.
Chapter 8
Creating a Monitor Out Template

This chapter contains the following sections:

- Setup
- Class Structure
- Customizing the Timecode
- Customizing Everything Else

The Monitor Out feature allows you to display active player and mixer information for your channel superimposed over your primary output while playing a clean output to air over the secondary output. Monitor Out information can include details such as mixer state, player name, player state, player looping, clip name (for loaded and cued clips), time until next clip, a player preview generated by the DVE, transport status (PLAY, REW, FF, PAUSE, IDLE), and timecode.

Use the following instructions to create your own Monitor Out Template starting with the monitor-out-blank template provided in the Template Authoring package. For instructions on modifying ActionScript code, refer to Customizing ActionScript code.

Setup

To create a custom Monitor Out template:

1. Copy the contents of the samples/sources/<raster size>/MonitorOut folder to the project folder. For example: sample/sources/1080i60/MonitorOut.
2. Open the project/<raster size>-monitor-out-blank.fla in Flash Pro.
3. Save the project with a new name, for example, 1080i60-monitor-out-custom.fla.
4. Customize the template according to the instructions in this chapter.

Class Structure

Before customizing your template, familiarize yourself with the contents of the template described in this section.

The Document Class for the template is set to CustomMonitorOut. The CustomMonitorOut class is ActionScript code that defines the main document class for the template. The CustomMonitorOut class is derived from MonitorOut, which is then derived from HarmonicTemplate. The MonitorOut class code is included in with the sample, but it is not intended to be modified.

There are four functions in the CustomMonitorOut class that will need to be implemented to customize the template:

- **constructor**: Add any initialization code here to the template. This will be dependent on your customization. Make sure that the super() function is called so that base class constructors get called.
- **getTimecodeBackgroundColor**: Defines the background color of the rendered timecode. See Customizing the Timecode.
- **getTimecodeBackgroundAlpha**: Defines the background alpha of the rendered timecode. See Customizing the Timecode.
- **handleKeyValue**: This function is the main interface for handling the dynamic portion of the Monitor Out functionality. During run-time, Spectrum X or ChannelPort will send information to the template via the `updateTextField` function located in the MonitorOut base class. The base class will parse the string and separate the contents into "key/value" pairs. It will then call the overridden `handleKeyValue` function that you will need to implement. You can use the standard or enhanced channel sample templates as a starting point for understanding.

### Customizing the Timecode

In the blank template you will find a text field whose instance name is 'timecode'. The properties of this text field will describe the x, y, width, height, foreground color, foreground alpha, background color, and background alpha of the rendered timecode. This information is queried once the template is loaded by the Monitor Out feature.

To change the properties of the timecode, modify the timecode text field as follows:

- **x**: Use the Flash editor to position the text field at the desired location.
- **y**: Use the Flash editor to position the text field at the desired location.
- **width**: Use the Flash editor to set the width of the text field to the desired size.

**NOTE:** The internally rendered timecode will attempt to fill this space so what is viewed in the Flash editor will not be the same as what is rendered by the Spectrum X or ChannelPort.

- **height**: Use the Flash editor to set the height of the text field to the desired size.

**NOTE:** The internally rendered timecode will attempt to fill this space so what is viewed in the Flash editor will not be the same as what is rendered by the Spectrum X or ChannelPort.

- **foreground color**: In the Flash editor, use the Color property of the text field to set the foreground color.
- **foreground alpha**: In the Flash editor, use the Color property of the text field to set the foreground alpha.
- **background color**: To change the background color, edit the main CustomMonitorOut document class by clicking on the stage and then clicking the pencil icon on the Document class. The background color value is located in the `getTimecodeBackgroundColor` function. The return value is a 24-bit RGB value. Examples: Red = 0xFF0000, Green = 0x00FF00, Blue = 0x0000FF.
- **background alpha**: To change the background alpha, edit the main CustomMonitorOut document class by clicking on the stage and then clicking the pencil icon on the Document class. The background alpha value is located in the `getTimecodeBackgroundAlpha` function. The return value is a number: 0.0 = transparent, 1.0 = opaque

### Customizing Everything Else

To customize the rest of the functionality, please fill in the `handleKeyValue` function with the desired behavior. Spectrum X or ChannelPort will send all key/value pairs once the template is loaded. This will allow the template to be initialized to the proper state. After initialization, only changes are sent.

The Key/Value pairs are documented in the header of the MonitorOut.as file. There is a section for the Standard Channel configuration as well as the Enhanced Channel configuration. You only need to use the key/value pairs that are applicable to your configuration.
Best Practices

Follow these guidelines for best practices to customize the rest of the template:

1. Create the graphical assets inside a MovieClip (1 MovieClip for each asset).
2. Drag the movie clip onto the stage and provide it an instance name. This will allow it to be accessed from ActionScript.
3. In the CustomMonitorOut constructor:
   a. Get references to the graphical assets by using the DisplayObjectContainer::getChildByName() function. The name should be the same as the instance name provided in the step above.
   b. Store the reference in a member variable so that it can be accessed later.
   c. Set the visible property on all MovieClip objects to false. This makes all graphical assets invisible.
4. In the CustomMonitorOut::handleKeyValue() function:
   a. Create a switch statement on the 'key' MovieClip.
   b. Add code to set the visible property of the stored MovieClip objects based on the 'value' parameter.

The HarmonicMonitorOutStandard.as and HarmonicMonitorOutEnhanced.as ActionScript files can be used as a reference for implementing this scheme.
Chapter 9
Using External Key/Fill

This Chapter includes:
- About External Key/Fill
- Using External Key/Fill
- Key/Fill Limitations, Restrictions, and Notes

About External Key/Fill

Spectrum modules that have been licensed for Enhanced Channel mode support a single or dual pair of external Key/Fill inputs.

When external Key/Fill input is activated, live video content received on the external inputs of a Spectrum module can be placed on any graphics layer, and then be blended and stacked with other supported graphics content.

*Figure 9–1* provides a general overview of the Key/Fill feature. The per-pixel transparency of the Fill input is determined by the per-pixel luma of the Key input, with black corresponding to fully transparent, and white corresponding to fully opaque.

![Key/Fill Overview Diagram](image)

**Figure 9–1: Key/Fill Overview**

About Key/Fill Templates and Module Inputs

You can control external Key/Fill inputs using the Key/Fill files that are available in the Template Authoring Package. The authoring package contains three Key/Fill files:

- `extkeyfill.ekf`: does not specify an input pair; can be used on 8100 or 8200 modules. If loaded on an 8200 module, `extkeyfill.ekf` will select Key/Fill pair 1 by default.

- `extkeyfill1.ekf`: specifies Key/Fill input pair 1 on ChannelPort 8200 modules and Spectrum X; can be used on ChannelPort 8100 modules.
**extkeyfill2.ekf**: specifies Key/Fill input pair 2 on ChannelPort 8200 modules and Spectrum X.

**NOTE**: If two Key/Fill pairs are used, only one pair can be active at a time. Refer to *Key/Fill Limitations, Restrictions, and Notes* for more information.

For ChannelPort 8100 modules, Key/Fill inputs are as follows:
- **Key**: External IN 1
- **Fill**: External IN 2

For ChannelPort 8200 modules and Spectrum X, Key/Fill inputs are as follows:
- **Key 1**: External IN 1
- **Fill 1**: External IN 2
- **Key 2**: External IN 4
- **Fill 2**: External IN 5

**TIP**: Refer to the *Spectrum ChannelPort Module Quick Reference Guide*, the *Spectrum X Quick Reference Guide*, or *Spectrum System Installation Guide* for illustrations of the rear panels of the ChannelPort modules.

For more information about the Template Authoring Package, refer to *Chapter 2, Installing and Using the Template Authoring Package*.

A Key/Fill template can be loaded on any layer, with graphics above or below it, as shown in *Figure 9–2*.

**Using External Key/Fill**

**To use the external key/fill feature:**

1. Configure the Spectrum X or ChannelPort for Enhanced Channel mode. Refer to “Enabling Enhanced Channel Mode” in the *Harmonic SystemManager User Guide*. 
2. Connect external sources of Key and Fill inputs to the correct external inputs on the rear panel. (Refer to About Key/Fill Templates and Module Inputs for input assignments.)

**IMPORTANT:** The incoming video content for both Key and Fill inputs must be reference aligned and in the same video output format as the primary video output format of the Spectrum X or ChannelPort.

3. From the Template Authoring Package, open the external-key-fill folder.
4. Copy the necessary extkeyfill.ekf file, and paste it into the graphics directory on your video server (gfx.dir is the default location).
5. Using FX tool or PreviewTool, load the extkeyfill.ekf file onto any layer to preview the Key/Fill input.

**Key/Fill Limitations, Restrictions, and Notes**

- Key and Fill inputs that are not reference aligned and in the same format as the primary video output format of the Spectrum X or ChannelPort are not supported.

- For ChannelPort 8200 modules: If you have inputs on both Key/Fill pairs, and you load extkeyfill1.ekf and extkeyfill2.ekf, the Key/Fill pair on the higher layer will be the one displayed on the output of the ChannelPort. In other words, if extkeyfill1.ekf is loaded on layer 1 and extkeyfill2.ekf is loaded on layer 6, the content of pair 2 will mask the content of pair 1.

- If your Spectrum X or ChannelPort is configured for Independent Branding mode, external Key/Fill is supported on the HD output, but will not show on the SD output. (For more information about Independent Branding, refer to Chapter 10, Independent Branding.)

If it is configured for Enhanced Channel, external Key/Fill is only supported for SD formats if SD is the primary video output format, and the external Key/Fill inputs are reference aligned and in an SD format identical to the primary SD video output.

- While SD-native formats are defined by non-square pixel aspect ratios, graphics played out on your Spectrum X or ChannelPort are rendered in square-pixel resolutions. When external Key/Fill inputs are applied to SD formats, edge softening and other rendering artifacts may be visible in content that has high-frequency characteristics along the horizontal axis. These artifacts may be more visible in 16:9 SD formats than in 4:3 SD formats because of the difference in pixel aspect ratios. For best results when applying external Key/Fill content to SD formats, minimize high-frequency transitions in the Key/Fill content.
Chapter 10
Independent Branding

This chapter includes:

- About Independent Branding
- Naming Primary and Secondary Templates

About Independent Branding

Independent Branding, a licensed feature, provides the ability to separately brand a channel’s Primary and Secondary outputs. Different configurations are supported on the Spectrum X and ChannelPort.

Spectrum X supports the following configurations:

- Primary (HD) and Secondary (SD)
- Primary (HD) and Secondary (HD)
- Primary (SD) and Secondary (SD)

ChannelPort supports the following configuration:

- Primary (HD) and Secondary (SD)

Independent Branding is a feature that can be applied to either Standard or Enhanced Channel configurations.

NOTE: For information about configuring Enhanced Channel mode, which is a licensed feature, refer to “Enabling Enhanced Channel Mode” in the Harmonic SystemManager User Guide.

If properly licensed, you can enable Independent Branding using SystemManager. Refer to “Configuring a Spectrum X or ChannelPort Channel” in the Harmonic SystemManager User Guide.

Independent Branding supports all graphic template types, including DVEs. For instructions on creating templates, refer to the relevant chapter in this guide.

Naming Primary and Secondary Templates

Since it is not possible to notify a device (such as an automation system) controlling a Spectrum X or ChannelPort that Independent Branding is enabled, both versions of your templates must be saved to the graphics directory (gfx.dir by default) on your video server and must follow one of two specific naming conventions.

The naming convention you choose depends on the settings you have configured in SystemManager. There are two methods for naming assets:

- Folder method: Create a separate folder in the gfx.dir directory for secondary templates. Create a primary and secondary version of the template, and name them identically (e.g., foo.swf). Save the primary version to gfx.dir and the secondary version to the sub-folder in gfx.dir.

In the example below, gfx.dir stores primary templates (in this case, HD) and the sub-folder stores secondary templates (in this case, SD).
Basename extension method: Save both primary and secondary templates in the gfx.dir directory, but apply a basename extension to each filename to indicate which output the template will be used for.

In the example below, the basename extensions “HD1” and “HD2” indicate on which output the template is used.

/fs0/gfx.dir/
  fooHD1.swf
  fooHD2.swf
Chapter 11
Authoring Guidelines

Performance Guidelines Overview

The following sections provide guidelines and troubleshooting tips for authoring graphics that play correctly on the Spectrum X or ChannelPort.

- **Performance Considerations**
- **Best Practices for Great Performance**
- **Troubleshooting Tips**

Unlike a video clip, graphics designed to play on the Spectrum X or ChannelPort are a collection of assets and instructions, created with Adobe® Flash® Professional CS6, Adobe Media Encoder CS6, or Adobe After Effects® that are interpreted by a Flash renderer running on the Spectrum module.

When you author graphics, the “look” of an animation can be achieved with different methods, but the best method is not always obvious. Simple changes can have dramatic effects on the rendering times of your graphics.

In general, for your animation to play smoothly, your animated content should:

- render completely within a frame time, and
- maintain its frame rate over time.

About the Flash Renderer Types

The Flash renderers in a Spectrum X or ChannelPort behave differently than Flash renderers on a desktop program or browser plug-in. Desktop and browser-based Flash renderers have non-constant, wide-ranging frame rates and capabilities. The Flash renderer on a Spectrum X or ChannelPort has a stage frame rate that is strictly controlled by the field rate of the primary video format.

When authoring graphics, please note the following:

- Changing the stage frame rate within ActionScript will have no effect on the graphic when it is played.
- When the template receives the **ENTER_FRAME** event, the template will play at 59.94 Hz for 525 versions of 1080i, 720p, SD, and 16x9 SD or at 50 Hz for 625 versions of 1080i, 720p, SD, and 16x9 SD, no matter what other settings you specify in Flash Professional or in the ActionScript.

Performance Considerations

Before you author graphics, consider the following factors that will affect performance:

- The size of the screen area your animation will use
- The complexity of your animation
- The types of elements used within your animation
- Additional effects applied to elements within the animation (for example, masks, filters, or pixel benders)
When you load several layers of templates, each active layer is interpreted by independent renderers that all share access to the same CPU and memory resources. When animations on different layers have the same processing and rendering times, some layer-to-layer interference effects may be observed.

**Graceful Degradation**

If you load a template onto a layer that requires more than a frame time to render, the Spectrum X or ChannelPort is designed to gracefully degrade displaying the content. In other words, if a layer is expected to produce a new image every frame time, the content of the template will repeat until new content has been rendered. This can happen when one or more templates have been loaded on Spectrum X or ChannelPort layers.

Please note the following guidelines for minimizing visible degradation in your animated templates:

- If templates change very little or not at all (for example, a static regulatory template in the corner of the screen), degradation is undetectable.
- If templates contain objects that move quickly, degradation is less noticeable.
- If templates use animation at a constant rate, degradation may appear as a “stutter” or “glitch.” These “stutters” or “glitches” are momentary changes in the frame rate of the animation.
- If your animated template is authored at a constant rate, animate the template at an integer multiple of pixels per frame time. Moving at exactly one pixel or less per frame time is noticeable if any degradation occurs in the animation.
- If possible, use as few high-contrast objects that move at constant rates as possible. Try to keep the animation running within a frame time.
- If possible, fade in and fade out to animate objects in your template rather than animating them at a constant fixed rate.
- If possible, apply ease-in and ease-out on any motion-based tween.

Many factors apply when developing animation with little to no degradation, but a full discourse on motion perception and animation is outside the scope of this document. For additional information, please refer to the following sources:

- [http://en.wikipedia.org/wiki/Motion_perception](http://en.wikipedia.org/wiki/Motion_perception)
- “Advanced Character Animation in Flash”
- “A Primer on Animation Techniques”
  - [http://www.albinoblacksheep.com/flash/animationprimer](http://www.albinoblacksheep.com/flash/animationprimer)

**Gradient Fills**

Gradient fills are computed regions of color & alpha. They are frequently used to soften elements or provide subtle details around other elements.

In general, gradients render quicker than static images derived from image files (for example, .bmp files, .jpg files, and .png files) and render slower than simple solid fills.

Please note the following guidelines when working with gradient fills:
Gradient fills are approximately 71% more expensive to render per pixel than a simple solid fill.

Filling 60% of the screen with a gradient will require approximately an entire frame time.

**Static Bitmap**

A simple static image (for example, a .bmp file, a .jpeg file, or .gif file) is the most common element used in a template.

Flash Professional encodes the imported image into the template in either a lossless or a lossy format. Static images encoded in the lossless format will generate a larger template file but will render on the screen with no compression-related artifacts. Static images encoded in the lossy format will generate a smaller template file but may exhibit compression artifacts when displayed on the screen.

When you load a template with encoded images, the images must be decoded on the first reference to the image before the image can be displayed on the screen. When the image is decoded, it will be converted into a native RGB or ARGB format that can be displayed on the screen. This initial decode time can take several milliseconds.

However, once the images are decoded, future uses of the images will not take any additional time.

In general, 24-bit images render faster than 32-bit images. Thirty-two-bit images with a per-pixel alpha channel take longer to compute the resulting ARGB pixel value than a 24-bit image without per-pixel alpha channel.

Image rendering time is proportional to the final resulting pixel area of the image on screen. Smaller images will render faster than larger images. If a large image is rendered and only part of the image is visible on the screen (for example, an animation moves the image from off screen and onto the screen), the rendering time is still proportional to the total on-screen area of the image.

Please note the following guidelines when working with static bitmaps:

- Bitmaps take approximately two times longer to render than gradient fills.
- Bitmaps take approximately four times longer to render than solid fills.

**Embedded Video**

You can embed a Flash video (.flv) file when you author a template. Embedded Flash videos require substantially more time to render than other objects (for example, solid fills, gradient fills, or static bitmaps).

Please note the following about working with Flash videos:

- Templates that contain Flash videos with smaller files sizes provide better quality.
- If you need an embedded video to play at a lower frame rate, consider spreading the frames of the embedded video throughout the timeline of your template.

**Text**

This section provides guidelines and considerations for using text in your authored templates.

It is outside the scope of this document to fully describe the rich text rendering capabilities of Flash Professional.

For detailed information about the TextField class, refer to:

For detailed information about the TextFormat class, refer to:

Please note the following guidelines when authoring templates with text:

- Smaller glyphs render faster than larger glyphs.
- Text fields with fewer glyphs render faster than text fields with more glyphs.
- Text field transforms (for example, rotation or scaling) do not significantly change the rendering time of the text. The transforms are proportional to the effective pixel area covered by the text.
- Changing the color of the text is the same as re-rendering all of the text.
- Filters, such as drop shadows, blurs, and glows must be re-computed when the text is rendered or updated.
- The Spectrum X or ChannelPort requires more time to re-render text fields than to render text fields and cache the resulting pixels.
- The time it takes to render a specific embedded font for the first time is longer than subsequent renderings of the same font.
- Larger point sizes of text require more time to render than smaller point sizes of text.
- Templates authored with high quality anti-aliasing with sub-pixel resolutions will affect performance during playout.
- Templates authored with filters (for example, drop shadows, blurs, and glows) will affect performance during playout.
- Templates authored with text animations will affect performance during playout.
- Templates authored with text fields that update after they appear on the screen will affect performance during playout.

About the Pixel Area of a Template

When you play a template, instructions within the template dictate how and when pixels of the template are rendered. Rendering performance varies with content and has a complicated relationship with each component of a template.

Templates that do not change from frame to frame are very easy and efficient to render. The primary exception to that rule is when you are fading a layer up or down. In such cases, every change in alpha for that layer will cause the Spectrum X or ChannelPort to redraw all the content currently on the screen.

You can estimate the performance of your template by considering the total pixel area of your template. Objects that cover smaller areas of the screen render faster than objects that cover larger areas of the screen. For example, changing the color of a 10 × 10 rectangle is always faster than changing the color of a 1920x1080 rectangle, no matter how either rectangle was authored.

Audio Performance

Spectrum X and ChannelPort support the following audio formats:

- .aiff files
- .wav files

For the best performance of these audio formats, Harmonic recommends the following encoding configuration:
- Up to 16 channels
- 24 bits
- 48 KHz

You can also export audio in Flash video (.flv) and H.264-encoded MPEG-4 (.mp4) files created with Adobe Media Encoder and After Effects®, as discussed in Chapter 5, Creating Flash Videos and .mp4 (MPEG-4) Files.

For the best performance of these formats, Harmonic recommends the following encoding configuration:

- .flv: 128 kbps (.mp3 bitrate)
- .mp4: 48 KHz (for best processing), 44.1KHz, or 32 KHz, 2 channels, AAC audio

**Best Practices for Great Performance**

- If you need a solid area of color, use a rectangular fill. Rectangular fills render faster than static bitmap images (for example, .jpeg files, .gif files, and .png files).
- If you need a gradient, use a gradient rather than an image of a gradient. In other words, author a gradient in Flash Professional rather than using a pre-rendered bitmap image of a gradient.
- If you do not need per-pixel alpha in your bitmap objects, use a 24-bit .png file rather than a 32-bit .png file.
- If you do not need a mask applied to an object, do not use one. Filters affect the amount of time it takes an object to render.
- If you are importing static images to your project, and if during animation those images may be transformed or scaled, you may want to select “Allow Smoothing” for better quality when the animation is rendered. This will affect the amount of time it takes to render the image.
- If you are importing static images to your project, you may want to select “Lossless Encoding” for better quality when the animation is rendered.
- Embed any fonts you intend to use in your template. This will ensure that they render correctly.
- If you author your animation based on time rather than on every ENTER FRAME event, your animations will appear to run more smoothly over non-constant frame rates if your content rendering time is near the edge of a frame time boundary.
- If your template takes too long to render, spread your template across two or more active loaded layers. Render operations on one layer are single-threaded.
- If one method of authoring a template performs poorly, do not be afraid to try different a different method.

**Troubleshooting Tips**

The following troubleshooting tips are provided for problems you may encounter when playing graphic templates.

**Encountering Problems when Loading Graphic Templates**

If you load a .swf file and it does not play, note the following possibilities:
The .swf file cannot be parsed.

The .swf file is not a valid Harmonic template.

If the .swf file cannot be played, verify that it was created correctly and contains the proper ActionScript code.

If you are using a Sample Harmonic Template, please try the following:

- Be sure you save the sample Harmonic .fla file to the Project folder in the Template Authoring Package before publishing the .fla file as a .swf file. The Project folder contains ActionScript files written by Harmonic that allow your Flash Project to be played on the Spectrum X or ChannelPort.
- If your published .swf file (that began as a sample Harmonic .fla file) cannot be played, validate that the .swf file was created correctly, and/or republish the .swf file.
- Refer to Chapter 3, Using Harmonic Templates for complete instructions on using Sample Harmonic Templates.

If you are creating a custom template from scratch using Flash Professional, please try the following:

**IMPORTANT:** Custom templates that you create from scratch cannot be linked to the Harmonic ActionScript code just by saving the .fla file to the Project folder in the Template Authoring Package—additional steps are required to link custom templates to the ActionScript code.

- If your published .swf file (that began as custom .fla file) cannot be played, validate that the ActionScript settings in Flash Professional were configured properly, and/or republish the .swf file.
- Refer to Chapter 4, Using Custom Templates for complete instructions on creating custom templates with Flash Professional.

**Encountering Problems when Playing Graphic Templates**

**Template Not Visible or Appears to be Cropped**

If you load a template and it is not visible or appears to be cropped during preview, note the following possibilities:

- The template is loaded on a layer that is not visible.
- The resolution of the template does not match the resolution of the primary video.

If your template is loaded but is not visible or appears to be cropped during preview, please try the following:

- Using FXTool, validate that the visibility of the layer is set to “Visible.” If the layer is not “Visible,” click the **Fade In** button. Refer to the *Spectrum X and ChannelPort Tools User Guide* for instructions on using FXTool.
- If the layer is faded in and “Visible,” but the template is still not visible, the active template may be cropped (for example, a 1920x1080 template was loaded on a primary video resolution of 1280x720). Use Flash Professional, Media Encoder, or After Effects to validate that the resolution of the template matches the resolution of the primary video, and/or republish the template.

**Template Animation Running too Fast/Slow**

If you load a .swf file and the animation appears to run too fast or too slow during preview, note the following possibilities:
- Animation is too slow: The frames per second (fps) setting of your .swf file is higher than the fps setting of the primary video.

- Animation is too fast: The fps setting of your .swf file is lower than the fps setting of the primary video.

If the animation of your .swf file appears to run too fast or too slow, please use Flash Professional to validate that the fps setting of the .swf file matches the fps setting of the primary video, and/or republish the .swf file.

**NOTE:** For .flv files that appear to run too slow, in Media Encoder to validate that the “Simple Profile” check box is selected from the Video tab in the Export Settings dialog box.

**Template Animation Running too Slow/Stutters (fps matches)**

If you load a .swf file and the animation appears to run too slow or stutter even though the fps setting of the .swf file matches the fps setting of the primary video, please note the following:

In some cases, a .swf file will appear to be slow or stutter if the .swf file cannot accurately render a new frame of graphics on every video field. When the .swf file is running slow, the last rendered frame will be repeated until a new frame is produced, which may result in a stutter.

Refer to *Performance Considerations* for more information on creating graphic templates that perform frame accurately.
Harmonic Global Service and Support has many Technical Assistance Centers (TAC) located globally, but virtually co-located where our customers can obtain technical assistance or request on-site visits from the Regional Field Service Management team. The TAC operates a Follow-The-Sun support model to provide Global Technical Support anytime, anywhere, through a single case management and virtual telephone system. Depending on time of day, anywhere in the world, we will receive and address your calls or emails in one of our global support centers. The Follow-the-Sun model greatly benefits our customers by providing continuous problem resolution and escalation of issues around the clock.

Report an issue online at:
http://harmonicinc.com/webform/report-issue-online

<table>
<thead>
<tr>
<th>Region</th>
<th>Telephone Technical Support</th>
<th>E-mail</th>
</tr>
</thead>
<tbody>
<tr>
<td>Americas</td>
<td>888.673.4896 (888.MPEG.TWO) or +1.408.490.6477</td>
<td><a href="mailto:support@harmonicinc.com">support@harmonicinc.com</a></td>
</tr>
<tr>
<td>Europe, Middle East, and Africa</td>
<td>+44.1252.555.450</td>
<td><a href="mailto:emeasupport@harmonicinc.com">emeasupport@harmonicinc.com</a></td>
</tr>
<tr>
<td>India</td>
<td>+91.120.498.3199</td>
<td><a href="mailto:apacsupport@harmonicinc.com">apacsupport@harmonicinc.com</a></td>
</tr>
<tr>
<td>Russia</td>
<td>+7.495.926.4608</td>
<td><a href="mailto:rusupport@harmonicinc.com">rusupport@harmonicinc.com</a></td>
</tr>
<tr>
<td>Mainland China</td>
<td>+86.10.6569.5580</td>
<td><a href="mailto:chinasupport@harmonicinc.com">chinasupport@harmonicinc.com</a></td>
</tr>
<tr>
<td>Japan</td>
<td>+81.3.5565.6737</td>
<td><a href="mailto:japansupport@harmonicinc.com">japansupport@harmonicinc.com</a></td>
</tr>
<tr>
<td>Asia Pacific – Other Territories</td>
<td>+852.3184.0045 or 65.6542.0050</td>
<td><a href="mailto:apacsupport@harmonicinc.com">apacsupport@harmonicinc.com</a></td>
</tr>
</tbody>
</table>

The Harmonic Inc. support website is:
http://www.harmonicinc.com/content/technical-support

The Harmonic Inc. software download locations are:

<table>
<thead>
<tr>
<th>All Harmonic software except Cable Edge software</th>
<th>Software updates are available from the Harmonic website. Contact Harmonic Technical Support for login information.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cable Edge software</td>
<td>ftp://ftp.harmonicinc.com</td>
</tr>
</tbody>
</table>
The Harmonic Inc. corporate address is:

Harmonic Inc.
4300 North First St.
San Jose, CA 95134, U.S.A.
Attn: Customer Support

The corporate telephone numbers for Harmonic Inc. are:

Tel. 1.800.788.1330 (inside the U.S.)
Tel. +1.408.542.2500 (outside the U.S.)
Fax.+1.408.542.2511