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The software described in this publication is furnished under a nondisclosure agreement, or the License Agreement and Limited Warranty stated below,
and the end user license agreement (which is furnished with the software), which may have additional terms. The software may be used or copied only
in accordance with the terms of those agreements. By using the software, you acknowledge you have read the end user license agreement and the
License Agreement and Limited Warranty provision.

The product described in this publication maybe covered by one or more of U.S. Patents, their foreign counterparts and pending patent applications.

The product is distributed with certain other software that may require disclosure or distribution of licenses, copyright notices, conditions of use,
disclaimers and/or other matter. Use of this product or otherwise fulfilling their conditions constitutes your acceptance of it, as necessary. Copies of
such licenses, notices, conditions, disclaimers and/or other matter are available in any one of the following locations: the LEGAL NOTICES AND
LICENSES section of the documentation directory of the product, user guide, or by contacting us at support@harmonicinc.com.

Notice

Information contained in this publication is subject to change without notice or obligation. While every effort has been made to ensure that the
information is accurate as of the publication date, Harmonic Inc. assumes no liability for errors or omissions. In addition, Harmonic Inc.assumes no
responsibility for damages resulting from the use of this guide.

License agreement and limited warranty

1. AGREEMENT: This is a legal agreement ("Agreement") between you ("you" or "your") and Harmonic, or its appropriate local affiliate ("Harmonic",
"we", "us" or "our"). Use of our product(s) and any updates thereto purchased or validly obtained by you (the "Products"), and/or the Software (as
defined below) (collectively, the "System"), constitutes your acceptance of this Agreement. "Use" includes opening or breaking the seal on the
packet containing this Agreement, installing or downloading the Software as defined below or using the Software preloaded or embedded in your
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System. As used herein, the term "Software" means the Harmonic owned software and/or firmware used in or with the Products and embedded
into, provided with or loaded onto the Products in object code format, but does not include, and this Agreement does not address, any third-party
or free or open source software separately licensed to you ("Third Party Software"). If you do not agree to this Agreement, you shall promptly
return the System with a dated receipt to the seller for a full refund.

2. LICENSE: Subject to the terms and conditions of this Agreement (including payment), we hereby grant you a nonexclusive, nontransferable
license to use the object code version of the Software embedded into, provided solely for use with or loaded onto the Product, and the
accompanying documentation ("Documentation") for your internal business purposes. The Software and any authorized copies are owned by us
or our suppliers, and are protected by law, including without limitation the copyright laws and treaties of the U.S.A. and other countries. Evaluation
versions of the Software may be subject to a time-limited license key.

3. RESTRICTIONS: You (and your employees and contractors) shall not attempt to reverse engineer, disassemble, modify, translate, create
derivative works of, rent, lease (including use on a timesharing, applications service provider, service bureau or similar basis), loan, distribute,
sublicense or otherwise transfer the System, in whole or part except to the extent otherwise permitted by law. The Software may be operated
on a network only if and as permitted by its Documentation. You may make one (1) back up copy of the object code of the Software for archival
purposes only. Evaluation Software will be run in a lab, nonproductive environment. Results of any benchmark or other performance tests may
not be disclosed to any third party without our prior written consent. Title to and ownership of the Software and Documentation, and all copyright,
patent, trade secret, trademark, and other intellectual property rights in the System, shall remain our or our licensors' property. You shall not
remove or alter any copyright or other proprietary rights notice on the System. We reserve all rights not expressly granted.

4. LIMITED WARRANTY: (a) Limited Warranty. We warrant to you that, commencing on your receipt of a Product and terminating 1 year thereafter,
the System will perform substantially in accordance with its then-current appropriate Documentation. The Product (including replacements) may
consist of new, used or previously-installed components. (b) Remedies. If the System fails to comply with such warranty during such period,
as your sole remedy, you must return the same in compliance with our product return policy, and we shall, at our option, repair or replace the
System, provide a workaround, or refund the fees you paid. Replacement Systems are warranted for the original System's remaining warranty
period. (c) Exclusions. EVALUATION SOFTWARE IS LICENSED ON AS-IS BASIS AND SUBJECT TO 4(d). We will have no obligation under
this limited warranty due to: (i) negligence, misuse or abuse of the System, such as unusual physical or electrical stress, misuse or accidents; (ii)
use of the System other than in accordance with the Documentation; (iii) modifications, alterations or repairs to the System made by a party other
than us or our representative; (iv) the combination, operation or use of the System with equipment, devices, software or data not supplied by
us; (v) any third party hardware or Third Party Software, whether or not provided by us; (vi) any failure other than by us to comply with handling,
operating, environmental, storage or maintenance requirements for the System in the Documentation, including, without limitation, temperature
or humidity ranges. (d) Disclaimers. We are not responsible for your software, firmware, information, or data contained in, stored on, or integrated
with any Product returned to us for repair or replacement. SUCH LIMITED WARRANTY IS IN LIEU OF, AND WE SPECIFICALLY DISCLAIM,
ANY AND ALL OTHER WARRANTIES, WHETHER EXPRESS, IMPLIED OR STATUTORY, INCLUDING, BUT NOT LIMITED TO, ANY IMPLIED
WARRANTIES OF SATISFACTORY QUALITY, MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR NON-INFRINGEMENT.
WE DO NOT WARRANT THAT THE SYSTEM WILL MEET YOUR REQUIREMENTS OR BE UNINTERRUPTED OR ERROR-FREE. NO
ADVICE OR INFORMATION, WHETHER ORAL OR WRITTEN, OBTAINED FROM US OR ELSEWHERE, WILL CREATE ANY WARRANTY
NOT EXPRESSLY STATED IN THIS AGREEMENT. Some jurisdictions do not allow the exclusion of implied warranties or limitations on how long
an implied warranty may last, so such exclusions may not apply to you. In that event, such implied warranties or limitations are limited to 60 days
from the date you purchased the System or the shortest period permitted by applicable law, if longer. This warranty gives you specific legal rights
and you may have other rights which vary from state to state or country to country.

5. LIMITATION OF LIABILITY: WE AND OUR AFFILIATES, SUPPLIERS, LICENSORS, OR SALES CHANNELS ("REPRESENTATIVES") SHALL
NOT BE LIABLE TO YOU FOR ANY SPECIAL, INCIDENTAL, CONSEQUENTIAL, PUNITIVE, OR EXEMPLARY DAMAGES OF ANY KIND,
INCLUDING BUT NOT LIMITED TO LOST REVENUES, PROFITS OR SAVINGS, OR THE COST OF SUBSTITUTE GOODS, HOWEVER
CAUSED, UNDER CONTRACT, TORT, BREACH OF WARRANTY, NEGLIGENCE, OR OTHERWISE, EVEN IF WE WERE ADVISED OF
THE POSSIBILITY OF SUCH LOSS OR DAMAGES. NOTWITHSTANDING ANY OTHER PROVISIONS OF THIS AGREEMENT, WE AND
OUR REPRESENTATIVES' TOTAL LIABILITY TO YOU ARISING FROM OR RELATING TO THIS AGREEMENT OR THE SYSTEM SHALL
BE LIMITED TO THE TOTAL PAYMENTS TO US UNDER THIS AGREEMENT FOR THE SYSTEM. THE FOREGOING LIMITATIONS SHALL
NOT APPLY TO DEATH OR PERSONAL INJURY TO PERSONS OR TANGIBLE PROPERTY IN ANY JURISDICTION WHERE APPLICABLE
LAW PROHIBITS SUCH LIMITATION. YOU ARE SOLELY RESPONSIBLE FOR BACKING UP YOUR DATA AND FILES, AND HEREBY
RELEASE US AND OUR REPRESENTATIVES FROM ANY LIABILITY OR DAMAGES DUE TO THE LOSS OF ANY SUCH DATA OR FILES.
SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO SUCH
EXCLUSIONS MAY NOT APPLY TO YOU.

6. CONFIDENTIALITY: Information in the System and the associated media, as well as the structure, organization and code of the Software, are
proprietary to us and contain valuable trade secrets developed or acquired at great expense to us or our suppliers. You shall not disclose to
others or utilize any such information except as expressly provided herein, except for information (i) lawfully received by the user from a third
party which is not subject to confidentiality obligations; (ii) generally available to the public without breach of this Agreement; (iii) lawfully known to
the user prior to its receipt of the System; or (iv) required by law to be disclosed.

7. SUPPORT: Updates, upgrades, fixes, maintenance or support for the System (an "Upgrade") after the limited warranty period may be available
at separate terms and fees from us. Any Upgrades shall be subject to this Agreement, except for additional or inconsistent terms we specify.
Upgrades do not extend the limited warranty period.

8. TERM; TERMINATION: The term of this Agreement shall continue unless terminated in accordance with this Section. We may terminate this
Agreement at any time upon default by you of the license provisions of this Agreement, or any other material default by you of this Agreement not
cured with thirty (30) days after written notice thereof. You may terminate this Agreement any time by terminating use of the System. Except for
the first sentence of Section 2 ("License") and for Section 4(a) ("Limited Warranty"), all provisions of this Agreement shall survive termination of
this Agreement. Upon any such termination, you shall certify in writing such termination and non-use to us.

9. EXPORT CONTROL: You agree that the Products and Software will not be shipped, transferred, or exported into any country or used in any
manner prohibited by the United States Export Administration Act or any other export laws, restrictions, or regulations (the "Export Laws"). You
will indemnify, defend and hold us harmless from any and all claims arising therefrom or relating thereto. In addition, if the Products or Software
are identified as export controlled items under the Export Laws, you represent and warrant that you are not a citizen, or otherwise located within,
an embargoed nation (including without limitation Iran, Iraq, Syria, Sudan, Libya, Cuba, North Korea, and Serbia) and that you are not otherwise
prohibited under the Export Laws from receiving the Software. All rights to the Products and Software are granted on condition that such rights
are forfeited if you fail to comply with the terms of this Agreement.

10. U.S. GOVERNMENT RIGHTS: The Software and the documentation which accompanies the Software are "Commercial Items," as that term is
defined at 48 C.F.R. §2.101, consisting of "Commercial Computer Software" and "Commercial Computer Software Documentation," as such terms
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are used in 48 C.F.R. §12.212 or 48 C.F.R. §227.7202, as applicable. Consistent with 48 C.F.R. §12.212 or 48 C.F.R. §§227.7202-1 through
227.7202-4, as applicable, the Commercial Computer Software and Commercial Computer Software Documentation are being licensed to U.S.
Government as end users (a) only as Commercial Items and (b) with only those rights as are granted to all other end users pursuant to the terms
and conditions herein. Harmonic, 4300 North First Street, San Jose, CA 95134, U.S.A.

11. GENERAL:You shall not assign, delegate or sublicense your rights or obligations under this Agreement, by operation of law or otherwise, without
our prior written consent, and any attempt without such consent shall be void. Subject to the preceding sentence, this Agreement binds and
benefits permitted successors and assigns. This Agreement is governed by California law, without regard to its conflicts of law principles. The
U.N. Convention on Contracts for the International Sale of Goods is disclaimed. If any claim arises out of this Agreement, the parties hereby
submit to the exclusive jurisdiction and venue of the federal and state courts located in Santa Clara County, California. In addition to any other
rights or remedies, we shall be entitled to injunctive and other equitable relief, without posting bond or other security, to prevent any material
breach of this Agreement. We may change the terms, conditions and pricing relating to the future licensing of our Systems and other intellectual
property rights, including this Agreement, from time to time. No waiver will be implied from conduct or failure to enforce rights nor effective unless
in a writing signed on behalf of the party against whom the waiver is asserted. If any part of this Agreement is found unenforceable, the remaining
parts will be enforced to the maximum extent permitted. There are no third-party beneficiaries to this Agreement. We are not bound by additional
and/or conflicting provisions in any order, acceptance, or other correspondence unless we expressly agree in writing. This Agreement is the
complete and exclusive statement of agreement between the parties as to its subject matter and supersedes all proposals or prior agreements,
verbal or written, advertising, representations or communications concerning the System.

Every reasonable attempt has been made to comply with all licensing requirements for all components used in the system. Any oversight is
unintentional and will be remedied if brought to the attention of Harmonic at support@harmonicinc.com.

Documentation conventions
In Harmonic documents, special symbols and fonts to call your attention to important information.

DANGER:  The Danger symbol indicates information that, if ignored, can cause physical
harm to you.

CAUTION:  The Caution symbol indicates information that, if ignored, can adversely affect
the performance of your Harmonic product, or that can make a procedure needlessly
difficult.

NOTE:  The Note symbol indicates especially important information you need, or it may
provide additional information that applies in only some carefully delineated circumstances.

IMPORTANT:  The Important symbol indicates information that should stand out when you
are reading product details and procedural information.

TIP:  The Tip symbol indicates parenthetical information that is not necessary for
performing a given procedure, but which, if followed, makes the procedure easier,
smoother, or more efficient.

In addition to these symbols, this guide may use the following text conventions:

Convention Explanation

Typed Command Indicates the text that you type in at the keyboard prompt.

Ctrl, Ctrl + Shift A key or key sequence to press.

http://www.harmonicinc.com The italics in blue text to indicate Cross-references, and
hyperlinked cross-references in online documents.

Bold Indicates a button to click, or a menu item to select.

Screen Output
The text that is displayed on a computer screen.

Emphasis The italics text used for emphasis and document references.
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Chapter 1

Introduction

The Harmonic Template Authoring Package is a custom authoring tool for integrating video graphics and
branding on your Spectrum playout device.

IMPORTANT:  The templates and files included in the Template Authoring Package are
examples only, and are provided as is. Harmonic assumes no responsibility or liability if the
provided templates do not work as expected in expanded workflows.

• About the Template Authoring Package
• Adobe tools for template authoring
• Sample templates
• Harmonic Template Widget Library

About the Template Authoring Package
The Template Authoring Package contains both blank and sample .fla files that can be turned into .swf
files for playout on your Spectrum playout device.

NOTE:  To create a project from scratch, you should use a blank template. If you prefer to
create a custom template that does not use one of the blank or sample files, you must first
properly configure Flash Professional and the ActionScript settings for your project.

Contents
Learn which folders and files make up the Template Authoring Package.

Folder name Description
external-key-fill Contains the external Key/Fill templates that, when loaded onto a

layer, enable the external Key/Fill feature.

project Contains the Flash ActionScript files written by Harmonic that are
needed to play a template.

HarmonicTemplate.swc (compiled ActionScript) is included in the
.swf file when you publish a template.

IMPORTANT:  Harmonic recommends that all
project files be placed in the project folder
in order for published .swf files to contain the
necessary Harmonic-provided ActionScript code.
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About the Template Authoring Package

Folder name Description
samples Contains the following subfolders:

• sources: Contains .fla files of the sample templates and blank
templates for each supported raster size.

• templates: Contains .swf files of the sample templates for
each supported raster size.

NOTE:  Within the sources and templates
folders, the anysize folder contains open caption
templates and source files.

widgets Contains the Harmonic Widget Library. Harmonic widgets are Flash
components that can be used for building templates.

Supported file types
Your Spectrum playout device supports a variety of file types.

Graphics

• .swf (Shockwave Flash Movie)
• .flv (Flash Video)
• .mp4 (MPEG-4)
• .png (Portable Network Graphic)
• .jpg/.jpeg (Joint Photographic Experts Group)
• .tga (Targa Graphic)
• .gif (Graphical Interchange Format)
• .bmp (Bitmap Image)
• .tif/.tiff (Tagged Image File)

NOTE:  JPEG file compression and planar formats within .tif files are not supported.

Audio

• .wav (Waveform Audio File Format)
• .aiff (Audio Interchange File Format)

NOTE:  Playback of audio embedded in a .swf file is not supported.

For best performance, Harmonic recommends the following audio settings: 48 kHz, 24-bit, up to 16
channels.

Bundled files

Spectrum X and ChannelPort will play out bundled files in a .zip file.

Supported raster sizes
Harmonic blank and sample templates are available in each supported raster size.

• 2160p60, 3840x2160 (Spectrum X only)
• 2160p50, 3840x2160 (Spectrum X only)
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• 1080p60, 1920x1080
• 1080p50, 1920x1080
• 1080i60, 1920x1080
• 1080i50, 1920x1080
• 720p60, 1280x720
• 720p50, 1280x720
• 625-16x9, 1024x576
• 625-4x3, 768x576
• 525-16x9, 864x486
• 525-4x3, 648x486

Adobe tools for template authoring
Review which Adobe® tools are required or recommended for authoring .swf, .flv, and .mp4
templates for the Spectrum X and ChannelPort.

Shockwave Flash Movie (.swf) templates

Spectrum X and ChannelPort support .swf files that are compatible with Flash Player 10.3 and
ActionScript 3.0. At this time, Harmonic recommends authoring .swf templates in Flash Professional®
CS6, and the procedures in this guide for creating and customizing .swf templates are based on the
Flash Professional CS6 environment.

NOTE:  Adobe® Animate CC is the next generation of Flash Professional, and is very
similar in terms of usage. If you wish to use Animate CC for authoring .swf files for the
Spectrum X and ChannelPort, your template project must be configured for Flash Player
10.3 and ActionScript 3.0.

IMPORTANT:  You must use Flash Professional CS6 if your template project requires Text
Layout Framework (TLF). The Harmonic Advanced Text Field Widget and Advanced Text
Scroll Widget use TLF.

Flash video (.flv) templates

At this time, After Effects CS6 or Media Encoder CS6 is required for authoring .flv templates for the
Spectrum X and ChannelPort.

MPEG-4 (.mp4) templates

At this time, Harmonic recommends using After Effects CS6 or Media Encoder CS6 for authoring .mp4
templates for the Spectrum X and ChannelPort.

NOTE:  After Effects CS6 and Media Encoder CS6 do not support 3840x2160 .mp4 files
at 50 or 59.94 Hz. Instead, use After Effects CC or Media Encoder CC to author .mp4
templates at this resolution and frame rate.
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Sample templates

Sample templates
The Template Authoring Package includes a variety of sample .swf templates.

Dynamic text field templates
These templates contain Harmonic text field widgets that can be updated after the template has been
loaded onto your Spectrum playout device.

Dynamic text banner

The following figure shows the second text field of the Dynamic Text Banner (or Now, Next, Later)
template.

Figure 1-1: Dynamic text banner template

The template contains several layers of Flash animation, as shown below.

Figure 1-2: Dynamic text banner Flash layers
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Full-page dynamic text banner

This template contains multiple instances of the Harmonic text field widget and uses a .jpeg file for the
background image. The dynamic text field containing the time animates from the left, and the dynamic
text field animates from the right.

Figure 1-3: Full-page dynamic text banner template

This template contains several layers of Flash animation, as shown below.

Figure 1-4: Full-page dynamic text banner Flash layers
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Sample templates

Countdown template
This template contains the Harmonic Text Field widget and the Harmonic Countdown widget.

After the template is loaded, a numeric value (in seconds) can be entered in the text field of the template.
When the countdown is complete, the template will hide its contents.

Figure 1-5: Countdown template

This template contains several layers of Flash animation, as shown below.

Figure 1-6: Flash layers

Regulatory templates
Regulatory templates contain a single .png image file that has been placed on the Flash stage.

Each regulatory template uses only one layer in Flash. The following templates are available:

• TV-Y
• Closed Captioning
• TV-14
• TV-MA
• E/I (Educational and Informational)
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Figure 1-7: TV-Y template

EAS templates
Three EAS templates are available. Each contains the Harmonic Text Scroll widget, and uses one layer in
Flash.

The following templates are provided:

• EAS Warning
• EAS Watch
• EAS Advisory

NOTE:  EAS templates are placed on the highest graphics layer to ensure they are not
obscured by other graphics. If your Spectrum playout device is configured to support an
EAS, be sure to reserve the highest layer for EAS templates.

Figure 1-8: EAS warning template
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Sample templates

Pillar Boxes template
This template contains two .png image files (one for each side of the screen) that have been manipulated
on the Flash stage. The template uses one layer in Flash.

Figure 1-9: Pillar boxes template

Logo Loop templates
Two versions of this template are provided. One contains a Flash video and the other contains a
sequence of .png image files that have been placed on the Flash stage.

The Logo Loop template uses one layer of animation in Flash. When played, the animation will continue
to loop until it is stopped.

Figure 1-10: Logo Loop template in which the animation (in blue) is captured toward the end of the loop

Three-point Animation templates
This template contains a Flash video with an intro section, a loop section, and an outro section.

The template depicts the following animations:

1. The laser animation slides in from the right of the screen.
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2. When the laser animation reaches the left boundary of the template, it reverses its direction, and the
Harmonic logo appears on the screen.

3. The laser animation slides in from the right of the screen again. When it reaches the left boundary of
the template, it reverses direction, and the Harmonic logo disappears from the screen.

The example below shows the three-point animation template in the second part of its animation.

Figure 1-11: Three-point animation template

The template contains several layers of Flash animation, as shown below.

Figure 1-12: Flash layers

Additional information
Configuring three-point animations on page 50

News Ticker template
This template contains the Harmonic Clock widget, the Harmonic Advanced Text Scroll widget, and a
static .png image file that has been placed on the Flash stage.

You can configure the News Ticker template to fetch data from an RSS feed or from a text file. You can
also update the text field of the News Ticker template when you preview the template using FXTool or
Preview Tool.
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Sample templates

Figure 1-13: News ticker template

This template contains several layers of Flash animation, as shown below.

Figure 1-14: Flash layers

Dual DVE Side-by-Side template
This template contains dual DVE component widgets and a .jpeg file for the background image.

The Dual DVE Side-by-Side template begins with a full-screen video, and then “squeezes” the video back
toward the left side of the screen. As the video is “squeezed” back, a blue background image appears,
and a second DVE is introduced from the bottom right-hand side of the screen.

Figure 1-15: Dual DVE side-by-side template
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The Dual DVE Side-by-Side template contains several layers of Flash animation, as shown below.

Figure 1-16: Flash layers

Additional information
Using the blank Harmonic Dual DVE template on page 61

DVE Squeezeback template
This template contains the Harmonic DVE widgets and a graphics folder that contains several .png files
and a collection of movie clips.

The DVE Squeezeback template begins with a full-screen video, and then “squeezes” the video back
toward the top-left portion of the screen. As the video is “squeezed back” a border and the Harmonic logo
slide in to frame the video.

Figure 1-17: DVE squeezeback template in 1280x720

The DVE Squeezeback template contains several layers of Flash animation, as shown below.

Figure 1-18: Flash layers
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Sample templates

Additional information
Using the blank DVE template on page 59

Live Audio Voiceover template
This template contains the Harmonic Live Audio Voiceover widget, and is intended for use only with live
audio (not recorded audio).

When this template is faded up, it allows the input of the AES channel to supersede any other audio that
is active on the Spectrum playout device. The audio voiceover template may be used in conjunction with
Harmonic EAS templates.

NOTE:  When you open the Live Audio Voiceover template in Flash Professional, you will
see a graphic, shown below. When the template is loaded, however, the graphic becomes
transparent.

 

 

Open Caption templates
Harmonic provides sample open caption templates and source files.

After you install the Template Authoring Package, you can find Open Caption templates here: Harmonic-
template-authoring.zip\samples\templates\anysize\OpenCaptions. This folder contains
.swf files, which are open caption templates for various languages.

The source code for the open caption templates is located here: Harmonic-template-
authoring.zip\samples\sources\anysize\OpenCaptions. Inside each sub-folder you will find
.fla files, which are the sources for the open caption templates.

Route Master Connection template
If you have Polaris Live: Route as a licensed feature, you can control input from an upstream router using
the Route Master Connection template.

The Route Master Connection template is stored in the anysize/Polaris/RouteMasterConnection
folder. It contains two dynamic text fields that automation can use to control the behavior of the router.

• Text Field 0: defines the IP address and port of the upstream router and uses the following format: <ip
address>:<port>.

• Text Field 1: defines the upstream router’s source and destination mapping and uses the following
format: <src>:<dest>
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Load the template onto your Spectrum playout device and use the Oxtel UpdateTextField command
to interact with the template.

Harmonic Template Widget Library
The Widget Library contains Flash components created by Harmonic that can be added to Flash projects.

Once the widget is in your Flash project library, it can be dragged onto the stage and manipulated in
your project. For example, you can re-size the widget or change its font, text size, or text color. After you
save your project in the project folder, you can edit the ActionScript code of the widget to customize its
behavior.

IMPORTANT:  Editing the ActionScript is an advanced procedure, and errors could make
the template incapable of being played. Some widgets contain commentary for editing the
ActionScript code correctly.

The follow widgets are available:

Harmonic Clock Contains ActionScript code that will update the clock accordingly once it is
placed in a Flash project.

Harmonic Text Field Contains ActionScript code that allows the text field to be updated dynamically
(for example, via an automation system).

Harmonic Text Scroll Contains the same ActionScript code as the Harmonic Text Field widget, but
also contains ActionScript that scrolls the text across the text field. The speed
and orientation of this scroll (right-to-left, left-to-right) can be controlled through
the ActionScript code.

Harmonic Advanced
Text Field and
Advanced Text Scroll

Used for languages that contain complex characters or right-to-left or bi-
directional text. These widgets contain ActionScript code that supports Adobe’s
Text Layout Framework.

Harmonic
Countdown

Contains ActionScript code that allows a text field to be updated (for example,
via an automation system) with a numeric value, in seconds, that will countdown
to zero when the template is loaded, and the layer is faded up.

Harmonic Voiceover Contains ActionScript code that controls the live audio voiceover mixer.

Harmonic Anchor
Override

Contains ActionScript code that allows templates that are smaller than
the raster size to be anchored to one of nine fixed locations on the stage.
When used, the widget overrides the default layer anchor point configured in
SystemManager.

Additional information
Using Harmonic widgets on page 36

DVE components
DVE widgets contain ActionScript code that provides various functionality for the DVE template.

DVE widgets are stored in the DVE Components folder. The following widgets are available:
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Harmonic Template Widget Library

Harmonic DVE Src
Preview Region

Contains ActionScript code that represents the input to the DVE in the Flash
Desktop environment.

Harmonic DVE Src
Region

Contains ActionScript code that controls the crop functionality of the DVE.

Harmonic DVE Dst
Region

Contains ActionScript code that controls the scale and position functionality of
the DVE.

Harmonic DVE Audio
Duck Level and
Audio Mix Level

These widgets contain ActionScript code that maps the audio duck level and
audio mix level of a DVE, in decibels, to the alpha value of the widget. When
used in conjunction, the Audio Duck Level widget can be used to lower the
background audio of the DVE, and the Audio Mix Level widget can be used to
raise new audio to the DVE. Versions of the widgets are also available for Dual
DVE templates.

Dual DVE
Components

This folder contains two additional folders: one folder with DVE widgets for DVE
0, and one folder with DVE widgets for DVE 1. These DVE widgets contain
ActionScript code that provides functionality for the Dual DVE template.
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Getting started

Find instructions for installing the Template Authoring Package, guidelines for creating templates that
render quickly and smoothly, and other information to help you get started with your template project.

• Installing the Template Authoring Package
• Overview of authoring and publishing templates in Flash Professional
• About primary and secondary template file names
• Template authoring guidelines

Installing the Template Authoring Package
The Template Authoring Package is available from the Harmonic software downloads site. Contact
Technical Support for login information.

For ease of use, Harmonic recommends that you store the Template Authoring Package in the same
location you store your Flash projects.

1. From the Harmonic downloads site, navigate to the Template Authoring Package available with your
Spectrum downloads.

2. Download the HarmonicTemplatesAndTools-v[version_number]-SWandDoc.exe.

3. Unzip Harmonic-template-authoring.zip, and set a destination path on your computer.

NOTE:  The destination path can be any location from which you want to work (for
example, C:\Users\[yourname]\DeskTop\FlashProjects\Harmonic-
template-authoring). However, you will need to access the project folder in the
Template Authoring Package throughout the procedures in this guide.

Overview of authoring and publishing templates in Flash
Professional
Follow this basic process when authoring templates in Flash Professional.

1. Verify your raster size and frame rate.

2. Start your Flash project by doing one of the following:

22



About primary and secondary template file names

• From the Template Authoring Package directory, copy the sample .fla file you wish to work with
to the project folder.

IMPORTANT:  If the .fla file is in a folder with other files that support it, you must
copy all the supporting files to the project folder as well.

• From the Template Authoring Package directory, copy the blank .fla file you wish to work with to
the project folder.

NOTE:  If you do not wish to use a blank or sample .fla file, you may create a custom
template. However, you must first properly configure Flash Professional and the
ActionScript settings for your project.

3. Open the .fla file in Flash Professional.

4. Save your file with a new file name.

CAUTION:  Do not use the following characters in the file name of your template: \ /
" % #.

5. If you are resizing the template to be smaller than full raster size, ensure that you apply the
anchor override widget to the template, or ensure that layer anchor points have been configured in
SystemManager.

6. View, edit, or add visual elements to the template as desired.

7. When you are ready to publish your template as a .swf file, click File > Publish.
The published .swf file saves to the project folder.

8. Copy the .swf file from the project folder to the graphics directory on your Spectrum video server.

The template can now be played on your Spectrum playout device.

About controlling the MovieClip timeline in Flash Professional
MovieClip objects allow you to control animations from within the template.

All Harmonic templates are derived from the Flash MovieClip class. The Spectrum playout device controls
the main timeline of a template in response to Oxtel commands. For example, after loading a template,
the playout device stops the main timeline if the layer is invisible, and then starts the timeline once the
layer starts fading in. If the template contains customized ActionScript code that tries to control the main
timeline using methods such as “stop(),” “play(),” or “gotoAndPlay(),” the playout device will not be able
to control the timeline. This can lead to unexpected behavior, and template animations may not play
correctly.

To avoid conflicts, create MovieClip objects for any animations that you wish to control from within
the template. These objects have their own timelines, and their animations can be controlled through
ActionScript to achieve the desired effects.

About primary and secondary template file names
If you have licensed Independent Branding for your Spectrum playout device, you must distinguish
between primary and secondary versions of templates by using either the folder method or the basename
extension method.

The naming convention you choose depends on the settings you have configured in SystemManager.
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Table 2-1: Template naming methods

Option Description

Folder method With this method, you name primary and secondary template
versions identically. Primary templates are stored in gfx.dir,
while secondary templates are stored in a subfolder.

In the following example, gfx.dir stores primary templates (in
this case, HD), and the subfolder stores secondary templates (in
this case, SD):

/fs0/gfx.dir/foo.swf

/fs0/gfx.dir/SD/foo.swf

Basename extension method With this method, you apply a basename extension to each file
name to indicate which output the template will be used for, and
then save all templates in gfx.dir.

In the example below, the basename extensions "HD1" and
"HD2" indicate which output the template is intended for:

/fs0/gfx.dir/fooHD1.swf

/fs0/gfx.dir/fooHD2.swf

Template authoring guidelines
Follow these guidelines to ensure that graphics render quickly and animation plays smoothly.

Guidelines for authoring UHD templates
Note these important guidelines for authoring UHD templates.

• By default, blank and sample .fla files are full raster size.

IMPORTANT:  Harmonic recommends that you re-size the stage to be just large
enough to contain the graphic, and then use anchor points to position the template on
the stage. This improves performance by reducing the number of transparent pixels
that must be rendered. Use full-size templates only when necessary. For example, DVE
squeezeback and pillar box templates should be full raster size.

• A "safe" image has been added to the blank and sample .fla files to represent the area of the stage
that contains active video. This can help you determine the location of the smaller stage size on a full
raster.

• When creating Flash video templates in Media Encoder or After Effects CS6, the highest resolution
available is 1920 x 1080. As a result, Harmonic recommends that you use anchor points for .flv
templates in UHD workflows.

• Adobe After Effects CS6 and Adobe Media Encoder CS6 do not support 3840x2160 .mp4 files at 50
or 59.94 Hz. Instead, use After Effects CC to create the composition, and then render the .mp4 in
Media Encoder CC.

• At this time, Harmonic does not support the Monitor Out template in 3840 x 2160.
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Template authoring guidelines

Additional information
Applying the anchor override widget on page 47

Performance considerations
In general, for your animation to play smoothly, your animated content should render completely within a
frame time and maintain its frame rate over time.

Unlike a video clip, graphics designed to play on a Harmonic device are a collection of assets and
instructions. These assets are interpreted by a renderer running on the playout device.

The “look” of an animation can be achieved with different methods, but the best method is not always
obvious. Simple changes can have dramatic effects on the rendering times of your graphics. Consider the
following factors that will affect performance:

• The size of the screen area your animation will use
• The complexity of your animation
• The types of elements used within your animation
• Additional effects applied to elements within the animation (for example, masks, filters, or pixel

benders)

When you load several layers of templates, each active layer is interpreted by independent renderers that
all share access to the same CPU and memory resources. When animations on different layers have the
same processing and rendering times, some layer-to-layer interference effects may be observed.

Flash renderer types

The Flash renderer on your Spectrum playout device behaves differently than desktop and browser-
based Flash renderers.

Desktop and browser-based Flash renderers have non-constant, wide-ranging frame rates and
capabilities. However, the Flash renderer on your Harmonic device has a stage frame rate that is strictly
controlled by the field rate of the primary video format.

When authoring graphics for playout on the Spectrum playout device, please note the following:

• Changing the stage frame rate within ActionScript will have no effect on the graphic when it is played.
• When the template receives the ENTER_FRAME event, the template will play at 59.94 Hz (for 525

video) or at 50 Hz (for 625 video) no matter what other settings you specify in Flash Professional or in
the ActionScript.

Graceful degradation

If you load a template onto a layer that requires more than a frame time to render, your Spectrum playout
device is designed to gracefully degrade displaying the content.

In other words, if a layer is expected to produce a new image every frame time, the content of the
template will repeat until new content has been rendered. This can happen when one or more templates
have been loaded.

Please note the following guidelines for minimizing visible degradation in your animated templates:

• If templates change very little or not at all (for example, a static regulatory template in the corner of the
screen), degradation is undetectable.

• If templates contain objects that move quickly, degradation is less noticeable.
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• If templates use animation at a constant rate, degradation may appear as a “stutter” or “glitch.” These
“stutters” or “glitches” are momentary changes in the frame rate of the animation.

• If your animated template is authored at a constant rate, animate the template at an integer multiple
of pixels per frame time. Moving at exactly one pixel or less per frame time is noticeable if any
degradation occurs in the animation.

• If possible, use as few high-contrast objects that move at constant rates as possible. Try to keep the
animation running within a frame time.

• If possible, fade in and fade out to animate objects in your template rather than animating them at a
constant fixed rate.

• If possible, apply ease-in and ease-out on any motion-based tween.

Many factors apply when developing animation with little to no degradation, but a full discourse on motion
perception and animation is outside the scope of this document. For additional information, please refer to
the following sources:

• http://en.wikipedia.org/wiki/Animation
• http://en.wikipedia.org/wiki/Motion_perception
• http://en.wikipedia.org/wiki/12_basic_principles_of_animation
• “Advanced Character Animation in Flash” (http://www.adobe.com/devnet/flash/articles/

adv_char_anima.html)
• “A Primer on Animation Techniques” (http://www.albinoblacksheep.com/flash/animationprimer)

Gradient fills

Gradient fills are computed regions of color and alpha. They are frequently used to soften elements or
provide subtle details around other elements.

In general, gradients render quicker than static images derived from image files (for example, .bmp
files, .jpg files, and .png files) and render slower than simple solid fills.

Please note the following guidelines when working with gradient fills:

• Gradient fills are approximately 71% more expensive to render per pixel than a simple solid fill.
• Filling 60% of the screen with a gradient will require approximately an entire frame time.

Static Bitmap

A simple static image (for example, a .bmp file, a .jpeg file, or .gif file) is the most common element used
in a template.

Flash Professional encodes the imported image into the template in either a lossless or a lossy format.
Static images encoded in the lossless format will generate a larger template file but will render on the
screen with no compression-related artifacts. Static images encoded in the lossy format will generate a
smaller template file but may exhibit compression artifacts when displayed on the screen.

When you load a template with encoded images, the images must be decoded on the first reference
to the image before the image can be displayed on the screen. When the image is decoded, it will be
converted into a native RGB or ARGB format that can be displayed on the screen. This initial decode time
can take several milliseconds.

However, once the images are decoded, future uses of the images will not take any additional time.

In general, 24-bit images render faster than 32-bit images. Thirty-two-bit images with a per-pixel alpha
channel take longer to compute the resulting ARGB pixel value than a 24-bit image without per-pixel
alpha channel.
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Image rendering time is proportional to the final resulting pixel area of the image on screen. Smaller
images will render faster than larger images. If a large image is rendered and only part of the image is
visible on the screen (for example, an animation moves the image from off screen and onto the screen),
the rendering time is still proportional to the total on-screen area of the image.

Please note the following guidelines when working with static bitmaps:

• Bitmaps take approximately two times longer to render than gradient fills.
• Bitmaps take approximately four times longer to render than solid fills.

Embedded video

You can embed a Flash video (.flv) file when you author a template.

Embedded Flash videos require substantially more time to render than other objects (for example, solid
fills, gradient fills, or static bitmaps). Please note the following about working with Flash videos:

• Templates that contain Flash videos with smaller file sizes provide better quality.
• If you need an embedded video to play at a lower frame rate, consider spreading the frames of the

embedded video throughout the timeline of your template.

Text

Please note important guidelines when authoring templates with text.

• Smaller glyphs render faster than larger glyphs.
• Text fields with fewer glyphs render faster than text fields with more glyphs.
• Text field transforms (for example, rotation or scaling) do not significantly change the rendering time of

the text. The transforms are proportional to the effective pixel area covered by the text.
• Changing the color of the text is the same as re-rendering all of the text.
• Filters, such as drop shadows, blurs, and glows must be re-computed when the text is rendered or

updated.
• The playout device requires more time to re-render text fields than to render text fields and cache the

resulting pixels.
• The time it takes to render a specific embedded font for the first time is longer than subsequent

renderings of the same font.
• Larger point sizes of text require more time to render than smaller point sizes of text.
• Templates authored with high quality anti-aliasing with sub-pixel resolutions will affect performance

during playout.
• Templates authored with filters (for example, drop shadows, blurs, and glows) will affect performance

during playout.
• Templates authored with text animations will affect performance during playout.
• Templates authored with text fields that update after they appear on the screen will affect performance

during playout.

It is outside the scope of this document to fully describe the rich text rendering capabilities of Flash
Professional. For detailed information about the TextField class, refer to: http://help.adobe.com/en_US/
FlashPlatform/reference/actionscript/3/flash/text/TextField.html. For detailed information about the
TextFormat class, refer to: http://help.adobe.com/en_US/FlashPlatform/reference/actionscript/3/flash/text/
TextFormat.html.

27 Spectrum 8.2 Template User Guide

http://help.adobe.com/en_US/FlashPlatform/reference/actionscript/3/flash/text/TextField.html
http://help.adobe.com/en_US/FlashPlatform/reference/actionscript/3/flash/text/TextField.html
http://help.adobe.com/en_US/FlashPlatform/reference/actionscript/3/flash/text/TextFormat.html
http://help.adobe.com/en_US/FlashPlatform/reference/actionscript/3/flash/text/TextFormat.html


Chapter 2: Getting started

About the pixel area of a template

When you play a template, instructions within the template dictate how and when pixels of the template
are rendered.

Rendering performance varies with content and has a complicated relationship with each component of
a template. Templates that do not change from frame to frame are very easy and efficient to render. The
primary exception to that rule is when you are fading a layer up or down. In such cases, every change in
alpha for that layer will cause the playout device to redraw all the content currently on the screen.

You can estimate the performance of your template by considering the total pixel area of your template.
Objects that cover smaller areas of the screen render faster than objects that cover larger areas of the
screen. For example, changing the color of a 10 × 10 rectangle is always faster than changing the color of
a 1920x1080 rectangle, no matter how either rectangle was authored.

Audio performance

Review important guidelines for working with .aiff and .wav audio formats.

For the best performance of these audio formats, Harmonic recommends the following encoding
configuration:

• Up to 16 channels
• 24 bits
• 48 KHz

You can also export audio in Flash video (.flv) and H.264-encoded MPEG-4 (.mp4) files created with
Media Encoder and After Effects.

For the best performance of these formats, Harmonic recommends the following encoding configuration:

• .flv: 128 kbps (.mp3 bit rate)
• .mp4: 48 KHz (for best processing), 44.1KHz, or 32 KHz, 2 channels, AAC audio

Best practices for great performance

• You may resize templates to be smaller than full raster size; however, ensure that you assign anchor
points for graphic layers in <keyword keyref="manager_a"/> so that the template will load in the
desired position. In Flash Professional, you can also use the <keyword keyref="company_name"/>
Anchor Override widget to position a template on the stage.

• If you need a solid area of color, use a rectangular fill. Rectangular fills render faster than static bitmap
images (for example, .jpeg files, .gif files, and .png files).

• If you need a gradient, use a gradient rather than an image of a gradient. In other words, author a
gradient in Flash Professional rather than using a pre-rendered bitmap image of a gradient.

• If you do not need per-pixel alpha in your bitmap objects, use a 24-bit .png file rather than a 32-bit .png
file.

• If you do not need a mask applied to an object, do not use one. Filters affect the amount of time it
takes an object to render.

• If you are importing static images to your project, and if during animation those images may be
transformed or scaled, you may want to select “Allow Smoothing” for better quality when the animation
is rendered. This will affect the amount of time it takes to render the image.

• If you are importing static images to your project, you may want to select “Lossless Encoding” for
better quality when the animation is rendered.

• Embed any fonts you intend to use in your template. This will ensure that they render correctly.
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• If you author your animation based on time rather than on every ENTER_FRAME event, your
animations will appear to run more smoothly over non-constant frame rates if your content rendering
time is near the edge of a frame time boundary.

• If your template takes too long to render, spread your template across two or more active loaded
layers. Render operations on one layer are single-threaded.

• If one method of authoring a template performs poorly, do not be afraid to try different a different
method.
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Setting up a custom template in Flash Professional

If you would like to create a custom template that does not use one of the Harmonic .fla files included
in the Template Authoring package, you must first properly configure Flash Professional and the
ActionScript settings for your custom project.

IMPORTANT:  A custom template will not play if it is not properly configured. Be sure to
follow the procedures in this section in order.

1. Configuring Flash Professional
2. Applying ActionScript code to a custom template
3. Customizing ActionScript code
4. Adding an event listener for accessing Flash stage properties

Configuring Flash Professional
When starting a new project, you need to configure Flash Professional to support Flash Player 10.3 as
well as ActionScript 3.0.

1. Click File > New to create a new Flash Professional project.
The New Document dialog box appears.

2. Under Type, select ActionScript 3.0.

3. Set the appropriate width, height, and frame rate for the project.

Example:
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Configuring Flash Professional

 

4. Click OK.

NOTE:  All templates should be authored at progressive frame sizes, and the frame
rate should be set to 50 or 60 frames per second.

5. Click File > Publish Settings to open the Publish Settings dialog box.

Example:
 

 

6. From the Player drop-down box, select Flash Player 10.3.

7. Click OK.

8. Save your project.
Harmonic recommends that you save your project in the project folder.

NOTE:  Do not use the following characters in the file name: \ / “ % #.
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Applying ActionScript code to a custom template
In order for your custom template to be controlled by the playout device, the .swf file needs to contain
specific ActionScript code that has been written by Harmonic.

1. In Flash Professional, select File > ActionScript Settings to display the Advanced ActionScript 3.0
Settings dialog box.

2. In the Document Class field, type SampleHarmonicTemplate.

3. From the Source path tab, click the Browse to Path icon to browse to the location where you saved
your template.

4. Select the required folder.
The selected folder appears in the Source path tab, as shown below.
 

 

5. From the Library path tab, click the Add New Path icon.

6. Click the Browse to Path icon to browse to the location where you saved your template, and then
select that location.

NOTE:  Do not delete any folders already listed under the Library path tab. Doing so
could cause the template not to play.

The selected folder appears in the Library path tab, as shown below.
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Customizing ActionScript code

 

7. Verify your settings by clicking the check mark icon to the right of the Document Class field.
A dialog should appear indicating that the definition of the document class was found in the correct
folder.
 

 

Customizing ActionScript code
You can modify the behavior of your template by customizing the ActionScript code.

Implementing a customized action in a template involves the following:

• Editing the Document class field and giving it a unique name (for example, CustomTemplate).
• Customizing the ActionScript of the “CustomTemplate” class.
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To customize the ActionScript code:

1. Set up your Flash project.

2. Click File > ActionScript Settings.

3. In the Document class field, type in a new, unique name, for example CustomTemplate.

4. Click the pencil icon.

Example:
 

 
An ActionScript file opens.

5. Change the value for [public class] to CustomTemplate.

6. Change the value for [extends] to HarmonicTemplate.

7. Type in the custom functionality.

Example:
 

 

8. Save the file using the following file name: CustomTemplate.as.
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Adding an event listener for accessing Flash stage properties

Adding an event listener for accessing Flash stage properties
To detect when the template has been put on the Flash stage, add an event listener to your ActionScript
code.

When you load a template, the playout device controls when the template is added to the Flash stage.
This is different from the Flash player, where the .swf file is attached to the stage immediately. Your
ActionScript code cannot access the stage properties, such as the width or height, until the template has
been added to the Flash stage.

1. Set up your Flash project.

2. In the ActionScript file, change the public class portion of the file to read CustomTemplate.

3. Change the extends portion of the file to read SampleHarmonicTemplate.

4. Add the event listener for accessing Flash Stage properties by extending the ActionScript code, as
shown below:

Example:
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Using Harmonic widgets

The Harmonic Template Widget Library contains Flash components that can be added to Flash projects.

• Applying a Harmonic widget to your Flash project
• Applying advanced text widgets
• Resizing dynamic text fields
• Naming multiple instances of a dynamic text field
• Creating a custom text field widget
• Setting up multiple, unique text fields
• Guidelines for working with text field widgets
• About dynamically loading files in a template
• Applying the anchor override widget

Applying a Harmonic widget to your Flash project
The Harmonic Template Widget Library contains Flash components that can be added to Flash projects.

1. Set up your Flash project.

2. In Flash, click File > Open and select the Template Authoring Package folder.

3. Open the widgets folder, and select the HarmonicTemplateWidgetLibrary.fla.

4. Select the Library tab.
If the Library tab is not available, click Window > Library.

5. Select HarmonicTemplateWidgetLibrary from the library drop-down menu.

Example:
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Applying a Harmonic widget to your Flash project

 

6. Copy the widget you need from the Widget Library.

7. From the Library drop-down menu, open your Flash project library.

8. Paste the widget into your Flash project library.
Once the widget is in your Flash project library, it can be dragged onto the stage and manipulated in
your project. For example, you can re-size the text field widget or change its font, text size, and text
color.

9. Save your file.

CAUTION:  Do not use the following characters in the file name: \ / “ % #.

10. Click File > Publish to publish your file as a .swf file.
The published .swf file is saved to the project folder.

11. Copy the .swf file from the project folder to your configured graphics directory on the video server.

After you copy the .swf file to the graphics directory on the video server, it can be played on your
Spectrum playout device.

Customizing the widget's ActionScript
You can modify the behavior of a widget by editing the ActionScript code that controls it.

IMPORTANT:  Editing the ActionScript is an advanced procedure, and errors could make
the template incapable of being played. Some widgets contain commentary for editing the
ActionScript code correctly.

NOTE:  Your Flash project must be saved in the project folder in order to edit the
ActionScript.

1. In your Flash project, select the Library tab.
If the Library tab is not available, click Window > Library.
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2. Right-click the widget and select Edit Class.
An ActionScript file will appear that can be manipulated as needed.

Applying advanced text widgets
The Harmonic advanced text widgets should be used for languages that contain complex characters, or
right-to-left or bi-directional text.

The Harmonic Template Widget Library contains two advanced text widgets: the Advanced Text Field and
the Advanced Text Scroll. You can add these widgets to a custom or blank Harmonic template. If using a
sample Harmonic template, you can also replace a regular text field or text scroll widget with an advanced
text widget.

IMPORTANT:  You must use Flash Professional CS6 when authoring a template that
contains Harmonic advanced text widgets.

1. Set up your Flash project.

NOTE:  If you are using a Harmonic template and the .fla file is in a folder with other
files that support it, you must copy all the supporting files to the project folder as well.

2. Open the Widget Library and copy the desired advanced text widget to your project library.

3. To replace a regular text widget in a sample Harmonic template, do the following:

a. In the Flash timeline, unlock the layer containing the text scroll, and select the text scroll widget on
the Flash stage.

b. Click Window > Properties to open the Properties dialog box.
c. Click Swap to open the Swap Symbol dialog box.
d. Select the advanced text widget and click OK.

Example:
 

 

4. Drag the advanced text widget to the Flash stage and manipulate it as needed.

38



Applying advanced text widgets

5. Click File > ActionScript Settings.

6. From the Advanced ActionScript 3.0 Settings, click the Library path tab.

7. In the Default Linkage drop-down menu, select Merged into code.

Example:
 

 

8. Save your file.

CAUTION:  Do not use the following characters in the file name: \ / “ % #.

9. Click File > Publish to publish your file as a .swf file.
The published .swf file is saved to the project folder.

10. Copy the .swf file from the project folder to your configured graphics directory on the video server.

After you copy the .swf file to the graphics directory on the video server, it can be played on your
Spectrum playout device.
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Resizing dynamic text fields
The Dynamic Text Field widget is a Flash MovieClip that contains a 100 × 100 text field.

To change the size of a dynamic text field, you must open the MovieClip and edit the width and height of
the contained text field. If you edit the size of the container MovieClip instead of the text field, Flash will
stretch the rendered fonts and thus distort your graphic.

1. Set up your Flash project.

2. Drag the Text Field widget to the stage.

3. Select the widget, and select the Properties tab.

Example:
 

 

4. In the Properties dialog box, resize the text field as needed.

IMPORTANT:  Always edit the internal text field to set the size of the dynamic text field.
Always edit the container MovieClip component to set the position of the text field and
to use it in motion tweens.
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Naming multiple instances of a dynamic text field
Any time you have multiple instances of the same dynamic text field in use in one project, you need to
give each instance of the text field a unique name.

In some cases, you may have several instances of the same dynamic text field template in use in one
project (for example, a Now, Next, and Later template). All dynamic text fields must have an instance
name that adheres to the following rules:

• The instance name for each field must start with the word “field.”
• The instance name must be followed by a number that indicates the box number for the field.
• Optionally, you can include a label in the instance name to help identify the field. Add an underscore

(_) after the number, and then enter the label text.

The following example shows a valid template field instance name: field3_Later.

To rename dynamic text field instances:

1. Set up your Flash project.

2. Drag the text field widget to the stage.

3. Click the widget, and select Properties.

4. In the Instance field, type in the new instance name.

NOTE:  Follow the supplied conventions when naming the instance.

5. Repeat Step 2 through Step 4 to name additional instances of the text field widget used in your
project.

Creating a custom text field widget
Ensure that you have read guidelines for working with text field widgets before you create a custom text
field widget.

1. Set up your custom template in Flash Professional.

2. Copy the text field widget from the library, and paste it into your Flash project library.

3. Rename the text field widget.

Example: Custom Text Field

4. Open the Advanced ActionScript 3.0 Settings dialog box for “Custom Text Field” and then rename
the Document class name.

Example: CustomTextField

5. From the Source path tab, click the Browse to Path icon to browse to the project folder, and then
select it.

6. From the Library path tab, click the Browse to Path icon to browse to the project folder, and then
select it.
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If you are storing your project file in the same location as the Template Authoring Package, you can
type a period to represent the current directory.

7. Drag the text field widget onto the stage and, if desired, edit the widget.
You can re-size the text field and change the display properties (for example the font, text size, and
text color).

IMPORTANT:  The internal text field has an instance name of "harmonicTextField". Do
not change this instance name or the text field type (Classic Text, Dynamic Text). If you
change this information, the widget will not function correctly.

Additional information
Setting up a custom template in Flash Professional on page 30

Setting up multiple, unique text fields
Learn how to set up several instances of a unique text field in one project (for example, each text field has
a different function, shape, or font).

1. Reconfigure the text field widget properties.

2. Copy the reconfigured text field widget for additional instances.

After you’ve copied the widgets, you can alter the text fields as needed.

Reconfiguring the text field widget properties
You must reconfigure a text field widget before you can insert multiple instances of the widget into a
template.

1. Set up your Flash project.

2. Right-click the text field widget and select Properties.
The Symbol Properties dialog box appears.

3. Select Advanced.

4. Type in a new, unique name for this symbol.

Example: For example, CustomTextField_01.

5. Select the Export for ActionScript check box.

6. Copy the text that appears in the Class field ("SampleHarmonicTextfield") and then paste that text into
the Base Class field.

7. In the Class field, type in a new, unique name.

Example: CustomTextField_1
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8. Click OK.
An error message will appear indicating that a definition for the class could not be found in the class
path.
 

 

9. Click OK.

10. Extend the ActionScript file for the custom template as follows:

a. Right-click the widget symbol, and select Edit Class.
An ActionScript file appears.

b. Edit the extends portion of the file to read SampleHarmonicTextField.

Example:
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c. Save the edited ActionScript file in the same location as your .fla file.

The widget can now be copied for additional instances.

Copying a reconfigured text field widget for additional instances
Complete this procedure for each text field instance the template requires.

1. In the Widget Library, tight-click the reconfigured widget and select Duplicate.
The Symbol Properties dialog will appear.

2. Type in a new, unique name for this symbol.

Example: CustomTextField_2

3. Select the Export for ActionScript check box.

4. Copy the text that appears in the Class field ("SampleHarmonicTextField") and then paste that text
into the Base Class field.

Example:
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5. In the Class field, type in a new unique name,

Example: CustomHarmonicTextField_2

6. Click OK.
An error message will appear indicating that a definition for the class could not be found in the class
path.
 

 

7. Click OK.

8. Extend the ActionScript file for the custom template as follows:

a. Right-click the widget symbol, and select Edit Class.
An ActionScript file appears.

b. Edit the extends portion of the file to read SampleHarmonicTextField.

Example:
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c. Save the edited ActionScript file in the same location as your .fla file.

9. Repeat steps 1 - 8 to copy additional instances of the text field widget.

After you have copied the total number of text fields you need, you can drag the text fields onto the stage
and manipulate them as desired.

Guidelines for working with text field widgets
Follow these guidelines to ensure that your text field widgets play correctly.

• Size the text field to match the longest text string you expect that field to display.
• Embed any fonts you intend to use in your Flash project. This will ensure that they render correctly.
• You can add filters, such as a drop shadow, but be aware that these filters may cause the template to

have a longer render time.
• The internal text field of the text field widget has an instance name of “harmonicTextField,” as shown

below.

IMPORTANT:  Do not change this instance name or the text field type (for example,
Classic Text, Dynamic Text). If you do, the widget will not function correctly.
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Figure 4-1: Text field widget properties

About dynamically loading files in a template
To dynamically update a text field or load an image into a template, the file must first be stored in the
graphics directory on the video server.

Before the template can dynamically access a text or image file, the ActionScript code of the template
needs to be edited. Specifically, the pseudo-directory “templates” must be pre-pended to the path of the
file being loaded.

For example, if you wanted to update the text field of a template with the contents of file named
credits.txt, the ActionScript would need to be edited to use the path templates/credits.txt to
load the file.

IMPORTANT:  Editing the ActionScript is an advanced procedure, and errors could make
the template incapable of being played. Some widgets contain commentary for editing the
ActionScript code correctly.

Applying the anchor override widget
The anchor widget allows you to specify the desired anchor point for a template that is smaller than
the full raster size. When used, the widget overrides the default layer anchor point configured in
SystemManager.

For more information about configuring anchor points for graphic layers, refer to "Graphics Anchor" in the
Harmonic SystemManager User Guide.

1. Set up your Flash project.

2. Adjust the stage size to be just large enough to contain the desired graphic.
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IMPORTANT:  With UHD workflows, Harmonic recommends that you use full-size
templates only when necessary. For example, DVE squeezeback and pillar box
templates should be full raster size. This improves performance by reducing the
number of transparent pixels that must be rendered.

3. Add the desired graphic to the template.

4. Open the Widget Library and copy the Anchor Override widget you need, then paste it into your
Flash project library.

5. Drag the Anchor Override widget onto the stage.
You can place the widget anywhere on the stage. The widget becomes transparent when the template
is loaded onto the playout device.

6. Save your file.

CAUTION:  Do not use the following characters in the file name: \ / “ % #.

7. Click File >  Publish to publish your file as a .swf file.
The published .swf file is saved to the project folder.

8. Copy the .swf file to your configured graphics directory on the video server.

About template anchor points
Anchor points enable you to create templates that are smaller than the raster size. This can improve
performance by reducing the number of transparent pixels that must be rendered.

Anchor points can be used across all supported raster sizes, but are particularly important in UHD
workflows. You can configure anchor points per graphic layer in SystemManager or Spectrum
Management. When authoring templates in Flash Professional, you can apply a Harmonic Anchor
Override widget, which overrides the pre-configured layer anchor point.

In the following image, the anchor points are represented by the red squares. The blue squares are an
example of how a small template will be placed when loaded on a layer with the corresponding anchor
point.

NOTE:  If a small template is loaded onto a graphic layer and no anchor point is configured,
the template is positioned in the upper left corner by default.
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Figure 4-2: Anchor points
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Configuring three-point animations

In three-point animation, the template will play the intro and then stay on the loop section until it receives
a command to play the outro.

To enable this functionality, you must provide the following frame labels in Flash:

• A frame label called loop start on the first frame of the looped section.
• A frame label called loop end on the last frame of the looped section.

1. Set up your Flash project.

NOTE:  The Template Authoring Package contains a sample three-point animation in
the Sample templates folder.

2. Click Insert > Timeline > Layer to add a new layer to the project.

3. Double-click the new layer, and give it a title (for example, Loop).

4. On the first frame of the loop section (in other words, the first frame after the end of the introduction),
right-click the timeline and select Insert Keyframe.

Example:
 

 

5. Click Window > Properties > Label, and type loop start in the Name box.

Example:
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The label, "loop start", appears in the timeline.

6. Add a blank keyframe on the last frame of the loop section (in other words, the last frame before the
start of the outro).

7. Click Window > Properties > Label, and type loop end in the Name box.

Example:
 

 
The label, loop end, appears in the timeline.

8. View, edit, or add visual elements to the template as desired.

9. Save your file.
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CAUTION:  Do not use the following characters in the file name: \ / “ % #.

10. Click File > Publish to publish your file as a .swf file.
The published .swf file will be saved to the project folder.

11. Copy the .swf file to your configured graphics directory on the video server.

After you copy the .swf file to the graphics directory on the video server, it can be played on your
Spectrum playout device.
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Authoring DVE templates

The templates that control the DVE(s) must be authored using Adobe® Flash® Professional CS6.
Harmonic recommends starting with one of the blank DVE templates that has been provided in the
Template Authoring Package.

• About Digital Video Effects
• About the Harmonic blank DVE templates
• Using the blank DVE template
• Using the blank Harmonic Dual DVE template
• Editing ActionScript to control DVE properties
• Creating a border on a DVE template
• Creating a full-screen slate reveal
• Using audio duck and mix widgets in a dual DVE template

About Digital Video Effects
A digital video effect (DVE) is where the video is cropped by the SrcRegion, scaled and positioned by the
DstRegion, and then composited with the underlying video.

When a DVE template is played on your Spectrum playout device, it can contain video from a clip,
the Mixer output, or an External input. When you preview your DVE templates in the desktop Flash
environment, the Src Preview represents the input to the DVE.

Figure 6-1: Single DVE

If your Spectrum playout device has been configured for Enhanced Channel mode, you may have up to
two DVEs loaded at once, either as two DVEs in a single template or as single DVEs in two templates.
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A Dual DVE template, for each frame rate and raster size, can be found in the Template Authoring
Package. Dual DVE templates contain the same components as single DVE templates.

DVE output example
View an example of single DVE output in the desktop Flash environment.

Once the Src Region is cropped and the Dst Region is scaled and positioned, a DVE has been created,
as shown below.

Figure 6-2: DVE output in desktop Flash environment

Figure 6-3: Dual DVE output in desktop Flash environment

About the Harmonic blank DVE templates
Understand the components of the blank DVE and blank dual DVE templates.

Layers

The DVE templates contain the following layers on the Flash Professional timeline.
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Layer Description

Actions layer Contains ActionScript code that controls DVE properties.

Src Preview layer A test pattern that represents the input to the DVE; in other words, the video
that will be affected by the DVE template. The screen resolution should match
that of the stage.

Src Region layer A white transparency that represents the portion of the Src Preview that will be
active in the DVE. Essentially, the Src Region is the result of the Src Preview
being cropped.

Dst Region layer A blue transparency that defines how Src Regions are scaled and positioned in
a DVE template.

In the dual DVE template, each DVE has its own Src Preview, Src Region, and Dst Region layers, as
shown below.

Figure 6-4: Dual DVE template layers

IMPORTANT:  The DVE will not work properly if the regions are not sized correctly in
relation to one another. The Src Region should never be larger than the Src Preview. The
Dst Region should never be larger than the Src Region.

Harmonic DVE widgets

The blank DVE templates also contain the following Harmonic DVE widgets:

• DVE Src Preview Region widget
• DVE Src Region widget
• DVE Dst Region widget

IMPORTANT:  All DVE template widgets must be present in the first frame of the template.
Otherwise, the template will not run correctly.

Src region layer
The src region layer represents the portion of the src preview that will be active in the DVE. Essentially,
the src region is the result of the src preview being cropped.

IMPORTANT:  The Src Region should never be larger than the Src Preview.

The following properties of the Src Region are used to crop the DVE:

• x: the x position of the crop
• y: the y position of the crop
• Width: the width of the crop region
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• Height: the height of the crop region

These properties can be accessed by clicking Window > Properties, and then selecting the src region
layer from the timeline. Once the Src Region of the DVE is defined, it can be scaled and defined, the Dst
Region can be scaled and positioned.

Figure 6-5: Src Region cropped to the center 4x3 region of a 16x9 output

IMPORTANT:  If your primary graphics format is NTSC, there may be closed captioning
(CC) present on line 21 of SDI input or from IMX clips. The full 486 line Src Region will
include these lines. To avoid including these lines in the DVE, crop off the top three lines
of the source using the Src Region. Line 0 is above the CC. Line 1 corresponds to line 21,
and line 2 corresponds to line 284 (CC in field 2). To crop the top three lines of the source,
in the Properties dialog for both the Src and Dst Regions, change the y axis value to 3 and
the Height value to 483.

Dst region layer
The dst region layer defines how Src Regions are scaled and positioned in a DVE template.

IMPORTANT:  The Dst Region should never be larger than the Src Region.

The following properties of the Dst Region are used to crop the DVE:

• x: the x position of the crop
• y: the y position of the crop
• Width: the width of the crop region
• Height: the height of the crop region

These properties can be accessed by clicking Window > Properties, and then selecting the dst region
layer from the timeline.
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Figure 6-6: Dst Region of a 4x3 Src Region, scaled and positioned in the lower right corner of the screen

NOTE:  The Dst Region layer is marked by a blue transparency. If necessary, this layer can
be hidden until you are ready to use it. In the timeline, select the Dst Region layer, and click
the show/hide button under the eye.

Figure 6-7: Dual DVE Dst Regions of a 4x3 Src Region, scaled and positioned in the lower corners of the
screen

NOTE:  The Dst Region layer of DVE 0 is marked by a blue transparency; the DST Region
layer of DVE 1 is marked by a green transparency. If necessary, these layers can be hidden
until you are ready to use them. In the timeline, select the Dst Region layers, and click the
show/hide button under the eye.

Src preview layer
The src preview layer represents the input to the DVE; in other words, it represents the video that will be
affected by the DVE template.

In the sample Harmonic DVE templates, the src preview layer is represented by a test pattern, as shown
below.
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Figure 6-8: Src preview layer test pattern

Since the src preview layer is a preview of the input of the DVE, its screen resolution should match the
screen resolution of the stage.

NOTE:  In each blank DVE template, the src preview layer is already properly configured
for the corresponding raster size, and the layer is locked.

The input to the DVE depends on the Spectrum module you are using and the channel mode you have
configured. Refer to the following table:

Table 6-1: ChannelPort 8100 module

Standard Channel Enhanced Channel

• Player
• External In
• Mixer Output

• Player A, B
• External In 1, 2
• Mixer Output

Table 6-2: ChannelPort 8200 module

Standard Channel Enhanced Channel

• Player
• External In 1, 2
• Mixer Output

• Player A, B
• External In 1-6
• Mixer Output

Table 6-3: Spectrum X

Standard Channel Enhanced Channel UHD

• Player
• External In 1, 2
• Mixer Output

• Player A, B
• External In 1-6
• Mixer Output

• Player
• External In 1, 2
• Mixer Output
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Using the blank DVE template
Learn how to use a blank Harmonic DVE .fla file to crop a 16:9 image to a 4:3 image and position that
on the bottom right corner of the screen.

Before you begin

NOTE:  Before beginning a template project, verify your raster size and frame rate.

1. From the Template Authoring Package, open the samples folder.

2. Open the sources folder.

3. Open the folder for the raster size and frame rate you want to work in, and copy the blank-dve.fla
file from that folder to the project folder.

4. In Flash Professional, open the blank-dve.fla file you copied to the project folder.

TIP:  To hide the Dst Region until you are ready to configure it, in the timeline, click the
show/hide button under the eye.

5. Use the Src Region to define the crop area:

a. In the timeline, click src region.
b. On the Flash stage, select the Src Region.
c. Click and drag the corner of the free transform box to set the 4x3 area.

6. In the timeline, for all layers, right-click the last frame of the DVE transition, and select Insert Frame.

Example:
 

 

7. In the timeline, click dst region.
If the Dst Region was previously hidden, in the timeline, click the show/hide button under the eye.

8. In the timeline of the dst region layer, right-click the timeline, and select Create Motion Tween.

9. Click and drag the blue transparency to animate, or scale and position, the Dst Region, as illustrated
below.

Example:
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Figure 6-9: Before scaling and positioning

Figure 6-10: After scaling and positioning

NOTE:  The Dst Region can also be scaled and positioned using the Properties dialog.
Click Windows > Properties, and the select the Dst Region layer.

10. Set the animation to stop on the last frame (otherwise, the DVE transition will continually loop).

a. In the Timeline of the actions layer, right-click the last frame and select Insert Blank Keyframe.
b. Right-click the newly created blank keyframe and select Actions.
c. In the ActionScript editor, on line 1, type stop();, as shown below.

Example:
 

 
d. Close the ActionScript editor.

11. If you have not already done so, save your file.

12. Click File > Publish to publish your file as a .swf file.
The published .swf file will be saved to the project folder.

13. Copy the .swf file from the project folder to your configured graphics directory on the video server
to preview it.

NOTE:  Unless you change the properties of the Actions layer, the DVE template will
display the SDI Input the first time it is played.
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Using the blank Harmonic Dual DVE template
In this procedure, learn how to use a blank Harmonic Dual DVE .fla file to create a “side-by-side” DVE.

To take advantage of Dual DVE functionality, you can create two single DVE templates, and load each
template on a different graphics layer to control the DVEs. Or, you can control two DVEs from a single
template by modifying the blank Dual DVE .fla file in the Template Authoring Package. Dual DVE
templates are available in each supported raster size and frame rate. The Template Authoring Package
also contains sample Dual DVE templates that you can view.

Before you begin
Before beginning your project, verify your raster size and frame rate.

1. From the Template Authoring Package directory, open the samples folder.

2. Open the sources folder.

3. Open the folder for the raster size and frame rate you want to work in.

4. Copy the blank-dual-dve.fla file from that folder to the project folder.

5. In Flash Professional, open the blank-dual-dve.fla file you copied to the project folder.
The timeline contains the SrcPreview, SrcRegion, and DstRegion layers for each DVE.

Example:
 

 
The Dual DVE template will appear on the Flash stage, as shown below.
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6. Position the DVE 0 Dst Region (marked by a blue transparency) off to the left side of the stage, as
follows:

a. In the timeline, click dve 0 dst region.
b. On the Flash stage, select DVE 0 Harmonic Dst Region.
c. Click and drag the object to the left side of the screen.

7. Resize DVE 1 Dst Region (marked by a green transparency) to fill the entire Flash stage, as follows:

a. In the timeline, click dve 1 dst region.
b. On the Flash stage, select DVE 1 Harmonic Dst Region.
c. In the Properties tab, set the x axis value to 0, the y axis value to 0, the width value to the

horizontal size of the stage, and the height value to the vertical size of the stage.

Your stage should appear as shown below.
 

 

8. In the timeline, for all layers, right-click the last frame of the Dual DVE transition, and select Insert
Frame.

Example:
 

 

9. Create the transition for DVE 0, as follows:

a. In the timeline of the dve 0 dst region layer, right-click the timeline and select Create Motion
Tween.

b. On the last frame, position the dve 0 dst region, as shown below.
The orange line represents the path of DVE 0.

Example:
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10. If you have not already done so, save your file.

11. Set the animation to stop on the last frame (otherwise, the DVE transition will continually loop).

a. In the Timeline of the actions layer, right-click the last frame and select Insert Blank Keyframe.

Example:
 

 
b. Right-click the newly created blank keyframe and select Actions.
c. In the ActionScript editor, on line 1, type stop();, as shown below.

Example:
 

 
d. Close the ActionScript editor.

12. Select the sources for each DVE, as follows:

a. In the timeline of the actions layer, right-click the first frame and select Actions.

Example:
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b. In the ActionScript editor, locate the commented out ActionScript code titled DVE Source Select.
c. Uncomment the Source Select that you want for DVE 0 and DVE 1, as shown below.

The input to the DVE can be an External input, a clip player, or the mixer output.

Example:
 

 
d. Close the ActionScript editor.

13. Click File > Publish to publish your file as a .swf file.
The published .swf file is saved to the project folder.

14. Copy the .swf file from the project folder to your configured graphics directory on the video server
to preview it.
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Editing ActionScript to control DVE properties
Harmonic DVE templates contain ActionScript code that can be edited to control various properties of a
DVE.

1. From the Template Authoring Package, open the samples folder.

2. Open the sources folder.

3. Open the folder for the raster size and frame rate you want to work in, and then copy the blank DVE
.fla file from that folder to the project folder.

4. In Flash Professional, open the .fla file you copied to the project folder.

5. Edit your DVE template as desired.

6. In the DVE template timeline, on the actions layer, right-click the first frame.

Example:
 

 

7. Select Actions.
You can also access the ActionScript by selecting the actions layer and then Window > Actions.
An ActionScript file appears, as shown below.
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8. To edit a property of the DVE template, uncomment that property, as shown below.

Example:
 

 
In this example, the boolean value for enabling/disabling the DVE Hole Punch Technology (HPT) has
been uncommented to “false" (disabled).

NOTE:  The ActionScript code has been commented to reveal the default values for
each property.

9. Close the ActionScript window.
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10. If you have not already done so, save your file.

11. Click File > Publish to publish your file as a .swf file.
The published .swf file will be saved to the project folder.

12. Copy the .swf file from the project folder to your configured graphics directory on the video server
to preview it.

DVE properties: enable
This DVE property is a boolean property that enables/disables the DVE.

• True: the DVE is enabled (default)
• False: the DVE is disabled

DVE properties: srcSelect
This DVE property controls the input source of the DVE.

Value Description

SRC_UNSPECIFIED The source is unspecified.

NOTE:  This is the default value. However, the first time
a DVE template is used, it will display an External Input.

SRC_PLAYER The source is a player. In Enhanced Channel mode, you may set the
source to SRC_PLAYER_A or SRC_PLAYER_B.

SRC_EXTERNAL_IN The source is an external input. If your Harmonic playout device is
configured for Enhanced Channel, you may specify which external input
to use, for example:

• EXTERNAL_IN_1
• EXTERNAL_IN_2

SRC_MIXER_OUTPUT The source is the mixer output.

DVE properties: enableHPT
When a DVE template is loaded on a graphics layer, a region in all the graphics layers below that
template is cleared so that the DVE can be seen. This functionality is called Hole Punch Technology
(HPT).

In the following example, if a DVE template is loaded on graphics layer 3 with HPT enabled, a transparent
region will be created on graphic layers 2 and 1. Essentially graphic layers 2 and 1 will be “under” the
DVE and, as a result, not visible. Any templates placed on graphic layers 4 through 8 will be visible
“above” the DVE.

This DVE property is a boolean property:

• True: HPT is enabled (default)
• False: HPT is disabled.

Example: DVE HPT enabled
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DVE properties: dveBlendMode
This DVE property controls how alpha is applied to the DVE.

• BLEND_WITH_VIDEO: (Default) The alpha value of the Dst Region is applied to the DVE and affects
how the DVE blends with the underlying video.

• BLEND_WITH_GRAPHICS: The inverse of the alpha value of the Dst Region is applied to the DVE, and
the inverse of the alpha value is applied to the regions of the lower layers affected by the DVE. The
DVE alpha value is set to 100% to achieve a semi-transparent DVE over graphics.

NOTE:  To control the alpha value when authoring a DVE, click the Dst Region on the
Flash stage, and then click Windows > Properties > Color Effect, and from the Style
drop-down menu, select Alpha.

Example:  BLEND_WITH_VIDEO

If a DVE template is loaded on graphics layer 1, and the dveBlendMode is set to BLEND_WITH_VIDEO,
the DVE will blend with the video layer. The amount of blending is dependent on the alpha value set on
the Dst Region.
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Example: BLEND_WITH_GRAPHICS

If a DVE template is loaded on graphics layer 2, and the dveBlendMode is set to
BLEND_WITH_GRAPHICS, the DVE will blend with the full-screen slate loaded on graphics layer 1, and
the video layer will be totally obscured. The amount of blending is dependent on the alpha value set on
the Dst Region.

 

 

DVE properties: stackPos
This DVE property controls where the DVE is located relative to other graphics in the template.

• AUTO_STACK_POS: (Default) The DVE is positioned depending on where the DST Region layer is
located in the timeline of the template.

• BOTTOM_MOST_STACK_POS: Places the DVE below all other graphics in the template. Any graphics
above the DVE will be seen.

• TOP_MOST_STACK_POS: Places the DVE above all other graphics in the template. Any graphics below
the DVE will not be seen.
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In the blank Harmonic DVE template, the DST Region is by default the first layer in the timeline, as shown
below.

Figure 6-11: DST Region in template timeline

If no changes are made, the auto-stack property sets the DST Region to TOP_MOST_STACK_POS.
If a new layer is placed above the DST Region, the auto-stack property sets the DST Region to
BOTTOM_MOST_STACK_POS.

The stackPos property can be used to create a border on a DVE or to create a full-screen slate reveal.

When Dual DVEs are used with other graphics in a template, and both DVEs have the same stack
position (in other words, if both DVEs are above or below other graphics), the stackPos property will
determine the stacking order of the DVEs in relation to the other graphics in the template.

DVE properties: relativePos
This DVE property is an integer property that defines the stacking position of a DVE relative to another
DVE in the template.

NOTE:  This property only applies when Dual DVE templates are used with other graphics
in the template, and both DVEs have the same stack position (in other words, if both DVEs
are above or below other graphics in the template).

• AUTO_RELATIVE_POS: The DVEs will be positioned depending on where the DST Region layer for
each DVE is located in the timeline of the Dual DVE template.

For example, if the dve 0 dst region is above the dve 1 dst region in the timeline of the template,
DVE 0 will be stacked above DVE 1.

• RELATIVE_POS_0: The DVE will be positioned above the other DVE in the template.
• RELATIVE_POS_1: The DVE will be positioned below the other DVE in the template.

Creating a border on a DVE template
A DVE template can be authored to contain a border around the DVE.

The border graphic must be contained in a separate layer on the timeline of the DVE template, and the
Dst Region should be set to BOTTOM_MOST_STACK_POS.

1. From the Template Authoring package directory, open the samples folder.

2. Open the sources folder.
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3. Open the folder for the raster size and frame rate you want to work in, and copy the blank DVE .fla
file from that folder to the project folder.

4. In Flash Professional, open the .fla file you copied to the project folder.

5. Edit and animate (scale and position) the Dst Region as desired.

6. Right-click the first frame of the actions layer, and select Actions.
An ActionScript file opens.

7. In the ActionScript file, uncomment the entry for BOTTOM_MOST_STACK_POS.

8. In the timeline, create a new layer above the Dst Region layer, and call it border.

9. Edit and animate the border to match the editing and animation of the Dst Region.

10. If you have not already done so, save your file.

11. Click File > Publish to publish your file as a .swf file.
The published .swf file will be saved to the project folder.

12. Copy the .swf file to your configured graphics directory on the video server to preview it.

When this DVE template is played, the border will appear above the DVE.

Creating a full-screen slate reveal
A DVE template can be authored to reveal a full-screen slate.

The Dst Region should be set to the TOP_MOST_STACK_POS.

1. From the Template Authoring package directory, open the samples folder.

2. Open the sources folder.

3. Open the folder for the raster size and frame rate you want to work in, and copy the blank DVE .fla
file from that folder to the project folder.

4. In Flash Professional, open the blank DVE .fla file you copied to the project folder.

5. Edit and animate (scale and position) the Dst Region as desired.

6. Right-click the first frame of the actions layer, and select Actions.
An ActionScript file opens.

7. In the ActionScript file, uncomment the entry for TOP_MOST_STACK_POS.

8. If you have not already done so, save your file.

9. Click File > Publish to publish your file as a .swf file.
The published .swf file will be saved to the project folder.

10. Copy the .swf file to your configured graphics directory on the video server to preview it.

IMPORTANT:  When using FXTool or PreviewTool to preview the full-screen slate
reveal, place the DVE template on a layer above the full-screen slate template.
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Using audio duck and mix widgets in a dual DVE template
You can use audio duck and mix widgets to create a template in which the audio is lowered in one DVE
and raised in the other.

Consider the following scenario: DVE 1 is active, full-screen with audio. DVE 0 comes in from the left-
side of the screen and causes DVE 1 to “squeeze back.” When DVE 0 comes in, its audio is “mixed” in,
and the audio of DVE 1 is “ducked.” After a few moments, DVE 0 is “squeezed off” the screen, and DVE
1 returns to full screen. When DVE 0 is removed, its audio is “ducked,” and the audio of DVE 1 is “mixed”
back in.

The sample Harmonic dual DVE side-by-side template already contains the audio widgets.

1. From the Template Authoring Package directory, open the samples folder.

2. Open the sources folder.

3. Open the folder for the raster size and frame rate you want to work in, and copy the blank-dual-
dve.fla file from that folder to the project folder.

4. In Flash Professional, open the blank-dual-dve.fla file you copied to the project folder.

5. Click File > Open and select the Template Authoring Package.

6. Open the widgets folder, and open the HarmonicTemplateWidgetLibrary.

7. From the Library tab, select HarmonicTemplateWidgetLibrary.fla from the library drop-down
menu, as shown below.
If the Library tab is not available, click Window > Library.

Example:
 

 

8. From the Dual DVE Components folder in the Widget Library, open the DVE 0 and DVE 1 folders,
copy the Audio Duck and Mix Level widgets, and paste them into the corresponding folder in your
Dual DVE project library.
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9. Drag each audio widget for each DVE just off the Flash stage.
If you do place them on the stage, the widgets will not be displayed on the output of the playout
device.

10. If you want to create an audio effect (in other words, make the audio slowly fade in or out), add a new
layer in the timeline and create a motion tween for the widget.

11. To set the decibel levels, adjust the alpha for each widget as follows:

a. Select each widget you want to adjust, and click Window > Properties.
b. Select Color Effect, and from the Style drop-down menu, select Alpha.
c. Set the alpha as desired.

12. Make any other changes you need, and save your work.

13. Click File > Publish to publish your file as a .swf file.
The published .swf file will be saved to the project folder.

14. Copy the .swf file to your configured graphics directory on the video server to preview it.

Alpha settings for decibel levels
When an audio duck level or audio mix level widget is applied to a template, the decibel level is controlled
by the alpha settings of the widget.

Alpha Value Decibel (dB) Audio Effect
0.0 -100 dBo dB no volume

0.5 -50 dB low volume

1.0 0 dB full volume
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Using the Monitor Out template

The Monitor Out template allows you to display active player and mixer information for your channel
superimposed over your primary output while playing a clean output to air over the secondary output.

• Customizing the Monitor Out template
• Guidelines for customizing the Monitor Out template

Customizing the Monitor Out template
To create your own Monitor Out template, start with the sample template provided in samples/
sources/[raster_size]/MonitorOut, and then customize the ActionScript and the timecode text
field.

Monitor Out information can include the mixer state, player name, player state, player looping, clip name
(for loaded and cued clips), time until next clip, a player preview generated by the DVE, transport status
(PLAY, REW, FF, PAUSE, IDLE), and timecode.

NOTE:  The Monitor Out functionality is not supported for a UHD channel.

Modifying the ActionScript
The CustomMonitorOut class is ActionScript code that defines the main document class for the template.

The CustomMonitorOut class is derived from MonitorOut, which is then derived from HarmonicTemplate.

TIP:  The HarmonicMonitorOutStandard.as or
HarmonicMonitorOutEnhanced.as ActionScript files can be used as a reference for
customizing the Monitor Out template.

NOTE:  The MonitorOut class code is included in the sample, but it is not intended to be
modified.

• In the CustomMonitorOut class code, modify the following four functions:
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Function Description

constructor Add any initialization code here to the template. This will be dependent on
your customization. Make sure that the super() function is called so that
base class constructors get called.

getTimecode-
BackgroundColor

Defines the background color of the rendered timecode.

getTimecode-
BackgroundAlpha

Defines the background alpha of the rendered timecode

handleKeyValue This function is the main interface for handling the dynamic portion of the
Monitor Out functionality. During run-time, the playout device will send
information to the template via the updateTextField function located
in the MonitorOut base class. The base class will parse the string and
separate the contents into "key/value" pairs. It will then call the overridden
handleKeyValue function that you will need to implement.

In the header of the MonitorOut.as file, fill in the desired behavior for Key/
Value pairs. You only need to use the key/value pairs that are applicable to
your configuration. There is a section for the Standard Channel configuration
as well as the Enhanced Channel configuration.

Customizing the Timecode text field
The properties this text field determine the x, y, width, height, foreground color, foreground alpha,
background color, and background alpha of the rendered timecode. This information is queried once the
template is loaded by the Monitor Out feature.

Modify the timecode text field properties as follows:

Option Description

x Use the Flash editor to position the text field at the desired location.

y Use the Flash editor to position the text field at the desired location.

width Use the Flash editor to set the width of the text field to the desired size.

NOTE:  The internally rendered timecode will attempt to fill
this space. As a result, what is viewed in the Flash editor will
not be the same as what is rendered by the playout device.

height Use the Flash editor to set the height of the text field to the desired size.

NOTE:  The internally rendered timecode will attempt to fill
this space. As a result, what is viewed in the Flash editor will
not be the same as what is rendered by the playout device.

foreground color In the Flash editor, use the Color property of the text field to set the
foreground color.

foreground alpha In the Flash editor, use the Color property of the text field to set the
foreground alpha.

75 Spectrum 8.2 Template User Guide



Chapter 7: Using the Monitor Out template

Option Description

background color To change the background color, edit the main CustomMonitorOut
document class by clicking on the stage and then clicking the pencil icon
on the Document class. The background color value is located in the
getTimecodeBackgroundColor function. The return value is a 24-bit RGB
value. Examples: Red = 0xFF0000, Green = 0x00FF00, Blue = 0x0000FF.

background alpha To change the background alpha, edit the main CustomMonitorOut
document class by clicking on the stage and then clicking the pencil icon
on the Document class. The background alpha value is located in the
getTimecodeBackgroundAlpha function. The return value is a number: 0.0 =
transparent, 1.0 = opaque

Guidelines for customizing the Monitor Out template
Follow these guidelines for customizing the Monitor Out template.

• Create the graphical assets inside a MovieClip (one MovieClip for each asset).
• Drag the movie clip onto the stage and provide it an instance name. This will allow it to be accessed

from the ActionScript.
• In the CustomMonitorOut constructor:

◦ Get references to the graphical assets by using the DisplayObjectContainer::getChildByName()
function. The name should be the same as the instance name provided in the guideline above.

◦ Store the reference in a member variable so that it can be accessed later.
◦ Set the visible property on all MovieClip objects to false. This makes all graphical assets invisible.

• In the CustomMonitorOut::handleKeyValue() function:

◦ Create a switch statement on the 'key' MovieClip.
◦ Add code to set the visible property of the stored MovieClip objects based on the 'value' parameter.
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Using external key/fill

Spectrum modules that have been licensed for Enhanced Channel mode support a single or dual pair of
external Key/Fill inputs.

• About external key/fill
• Configuring external key/fill
• Key/fill limitations, restrictions, and notes

About external key/fill
When external key/fill input is activated, live video content received on the external inputs of a Spectrum
module can be placed on any graphics layer, and then be blended and stacked with other supported
graphics content.

The per-pixel transparency of the Fill input is determined by the per-pixel luma of the Key input, with black
corresponding to fully transparent, and white corresponding to fully opaque.

Figure 8-1: External key/fill diagram

You can control external Key/Fill inputs using the Key/Fill files that are available in the Template Authoring
Package. The following files are included:

File Description

extkeyfill.ekf Does not specify an input pair. Can be used on ChannelPort
8100 or 8200 modules. If loaded on an 8200 module,
extkeyfill.ekf will select Key/Fill pair 1 by default.
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File Description

extkeyfill1.ekf Specifies Key/Fill input pair 1 on ChannelPort 8200 modules and
Spectrum X. Can be used on ChannelPort 8100 modules.

extkeyfill2.ekf Specifies Key/Fill input pair 2 on ChannelPort 8200 modules and
Spectrum X.

NOTE:  If two Key/Fill pairs are used, only one pair can be active at one time.

You can load a Key/Fill template on any graphic layer, with other graphics above or below it. Refer to the
following diagram.

Figure 8-2: Layering extkeyfill.ekf

Configuring external key/fill
Your Spectrum module must be licensed for Enhanced Channel mode in order to configure this feature.

Refer to “Enabling Enhanced Channel Mode” in the Harmonic SystemManager User Guide for information
on configuring your Spectrum device for Enhanced Channel.

1. Connect external sources of Key and Fill inputs to the correct external inputs on the rear panel.

IMPORTANT:  The incoming video content for both Key and Fill inputs must be
reference aligned and in the same video output format as the primary video output
format of the playout device.

2. From the Template Authoring Package directory, open the external-key-fill folder.

3. Copy the necessary extkeyfill.ekf file, and paste it into the graphics directory on your Spectrum
video server.
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You may now load the extkeyfill.ekf file onto any layer to preview the Key/Fill input in FXTool or
PreviewTool.

External key/fill module inputs
Find Key/fill inputs for the ChannelPort 8100, 8200 and the Spectrum X.

Module Key Fill

ChannelPort 8100 External IN 1 External IN 2

ChannelPort 8200 and
Spectrum X

External IN 1 (Key 1)

External IN 4 (Key 2)

External IN 2 (Fill 1)

External IN 5 (Fill 2)

Key/fill limitations, restrictions, and notes
Key and Fill inputs that are not reference aligned and in the same format as the primary video output
format of the playout device are not supported.

For ChannelPort 8200 modules: If you have inputs on both Key/Fill pairs and you load
extkeyfill1.ekf and extkeyfill2.ekf, the key/fill pair on the higher layer will be the one
displayed in the output.

If your Spectrum X or ChannelPort is configured for Independent Branding mode, external Key/Fill is
supported on the HD output, but will not show on the SD output. External key/fill will only be shown on the
SD output if all of the following are true:

• The playout device is configured for Enhanced Channel
• SD is the primary video output format
• External key/fill inputs are reference aligned and in an SD format identical to the primary SD video

output

While SD-native formats are defined by non-square pixel aspect ratios, graphics played out on your
Spectrum module are rendered in square-pixel resolutions. When external Key/Fill inputs are applied
to SD formats, edge softening and other rendering artifacts may be visible in content that has high-
frequency characteristics along the horizontal axis. These artifacts may be more visible in 16:9 SD
formats than in 4:3 SD formats because of the difference in pixel aspect ratios. For best results when
applying external Key/Fill content to SD formats, minimize high-frequency transitions in the Key/Fill
content.
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Creating Flash videos and MPEG-4 files

Your Spectrum playout device supports templates encoded as Flash Video (.flv) files with alpha
(transparency) and MPEG-4 (.mp4) files.

• Creating a Flash video file with Alpha using Media Encoder CS6
• Creating a Flash video file with Alpha using After Effects CS6
• About MPEG-4 layering
• Creating an MPEG-4 file using Media Encoder CS6
• Creating an MPEG-4 file using After Effects CS6
• Creating a UHD MPEG-4 file in After Effects CC and Media Encoder CC

Creating a Flash video file with Alpha using Media Encoder CS6
You can use Media Encoder CS6 to encode a large sequence of image files (for example, .tga files) that
will be exported as a .flv file with alpha and played as a graphic template.

1. In Media Encoder, click File > Add Source, and choose the necessary file(s).

NOTE:  If you are adding an image sequence, in the Open dialog box, click the first file
in the sequence, and select the Enable Sequence check box.

2. From the Format drop-down menu, select FLV.

3. From the Preset drop-down menu, select the appropriate resolution and frame rate, and then click
OK.

NOTE:  The highest resolution available for .flv files is 1920 x 1080. If the .flv
template will be used in UHD output, be sure that you have configured anchor points
per layer so that the template will be loaded in the desired position.

4. Click FLV to open the Export Settings dialog box.

5. In the Export Settings dialog, configure the following settings:

a. Select the check box for Export Video.
b. If you do not want to export audio with your file, clear the check box for Export Audio.
c. Ensure that Use Maximum Render Quality is cleared (default).
d. Ensure that Use Frame Blending is cleared (default).

Example:
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6. On the Filters tab, make sure the check box for Gaussian Blur is cleared (default).

7. On the Video tab, configure the following settings:

a. Select the check box for Encode Alpha Channel.
b. Make sure the check box for Resize Video is cleared (default) or is set to the target resolution.
c. From the Frame Rate drop-down menu, select the necessary frame rate.
d. Make sure the check box for Render at Maximum Depth is cleared (default)

Example:
 

 

8. On the Video tab, scroll down to the Bitrate Settings, and make sure the check box for VBR is
selected (default).

9. On the Video tab, scroll down to the Advanced Settings, and configure the following settings:
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a. Select the check box for Set Key Frame Distance, and set the Key Frame Distance to 72.

NOTE:  A key frame distance of 72 frames is suitable for most videos; however,
you may adjust the key frame distance based on the content of the video. For
instance, for motion-heavy video, a shorter key frame distance increases the visual
quality. Bear in mind that a shorter key frame distance also results in a larger file
size, while a longer key frame distance reduces the file size.

b. Select the check box for Simple Profile.
c. Make sure the Undershoot [% target] is set to 90 (default).
d. From the Quality drop-down box, select Best.

10. If you want to include audio with your file, click the Audio tab and then configure the following
settings:

a. In the Basic Audio Settings area, for Output Channels, make sure Stereo is selected (default).
b. In the Bitrate Settings area, from the Bitrate drop-down menu, select 128 (default).

11. Click OK.

12. From the Queue area, click Start Queue.
You can view the encode process from the Encoding area.

Example:
 

 

13. When the encode is complete, copy the .flv file to your configured graphics directory on the video
server.

The .flv file can now be played on your Spectrum playout device.
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Creating a Flash video file with Alpha using After Effects CS6
You can use After Effects CS6 to encode a large sequence of image files (for example, .tga files) that
will be exported as an .flv file with alpha and played as a graphic template.

1. In After Effects, select Composition > New Composition.

2. In the Composition Settings dialog, select the appropriate resolution, frame rate, and duration.

NOTE:  The highest resolution available for .flv files is 1920 x 1080. If the .flv
template will be used in UHD output, be sure that you have configured anchor points
per layer so that the template will be loaded in the desired position.

Example:
 

 

3. Click OK.

4. Select File > Import > File.

NOTE:  If you are adding an image sequence, in the Open dialog box, click the first file
in the sequence, and select the Enable Sequence check box.

5. In the Project area, right-click the imported sequence, and select Interpret Footage > Main.

6. In the Interpret Footage dialog box, make sure the value for Assume this frame rate matches the
target frame rate.

7. Drag your new composition to the Render Queue area.

8. From the Output Module drop-down menu, select FLV with Alpha.

9. Click FLV with Alpha to open the Output Module Settings dialog box.

10. Configure the following settings:

a. Select the check box for Include Source XMP Metadata.
b. If you do not want to export audio with your file, clear the check box for Audio Output.
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Example:
 

 

11. In the Video Output area, from the Color drop-down menu, select Straight (Unmatted).

12. In the Video Output area, click Format Options to open the FLV Options dialog box.

Example:
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13. In the Bitrate Settings area, configure the following settings:

a. Select VBR bitrate encoding.
b. Set the Bitrate to 5,404 kbps.

14. In the Advanced Settings area, configure the following settings:

a. Select the check box for Set Key Frame Distance, and set the Key Frame Distance to 72.

NOTE:  A key frame distance of 72 frames is suitable for most videos; however,
you may adjust the key frame distance based on the content of the video. For
instance, for motion-heavy video, a shorter key frame distance increases the visual
quality. Bear in mind that a shorter key frame distance also results in a larger file
size, while a longer key frame distance reduces the file size.

b. Select the check box for Simple Profile.
c. From the Quality drop-down menu, select Best.

15. If you want to include audio with your file, do the following:

a. Click Format Options.
b. Click the Audio tab.
c. In the Bitrate Settings area, from the Bitrate drop-down menu, select 128 (default).

16. Click OK to close the FLV Options dialog box.

17. Click OK to close the Output Module Settings dialog box.
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18. Select the Render Queue tab, and then double-click the Output To field to name the file.

NOTE:  If the Render Queue tab is not available, go to Window > Render Queue.

19. Select the Render check box for your composition, and then click Render.

Example:
 

 

20. When the encode is complete, copy the .flv file to your graphics directory on the video server.

The .flv file can now be played on your Spectrum playout device.

About MPEG-4 layering
The format .mp4 (MPEG-4) is a wrapper format for a video file that has been encoded with the H.264
encoding process.

The following figure a sample method of layering graphics using an .mp4 file and other template types.

Figure 9-1: Layering .mp4 file
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Creating an MPEG-4 file using Media Encoder CS6
You can use Media Encoder CS6 to encode a large sequence of image files (for example, .tga files) as
an .mp4 file that can be played as a full-screen opaque graphic template or video.

1. In Media Encoder, click File > Add, and choose the necessary file(s).

NOTE:  If you are adding an image sequence, in the Open dialog box, click the first file
in the sequence, and select the Enable Sequence check box.

2. From the Format drop-down menu, select H.264 (Legacy).

3. Click H.264 (Legacy) to open the Export Settings dialog box.

4. In the Export Settings area, configure the following settings:

a. Select the check box for Export Video.
b. If you do not want to export audio with your file, clear the check box for Export Audio.

5. On the Filters tab, make sure the check box for Gaussian Blur is cleared (default).

6. From the Multiplexer tab, configure the following settings:

a. From the Multiplexing drop-down menu, select MP4.
b. From the Stream Compatibility drop-down menu, select Standard.

Example:
 

 

7. From the Video tab, configure the following settings:

a. In the Basic Video Settings area, from the Profile drop-down menu, select Main.
b. From the Level drop-down menu, select 4.1.
c. From the Frame Rate drop-down menu, select the appropriate frame rate.

NOTE:  Media Encoder CS6 does not support 3840x2160 .mp4 files at 50 or 59.94
Hz.

87 Spectrum 8.2 Template User Guide



Chapter 9: Creating Flash videos and MPEG-4 files

d. If necessary, change the Frame Width.
The Frame Height changes automatically based on your selection.

e. Make sure the check box for Render at Maximum Depth is cleared (default).
f. In the Bitrate Settings area, from the Bitrate Encoding drop-down menu, select VBR, 1 Pass.
g. Set the Target Bitrate to 32 Mbps.
h. Set the Maximum Bitrate to 40 Mbps.
i. In the Advanced Settings area, make sure that the check box for Set Key Frame Distance is

cleared (default).

Example:
 

 

8. If you want to include Audio with your file, click the Audio tab, and configure the following settings:

a. In the Audio Format Settings area, for Audio Format, select AAC (default).
b. In the Basic Audio Settings area, from the Codec drop-down menu, make sure AAC is selected

(default).
c. From the Output Channels drop-down menu, select Stereo (default).
d. From the Frequency drop-down menu, select 48 kHz (for best performance).
e. From the Audio Quality drop-down menu, select High (default).
f. In the Bitrate Settings area, from the Bitrate drop-down menu, select 56 (default).
g. In the Advanced Settings area, for Precendence, select Frequency (default).

9. Click OK.

10. In the Queue area, click Start Queue.
You can view the encode process from the Encoding area.

11. When the encode is complete, copy the MPEG-4 file to your graphics directory on the video server.

The .mp4 file can now be played on your Spectrum playout device.
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Creating an MPEG-4 file using After Effects CS6
You can use After Effects CS6 to encode a large sequence of image files (for example, .tga files) as an
.mp4 file that can be played as a full-screen opaque graphic template or video.

1. In After Effects, select Composition > New Composition.

2. Select the appropriate resolution, frame rate, and duration.

NOTE:  After Effects CS6 does not support 3840x2160 .mp4 files at 50 or 59.94 Hz.

Example:
 

 

3. Click OK.

4. Select File > Import > File.

NOTE:  If you are adding an image sequence, in the Open dialog box, click the first file
in the sequence, and select the Enable Sequence check box.

5. In the Project area, right-click the imported sequence, and select Interpret Footage > Main.

6. In the Interpret Footage dialog box, make sure the field for Assume this frame rate matches the
target frame rate.

7. Drag your new composition to the Render Queue area.

8. From the Output Module drop-down menu, select H.264.

9. Click H.264 to open the Output Module Settings dialog box, and then configure the following
settings:

a. Select the check box for Include Source XMP Metadata.
b. If you do not want to export audio with your file, clear the check box for Audio Output.

Example:
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10. In the Video Output area, click Format Options to open the H.264 Options dialog box.

11. From the Multiplexer tab, configure the following settings:

a. From the Multiplexing drop-down menu, select MP4 (default).
b. From the Stream Compatibility drop-down menu, select Standard (default).

Example:
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12. From the Video tab, configure the following settings:

a. In the Bitrate Settings area, for Bitrate Encoding, select VBR, 1 Pass.
b. For Target Bitrate [Mbps], select 32.
c. For Maximum Bitrate [Mbps], select 40.

Example:
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13. If you want to include audio with your file, do the following:

a. From the drop-down menu, select 48.000 KHz (for best performance).
b. Click Format Options.
c. In the Basic Audio Settings area, from the Codec drop-down menu, select AAC (default).
d. From the Audio Quality drop-down menu, select High (default).
e. In the Advanced Settings area, for Precedence, select Frequency.

14. Click OK to close the H.264 Options dialog box.

15. Click OK to close the Output Module Settings dialog box.

16. Select the Render Queue tab, and double-click the Output To field and name the file.
If the Render Queue tab is not available, clickWindow > Render Queue. The Render Queue tab will
appear at the bottom of the screen.

17. Select the Render check box for your composition, and click Render.

18. When the encode is complete, copy the .mp4 file to your graphics directory on the video server.

The .mp4 file can now be played on your Spectrum playout device.
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Creating a UHD MPEG-4 file in After Effects CC and Media
Encoder CC
If you wish to create a 3840 x 2160 MPEG-4 file at 50 or 59.94 Hz, you must first create the composition
in After Effects CC and then render the MPEG-4 in Media Encoder CC.

1. In After Effects CC, create a new composition as follows:

a. Select Composition > New Composition.
b. Select the appropriate resolution, frame rate, and duration.
c. Click OK.
d. Select File > Import > File.

NOTE:  If you are adding an image sequence, in the Open dialog box, click the
first file in the sequence, and ensure that Targa Sequence or PNG Sequence is
selected.

e. In the Project area, right-click the imported sequence, and select Interpret Footage > Main.
f. In the Interpret Footage dialog box, make sure the field for Assume this frame rate matches the

target frame rate.

2. When you are ready to render the .mp4, click Composition > Add to Adobe Media Encoder
Queue.
Media Encoder CC launches with the composition loaded in the Render Queue panel.

3. From the Format drop-down menu, select H.264.

4. Click H.264 to open the Export Settings dialog, and then configure the following settings:

TIP:  You can save the following configuration as a preset. Click the Save as preset
icon to the right of the Preset field, enter a unique name for the preset and then click
Save.

a. Select the check box for Export Video.
b. If you do not want to export audio with your file, clear the check box for Export Audio.

 

 
c. On the Effects tab, add or remove all necessary effects.
d. On the Multiplexer tab, configure the following settings:

◦ From the Multiplexer drop-down menu, select MP4.
◦ For Stream Compatibility, select Standard.

e. On the Video tab, configure the following settings:
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◦ Under Basic Video Settings, click Match Source if you wish to match the composition
settings in After Effects CC; or, override the default settings as necessary (the default settings
are sufficient).

◦ Ensure that the check box for Render at Maximum Depth is cleared.
 

 
◦ From the Bitrate Encoding drop-down menu, select VBR, 1 pass.
◦ Set the Target Bitrate [Mbps] to 32.
◦ Set the Maximum Bitrate [Mbps] to 40.

 

 
◦ Under Advanced Settings, ensure that the check box for Key Frame Distance is cleared.

5. If you want to include Audio with your file, click the Audio tab, and then configure the following
settings:

a. From the Audio Format drop-down menu, select AAC (default).
b. From the Audio Codec drop-down menu, select AAC.
c. From the Sample Rate drop-down menu, select 48 kHz (for best performance).
d. From the Channels drop-down menu, select Stereo (default).
e. From the Audio Quality drop-down menu, select High (default).
f. From the Bitrate drop-down menu, select 56 (default).
g. For Precendence, select Sample Rate (default).
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6. Click OK.

7. In the Queue area, click Start Queue.
You can view the encode process from the Encoding area.

8. When the encode is complete, copy the MPEG-4 file to your graphics directory on the video server.
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Creating bundled files

Your Spectrum playout device supports playout of files that have been bundled in a zip file. You may use
any .zip file tool and any combination of the supported file types.

When your .zip file is ready, simply copy it to your configured graphics directory on your Spectrum video
server.

• Important notes about bundled files
• Supported file types
• Creating a .zip file playlist

Important notes about bundled files
Read these important notes before creating a bundled file for your Spectrum playout device.

• Your Spectrum playout device will play only the FIRST THREE files in the .zip file, so Harmonic
recommends building .zip files with only files you want to play.

• If there is no playlist specifying the order of playout, the order of playout cannot be guaranteed due to
variations of bundling methods among ZIP creation tools.

• If you choose to have each .flv in a different folder in the .zip file, be sure to include only one
playlist at the top of the directory. Also, Harmonic strongly recommends that you give each file a
unique name to avoid potential file name conflicts.

• The amount of memory used by a single pre-loaded file is computed from the size of the file as it exists
in the graphics directory. For .zip files, this value is based on the size of the .zip file, not the size of
the extracted files. In other words, when the files are unbundled, there may not be enough memory to
play the files correctly.

• For 720p outputs, make sure any video files bundled in the .zip file have an even number of frames.

Example .zip file
See an example .zip file that was created to contain .flv files for a three-point animation and a playlist.

/fs0/gfx.dir/ThreePoint.zip/ contains the following files:

• playlist.txt
• intro.flv
• loop.flv
• outro.flv
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Supported file types
Review which file types may be bundled in a .zip file.

• .flv
• .mp4
• .jpeg (or .jpg)
• .bmp
• .tga
• .png
• .tiff (or .tif)

NOTE:  For image files, playout is dependent on the primary video frame rate. If no play
count is specified in a playlist, the image will play out at the default value—which is one full
frame time.

Creating a .zip file playlist
You can include a playlist in a .zip file to specify the order in which the bundled files will be played.
Playlists for .zip files must use the .txt file format.

IMPORTANT:  Playlists for bundled files must have the following file name:
playlist.txt. Do not use any other characters or naming conventions. Also, include
only one playlist file in a .zip file.

• Create a playlist that meets the following criteria:

◦ There should be only one line of text per file to be played.
◦ Each line of text contains the file name, and, if necessary, a play count descriptor (playcount

(n)) or an end mode descriptor, such as (end (still)) or (end (disappear)).
◦ Add a space and then two dashes between the file name and the descriptor; add a space between

the descriptor and the value.
◦ If needed, you can comment the playlist using #.

NOTE:  The ZIP renderer ignores case when matching file names.

The following is an example playlist for a .zip file containing three-point animation files:

#this is an example playlist

intro.flv 

loop.flv --playcount 5 

outro.flv --end disappear
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Troubleshooting tips

Find troubleshooting tips for problems you may encounter when playing graphic templates.

• Encountering problems when loading graphic templates
• Template not visible or appears to be cropped
• Template animation running too fast or too slow
• Template animation is too slow or stutters (fps matches)

Encountering problems when loading graphic templates
Find possible causes and troubleshooting tips for a .swf file that does not play when loaded.

The following could be causing the .swf file to not play:

• The .swf file cannot be parsed.
• The .swf file is not a valid Harmonic template.

To troubleshoot this problem:
• Verify that the .swf file was created correctly and contains the proper ActionScript code.
• If you are using a sample Harmonic Template, please try the following:

a. Be sure you save the sample Harmonic .fla file to the project folder in the Template Authoring
Package before publishing the .fla file as a .swf file. The project folder contains ActionScript
files written by Harmonic that allow your Flash project to be played on your Spectrum playout
device.

b. If your published .swf file (which began as a sample Harmonic .fla file) cannot be played,
validate that the .swf file was created correctly, and/or republish the .swf file.

• If you created a custom template and the published .swf file cannot be played, validate that the
ActionScript settings in Flash Professional were configured properly, and/or republish the .swf file.

IMPORTANT:  Custom templates that you create from scratch cannot be linked to the
Harmonic ActionScript code just by saving the .fla file to the project folder in the
Template Authoring Package. Additional steps are required to link custom templates to
the ActionScript code.
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Template not visible or appears to be cropped
Find possible causes and troubleshooting tips for a template that is not visible, or appears to be cropped
during preview.

Note the following possible causes:

• The template is loaded on a layer that is not visible.
• The resolution of the template does not match the resolution of the primary video.

Try the following:
• Using FXTool, validate that the layer is set to “Visible.” If the layer is not “Visible,” click the Fade In

button.
Refer to the Spectrum X and ChannelPort Tools User Guide for instructions on using FXTool.

• If the layer is faded in and “Visible,” but the template is still not visible, the active template may be
cropped (for example, a 1920x1080 template was loaded on a primary video resolution of 1280x720).
Use Flash Professional, Media Encoder, or After Effects to validate that the resolution of the template
matches the resolution of the primary video, and/or republish the template.

Template animation running too fast or too slow
Find possible causes and troubleshooting tips for animation that appears to run too fast or too slow during
preview.

Note the following possible causes:

• Animation is too slow: The frames per second (fps) setting of your .swf file is higher than the fps
setting of the primary video.

• Animation is too fast: The fps setting of your .swf file is lower than the fps setting of the primary video.

Try the following:
• Use Flash Professional to validate that the fps setting of the .swf file matches the fps setting of the

primary video, and/or republish the .swf file.

NOTE:  For .flv files that appear to run too slow, in Media Encoder, validate that the
Simple Profile check box is selected from the Video tab in the Export Settings dialog
box.

Template animation is too slow or stutters (fps matches)
If the template animation is too slow or stutters, and you've confirmed that the fps of the .swf file
matches that of the primary video, find possible causes.

In some cases, a .swf file will appear to be slow or stutter if the file cannot accurately render a new
frame of graphics on every video field. When the .swf file is running slow, the last rendered frame will be
repeated until a new frame is produced, which may result in a stutter.
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• Refer to "Performance considerations" in this guide for more information on creating graphic templates
that perform frame accurately.

Additional information
Performance considerations on page 25
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Appendix A

Harmonic Technical Assistance Center contact information

A list of phone numbers, e-mail addresses, and important links for the Harmonic Technical Assistance
Center (TAC).

Table A-1: Technical Assistance Center phone numbers and email addresses

Region Telephone Technical Support Email

Americas 888.673.4896
(888.MPEG.TWO)408.490.6477

support@harmonicinc.com

Europe, the Middle East
and Africa (EMEA)

+44.1252.555.450 emeasupport@harmonicinc.com

India +91.120.498.3199 apacsupport@harmonicinc.com

Russia +7.495.926.4608 rusupport@harmonicinc.com

China +86.10.6569.5580 chinasupport@harmonicinc.com

Japan +81.3.5565.6737 japansupport@harmonicinc.com

Asia Pacific (APAC) –
Other Territories

+852.3184.0045
+65.6542.0050

apacsupport@harmonicinc.com

Report an issue online

http://www.harmonicinc.com/webform/report-issue-online

Harmonic support website

http://www.harmonicinc.com/content/technical-support

Software download location for Cable Edge products

ftp://ftp.harmonicinc.com

Contact Harmonic Technical Publications

techdocs@harmonicinc.com

• Harmonic corporate contact information
• Useful information for Technical Support

101

mailto:support@harmonicinc.com
mailto:emeasupport@harmonicinc.com
mailto:apacsupport@harmonicinc.com
mailto:rusupport@harmonicinc.com
mailto:chinasupport@harmonicinc.com
mailto:japansupport@harmonicinc.com
mailto:apacsupport@harmonicinc.com
http://www.harmonicinc.com/webform/report-issue-online
http://www.harmonicinc.com/content/technical-support
ftp://ftp.harmonicinc.com
mailto:techdocs@harmonicinc.com


Appendix A: Harmonic Technical Assistance Center contact information

Harmonic corporate contact information
Phone numbers and addresses for the corporate office.

Harmonic corporate address

4300 North First Street
San Jose, CA 95134
U.S.A.

Harmonic corporate telephone numbers

Tel. 1.800.788.1330 (from the U.S. and Canada)
Tel. +1.408.542.2500 (outside the U.S. and Canada)
Fax.+1.408.542.2511

Useful information for Technical Support
In order to expedite diagnosis and remediation, please gather helpful information about your Spectrum
system as well as your SystemManager platform before contacting Technical Support.

Information about your Spectrum system
In the event of a component or device failure, please gather the following information about your
Spectrum system before contacting Technical Support.

Technical Support may request the following information:

• What is the model and serial number of the hardware involved?

For Spectrum devices: from the Home tab in SystemManager, click the Upgrade Firmware icon in the
left-hand column to display the Upgrade Firmware page. All Spectrum video servers in your system
are listed in the Spectrum Servers section. Find the model numbers and serial numbers listed in their
respective columns.

Scroll down to the I/O modules section to view the model numbers and serial numbers for I/O
modules.

• What is the name of the Player that is being used?

From the Configuration tab in SystemManager, click the Player Configuration link in the left-hand
column, and then click the name of the Spectrum video server. The Player List page for that device
appears. The names and status of all players are listed.

• What file format and bit rate is the Player configured for? (for example, MPEG, DV, or IMX?)

From the Configuration tab in SystemManager, click the Player Configuration link in the left-hand
column, and then click the name of the Spectrum video server. The Player List page for that device
appears. From the player list, click the Properties link to view all the details for a player.

• If the problem is related to Ingest or Playout of a clip, what is the Clip ID involved?

The clip name or clip ID should be indicated by whatever software application you are using to play or
record video. For ClipTool, clip names are displayed in the clip management area of the ClipTool main
window.

• What brand of Automation, if any, is being used for control?
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• Is the Automation using VDCP or API for communication control?

Information about the SystemManager client PC
Please gather information about the SystemManager client PC as well as the SystemManager database
file before contacting Technical Support.

Technical Support may request the following information:

• SystemManager version

You can find the version here: Help  > Server Software.
• Windows operating system installed on the SystemManager client PC

The run command winver shows the Windows operating system running on the client PC.
• Amount of memory installed on the SystemManager platform

Open the System Properties dialog on the client PC to find the amount of memory installed.
• The SystemManager database file from the SystemManager platform or client PC

This file is located on the SystemManager platform at D:\Omneon\Manager\omdb\manager.oda.
Or, if you are using a client PC with a single C: partition, it will be in the same directory on the C: drive.

Gathering drive failure information
In the event of a drive failure, before contacting Technical Support, please gather the requested
information to assist in drive problem diagnosis and remediation.

1. Provide the following general details about the drive failure:

◦ Site Location
◦ Server Name
◦ Date of Failure
◦ Time of Failure
◦ Description of Failure

2. Collect the following information from the Spectrum Server Properties page in SystemManager:

TIP:  To view the Spectrum Server Properties page in SystemManager, from the
System Diagram page of the Configuration tab, click the icon for your Spectrum
video server. Then, from the Physical Configuration tab, click the icon for your
Spectrum.

◦ Firmware Version
◦ Host Name
◦ Serial Number

3. Collect the following information from the Drive Properties page:

TIP:  To view Drive Properties, from the Configuration tab, click Disk Utilities, then
click the icon for your Spectrum server. From the second Disk Utilities page, click the
icon for the drive that has failed.

◦ Disk GUID
◦ Disk Serial Number
◦ Disk Size (GB)
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4. From your SystemManager platform or client PC, use Windows Explorer to navigate to the following
directory:
\\IPADDR\FSNAME\om(serial_number_of_director)\logs

◦ IPADDR = IP address or host name if using DNS
◦ FSNAME = file system name

5. Locate Badblockhistory.txt and the log file that coincides with the date/time of the failure.

Badblockhistory.txt

Note the naming of the log files: syslog_(server_name)_NNNN_YYYY_MM_DD_hh_mm_ss.log,
where

◦ NNNN = serial number of unit
◦ YYYY = year of log start
◦ MM = month of log start
◦ DD = day of log start
◦ hh = hour of log start
◦ mm = minute of log start
◦ ss = second of log start

What to do next
Once you obtain a Return Authorization Number (RA) from Harmonic Technical Support, email a copy of
the requested file(s) to Technical Support and quote the RA number in the email.
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